Learning AutoCAD® 2010, Volume 1

Using hands-on exercises, learn the features, commands, and techniques for creating, editing, and printing drawings with AutoCAD® 2010 and AutoCAD LT® 2010 software.
© 2009 Autodesk, Inc. All rights reserved.

Except as otherwise permitted by Autodesk, Inc., this publication, or parts thereof, may not be reproduced in any form, by any method, for any purpose.

Certain materials included in this publication are reprinted with the permission of the copyright holder.

**Trademarks**


The following are registered trademarks or trademarks of Autodesk Canada Co. in the USA and/or Canada and other countries: Backburner, Multi-Master Editing, River, and Sparks.

The following are registered trademarks or trademarks of Moldflow Corp. in the USA and/or other countries: Moldflow MPA, MPA (design/logo), Moldflow Plastics Advisers, MPI, MPI (design/logo), Moldflow Plastics Insight, MPX, MPX (design/logo), Moldflow Plastics Xpert.

All other brand names, product names, or trademarks belong to their respective holders.

**Disclaimer**

THIS PUBLICATION AND THE INFORMATION CONTAINED HEREIN IS MADE AVAILABLE BY AUTODESK, INC. “AS IS.” AUTODESK, INC. DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS.

Published by:
Autodesk, Inc.
111 McInnis Parkway
San Rafael, CA 94903, USA
Contents

Introduction ....................................................................................................... ix

Chapter 1: Taking the AutoCAD Tour ................................................................. 1
  Lesson: Navigating the Working Environment ............................................ 2
  Setting the Workspace ............................................................................... 3
  Keyboard Input .......................................................................................... 7
  User Interface Layout ............................................................................. 8
  About Shortcut Menus ........................................................................... 14
  More AutoCAD-Specific Interface Tools ............................................. 15
  Lesson: Working with Files ....................................................................... 22
  Working with Files .................................................................................. 22
  Lesson: Displaying Objects ................................................................. 26
  Display Tools .......................................................................................... 27
  Pan ......................................................................................................... 27
  Zoom Realtime ....................................................................................... 30
  Zoom Command Options ....................................................................... 32
  Wheel Mouse Features ........................................................................... 34
  Regen ..................................................................................................... 35
  Exercise: Zoom and Pan in the Drawing ............................................. 36
  Exercise: Hands-On Tour ...................................................................... 38
Chapter Summary ..................................................................................... 41

Chapter 2: Creating Basic Drawings ................................................................. 43
  Lesson: Inputting Data ........................................................................... 45
  About the Command Line ..................................................................... 46
  About the Coordinate System .............................................................. 47
  About Dynamic Input .......................................................................... 50
  Using the Dynamic Input Interface .................................................... 53
  Using Direct Distance Entry ............................................................... 58
  Exercise: Input Data ............................................................................. 62
Lesson: Creating a Mirror Image of Existing Objects ................................. 205
  Mirroring Objects ................................................................................ 206
  Exercise: Mirror Objects in the Drawing ............................................. 212
Lesson: Creating Object Patterns .............................................................. 214
  Creating an Array of Objects .............................................................. 215
  Exercise: Array Objects in the Drawing ............................................. 223
Lesson: Changing an Object’s Size ........................................................... 228
  Scaling Objects .................................................................................. 229
  Exercise: Scale Objects Using the Copy Option .................................... 234
Challenge Exercise: Grips ..................................................................... 236
Challenge Exercise: Architectural .......................................................... 243
Challenge Exercise: Mechanical ............................................................ 248
Chapter Summary ..................................................................................... 251

Chapter 4: Drawing Organization and Inquiry Commands .................. 253
Lesson: Using Layers ............................................................................... 255
  Organizing Objects with Layers .......................................................... 256
  Default Layer .................................................................................... 258
  Layer Tools ........................................................................................ 259
  Exercise: Work with Layers ................................................................ 268
Lesson: Changing Object Properties ........................................................ 273
  About Object Properties .................................................................. 274
  ByLayer Property ............................................................................. 277
  Changing Object Properties ........................................................... 279
  Exercise: Change Object Properties .................................................. 288
Lesson: Quick Properties ........................................................................... 291
  About Quick Properties .................................................................... 292
  Using Quick Properties .................................................................... 294
  Exercise: Use Quick Properties .......................................................... 295
Lesson: Matching Object Properties .......................................................... 297
  Matching an Object’s Properties ....................................................... 298
  Exercise: Match Object Properties ..................................................... 302
Lesson: Using the Properties Palette ........................................................ 306
  Using the Properties Palette .............................................................. 307
  Exercise: Manipulate Object Properties ............................................. 310
Lesson: Using Linetypes .......................................................................... 313
  About Linetypes ................................................................................ 314
  Adding Linetypes to Your Drawing .................................................... 316
  Exercise: Use Linetypes .................................................................... 324
Lesson: Using Inquiry Commands ............................................................ 332
  About Measuring .............................................................................. 333
  Using Measure Tools .......................................................................... 334
  Obtaining Object Information .......................................................... 344
  Exercise: Obtain Geometric Information ............................................ 347
  Exercise: Measure Objects ................................................................. 350
Acknowledgements

The Autodesk Learning team wishes to thank everyone who participated in the development of this project, with special acknowledgement to the authoring contributions and subject matter expertise of Ron Myers and CrWare, LP.

CrWare, LP began publishing courseware for Autodesk® Inventor® in 2001. Since that time, the company has grown to include full-time curriculum developers, subject matter experts, technical writers, and graphics specialists, each with a unique set of industry experiences and talents that enables CrWare to create content that is both accurate and relevant to meeting the learning needs of its readers and customers.

The company’s Founder and General Partner, Ron Myers, has been using Autodesk® products since 1989. During that time, Ron Myers worked in all disciplines of drafting and design, until 1996 when he began a career as an Applications Engineer, Instructor, and Author. Ron Myers has been creating courseware and other training material for Autodesk since 1996 and has written and created training material for AutoCAD®, Autodesk Inventor, AutoCAD® Mechanical, Mechanical Desktop®, and Autodesk® Impression.
Acknowledgements
Introduction

Welcome to the Learning AutoCAD 2010 and AutoCAD LT 2010 Autodesk Official Training Guide, a training guide for use in Authorized Training Center (ATC®) locations, corporate training settings, and other classroom settings.

Although this guide is designed for instructor-led courses, you can also use it for self-paced learning. The guide encourages self-learning through the use of the AutoCAD® or AutoCAD LT® Help system.

This introduction covers the following topics:

- Course objectives
- Prerequisites
- Using this guide
- Default installation
- CD contents
- Completing the exercises
- Settings for the exercises
- Installing the exercise data files from the CD
- Imperial and metric datasets
- Notes, tips, and warnings
- Feedback

This guide is complementary to the software documentation. For detailed explanations of features and functionality, refer to the Help in the software.

Course Objectives

After completing this course, you will be able to:

- Navigate the interface, open and close files, and use the Zoom commands to adjust the display of objects on the screen.
- Describe units, function keys, and coordinate systems and create basic objects, using different data input techniques, object snaps, object snap tracking, polar tracking, and PolarSnap.
- Select, modify, and adjust the properties of objects using object grips and the Move, Copy, Rotate, Mirror, and Array commands.
- Create and manage layers and linetypes and obtain geometric information from objects in the drawing.
- Modify objects by changing their size, shape, orientation, or geometric composition using Trim, Extend, Offset, Join, and other commands.
- Create layouts, and create and manipulate viewports on the layouts.
- Create and edit annotation objects using multiline and single line text.
- Create, edit, and manage dimensions and dimension styles.
Enhance the drawing's visual appearance with hatch patterns and gradient fills.

Create blocks and reuse them in your drawings using the Insert command, DesignCenter, and tool palettes. Utilize the DesignCenter and tool palettes to insert and create other content in your drawings.

Create multiple segmented polyline objects, create the smooth curve objects of splines and ellipses, and add tables to your drawings.

Create and use page setups, and plot your designs from layouts and model space.

Use drawing templates to simplify the process of creating new drawings that contain all the required dimension styles, text styles, and layers that you would otherwise create manually, each time you create a new drawing.

Prerequisites

This guide is designed for the new user who needs to know the essential commands necessary for professional 2D drawing, design, and drafting using AutoCAD or AutoCAD LT. No previous computer-aided design (CAD) experience is required.

It is recommended that you have a working knowledge of:

- Microsoft® Windows® XP, or Microsoft® Vista®.
- Drafting and design experience is a plus.

Using This Guide

The lessons are independent of each other. However, it is recommended that you complete these lessons in the order that they are presented unless you are familiar with the concepts and functionality described in those lessons.

Each chapter contains:

- **Lessons:** Usually two or more lessons in each chapter.
- **Exercises:** Practical, real-world examples for you to practice using the functionality you have just learned. Each exercise contains step-by-step procedures and graphics to help you complete the exercise successfully.

Default Installation

The information in this guide is presented in such a way that it is assumed you have installed AutoCAD or AutoCAD LT using the default installation parameters. You should be using the 2D Drafting & Annotation workspace as your active workspace throughout the course. You will learn how to do this in Chapter 1.

CD Contents

The CD attached to the back cover of this book contains all the data and drawings you need to complete the exercises in this guide.
Completing the Exercises

You can complete the exercise in two ways: using the book or the onscreen version.

- **Using the book:** Follow the step-by-step exercises in the book.
- **Onscreen:** Click the Learning AutoCAD 2010 icon on your desktop, installed from the CD, and follow the step-by-step exercises on screen. The onscreen exercises are the same as those in the book. The onscreen version has the advantage that you can concentrate on the screen without having to glance down at your book.

After launching the on-screen exercises, you might need to alter the size of your application window to align both windows.
**Settings for the Exercises**

Each exercise is written with the assumption that the following Object Snap settings are active. You might need to confirm these settings for each exercise.

![Drafting Settings window with Object Snap mode options]

Each exercise is written with the assumption that the following Status Bar options are turned ON. If necessary adjust these options when you open the dataset for each exercise.

![Status Bar options]

**Installing the Exercise Data Files from the CD**

To install the data files for the exercises:

1. Insert the CD.
2. Double-click the self-extracting archive `setup.exe`.

Unless you specify a different folder, the exercise files are installed in the following folder:

```
C:\Autodesk Learning\AutoCAD 2010\Learning AutoCAD 2010\
```

After you install the data from the CD, this folder contains all the files necessary to complete each exercise in this guide.
The datasets and exercises can be used with AutoCAD LT. The location of the files will be the same whether you are using AutoCAD or AutoCAD LT. The name of the shortcut for the online version of the exercises is named Learning AutoCAD 2010, but can also be used with AutoCAD LT 2010.

**Imperial and Metric Datasets**

For some of the exercises that specify units of measurement, alternative exercise tables are provided. You will see a note stating that an imperial and metric version are available. An example of the file naming convention is as follows:

- Open `i_stair_settings.dwg` (imperial) or `m_stair_settings.dwg` (metric).

In the exercise steps, you will see either the imperial or metric value as shown in the following example:

- For Length, enter 13'2".
- For Length, enter 4038 mm.

For exercises with no specific units of measurement, files are provided as shown in the following example:

- Open `c_stair_settings.dwg` (common).

In the exercise steps, the unitless value is specified as shown in the following example:

- For Length, enter 400.

**Notes, Tips, and Warnings**

Throughout this guide, notes, tips, and warnings are called out for special attention.

- **Notes** contain guidelines, constraints, and other explanatory information.
- **Tips** provide information to enhance your productivity.
- **Warnings** provide information about actions that might result in the loss of data, system failures, or other serious consequences.

**Feedback**

We always welcome feedback on Autodesk Official Training Guides. After completing this course, if you have suggestions for improvements or if you want to report an error in the book or on the CD, please send your comments to learningtools@autodesk.com.
Taking the AutoCAD Tour

Before you begin to use the software, you need to become familiar with the interface and some of the core functionality and features.

Objectives

After completing this chapter, you will be able to:

■ Identify and state the purpose of the main interface elements.
■ Open, create, and save drawings.
■ Use the Zoom and Pan commands to view different areas of the drawing.

Standard Object Snap and Status Bar Settings
Before completing the exercises in this chapter, refer to the "Settings for the Exercises" section in the Introduction in Volume 1.
Lesson: Navigating the Working Environment

This lesson describes the working environment and the types of interface elements that you must become familiar with if you are to become proficient in the software.

Before you begin creating drawings, you should familiarize yourself with the interface.

After completing this lesson, you will be able to start the application, activate the appropriate workspace, and identify key parts of the interface.

The following image identifies key interface elements:

1. Application Menu
2. Quick Access Toolbar
3. Info Center
4. Title Bar
5. Ribbon
6. Drawing Area
7. Crosshairs
8. Command Window
9. Status bar
Objectives

After completing this lesson, you will be able to:

- Describe and set the workspace.
- Identify and use keyboard functions.
- Identify key parts of the interface.
- Use the shortcut menu to access commands and options.
- Explain the purpose of AutoCAD-specific interface tools.

Setting the Workspace

Introduction

You launch AutoCAD® in the same way you launch other Windows applications, using one of the following two methods:

- Double-click the AutoCAD 2010 icon on the Windows desktop.
- Click Start > All Programs (or Programs) > Autodesk > AutoCAD 2010 > AutoCAD 2010.

Depending on the options chosen during installation or the status of AutoCAD when it was last closed, you may need to adjust the active workspace.

Warning!

If using AutoCAD LT®, select the icon and start menu options associated with AutoCAD LT.

Workspaces Defined

When you launch the application, the interface elements displayed are only those associated with the active workspace. A workspace is a task-oriented drawing environment oriented in such a way as to provide you with only the tools and interface elements necessary to accomplish the tasks relevant to that environment.

By default, AutoCAD has four workspace configurations:

- 2D Drafting & Annotation
- 3D Modeling
- AutoCAD Classic
- Initial Setup Workspace

Warning!

AutoCAD LT has two workspaces, one workspace named 2D Drafting & Annotation, the other named AutoCAD LT Classic.
AutoCAD is shown here with the 2D Drafting & Annotation workspace active.

AutoCAD is shown here with the 3D Modeling workspace active.
AutoCAD is shown here with the AutoCAD Classic workspace active.

After you start the program you can switch to the desired workspace. The application will open with the last workspace used. The Workspace Switching dropdown list is accessed in the lower right corner of the AutoCAD window on the Status Bar.

**Procedure: Setting the 2D Drafting & Annotation Workspace**

The following steps give an overview of activating the 2D Drafting & Annotation workspace.

1. Start AutoCAD.
2. Use the default drawing or on the Quick Access toolbar, click New.
3. Select `acad.dwt` (imperial) or `acadiso.dwt` (metric) as the template file.

4. Click the Workspaces settings icon, located at the bottom right corner of the AutoCAD window. Select 2D Drafting & Annotation.

---

**Procedure: Setting the AutoCAD LT Workspace**

The following steps give an overview of activating the AutoCAD LT 2D Drafting & Annotation workspace.

1. Launch AutoCAD LT.
2. On the Workspaces toolbar, select 2D Drafting and Annotation from the list.
3. Start a new drawing and select `acadlt.dwt` (imperial) or `acadltiso.dwt` (metric) as the template file.

The instructions and exercise steps covered in this course are based on the 2D Drafting & Annotation workspace. Please activate this workspace if you have not already done so.
Keyboard Input

Using the keyboard is familiar to everyone who works with computers. For much of the work that you do in AutoCAD you use the keyboard, but you use a few keystrokes more often than others.

Special Keys
You use the following keys most often. These keys have special meaning to the software.

- Use the **ESC** key to cancel all current actions and return to the **Command**: prompt.
- Press the **ENTER** key following all keyboard input. You also complete many commands by pressing **ENTER**.
- Pressing the **SPACEBAR** is equivalent to pressing the **ENTER** key and is often easier to use.
- Pressing the **SPACEBAR** or **ENTER** at the **Command**: prompt repeats the last command used.
- Pressing the **UP** and **DOWN** arrow keys will cycle through previous commands used.
- The **TAB** key is especially useful to navigate in a dialog box. You should use the **TAB** key to move from field to field. Be careful not to press **ENTER**.

Function Keys
The use of each of the function keys can be duplicated in other ways with the exception of F2. You may find that the on-screen equivalents to the function keys are easier and allow you to keep your eyes on the screen.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Displays Help</td>
</tr>
<tr>
<td>F2</td>
<td>Toggles Text Window</td>
</tr>
<tr>
<td>F3</td>
<td>Toggles OSNAP</td>
</tr>
<tr>
<td>F4</td>
<td>Toggles TABMODE</td>
</tr>
<tr>
<td>F5</td>
<td>Toggles ISOPLANE</td>
</tr>
<tr>
<td>F6</td>
<td>Toggles UCSDETECT (Not available in AutoCAD LT)</td>
</tr>
<tr>
<td>F7</td>
<td>Toggles GRIDMODE</td>
</tr>
<tr>
<td>F8</td>
<td>Toggles ORTHOMODE</td>
</tr>
<tr>
<td>F9</td>
<td>Toggles SNAPMODE</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>F10</td>
<td>Toggles Polar Tracking</td>
</tr>
<tr>
<td>F11</td>
<td>Toggles Object Snap Tracking</td>
</tr>
<tr>
<td>F12</td>
<td>Toggles Dynamic Input</td>
</tr>
</tbody>
</table>

**User Interface Layout**

There are interface elements common to other Windows applications such as ribbon panels, toolbars, and menus. If you have used other Windows applications, these user interface elements should appear familiar. However, there are interface elements such as the command line and the status bar, which are unique to AutoCAD.

**Heads-up Design Defined**

Heads-up design is a methodology intended to increase your efficiency while using the software. Whenever you turn your visual focus away from your design to locate a tool, it slows you down. Instead, you should use the most efficient access methods such as Dynamic Input, right-click shortcut menus and the ribbon control panels whenever possible.

**Ribbon Defined**

The ribbon is a special tool palette associated with each workspace containing only the tools and controls relevant to that workspace. For example, the ribbon for the 2D Drafting & Annotation workspace contains tools relevant to 2D drawing, dimensioning, and annotating, but does not contain tools for 3D geometry creation.

The ribbon supports the heads-up design process because it is space efficient and eliminates the clutter of tool palettes and toolbars. Using the ribbon alone provides you with more space on your screen in the drawing area and enables you to maintain access to the tools and controls you need.
Ribbon Controls

The ribbon is turned on by default when you start the software in either the 2D Drafting & Annotation or the 3D Modeling workspace. The ribbon is organized into a series of tabs. Each tab includes a different set of panels with related commands and controls that may be found on the Classic AutoCAD toolbars and dialog boxes.

You can turn the tabs and associated panels on the ribbon on or off by right-clicking on the ribbon area and selecting Tabs or Panels to select the desired options. You can also turn Panel Titles on or off by right-clicking the Panel tabs. Additionally you can save your Ribbon configuration.

Each tab on the ribbon has its own set of panels that contain groups of related tools, such as those used for 2D drawing, adding text, or adding dimensions. Some panels can be expanded to display more tools. Likewise some tools can be expanded for more options, such as the Circle tool as indicated by an arrow in the corner of the icon.

1. Tabs
   Identifies the purpose and name of the control panel.

2. Panels
   Contains groups of related tools associated with the selected tools.

3. More tools
   Click and hold the down arrow to display more tools and options in the selected panel.
Add or Remove Tabs

To turn specific tabs on or off, right-click in the ribbon and select Tabs. Choose to display or remove tabs from the ribbon. Tabs currently displayed are indicated with a check mark.
Application Menu

You can use the Application Menu to access several key commands such as New, Open, Save, Print, and Close. Most of these commands lead to submenus that give you more detailed options.

Panels

AutoCAD uses ribbon panels as one means to access commands and settings. Similar tools commands are grouped together in panels and can be accessed by clicking the button or icon that indicates the tool’s purpose. Each panel consists of a collection of tools that performs related or similar tasks.

When using the 2D Drafting & Annotation workspace, a standard set of panels is displayed on each of the standard set of tabs located on the horizontal ribbon at the top of the AutoCAD drawing area. Notice that when you select a different tab, a different set of panels is displayed.

By default, each panel is docked at the top of the drawing area on the ribbon. You can move the panels away from the docked position to a floating position or drag them back into the ribbon.
Panel Visibility

To turn specific panels on or off, right-click in the ribbon and select Panels. Select to display or remove panels from the ribbon tab. Panels currently displayed are indicated with a check mark, as shown in the illustration on the right.

Panels will appear in the last position (docked or floating) they were in before the panel was removed from the display.

When you click icons on the ribbon panel, the command is not executed unless the cursor is over the icon when you release the mouse button. If you click the wrong icon, simply drag the cursor away from the button before releasing.

Panel Tools Visibility

Some panels will cascade to reveal additional tools when you select the black arrow in the lower right-hand corner of the panel. You can keep these panels open to display all of the tools by selecting the thumbtack located in the lower left-hand corner of the cascading panel.
Status Bar

The status bar is located at the bottom of the application window.

The left end of the status bar displays the coordinates that show the numerical position of the crosshairs in the drawing. Click this area to turn the coordinate display off or on. In the on position, there are two possibilities. The readout displays the X,Y,Z values, or the distance and polar angle of the crosshairs as it is moved in the drawing window.

Coordinates Display

To the right of the Coordinates Display, there are buttons that activate features to facilitate drawing construction. Collectively, these features are termed drafting settings.

Drafting Settings

In the middle-right of the status bar are buttons to display the drawing model or the drawing layout views.

Model Space and Layout Settings

To the right of the Model Space and Layout buttons are the realtime Pan command and the Zoom command.

Annotation Settings

Towards the right side of the status bar are the Annotation options for the display of annotative objects such as text and dimensions. When you create annotations with the annotative property selected, the Annotation Scale displayed in the status bar represents the scale in which the new objects are created.
About Shortcut Menus

The shortcut menu is context-sensitive. When you right-click in the graphics window, you can use the options presented on the shortcut menu to perform a variety of tasks. Context-sensitive means that the menu will change depending on what you are currently doing in the software. For example, if you are at the Command prompt your shortcut menu will have different options available than if you are in the Pline command.

Definition of Shortcut Menu

Shortcut menu options are organized into different areas. The options that are made available to you are based on the current context of your work and will change when you activate the shortcut menu. The following image shows the shortcut menu as it appears when you are creating a polyline.

The top area of the menu offers Enter, Cancel, and Recent Input options.

The middle area of the menu offers options specific to the current command. Notice how the options on the menu match the options on the command line. To use an option for a command, select the option on the shortcut menu. This has the same effect as typing the capital letter(s) of the option on the command line.

The lower area of the menu offers Pan and Zoom functions and access to the QuickCalc command.

Key Points

- The shortcut menu is context-sensitive, so its options differ depending on the current context of the software, for example, whether you are drawing or editing.
- You can use the shortcut menu as an alternative to entering command options on the command line. This speeds up the design process and is the preferred method for working with sub-options of the active command.
More AutoCAD-Specific Interface Tools

While the software complies with Windows standards for user interface elements, there are some element types that are specific to the application.

The following image shows the command window. Somewhat unique to a graphical windows application, the command window provides another method for the user to interact with the application.

<table>
<thead>
<tr>
<th>Command:</th>
<th><code>ERASE</code></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select objects:</strong></td>
<td></td>
</tr>
</tbody>
</table>

**Layouts (Drawing Sheets)**

Model space (the Model tab) is the area where you create your designs. Layouts (drawing sheets) are for annotation, borders, title blocks, and plotting.

When you design, you should always draw at full scale. The model space environment offers an unlimited amount of space to create your designs. Use layouts to create drawing sheets that represent an area equal to the actual size of the paper.

You can switch between Model space and the Layout by selecting the button located in the Status Bar at the bottom of the AutoCAD window.
Layer List

The Layer list displays the drawing's layers. Using this list, you can switch the current layer, assign selected objects to a layer, turn layers on and off, freeze layers, and lock layers.

Tool Palettes

Tool palettes simplify the task of adding predefined design content to your drawing.
The tool palettes are a set of overlapping panels contained in a floating window. For easy identification, they are grouped by tabs.

The palettes provide an efficient method for organizing, sharing, and placing area fill patterns and symbols that you use regularly.

You can customize the individual tools on the palettes by setting properties that are specific to the object, such as scale, rotation angle, or a predefined color.

Palettes can also contain custom tools provided by third party developers.

**InfoCenter Defined**

The InfoCenter, located to the far right of AutoCAD title bar, consists of the InfoCenter search and access to the Communication Center panel. You can use the InfoCenter search by typing in key words or by typing a question. While there are many locations for which InfoCenter can be configured, the following locations are provided as examples:

- User's Guide
- Command Reference
- New Features Workshop

The InfoCenter is shown in the following illustration.
Communication Center

The Communications Center, accessed through the InfoCenter menu bar, provides real-time notifications, announcements, and news to your desktop. You must be connected to the Internet to take advantage of this feature. The following is a partial list of information sources you can access:

- New Software Updates
- Product Support
- CAD Manager Channel
- RSS Feeds

Access

1. Search for information or help in the configured search locations by entering search keywords, or enter a question in the Help field.

2. Click the search icon to display the search results after entering search keywords. You can browse the results in the Search window.

3. Click the drop-down list to configure InfoCenter. Click Search Settings in the drop-down list to configure InfoCenter search locations and Communication Center settings.

4. Click the key to open Subscription Center.

5. Click the satellite dish icon to open Communication Center.

6. Click to access a list of favorites.

7. Click to access the Help dialog box.

Communication Center Options

Expand the Communications Center title bar to see all of the configured Autodesk channels.
Expand the RSS Feeds title bar to see all of the configured RSS feeds. By default, several RSS feeds are created for you when you install AutoCAD.

Select the Subscription Center button to view all of the configured Subscription Center items, such as product support requests and e-Learning catalogs and lessons (Available to subscription customers only.).

Command Window

The command window is normally located at the bottom of the application window and docked between the drawing area and status bar. Whether you enter a command manually at the command line or click a command tool on a toolbar, all commands are passed through and evaluated by the command line.

```
Command: e
ERASE
Select objects:
```

It is important that you monitor the activity that occurs in this area. At each stage of the command process, the software either provides you with a series of options to choose from or requires that you input values relevant to that stage of the process.

In normal operation, the command window contains three lines of text. The first two lines list the immediate command history and display the settings or options available within the current command. The bottom line is the command line. You should focus your attention here during the majority of commands.
You type at the cursor position on the command line, that is, the \textit{Command}: prompt.

\textbf{Note}: Always press \texttt{ENTER} after you type values on the command line.

Although the command window is usually docked at the bottom of the drawing window, you can move it freely around the drawing. You can dock it to the edge of the application window or leave it floating over the drawing area. Click and drag the vertical bars to the left of the command window to place it in a floating position over the drawing area.

\begin{figure}[h]
\includegraphics[width=\textwidth]{example.png}
\caption{While floating the command window over the drawing area can partially obstruct your view, you may benefit from this configuration because it serves as a reminder to monitor the command window.}
\end{figure}

\textbf{Command Sequence}

The process of entering command sequences is straightforward but important. To use the software successfully, you must become comfortable with typical command sequences such as the following one for drawing a circle.

- Circle
  - Specify center point for circle or \{3P/2P/Ttr\ (tan tan radius)}: \textbf{Select a point or enter a coordinate.}
  - Specify radius of circle or [Diameter] <25.0000>: \texttt{d} (Use a command option.)
  - Specify diameter of circle <50.0000>: \texttt{75} (Enter values when prompted.)

If you spend enough time working with the software and paying attention to the command line and other interface elements, you will soon know what information is required without even looking at the command line.
Help Menu

Before you explore the software any further, you should familiarize yourself with the extensive Help documentation provided.

The Help menu provides access to the Help system as well as online resources for Knowledge Base, Training Resources, and the Autodesk User Group International (AUGI). You can also find out more information about and volunteer to participate in the Customer Involvement Program.
Lesson: Working with Files

This lesson describes how to open, create, and save drawings.

Objectives

After completing this lesson, you will be able to:

■ Open drawings, create drawings, and save drawings.

Working with Files

Drawings are created and saved in the DWG drawing file format. To access this data, you must learn how to create a new drawing, save a drawing, and open these file types.

Use the Quick Access toolbar to create, open, and save new drawings.

Open a Drawing

To open a drawing, use the Open command and select the files that you want to open.

Command Access

Command Line: OPEN
Application Menu: File > Open
Toolbar: Quick Access
Open File Dialog Box

Use standard Windows CTRL+ and SHIFT+ selection methods to select and open multiple files at once.

Create a New Drawing

To create a new drawing, use the New command. Select a template or select Open with no Template (Imperial or Metric). Drawing Templates are drawings that are saved in template format (.dwt) and that can contain information such as a title block, layers, text styles, dimension styles, and settings relevant to your specific drawing needs.

Command Access

| Command Line: NEW |
| Application Menu: File > New |
| Toolbar: Quick Access |
Select Template Dialog Box

Saving Your Drawings

Use the Save command to save your drawing. The first time you save a drawing, the Save Drawing As dialog box appears. Navigate to the folder where you want to store the drawing, enter a file name, and select Save. To save a drawing with a different name, select Save As.

Command Access

**Save; Save As**

Command Line: **SAVE; SAVEAS**
Application Menu: **File > Save; Save As**
Toolbar: **Quick Access**
Save Drawing As Dialog Box

Save First and Save Often
As a new user, you should get in the habit of saving your drawing as soon as you create it and save often as you work on your drawings. This is a habit that can be easily learned and could prove to be very valuable in the event of unexpected system failures. A quick way to save your work is to use the shortcut keys: Ctrl + S.
Lesson: Displaying Objects

When you use the software, you draw all objects at full scale. Sometimes you need to view the whole drawing, sometimes just smaller details. To assist you in viewing different areas of the drawing, there are a number of zoom and pan tools. You can easily magnify small areas of your drawing to provide a closer view or shift the view to a different or larger part of the drawing. You can save views by name and restore them later.

In this lesson, you explore different methods of using these tools and develop your use of the interface.

Many of the zoom and pan options operate transparently. This means that you can use the options while you are in another command.

After completing this lesson, you will be able to use zoom and pan commands to control the drawing view display, use the wheel mouse to pan and zoom in the drawing, and regenerate the drawing view.

In the following example of a typical drawing, it would be nearly impossible to work on if it were on a sheet of paper that was the size of common computer monitors. Using the display tools, you can magnify any portion of the drawing to fill the available space on your monitor.

Objectives

After completing this lesson, you will be able to:

■ Identify tools that control the drawing view display.
■ Use the Pan Realtime command to perform real time pan operations in the drawing.
■ Use the Zoom Realtime command to perform real time zoom operations in the drawing.
■ Use different Zoom commands to control the view magnification.
■ Use a wheel mouse to zoom and pan in the drawing.
■ Use the Regen command to regenerate the drawing.
Display Tools

Most of the time you will use the wheel on your mouse to zoom in and out of display views in your drawing. Additional zoom tools are located on the Navigate panel in the View tab on the toolbar ribbon.

Command Access

Command Line: **Zoom, Z** or **Pan**
Status Bar: **Pan** or **Zoom**
Ribbon: **View tab > Navigate panel > Pan**

There are additional options for the Zoom command, but they are beyond the scope of this course. See Help for additional command information.

Pan

You can reposition the center of your view on the drawing by using the Pan command. Just like panning with a video camera, panning your drawing changes only the position of your view of the drawing, not the location or magnification of objects in the drawing.
Command Access

Pan

Command Line: PAN, P
Ribbon: View tab > Navigate panel > Pan

Shortcut Menu: Pan

When the Pan command is active, the cursor changes to a hand icon as shown above. Click and drag the cursor to pan the drawing view.
Command Options

While in the Pan command you may access other Pan and Zoom options when you right-click in the drawing window to display a shortcut menu.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exit</td>
<td>Select to exit the Pan or Zoom Realtime commands.</td>
</tr>
<tr>
<td>Pan</td>
<td>Select to switch to Zoom Realtime.</td>
</tr>
<tr>
<td>Zoom</td>
<td>Select to perform a 3D Orbit of the view.</td>
</tr>
<tr>
<td>3D Orbit</td>
<td>Select to perform a 3D Orbit of the view and return to the Pan or Zoom Realtime command.</td>
</tr>
<tr>
<td>Zoom Window</td>
<td>Select to perform a Zoom Window operation and return to the Pan or Zoom Realtime command.</td>
</tr>
<tr>
<td>Zoom Original</td>
<td>Select to return to the view prior to starting the Pan or Zoom Realtime command.</td>
</tr>
<tr>
<td>Zoom Extents</td>
<td>Select to zoom to the drawing extents and return to the Pan or Zoom Realtime command.</td>
</tr>
</tbody>
</table>

Warning!

The 3D Orbit option is not available in AutoCAD LT.

Procedure: Panning in Real Time

The following steps outline how to pan dynamically in real time.

1. On the ribbon, click View tab > Navigate panel > Pan.
2. Click and drag the cursor in the direction that you want to pan the drawing view. Release the button when you are in your desired position.
3. Continue to click and drag as required.

4. Press ESC or ENTER to exit the Pan command.

**Panning Considerations**
- Panning has the same effect on the drawing as using the horizontal and vertical scroll bars.
- When you pan the drawing, you are not moving geometry, only changing the position from which you view the drawing.

**Zoom Realtime**

The Zoom command increases or decreases the magnification of the objects displayed in the drawing area. When you zoom out, you see more of the overall drawing. When you zoom in, you magnify parts of your drawing to view them in greater detail.

Just like zooming in and out with a camera, using Zoom does not alter the actual size of the object. It simply changes the relative magnification of objects displayed in the drawing area.

**Command Access**

Command Line: **Zoom, Z** Press ENTER on the keyboard for Realtime option
Status Bar: **Zoom**
Ribbon: View Tab > Navigate Panel > Zoom drop-down > Realtime
Zoom

Shortcut Menu: Zoom

When the Zoom Realtime command is active, the cursor changes to the icon above. Click and drag the cursor up to increase magnification or down to decrease magnification.

Procedure: Zooming in Real Time

The following steps outline how to zoom dynamically in real time.

1. On the ribbon, click View Tab > Navigate Panel > Zoom drop-down > Realtime. Press ENTER.
2. Click and drag the cursor up to increase magnification.
3. Click and drag the cursor down to decrease magnification.

4. Continue to zoom in and out as required.

5. Press ESC or ENTER to exit the command.

**Zoom Command Options**

The Zoom command has multiple options available to customize the Zoom.

**Command Access**

Following are the most frequently used Zoom command options for viewing different areas of the drawing.

*Note*: Not all Zoom command options are discussed.

**Zoom Command Options**

- **Command Line**: `Zoom, Z` *(see the Command Line option for the Zoom commands listed below)*
- **Ribbon**: View tab > Navigate panel > Zoom pull-down
Zoom Command Options

Zoom Window  
ZOOM, Z; Pick 2 points to define the window in the drawing area
To use the Zoom Window option, use any method listed above to start the command, click in the drawing to specify the first corner of the window (1), and then click to specify the second corner of the window (2). As a result, the drawing view is magnified and fills the drawing space with the area defined by the zoom window.

Zoom Extents  
Use the Zoom Extents option to zoom to the extents of the drawing, that is, the area of the drawing in which objects are placed. When you zoom to the drawing extents, you magnify the drawing view so that all geometry in the current space (model space or paper space) is visible.
ZOOM, Z; > E then press ENTER

Zoom Previous  
Use the Zoom Previous option to return to the previous view.
ZOOM, Z; > P then press ENTER
Wheel Mouse Features

The wheel mouse is a variant of the standard pointing device that is modified with a small wheel between the left and right buttons. You can rotate this wheel in small increments. You can use the wheel to zoom and pan in your drawing without using any commands. When zooming in, the location near your cursor is the focal point of the zoom and thus remains on the screen.

The ZOOMFACTOR system variable controls the incremental change, whether forward or backward. The higher the number of the variable, the greater the zoom.

How to Use the Wheel Mouse

<table>
<thead>
<tr>
<th>Do this...</th>
<th>To...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roll the wheel forward</td>
<td>Zoom In</td>
</tr>
<tr>
<td>Roll the wheel backward</td>
<td>Zoom Out</td>
</tr>
<tr>
<td>Double-click the wheel button</td>
<td>Zoom Extents</td>
</tr>
<tr>
<td>Hold down the wheel button and drag the mouse</td>
<td>Pan</td>
</tr>
<tr>
<td>Press and hold the SHIFT key and the wheel button and drag the mouse</td>
<td>Constrained Orbit</td>
</tr>
<tr>
<td>Press and hold the CTRL key and the wheel button and drag the mouse</td>
<td>Pan (Joystick)</td>
</tr>
</tbody>
</table>

In some situations, when using the mouse wheel to pan or zoom, the actions have no effect on the drawing. For example, you might only be able to zoom out to a certain point. When this occurs, you must regenerate the drawing by clicking Regen on the View menu.

Wheel Button Modes

You can set the wheel button to function in two different modes. The value of the MBUTTONPAN system variable controls whether panning is supported.

- If MBUTTONPAN is set to 1, the PAN command is activated when you use the wheel.
- If MBUTTONPAN is set to 0, the Object Snap menu is displayed when you use the wheel.
Regen

Use the Regen command to regenerate all the geometry in the drawing. Use the Regenall command to regenerate all the geometry when there are multiple drawing viewports. When you regenerate the drawing, the screen coordinates for all objects in the drawing are recomputed and the drawing database is reindexed for optimal display performance.

Command Access

Regen

Command Line: RE, REGEN, REGENALL

Automatic Drawing Regeneration

By default, when you create a new drawing, the REGENMODE system variable is set to 1. This enables the drawing to regenerate automatically whenever you perform an action that requires regeneration.

Guidelines When Regenerating Large Drawings

- Because regeneration recalculates the screen coordinates for all objects in the drawing, it usually takes longer to regenerate large drawings than smaller ones.
- If you experience performance decreases on larger drawings, consider setting REGENMODE = 0 to prevent automatic regeneration. You can manually regenerate the drawing when you need to.
Exercise: Zoom and Pan in the Drawing

In this exercise, you open an existing drawing and use the Zoom and Pan tools to view different areas.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 1: Taking the AutoCAD Tour. Click Exercise: Zoom and Pan in the Drawing.

1. Open C_Displaying-Objects.dwg.
2. On the View Tab, click Navigate Panel > Pan.
3. Alternatively:
   ■ Right-click anywhere in the drawing area. Click Pan.
   ■ Click and hold the mouse button and drag to change your view of the drawing.
4. While still panning the drawing, press and hold SHIFT.
   Note: This temporarily restricts the movement of the pan from any direction to orthogonal mode.
5. Right-click anywhere in the drawing. Click Exit to end the Pan command.
   Note: You can also press ESC to end the command.
6. On the status bar, click Zoom. Enter E in the command line to select the Extents option. Notice how the view changes.
   Note: If you have a three-button mouse with a scroll wheel, you can double-click the wheel button for the Zoom Extents command.
7. Zoom in real time:
   ■ On the status bar, click Zoom.
   ■ Press ENTER to select real time.
   ■ Click and hold your mouse button and move the cursor up.
   ■ Still holding the mouse button, move the cursor down.
   ■ Notice that as you move the cursor up, the drawing zooms in and as you move the
cursor down, it zooms out.
   **Note:** You can also activate the Zoom Realtime command by rotating the wheel on a wheel
mouse. Rotating the wheel away from you zooms in, and rotating toward you zooms out.

8. Zoom to a window:
   ■ On the View tab, click Navigate panel > Zoom drop-down > Window.
   ■ Click two points around the center section of the drawing as shown by the arrows in
the following illustration.

![Illustration showing how to zoom to a window](image)

9. Pan to the lower left corner of the drawing.

10. On the View tab, click Navigate panel > Zoom drop-down > Previous. This returns you to the
last view of the drawing that you zoomed or panned to.
   **Note:** Only the last 10 view changes are saved.

11. Close all files. Do not save.
Exercise: Hands-On Tour

In this exercise, you open an existing drawing. You use display commands and explore the user interface.

1. Open C_Hummer-Elevation.dwg. Because the drawing was last saved with the Color layout view active, the drawing opens to that layout.

2. On the status bar, click Zoom. Enter E and press ENTER to select the Zoom Extents option. The drawing is magnified to fill the screen. If your workstation is equipped with a wheel mouse, double-clicking the roller button also selects Zoom Extents.

3. Use the wheel mouse, if you have it. Position the cursor to the left of the top view and roll the wheel forward then backward. If you do not have a wheel mouse, right-click anywhere in the drawing window and click Zoom. Hold the left button down and drag the mouse up and down. See how the magnification changes.
4. On the View tab, click Navigate panel > Zoom drop-down > Extents to view the entire drawing layout.

5. Now you switch the drawing view to model space, which is where the geometry for the drawing resides. On the status bar, at the bottom of the AutoCAD window and to the right, click Model.

6. On the View tab, click Navigate panel > Zoom drop-down list > Window. Click near the points indicated in the following illustration to magnify the area defined by the window.

7. On the View tab, click Navigate panel > Zoom drop-down list > Previous. This returns you to the previous view.

8. On the Quick Access toolbar, click Save.

9. In the Application Menu, select File > Close.

10. In the Application Menu, top right, you see a list of previously opened files for quick access.
Select the _C_Hummer-Elevation_ drawing. Notice that it is opened to the last view in which it was saved.

11. On the bottom right of the AutoCAD window, click Layout to activate the color layout. Close the drawing.


13. In the Select Template dialog box, click the arrow next to Open. Click Open with no Template - Imperial. This opens a blank drawing with basic settings that you can change, such as the units format.

   **Note:** For AutoCAD LT users, click _acadlt.dwt_.

14. Move your cursor near the upper right corner of your drawing area. Observe that the coordinate readout shows a screen size of about 12 x 9 units.

15. Close all files. Do not save.
Chapter Summary

Now that you have been introduced to several core features, you can begin learning how to create geometry.

Having completed this chapter, you can:

- Identify and state the purpose of the main interface elements.
- Open, create, and save drawings.
- Use the Zoom and Pan commands to view different areas of the drawing.
Creating Basic Drawings

Every drawing begins with the creation of basic geometry, objects such as lines, circles, arcs, and rectangles. These objects serve as building blocks for complex drawings and, as a result, you must master the use of the commands that create these objects.

Mastering these commands involves more than just knowing where the command is and how it works. You must also develop an understanding of the underlying coordinate system, and the settings such as object snaps, object snap tracking, and other features that are designed to assist you in creating basic objects.

There is generally more than one way to accomplish a task in the software. After you learn about the commands and features available, you can determine the methods that work best for you.

This chapter, and all subsequent chapters of the book, assume that you will be using the 2D Drafting & Annotations workspace with the toolbar ribbon at the top of the AutoCAD® window. If you are using AutoCAD LT®, while you might see slight interface differences, every attempt has been made to retain the fidelity of the learning experience when using this book.

Objectives

After completing this chapter, you will be able to:

- Identify the default coordinate system and use dynamic input, direct distance, and shortcut menus.
- Use the Line, Circle, Arc, Erase, Rectangle, and Polygon commands to create and erase geometry in the drawing.
- Use object snaps to accurately place and create objects in the drawing.
- Activate and use the Polar Tracking and PolarSnap modes to more accurately create geometry at different angles in the drawing.
- Explain, enable, and use object snap tracking to position geometry in the drawing.
- Use the Unit command to set up the drawing environment.
- Use the concepts and tools that you learned in Chapter 2 to begin a small architectural floor plan.
- Use the concepts and tools that you learned in Chapter 2 to create the initial geometry for a small mechanical assembly drawing.
Standard Object Snap and Status Bar Settings
Before completing the exercises in this chapter, refer to the "Settings for the Exercises" section in the Introduction in Volume 1.
Lesson: Inputting Data

Every drawing action requires some form of data input. Regardless of the types of geometry you create, you are constantly inputting data in one form or another.

In this lesson, you will learn to input data using the command line, dynamic input, direct distance entry, shortcut menus, and the Cartesian coordinate system. You will use the concepts you learn in this lesson in exercises throughout this course.

After completing this lesson, you will be able to use the command line, explain different types of coordinates, activate and use the Dynamic Input interface, use direct distance to enter values, and use the shortcut menu to access commands and options.

The following image illustrates how to use the Dynamic Input interface to draw a 10 unit line at 30 degrees.

Objectives

After completing this lesson, you will be able to:

- Use the command line to enter commands and command options.
- Explain the difference between a Cartesian and a polar coordinate, and between an absolute and a relative coordinate.
- Activate the dynamic input interface and list key points about using it.
- Create and edit geometry using the dynamic input interface.
- Use direct distance entry to enter distance values.
About the Command Line

There are specific AutoCAD elements such as the ribbon, menus, and other tools that are common to all Microsoft Windows applications. However, the command line interface is unique to AutoCAD.

Most commands have options with which you can control various aspects of how the command is used. You should pay attention to the command line as you work.

Command Line Defined

The command line is the primary place where you communicate with the software. On the command line, you are prompted to input information.

Command Line Options

- Command options appear on the command line. The capitalized letter(s) represents the letter(s) you enter to use that option. You are not required to enter the letter(s) as a capital letter.
- Options for the command appear within [...] brackets. If there is a default option for the command, it appears within <...> brackets. To use the default option, press ENTER.
- Press the F2 key to display the full command window. Each command that you use during your drawing session is saved here. Press F2 again to close the full command window.

The following image shows command line options and a command line default value. In this situation, the user has started the rectangle command, and has entered d for the Dimension option. After pressing ENTER, a default distance of 7.0000 is displayed. If the user does nothing but press ENTER, a value of 7.0000 is used.

![Command Line Example](image)

Command Line Example

The following image shows a typical command and its options as they are presented on the command line. The last line shows the current status of the command. The previous lines show the command line history.

```
Command: _pline
Specify start point: 0.0000
Current line-width is 0.0000
Specify next point or [Arc/Halfwidth/Length/Undo/Width]:
```
About the Coordinate System

Every object you draw is placed in either the world coordinate system (WCS) or a user coordinate system (UCS). When you create 2D geometry, data input is ultimately passed to the software in the form of Cartesian \((x,y)\) or polar coordinates \((\text{distance, angle})\). You can either manually enter these coordinates or infer them by picking a point in the drawing window.

**Cartesian Coordinate System**

Every object you draw is placed in either the World Coordinate System (WCS) or a User Coordinate System (UCS). When you create 2D geometry, data input is ultimately passed to the software in the form of Cartesian \((x,y)\) or polar coordinates \((\text{distance, angle})\). You can either manually enter these coordinates or infer them by picking a point in the drawing window.

The Cartesian coordinate system is used to determine points in space that are a specified distance from a set of perpendicular axes that intersect at the origin of the system.

In the World coordinate system, the \(X\) axis represents the horizontal direction, the \(Y\) axis represents the vertical direction and the origin is located at 0,0. Positive \(X\) moves to the right, positive \(Y\) moves up, and the \(Z\) axis moves in the positive direction directly towards you, the viewer.

*Note that for this course we will only be concerned with the \(X\) & \(Y\) coordinates since we are working in 2D. The \(Z\) coordinate will always be zero and need not be specified.*

The following image illustrates a line drawn from the origin of the coordinate system 0,0 with its endpoint at the coordinate 4,6.

![Cartesian Coordinate System Diagram](image)

To specify a Cartesian coordinate, type the \(X\) and \(Y\) coordinates and press ENTER. Example: 4,5 where \(X\) is equal to the distance from the origin along the \(X\) axis and \(Y\) is equal to the distance from the origin along the \(Y\) axis.
Polar Coordinates

A polar coordinate is a point in the coordinate system that is determined by a distance and an angle. The following illustration shows a line drawn from the origin of the coordinate system with a length of 7 units and an angle of 45 degrees.

To specify a polar coordinate, type the distance < angle, example 5<45, where Distance equals the distance traveled from the specified origin point and Angle equals the angle from the X axis.

Polar Angle

The default polar angle is measured counterclockwise from the zero angle position. The default zero angle is in the East compass direction.

The following illustration shows how angles are defined with a polar coordinate. This angle measurement applies to entering coordinates, working with arcs, and rotating objects.
Absolute and Relative Coordinates

When you type coordinates, they can be in the form of an absolute or a relative coordinate.

- An absolute coordinate represents a specific point in the current coordinate system relative to the origin point (0,0). To enter an absolute coordinate, type the values as a Cartesian coordinate (x,y) or Polar coordinate (distance angle).
- A relative coordinate is a point located from a previously selected point. To enter a relative coordinate, select your first point, then precede the next coordinate point with the @ symbol. For example @5<45 would mean 5 units at 45 degrees from the last point selected, and @3,5 would mean 3 units in the positive x direction and 5 units in the positive y direction from the last point selected.

*Note that when the Dynamic Input option is selected in the Status Bar relativity is automatically assumed.*

Entering Coordinates

- You can enter coordinates any time the software is in point acquisition mode, that is, when the Command line is prompting you to specify a point or distance.
- Every drawing contains the world coordinate system (WCS). The WCS is identical in every drawing and cannot be altered. For example, an object placed at the absolute coordinate 10,10 would be positioned in the same location in any drawing.
- Unless you specifically define a User Coordinate System, all geometry you create is drawn relative to the WCS.

<table>
<thead>
<tr>
<th>Coordinate</th>
<th>Absolute</th>
<th>Relative</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cartesian</td>
<td>24,46</td>
<td>@24,46</td>
</tr>
<tr>
<td>Polar</td>
<td>15&lt;45</td>
<td>@15&lt;45</td>
</tr>
</tbody>
</table>

The UCS icon displays differently when you are working in the world coordinate system versus a user coordinate system. The UCS icon for the world coordinate system contains a small box at the origin of the X and Y axes.
Example of Cartesian Coordinate Input

The following lines could have been drawn using Cartesian or Polar coordinates. Assuming the start point at the red arrow, the command line input for relative Cartesian or Polar coordinates would be as follows:

Point 2: @4,0 or @4<0
Point 3: @0,2 or @2<90
Point 4: @-1,0 or @1<180

About Dynamic Input

The Dynamic Input interface is a way of entering data dynamically. Rather than entering data on the command line, which is generally positioned at the bottom of the screen, you can use the Dynamic Input interface for heads-up design, entering command information on screen at the cursor location.

Using the Dynamic Input Interface

The Dynamic Input interface is context sensitive based on the current operation. For example, the input and options are different when you are drawing a line than when you are drawing a circle; they also differ based on whether you are creating or editing geometry.

Dynamic Input Interface: Dimensional Input Mode

There are two Dynamic Input interface modes: Dimensional Input and Pointer Input. The following image represents the Dynamic Input interface in Dimensional Input mode. This mode is available when the Dynamic Input option is selected in the status bar and is commonly used for the typical drawing commands such as Line, Circle, and Arc.

Note: Numbers in the following image correspond to the numbers in the list below.
1. **Tooltip:** Displays instructions for the current step in the command and also reflects the current prompt on the command line.

2. **Coordinate, Length, or Angle input fields:** Depending on the mode, these fields may vary in value and position. In the image, one field represents the current length of the polyline while the other represents the angle of the cursor. Enter a value to specify an explicit value. Press TAB to cycle between the fields.

3. **Down Arrow:** Press DOWN ARROW (on the keyboard) to display the Dynamic Input menu. Press UP ARROW to cycle through previously selected coordinates.

4. **Dynamic Input Menu:** Select an option for the command. Available options vary based on the current context and reflect the options available on the command line.

### Dynamic Input Interface—Pointer Input Mode

In the following illustration, the Dynamic Input interface has changed to Pointer Input mode because the values @ 10 < 45 were entered on the keyboard. In Pointer Input mode, you can enter coordinate information at the pointer as though your focus were on the command line. Use this mode for absolute and relative coordinates. It is also the default mode for commands such as Move, Copy, and Rotate.

Lock icons indicate a value that has been manually entered. To unlock a value, press TAB to enter the input field, press DELETE to clear the value, then press TAB to exit the input field.

The default mode for dynamic input is for relative coordinates, but you can also enter absolute coordinates. To do so, enter a pound sign before the first coordinate, for example, #2,20. If you enter 2,20 (without the # sign), the point will be relative to the last selected point. The dynamic input fields adjust to reflect the entry format. In this case, the second field represents the Y coordinate.
Dynamic Input Options

Use the Dynamic Input tab in the Drafting Settings dialog box to change settings related to the Dynamic Input interface.

Click to adjust Pointer Input options.

Click to adjust Dimensional Input options.

Click to adjust appearance-related options for the Dynamic Input tooltips.

Guidelines for Using Dynamic Input

- When you use grips to stretch objects, or when you create new objects, dimensional input displays only acute angles; that is, all angles are displayed as 180 degrees or less. Thus, an angle of 270 degrees is displayed as 90 degrees. Angles that you specify when creating new objects rely on the cursor location to determine the positive angle direction.
- Dynamic Input is not intended to replace the command window. You use both the dynamic interface prompts and the command line in your workflow.
- The Dynamic Input interface is context sensitive.
- When Dynamic Input is on, points that you enter in response to second or next point prompts default to relative.
- Depending on the location of the cursor and the status of other settings such as object snaps, polar tracking, and tooltips, other information may appear on the Dynamic Input interface including object snap tips and command line prompts.
Using the Dynamic Input Interface

You can use the Dynamic Input interface in several ways, but the primary goal of the tool is to let you draw and edit in a heads-up mode, with your focus on the graphics window instead of the command line. Because the Dynamic Input interface is context sensitive, its options and display modes are dependent on the context in which you are working. The following guidelines give an overview of how you can use the Dynamic Input interface during typical drawing and editing tasks.

Command Access

Dynamic Input Mode

Command Line: DYNMODE
Function Key: F12

Procedure: Drawing with Dynamic Input

The following steps give an overview of creating geometry using the Dynamic Input interface and Polar coordinates. Note that because the Dynamic Input display is activated, relativity is assumed and it is not necessary to enter the ampersand symbol (@).
1. Begin a command. The Dynamic Input field displays the command.

2. After you press ENTER, the interface immediately switches to Point Input mode. The tooltip gives instructions for what is required and the input fields reflect the current XY coordinate location of the cursor.

3. The Dynamic Input display prompts you for the next point. Enter a value in the Distance input field and press TAB to lock the distance and activate the Angle input field. Enter a value in the Angle input field and press TAB to lock the angle at 0 degrees. Click to select the point.
4. Enter another value in the Distance input field and press TAB to lock the distance. Move the cursor to adjust the angle value shown but note that if you simply click, the angle is rounded up to the nearest whole number as determined in the Units settings. It would be best to enter the angle for accuracy.

5. Click the final point and press ENTER to complete the line.

6. Your finished object is shown.
Procedure: Editing with Dynamic Input

The following steps give an overview of some of the ways you can edit with the Dynamic Input interface.

1. On the Home tab, click Modify panel > Copy. Select the objects to be copied and press ENTER to complete your selection.

![Select objects:]

2. The Dynamic Input interface prompts you to Specify a base point. Notice the blue down arrow. Using the arrow keys on your keyboard, you may switch to single copy mode or multiple copy mode. Select a base point on or near the object.

![Specify base point: 14.5 579.1421]

3. The Dynamic Input tooltip provides feedback. Entering @38.500<180 puts the interface in Relative Coordinate mode and places the values in the correct input fields. Press ENTER to complete the Copy command.

![Specify second point: 38.5000 <100°]
4. Select the circle to activate the grips.

5. Select a quadrant grip to display the Dynamic Input interface. Grip editing displays several options. You can resize the circle either by entering a new radius (1), or Tab for one of the other options to increase or decrease the radius (2). Enter a value in one of the input fields and press ENTER.

The circle is resized.
Using the Dynamic Input Interface to Reveal Information

You can see the length or angle of a line or the radius of an arc or circle by using the object grips. With the command line blank, select the geometry to activate the grips. Hover the cursor over one of the end grips or circle quadrants without selecting the grip. The Dynamic Input interface displays size information for the selected geometry.

Guidelines for Using Dynamic Input

■ When entering length or angle, press TAB to lock the values.
■ Before entering the length or angle, you may press TAB to cycle through the available input fields. Enter the desired values and press ENTER to complete the command.
■ To reveal the length or angle of a line, or the radius of an arc or circle, select the geometry (with the Command line blank) to activate the grips. Hover the crosshairs over one of the grips. The Dynamic Input interface displays size information for the selected geometry.
■ To Modify an object using Grips, select the object (with the Command line blank) and then select a grip. Press TAB to cycle through the available fields. Supply the desired data and press ENTER.
■ When Dynamic Input is on, points you enter in response to second or next point prompts default to relative.
■ To enter X,Y coordinate values, press # to switch to absolute coordinate entry mode.

Using Direct Distance Entry

Direct distance entry is by far the easiest and quickest way to enter data while using the Draw and Modify commands. You can enter a distance value whenever the software prompts you to select a point. The point coordinates are calculated based on the angle of the cursor from the previous point selected and the distance you enter. It is a good idea to have Polar Tracking on when using this method.

You may use this method of data entry whether the Dynamic Input mode is on or off.
Guidelines for Using Direct Distance Entry

- Turn Polar Tracking on to display the cursor's angle.
- Set the desired incremental polar angles in Polar Tracking settings.
- Enter the desired distance and press ENTER. Be sure that the accurate Polar angle is displayed.
- AutoCAD is accurate 14 places to the right of the decimal point (1.00000000000000). Therefore, it is important to enter the distance and use Polar Snap for absolute precision.
- Although turning Dynamic Input off limits the data fields displayed by your pointer, you may use Direct Distance entry with this feature on or off.

Procedure: Using Direct Distance Entry

The following steps give an overview for using the direct distance entry method.

1. Start a command such as Line and click a point to begin.
   **Tip:** Toggle off Dynamic Input on the status bar for clearer results.
2. When you are prompted to specify the next point, drag your cursor in the direction you want the line to travel, enter a distance on the command line, then press ENTER. **Tip:** Turn polar tracking on to display the current angle of your cursor.

3. Drag the cursor in the direction of the next line segment, enter a distance value, and press ENTER.

4. Repeat step 2 until the geometry is completed.
5. Press ENTER to exit the command. Your object is completed.
Exercise: Input Data

In this exercise, you gain familiarity with the various input methods including the command line, the keyboard, and the dynamic interface.

1. On the Quick Access toolbar, click New.
2. In the Select Template dialog box, click the arrow next to Open and select Open with no Template - Imperial.
3. On the status bar, make sure dynamic input is off.

Note: For AutoCAD LT users, select acadlt.dwt.

Completing the Exercise

To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 2: Creating Basic Drawings. Click Exercise: Input Data.
4. Use the Command line to create a circle:
   ■ Enter Circle. Press ENTER.
   ■ Observe the options listed in the brackets.
   ■ Click near the center of the graphics window for the center point.
   ■ Enter 1. Press ENTER.
   Zoom to view your drawing, if necessary.

5. To draw a second circle the same size as the first:
   ■ Press ENTER. This repeats the previous command.
   ■ Click to select a point to the left of the first circle.
   ■ Press ENTER to accept the default value for the circle radius.

6. Use the Line command with relative polar coordinates to draw a triangle near the circles:
   ■ To begin the Line command, enter L for line. Press ENTER.
   ■ Specify a point in the drawing window for the first point (1).
   ■ Enter the polar coordinate @2<45 (2). Press ENTER.
   ■ Enter the polar coordinate @2<135 (3). Press ENTER.

7. Display the command history:
   ■ Press F2.
   ■ Review the command history shown. Use the scroll function on the right side of the window or the mouse wheel to display additional history.
   ■ Press F2 again to turn off the command window.

8. Turn on Dynamic Input. On the status bar, click Dynamic Input.
9. Reveal geometric data using the dynamic interface:
   - Click to select the first circle that you created.
   - Place your crosshairs over, but do not click the square grip box on the right edge of the circle.
   - Verify that the circle radius is 1.
   - Press **ESC** to remove the circle selection.

10. Reveal additional geometric data using the Dynamic Input interface:
    - Click the two angular lines that you created.
    - Place your crosshairs over, but do not click the square grip box at the intersection of the two lines.
    - Observe that both the length and angle data are displayed for the selected lines.
    - Press **ESC** to remove the line selection.

11. Close all files. Do not save.
Lesson: Creating Basic Objects

All drawings consist of basic objects that you create using basic commands. In this lesson, you learn how to create objects such as lines, circles, arcs, rectangles, and polygons. You also learn how to use the Erase command to erase objects.

Learning to create basic geometry is critical to success in the software. As you become proficient with basic geometry creation, you can move on to creating more advanced object types.

Objectives

After completing this lesson, you will be able to:

- Use the Line command to create lines in the drawing.
- Use the Circle command to create circles in the drawing.
- Use the Arc command to create arcs in the drawing.
- Use the Erase command to erase objects in the drawing.
- Use the Undo and Redo commands to return to previous drawing states.
- Use the Rectangle command to create rectangles in the drawing.
- Use the Polygon command to create equal-sided polygons in the drawing.
Line Command

Use the Line command to create a single line or multiple line segments from a start point to an endpoint.

The following illustration shows a line segment being drawn using the dynamic input interface to specify the length (1) and angle (2) of the segment.

Command Access

Command Line: **Line, L**
Ribbon: **Home tab > Draw panel > Line**
Menu Bar: **Draw > Line**
Command Options

The following Line command options are available from the shortcut menu (right-click) or the Command line:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>First point</td>
<td><em>(default)</em> Specifies the start point of the line segment.</td>
</tr>
<tr>
<td>Next point</td>
<td><em>(default)</em> Specifies the endpoint of the line segment. Continue to specify next points for additional line segments.</td>
</tr>
<tr>
<td>Undo</td>
<td>Removes the previous line segment without exiting the Line command. <em>Select or enter the capitalized letter only.</em></td>
</tr>
<tr>
<td>Close</td>
<td>Appears only after you have drawn two line segments. Uses the first point of the line segments as the next point for the current segment to create a closed boundary of line segments. <em>Select or enter the capitalized letter only.</em></td>
</tr>
</tbody>
</table>

Line Command Guidelines

- Use to create a single line or multiple line segments.
- Use the Close option to connect the last segment to the beginning of the first segment.
- Line segments, even though connected, are separate, independent objects.
- If you begin the Line command and press ENTER instead of selecting a start point, the Line will resume at the last point selected, such as the end of the previous line.
- You can Undo a line segment without completely exiting the line command by typing **U** and then pressing ENTER, or selecting Undo.
Practice Exercise: Line Command

In this practice exercise you will practice using the Line command to draw the object below.

1. Begin a new drawing.
2. In the Select template dialog box, select the acad template file (dwt) and click Open.
3. Be sure the following status bar settings are on:
   - Polar tracking
   - Object snap
   - Object snap tracking
4. To draw the horizontal line:
   - On the ribbon, click Home tab > Draw panel > Line.
   - For the start point (1), select a point on the screen.
   - Drag the line to the right until you see that the tooltip indicates the polar angle is 0.

   ![Polar Angle 0]

   - Enter 4 and press ENTER.
5. Continue with the Line command to draw the remaining line segments from points (2) to (3):
   - Drag your mouse up until you see that the tooltip indicates that the Polar angle is 90.
   - Enter 1 and press ENTER.
   - Drag to < 0, and enter 1 and press ENTER.
   - Drag to < 90, and enter 1.5 and press ENTER.
   - Drag to < 180, and enter 1 and press ENTER.
   - Drag to < 90, and enter 1 and press ENTER.
   - Drag to < 180, and enter 4 and press ENTER.
6. Drag the mouse down to Polar < 270 until you see the that the object snap indicates you have reached the original endpoint (1), and click the endpoint. Be sure to click inside the Endpoint Object Snap box. Press ENTER to end the Line command.
Circle Command

Use the Circle command to create circles in the drawing. When you start the Circle command, you are prompted to select a center point, then specify the radius. Use the data input methods discussed earlier to input these values.

In the following image, the circle center point is selected and you are prompted to specify a radius.

Command Access

Circle

Command Line: CIRCLE, C
Menu Bar: Draw > Circle > choose option
Ribbon: Home tab > Draw panel > Circle
**Circle Command Options**

Circle options can be accessed from the drop down menu next to the Circle button.

![Circle Command Options](image)

Circle options can be selected from the shortcut menu (right-click) or typed at the Command line. *Type the capitalized letter(s) only.*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify center point</td>
<td><em>(default)</em> Click a point or enter a coordinate for the center of the circle.</td>
</tr>
<tr>
<td>D</td>
<td>After you specify a center point, you have the option to specify a Diameter instead of the radius.</td>
</tr>
<tr>
<td>3P</td>
<td>Create the circle based on three points you specify to define the circle's diameter.</td>
</tr>
<tr>
<td>2P</td>
<td>Create the circle based on two points you specify to define the circle's diameter.</td>
</tr>
<tr>
<td>Ttr (tan tan radius)</td>
<td>Create a circle tangent to other objects at a radius you specify.</td>
</tr>
</tbody>
</table>

The Circle command remembers the radius or diameter of the last circle drawn. If the prompt for the radius or diameter contains a value in brackets, press ENTER to reuse the value for the radius or diameter of the new circle.

*Specify radius of circle or [Diameter] <25.000>:*

Press ENTER to create a new circle with a 25 unit radius.
Circle Command Guidelines

- The Circle default when executed from the command line is Center, Radius. Specify a center point and a radius to define the circle.
- When you specify a Circle option from the drop down menu, that button remains visible in the toolbar panel.
- After specifying a center point for the Circle, simply press ENTER, if you want the circle to be the same size as the last circle made.
- After specifying a center point, type D and press ENTER if you prefer to type a diameter for the circle.
Practice Exercise: Circle Command

In this practice exercise, you use the Tan, Tan, Radius, Circle command and the 2-Point Circle. First, you draw two adjacent lines that are 5.25 units each.

1. Begin a new drawing.

2. In the Select template dialog box, select the acad template file (dwt) and click Open.

3. Be sure the following status bar settings are on:
   - Polar tracking
   - Object snap
   - Object snap tracking

4. To draw the lines:
   - Start the Line command.
   - For the start point, select the endpoint of the line (1).
   - Drag the mouse down until the Polar angle indicates that it is < 270. Enter 5.25 and press ENTER.
   - Drag the mouse to the right until the Polar angle indicates < 0. Enter 5.25 and press ENTER.
   - Press ENTER to end the Line command.

5. Adjust the display of your drawing using Zoom or Pan Real-time, if necessary.

6. To draw the smaller circle (3):
   - On the ribbon, click Home tab > Draw panel > Circle drop-down > Tan, Tan, Radius.
   - Move the cursor to the vertical line until you see the Deferred Tangent object snap and then click.
   - Now move the cursor to the horizontal line until you see Deferred Tangent again and click.
   - Specify the radius of the circle. Enter 2 and press ENTER.

7. To draw the larger circle (4):
   - On the Home tab, click Draw panel > Circle drop-down > 2-Point.
   - Move the cursor to the end of the vertical line (1) until you see the Endpoint object snap and click.
   - Now move the cursor to the end of the horizontal line (2) until you see the Endpoint object snap and click.
Arc Command

The Arc command creates an arc based on three points. Using the default method for creating an arc, you specify a start point, a second point, and an end point. The arc radius and center point are calculated based on the position of the three consecutive points you specify.

The following illustration represents an arc being created through three points.

Command Access

Arc

Command Line: ARC, A
Menu Bar: Draw > Arc > 3 Points
Ribbon: Home tab > Draw panel > Arc
Command Options

Arc options can be accessed from the drop-down menu next to the Arc button. The most common Arc options are indicated by red arrows in the following illustration.

Arc options can be selected from the shortcut menu (right-click) or typed at the Command line. Type the capitalized letter(s) only and follow the Command line prompts.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td>Specify the center point of the arc. Then you will be prompted to specify the start point.</td>
</tr>
<tr>
<td>Angle</td>
<td>Specify included angle.</td>
</tr>
<tr>
<td>chord Length</td>
<td>Specify the length of the angle chord.</td>
</tr>
</tbody>
</table>

**Arc Note**

Arcs are drawn in a counterclockwise direction unless using the 3-Point default method.
Practice Exercise: Arc Command

In this practice exercise, you use the Start, Center, End Arc command. First, you draw a rectangle. Remember that arcs are drawn counterclockwise, so it is important that you select your points in the correct order. Draw all of the arcs so that they are outside of the rectangle.

1. Begin a new drawing.
2. In the Select template dialog box, select the acad template file (dwt) and click Open.
3. Be sure the following status bar settings are on:
   - Polar tracking
   - Object snap
   - Object snap tracking
4. To draw the rectangle (any size):
   - On the ribbon, click Home tab > Draw panel > Line.
   - For the start point, specify the first corner (1).
   - Use Polar Tracking to create a rectangle and make sure you snap to the first corner (1) when done.
5. To draw the first arc:
   - On the ribbon, click Home tab > Draw panel > Start, Center, End Arc (select the down arrow by the Arc button).
   - Specify the start point of the arc. Click the rectangle Endpoint (2).
   - Specify the center point of the arc. Enter MID and press ENTER.
   - Click the midpoint of the rectangle at (3).
   - Specify the endpoint of the arc. Click the rectangle endpoint (4).
6. Repeat these steps until you have finished. Remember to draw your arcs in a counterclockwise direction, using the Start, Center, End Arc command.
Erase Command

Use the Erase command to remove geometry from the drawing. You can select objects by picking them directly, or using selection options such as a window or crossing window.

Command Access

**Command Line:** ERASE, E

**Menu Bar:** Modify > Erase

**Ribbon:** Home tab > Modify panel > Erase

---

**OOPS Command**

Use the OOPS command to retrieve geometry you accidentally erased without undoing any work you did since you last Erased.

---

**Use a Shortcut Menu**

Use the shortcut menu to alter your design more quickly. Select the objects you want to erase before entering the command or right-click and select Erase from the shortcut menu.
Practice Exercise: Erase Command

Practice the Erase command. First, draw some lines, circles, and arcs. Then practice removing them from your drawing. Try a few different ways to select the objects.

1. Begin a New drawing.
2. In the Select Template dialog box, select the `acad` template file (dwt) and click Open.
3. Draw at least eight objects in the drawing window:
   - Start the Line command. Draw some lines.
   - Start the Circle command. Draw some circles.
   - Start the Arc command. Draw some arcs.
4. To Erase, try these methods:
   - On the ribbon, click Home tab > Modify panel > Erase. Select three objects to erase, then press ENTER.
   - On the command line, enter `U`. Press ENTER to undo.
   - With the command line blank, select three objects. Notice the objects are highlighted and the grips are visible. Right-click and select Erase from the shortcut menu.
   - On the command line, enter `U`. Press ENTER to undo.
   - Start the Erase command. At the Select objects prompt, enter `L` (for Last) and press ENTER. Notice that the last object you drew is highlighted. Press ENTER to start the Erase command.
   - With the command line blank, select an object. Press DELETE.
5. Erase the objects using the Cross window option.
   - Enter `E` on the command line and press ENTER. At the select objects prompt, select a spot in the blank area on the right side of the drawing. This will initiate a selection window. Drag your mouse up (or down) and to the left. Notice that the selection window is made of dashed lines.
   - Cross the objects in the drawing, but leave some parts of the objects out of the selection window. Select to specify the opposite corner of the selection window.
   - Notice that the objects that were completely inside the selection window, are highlighted as well as the objects that were crossed by the selection window. Press ENTER to erase the objects.
   - Enter `U` at the command line and press ENTER to undo.
6. Erase the objects using the Window option.
   - On the command line, enter `E`. Press ENTER. At the select objects prompt, click in a blank area on the left side of the drawing. This will initiate a selection window. Drag your mouse up (or down) and to the right. Notice that the selection window is made of a continuous line.
   - Cross the objects in the drawing, so that some are completely within the selection but others are partially out of the window. Click to specify the opposite corner of the selection window.
   - Notice that the objects that were completely inside the selection window are highlighted but the objects that were partially out of the selection window are not highlighted. Press ENTER to erase the objects.
   - On the command line, enter `U`. Press ENTER to undo.
7. To use the OOPS command on previously erased objects:
   - On the command line enter, E. Press ENTER. Enter ALL at the Select objects prompt and press ENTER.
   - Press ENTER again to start the Erase command.
   - Now draw some more objects using the Line, Circle, or Arc commands.
   - Enter OOPS and press ENTER.
   - Notice that the objects you erased were returned to the drawing.

8. Close all drawings. Do not save.
Undo and Redo Commands

Use the Undo command to step back through every action you made, including pan and zoom. Use the Redo command to step forward through those actions again. These commands are conveniently located on the Quick Access toolbar. You can Undo at any point in the drawing session, even within some of the draw and modify commands. However you can only Redo immediately after an Undo Command.

You may also type the Undo command at the Command line. Enter U and press ENTER. If you continue to press ENTER, the Undo command will be repeated. If you enter the entire word UNDO at the Command line and press ENTER, you will see a list of Undo options at the Command line prompt.

If you are working in the AutoCAD Classic workspace the Undo and Redo buttons include down arrows that reveal lists which you can choose to undo or redo up to a selected item or step.

Command Access

**Undo**

Command Line: U, UNDO
Menu Bar: Edit > Undo
Quick Access Toolbar: Undo
Command Access

Command Line: **REDO**
Menu Bar: **Edit > Redo**
Quick Access Toolbar: **Redo**

Command Options

The following options are available only when you type the entire word **UNDO** at the Command Line. Right-click to access the shortcut menu or type the capitalized letter of the option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto</td>
<td>Groups all actions of a single command, making them reversible with a single U command.</td>
</tr>
<tr>
<td>Control</td>
<td>Limits or turns off Undo.</td>
</tr>
<tr>
<td>Begin, End</td>
<td>Groups a sequence of actions into a set. After you use the Begin option, all subsequent actions become part of this set until you use the End option.</td>
</tr>
<tr>
<td>Mark</td>
<td>Places a mark in the undo information. If you use the Back option, all sequences are undone to the mark.</td>
</tr>
<tr>
<td>Back</td>
<td>Undoes all work to the first mark that is encountered. If there are no marks placed in the undo information, the following prompt appears:</td>
</tr>
<tr>
<td></td>
<td><em>This will undo everything. OK? &lt;Y&gt;</em></td>
</tr>
<tr>
<td></td>
<td>If you continue, all steps in the drawing are undone to the beginning of the drawing session.</td>
</tr>
</tbody>
</table>

The Mredo command is similar to the expanded UNDO command in that it offers other options to redo, such as the last step of all of the prior Undo operations.
Procedure: Using Undo and Redo

The following steps give an overview of how to use the Undo and Redo commands in the drawing.

1. On the Quick Access Toolbar, click Undo (1), or enter U in the command line.

2. Each time you select the Undo button a single operation is undone. If you entered U in the command line, you can continue to press ENTER to repeat the Undo command.

3. To Redo an operation, click Redo (2) in the Quick Access toolbar or type REDO immediately following an undo operation.

4. Continue to select Redo until the drawing is returned to the desired state.

5. You can access the Undo or Redo lists on the Standard Toolbar to highlight the steps to undo or redo.

Undo and Redo Guidelines

- Undo information is only saved in the current session of the drawing. If you exit the drawing and reopen it, you cannot undo steps that were done in the previous session.
- The Redo command is only available immediately after an Undo operation.
- You can undo all the way back to the beginning of the drawing.
- Enter UNDO on the command line to view advanced Undo options.
- Enter MREDO on the command line to view advanced Redo options.
- If you have multiple drawings open at once, each drawing contains separate undo information and, as a result, you can use the Undo command independently within each drawing.
Practice Exercise: Undo and Redo Commands

Most of the time you use Undo and Redo in single steps. In this exercise, you practice using the Undo and Redo commands and some of the Undo options.

1. Begin a new, blank drawing.
2. In the Select Template dialog box, choose the acad template.
3. Draw some circles and then undo them:
   - On the command line, enter C. Press ENTER. Draw five circles.
   - On the Quick Access toolbar, click Undo until all five circles are gone.
   - On the Quick Access toolbar, click Redo repeatedly to bring all five circles back.

4. Draw some lines. Practice using the Undo command within the line command.
   - On the command line, enter L and press ENTER. Draw several continuous line segments. Press ENTER to complete the Line command.
   - On the command line, enter U. Press ENTER. Notice that all of the line segments are undone.
   - On the command line, enter L. Press ENTER. Draw several continuous line segments. Do not exit the line command. Right-click and select Undo from the shortcut menu.
   - Notice that the last line segment is undone. Right-click and select Undo again from the shortcut menu. Do not exit the line command. Continue to draw line segments. Press ENTER to complete the Line command.
5. Practice using the Undo options, BEgin and Back.
   - On the command line, enter **UNDO**. Press ENTER.
   - Enter **BE** (for BEgin). Press ENTER.
   - On the command line, enter **L**. Press ENTER. Draw some continuous line segments. Press ENTER to complete the line command.
   - Draw some circles, rectangles and arcs.
   - With the command line blank, press the up arrow on the keyboard to scroll to the UNDO command. If you pass it, use the down arrow to scroll back. When Undo is in the command line, press ENTER.
   - Enter **B** (for Back). Press ENTER.
   - This should undo the lines that you created.
Rectangle Command

Use the Rectangle command to create rectangular objects. A single polyline object is created with this command. The simplest method for creating a rectangle is to specify the first corner, then the opposite corner. Other options for creating the rectangle include the Area, Dimension, and Rotation options.

This illustration shows a rectangle with the point used to create it specified.

Command Access

Command Line: **RECTANGLE, REC**
Menu Bar: **Draw > Rectangle**
Ribbon: **Home tab > Draw panel > Rectangle**
Command Options

These Rectangle options are available after you have selected the first point for the rectangle. Right-click to select from the shortcut menu or type the capitalized letter at the Command line.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Area</td>
<td>Use this option to create a rectangle based on its area and the distance of one side, whether length or width.</td>
</tr>
<tr>
<td>Dimensions</td>
<td>Use this option to manually enter the length and width of the rectangle.</td>
</tr>
<tr>
<td>Rotation</td>
<td>Use this option to specify a rotation angle for the rectangle.</td>
</tr>
</tbody>
</table>

When you use the Distance or Area options to specify the rectangle size, the Length prompt refers to the horizontal distance, while the Width prompt refers to the vertical distance. If the rectangle is being rotated, Length refers to the distance along the rotation angle, while Width refers to the distance perpendicular to the rotation angle.

Rectangle Command Guidelines

- The Rectangle command generates polyline objects.
- Because rectangles are polylines, selecting any segment selects the entire rectangle.
- The simplest method for drawing a rectangle is to specify the first corner, then the opposite corner using relative x,y coordinates. Example: after selecting the first point, type @4,5 to make a rectangle that is 4 x 5.
- Rectangles can be initiated from any corner. After selecting the first point, if you type @-4,-5 you will make a rectangle that is located below and to the left of the first point selected.

When using the dimension input option, you need to click to select an orientation. After you enter the length and width values, move your cursor up and down or left and right to view the available orientations. When the orientation you want is displayed, click to create the rectangle.
Practice Exercise: Rectangle Command

Practice drawing rectangles using coordinate dimensions. Practice other Rectangle options. Adjust your display as you work using the Zoom and Pan Realtime commands.

1. Open a new drawing.
2. Check that the Dynamic Input option on the status bar is not selected.
3. To draw Rectangles using relative coordinates @x,y:
   - On the ribbon, click Home tab > Draw panel > Rectangle.
   - To specify the first corner, click anywhere in the drawing window.
   - At Specify first corner point prompt, enter @4,5 and press ENTER.
   - Notice that a rectangle was drawn up and to the right of the first point selected. If this did not happen, then you forgot to enter @ before the x,y coordinates. Try again.
4. Continue to draw Rectangles using relative coordinates @x,y:
   - On the Home tab, click Draw panel > Rectangle. Click the first corner anywhere in the drawing window.
   - Enter the relative coordinates @x,y and press ENTER to make rectangles with the following dimensions:
     - 6 x 7 (enter @6,7)
     - 7 x 6 (enter @7,6)
     - 9 x 9 (enter @9,9)
5. Turn on the Dynamic Input option on the status bar.
6. To draw a rectangle 7 x 10:
   - On the Home tab, click Draw panel > Rectangle. Click the first corner anywhere in the drawing window.
   - Enter 7,10 (do not enter the @ symbol) and press ENTER.
   - A rectangle should have been made up and to the right of the start point. If not, check to be sure that Dynamic Input is on in the Status Bar and try again.
   - Press F2.
   - Observe that @ symbol was automatically added to the coordinate making it relative to the last point you selected.
   - Practice making the following rectangles:
     - 2 x 2 (enter 2,2)
     - 4 x 6 (enter 4,6)
7. To use the Rectangle > Area option:
   - On the Home tab, click Draw panel > Rectangle.
   - Click a point anywhere in the drawing window for the first corner.
   - Enter A (for Area) and press ENTER.
   - Enter 35 for the area and press ENTER.
   - To specify the Length, press ENTER to accept the default if [Length] is already in brackets. Otherwise, enter L and press ENTER.
   - Enter 7 for the rectangle length and press ENTER.
Polygon Command

Use the Polygon command to create regular polygon geometry by specifying the center point and radius of an imaginary circle, or the start point and endpoint of one of the polygon edges. Regardless of the method you choose to define the polygon, all of its sides are equal in length.

The default method for creating polygons is to specify a center point and radius. When you choose this method, you must choose either the Inscribed or Circumscribed option. Depending on the option you choose, the size of the polygon is calculated as shown in the following image.

Command Access

Command Line: POLYGON, POL
Menu Bar: Draw > Polygon
Ribbon: Home tab > extended Draw panel > Polygon
Command Options

The following Polygon command options are available from the shortcut menu (right-click) or the Command line. *Type the capitalized letter(s) of the option.*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter number of sides</td>
<td>Polygons can have between 3 and 1024 sides.</td>
</tr>
<tr>
<td>Specify center of polygon</td>
<td><em>(default)</em> Note that while you may pick any point for the center of a polygon, once it is made you will not be able to simply snap to its center.</td>
</tr>
<tr>
<td>Inscribed in circle</td>
<td>Draws a polygon within a designated radius.</td>
</tr>
<tr>
<td>Circumscribed about circle</td>
<td>Draws a polygon outside of a designated radius.</td>
</tr>
<tr>
<td>Edge</td>
<td>Draws a polygon based on the number of sides and the length of a specified edge.</td>
</tr>
</tbody>
</table>

Polygon Command Guidelines

- Polygons can have between 3 and 1024 sides.
- Regardless of the number of sides you choose, all sides are equal in length.
- The Polygon command creates polyline objects.
- Polygon is a good tool for creating balloons and other types of annotation symbols.
Practice Exercise: Polygon Command

Use the Polygon command to draw a 6-sided polygon that is inscribed about a circle, one that is circumscribed about a circle, and one that has an edge length of 1. First, draw two circles with a radius of 1.5, then draw the polygons.

Note: Although you will draw the inscribed and circumscribed polygons inside a circle, it is only to compare the two options. It is not necessary to draw a circle first to make a polygon.

1. Open a new drawing using the acad.dwt template.
2. Click the following status bar options so that they are on:
   - Polar tracking
   - Object snap
   - Object snap tracking

On the status bar, right-click Object Snap and click the Center snap mode so that it is also on.

3. To draw a polygon that is inscribed in a circle, as shown in example 1:
   - On the ribbon, click Home tab > Draw panel > Polygon.
   - Enter 6 for the number of polygon sides.
   - Click the center of the circle for the center of the polygon. If object snap is on and center mode is selected, you will see the center snap indicator, as shown below.

   - Enter I (for Inscribed). Press ENTER.
   - To specify the radius of the polygon circle, enter 1.5. Press ENTER.
4. To draw a polygon that is circumscribed about a circle, as shown in example 2:
   - On the Home tab, click Draw panel > Polygon.
   - Enter 6 for the number of polygon sides.
   - Click the center of the circle for the center of the polygon. Click when you see the circle’s center object snap.
   - Enter C (for Circumscribed). Press ENTER.
   - To specify the radius of the circle, enter 1.5. Press ENTER.

5. To draw a polygon using the Edge option, as shown in example 3:
   - On the Home tab, click Draw panel > Polygon.
   - Enter 6 for the number of polygon sides.
   - Enter E (for Edge). Press ENTER.
   - Click anywhere in the drawing window to specify the first endpoint of the edge.
   - Drag the cursor and notice that with PolarSnap on you can specify the polar angle of the edge. Enter 1. Press ENTER.
Exercise: Create Basic Objects

In this exercise, you create a simple mechanical bracket using the basic geometry commands such as Line, Circle, Arc, Rectangle, and Polygon.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 2: Creating Basic Drawings. Click Exercise: Create Basic Objects.

Practice Creating Basic Objects: Part 1

In this part of the exercise, you begin to draw the front view of the bracket, beginning at point (1) and ending at point (2). Then, you resume drawing from point (1) to point (3).

1. Open M_Create-Basic-Objects.dwg.

2. On the status bar, make sure the following settings are on:
   - Polar tracking
   - Object snap
   - Object snap tracking
   - Dynamic input

3. To begin the line at point (1):
   - On the Home tab, click Draw panel > Line.
   - Enter 100, 50. Press ENTER.
   - Enter 100. Press TAB.
   - Enter 0
     The values should appear in the Input interface as shown in the following image. Note: The values should appear in the Input interface as shown in the following image.
     - Click to create the line.
4. To draw a second line perpendicular to the first:
   - Drag the cursor upwards and enter 100. Press TAB.
   - Make sure the angle field displays 90 degrees, then click to draw the line.

5. To draw another line:
   - Drag the cursor to the left making sure that the angle field displays 180 degrees.
   - Enter 25. Press ENTER.
   **Note:** Using direct distance entry in combination with dynamic input provides you with optimal flexibility in creating your drawings.

6. To draw another line:
   - Drag the cursor downward making sure that the angle field displays 90 degrees.
   - Enter 50. Press ENTER.
   - Press ENTER again to finish the line command at point (2).

7. To undo all the lines that you just drew:
   - On the Quick Access toolbar, click Undo.
   - Notice that all of the lines that you created in the previous steps are removed.
8. To redo the lines:
   ■ On the Quick Access toolbar, click Redo.

   Notice that all of the lines removed with the Undo command are returned.

9. To draw a line using object snaps:
   **Note:** Object snaps are points on objects which enable you to accurately position other objects. They are covered in detail in another lesson.
   ■ On the Home tab, click Draw panel > Line.
   ■ As you approach the endpoint of the line, the endpoint object snap marker should appear.
   ■ Click to select the endpoint of the line.

10. To draw a line perpendicular to the last:
    ■ Drag the cursor upward making sure that the angle field displays 90 degrees.
    ■ Enter 100. Press ENTER.

11. To draw a line and correct a mistake using the Undo command:
    ■ Drag the cursor to the right making sure the angle field displays 0 degrees.
    ■ Enter 35. Press ENTER.
    ■ Right-click near your last point. Click Undo.
    ■ Because you are still in the Line command, only the last line segment that you drew is removed.
    ■ Drag the cursor to the right again, making sure that the angle field displays 0 degrees.
    ■ Enter 25. Press ENTER.
12. To draw a line perpendicular to the last:
   ■ Drag the cursor downward, making sure that the angle field displays 90 degrees.
   ■ Enter 50. Press ENTER.

   ![Drawing example](image)

13. Press ENTER to exit the Line command. Proceed to part two of this exercise.

![Drawing example](image)

**Practice Creating Basic Objects: Part 2**

In this part of the exercise, you draw the arc (1) in the front view of the bracket and add the side view (2). You then place the circles and polygons (3) in the four corners of the front view.

1. Now draw the arc:
   ■ On the Home tab, click Draw panel > Arc.
   ■ Select the endpoint of the previous line.
   ■ Press DOWN ARROW and click End on the shortcut menu.

   ![Drawing example](image)

2. Select the endpoint on the right side of the opening.
3. To finish the arc:
   - Drag the cursor to the left, making sure that the angle field displays 180 degrees.
   - Enter 25. Press ENTER.
   - Your drawing should now appear as shown.

4. Click File menu > Save.
   Tip: You should develop a habit of saving files often.

5. To draw a rectangle:
   - On the Home tab, click Draw panel > Rectangle.
   - Touch (DO NOT CLICK) point (1) as indicated in the following image.
   - Drag the cursor to the right. The extension object snap draws a dashed extension line.
   - Click near point (2).

6. To position the rectangle:
   - Right-click near your first point and select Dimensions on the shortcut menu.
   Note: This specifies the Dimension option of the Rectangle command.
   - For the length, enter 25. Press ENTER.
   - For the width, enter 100. Press ENTER.
   - Click in the upper right of the drawing to position the rectangle.
7. To draw a circle:
   - On the Home tab, click Draw panel > Circle.
   - Enter 112.50,65. Press ENTER.
   - In the Dynamic Input Radius field, enter 7.5. Press ENTER.

8. To draw a rectangle:
   - On the Home tab, click Draw panel > Rectangle.
   - Select the center point of the circle (1).
   - Note: The object snap marker should appear as you approach the center of the circle.
   - Drag the cursor to the upper right (2) and enter 75,70. Press ENTER.
   - Your drawing should appear as shown.

9. To draw three more circles as shown:
   - On the Home tab, click Draw panel > Circle.
   - Create three circles, each with a 7.5 unit radius, using the corners of the rectangles as center points.
   - Tip: The software stores the last radius that you entered. If the command prompt is reading <7.500> you can press ENTER to reuse that value for the radius.

10. On the Home tab, click Modify panel > Erase. Select the rectangle that was used to position the circles. Press ENTER.

11. To draw a polygon circumscribing the top left circle:
   - On the Home tab, click Draw panel > Polygon.
   - When prompted for the number of sides, enter 6.
   - Select the center of the top left circle.
   - In the Dynamic Input menu, select Circumscribed About Circle.
   - For the radius, enter 8. Press ENTER.
12. To create three similar polygons circumscribing the other circles:
   - Press ENTER to repeat the Polygon command.
   - Create three additional polygons on the remaining circles as shown.

13. Close all files. Do not save.
Lesson: Using Object Snaps

In this lesson, you learn what object snaps are, why they are important, and how to use them effectively in your drawing. You will be able to explain what object snaps are including the difference between running object snaps and object snap overrides. You will also be able to use objects snaps to select snap points in the drawing.

You will use object snaps for all drawing and most editing operations. Using object snaps is the best way to ensure the accuracy of all of your objects.

In the following illustration, the image on the left shows a door placement that used an object snap to place the door. The image on the right shows what the door placement looks like if you do not use an object snap.

Objectives

After completing this lesson, you will be able to:

- Explain what object snaps are and why they are used.
- State the difference between running object snaps and object snap overrides and identify the different Object Snap modes.
- Use running object snaps and object snap overrides to select snap points in the drawing.
**About Object Snap**

Every object you create has various selectable points that you can use to position other objects. Every time you create an object you are required to specify a point or location. It is critical that these points be defined accurately if you expect your drawing to be accurate.

**Object Snaps Defined**

The following image shows three of the most basic types of objects that you can create: a line, a circle, and an arc. In this example, the line has two unique snap types with three possible locations that you can select; the circle has two unique snap types with five possible locations that you can select; the arc has three unique snap types with four possible locations that you can select.

1. Endpoint
2. Midpoint
3. Center point
4. Quadrant

Object snaps exist for each of the previously mentioned points and more. You use them to select those points accurately. Attempting to accurately select these points without using object snaps would be very time-consuming and inaccurate.

**Effect of Using Object Snaps**

In the following image, the smaller circle needs to be concentric within the larger circle. By using the Center object snap, you can place the smaller circle precisely in the center of the larger circle.

By examining each circle’s coordinates, you can verify that they both share the same center point.
Effect of Not Using Object Snaps

In the following image, the user attempted to create the vertical line at the endpoint of the horizontal line without using object snaps. Under normal viewing circumstances, the lines appear to be connected correctly; however, after zooming in to the geometry, you can see that the lines are not connected at the endpoints.

Object Snap Key Points

- Using object snaps to place objects in relation to other objects in the drawing is critical for accuracy.
- Every object you can create contains at least one point that is selectable with an object snap.

Object Snaps

You can access object snaps using several different methods. Running object snaps are generally set and then turned on or off, while object snap overrides represent a one-time use of the selected object snap.

- Running object snaps refer to object snaps that are set and available when the Osnap setting is on.
- Object snap overrides refer to an object snap that you select manually via the toolbar, shortcut menu, or command line. The object snap remains in effect until you specify the next point.

Running Object Snap

If you need to use the same object snap repeatedly, you can set it as a running object snap, which means it stays on until you turn it off. For example, you might set the object snap to center if you need to connect the centers of a series of circles with a line. This feature increases speed and accuracy.

Another feature of running object snap is that multiple object snaps can be on at the same time.
Running Object Snap

Command Line: \texttt{OSNAP}
Menu Bar: \textit{Tools} > \textit{Drafting Settings} > \textit{Object Snap Tab}
Keyboard Shortcut: \texttt{F3}
Toolbar: \textit{Object Snap}
Status Bar: \textit{Object Snap}

Object Snap Settings

The quickest way to turn Running Object Snap on or off is from the Status bar button (1). If you right-click on this button, you can select Settings (2) to change the object snap options in the Drafting Settings dialog box (shown below). You can also select the snap modes from the shortcut menu. A selected object snap mode will be highlighted (3).

Notice that information in the Object Snap tab of the Drafting Settings dialog box is similar to the shortcut menu shown above.
Next to each available object snap is an icon referred to as the AutoSnap marker. If AutoSnap is turned on, the marker appears whenever you move the cursor over a snap point. Press the Tab key to cycle through the available snap points. Never turn all the object snap modes on at once. It is better to have several object snaps chosen (such as Endpoint, Midpoint and Intersection) and go back to add others as needed or use the object snap override.

When Are Object Snaps Available?
You can specify an object snap whenever the software prompts for a point.
Object Snap Override

Object Snap override means that the snap stays in effect until you specify the next point. You are in snap override mode if you click an object snap from the shortcut menu or the object snap toolbar before selecting the specified point.

Command Line: While being prompted to select a point, enter the first 3 letters of the object snap and press ENTER (i.e. MID, INT, NEA)
Menu Browser: Tools > Toolbars > ACAD > Object Snap
Toolbar: Object Snap (access from the Menu Browser)
Shortcut Menu: SHIFT + right-click in the drawing window
Object Snap Modes

Note that an object snap override will cancel:
- If you miss your mark.
- If you select an object snap twice before selecting your point.

In the following examples:
- Point 1 identifies the initial point used to select the object.
- Point 2 identifies the point snapped to, or the second pick point if it is required.
- Point 3 identifies the point snapped to if two pick points were required.

**Endpoint**: Snaps to the closest endpoint of an arc, elliptical arc, line, multiline, polyline segment, spline, region, or ray, or to the closest corner of a trace, solid, or 3D face.

![Endpoint example](image1)

**Midpoint**: Snaps to the midpoint of an arc, elliptical arc, line, multiline, polyline segment, region, solid, spline, or xline.

![Midpoint example](image2)

**Center**: Snaps to the center points of circles, arcs, or ellipses.

![Center example](image3)
**Node:** Snaps to a point object, dimension definition point, or dimension text origin.

**Quadrant:** Snaps to quadrant points on a circle, arc, or ellipse.

**Intersection:** Snaps to the intersection of any two of the following: arc, circle, ellipse, elliptical arc, line, multiline, polyline, ray, region, spline, or xline.

**Extended Intersection:** Snaps to the imaginary intersection of two objects that would intersect if the objects were extended along their natural paths.

**Note:** This option is not available as a running object snap. Use the Intersection object snap as an override.
**Extension:** Causes a temporary extension line to display when you pass the cursor over the endpoint of objects, so you can draw objects to and from points on the extension line. You can also use the Extension object snap to find the intersection of two objects that would intersect if the objects were extended along their natural paths.

**Insertion:** Snaps to the insertion point of an attribute, a block, a shape, or text.

**Perpendicular:** Snaps to a point perpendicular to an arc, circle, ellipse, elliptical arc, line, multiline, polyline, ray, region, solid, spline, or xline.

**Tangent:** Snaps to a point on a circle or an arc that forms a line tangent to the object. Snaps to the tangent of an arc, circle, ellipse, elliptical arc, polyline arc segment, or spline.
**Nearest:** Snaps to the nearest point on an arc, circle, ellipse, elliptical arc, line, multilines, points, polylines, rays, splines, or xlines.

**Apparent Intersection:** Snaps to the apparent intersection of two objects (arc, circle, ellipse, elliptical arc, line, multilines, polylines, rays, splines, or xlines) that do not intersect in 3D space but may appear to intersect in the current view.

**Parallel:** Draws a vector parallel to another object whenever you are prompted for the second point of a vector.

**None:** Temporarily turns off all running object snaps for the next selection. Available only as an override, use this object snap when running objects snaps are turned on and you need to temporarily override all object snaps.
Using Object Snap

When you turn on multiple running object snaps, the software uses the object snap most appropriate to the object you select. If two potential snap points fall within the selection area, the softwaresnaps to the eligible point closest to the center of the target box.

You can add to or subtract from your object snap modes without exiting a current command. Right-click OSNAP on the status bar and then click Settings. Add additional modes or remove modes. When you click OK, you return to the drawing area and can continue creating your design.

In the following illustration, the image on the left shows the cursor closer to the midpoint of the line; therefore, the midpoint will be selected. On the right, the cursor is closer to the end of the line; the endpoint will be selected.

Cycling Through Multiple Object Snaps
If the Dynamic Input interface is turned off, you can press TAB to cycle through multiple valid object snaps while touching an object.

Procedure: Using Running Object Snaps

The following steps are an overview of using running object snaps.

1. On the Status Bar, right-click Object Snap. Click Settings.
2. In the Drafting Settings dialog box, verify that some of the object snaps are selected and the Object Snap On (F3) option is selected. Click OK.
3. On the Home tab, click Draw panel > Line. Place the cursor near other geometry in the drawing. The AutoSnap marker appears as your cursor approaches a snap point.

4. Click to select the snap point, then move the cursor to the next point on the screen. As you approach a snap point, the AutoSnap marker appears near the cursor. Click to select the snap point.

If you are using a three-button mouse or a wheel mouse, you can set the default behavior for the middle button or wheel to activate the Object Snap shortcut menu. Do this by setting the MBUTTONPAN system variable to 0.

- On the command line, enter MBUTTONPAN. Press ENTER.
- Enter 0.
- Press ENTER.

**Procedure: Using Object Snap Overrides**

The following steps are an overview of how to use the object snap overrides.

1. Begin creating or editing geometry.

2. When the software prompts you to select a point, select an object snap from the shortcut menu. Then position your cursor near the object containing the snap point. The AutoSnap marker should appear (1), indicating the snap point. Click to select the point.
3. SHIFT+right-click and select the object snap from the shortcut menu.

4. Move your cursor to the next object. The AutoSnap marker appears next to the snap point.

AutoSnap Aperture

You can use the AutoSnap aperture box to inform you when object snaps are active. By default, this option is turned off. The following image shows the AutoSnap aperture box. When any portion of the aperture box touches an object with a valid snap point, the AutoSnap marker appears, indicating a selectable snap point.
Options Dialog Box: Drafting Settings Tab

Under AutoSnap settings, place a check mark in the box next to the AutoSnap Aperture Box.

Under Aperture Size, adjust the aperture size by dragging the slider left or right. You can see a preview of the size to the left of the slider. *Hint: These kinds of adjustments work well just left of center on the sliding adjustment bar.*
Practice Exercise: Running Object Snap and Object Snap Overrides

In order to practice using running object snap and object snap overrides, you create this drawing two times. The first time, do this drawing with the Running Object Snap option turned on. The second time, turn it off and use the overrides by selecting the object snap each time before you pick your point.

1. Begin a new drawing.
2. Be sure that the object snap is on.
3. Draw a rectangle (any size):
   - On the Home tab, click Draw panel > Rectangle.
   - Click to specify the first corner.
   - Drag your mouse and click to specify the other corner.

Right-click and check Endpoint, Midpoint, and Intersection.

4. Draw four circles the same size with the centerpoints at each corner of the rectangle:
   - On the Home tab, click Draw panel > Circle.
   - For the centerpoint of the circle, click the intersection (or endpoint) of the lines at a corner.
   - Make your first circle (any size).
   - Press ENTER to repeat the Circle command.
   - Click the endpoint of a line at another corner.
   - Press ENTER to accept the default size [which will be in brackets]
   - Repeat for the other two circles.

5. Draw four connecting lines from the midpoint of each line in the rectangle:
   - On the Home tab, click Draw panel > Line.
   - Move the mouse to the midpoint of a line on the rectangle.
   - Click when you see the Midpoint object snap marker.
   - Move the mouse to the midpoint of the adjacent line and click when you see that Midpoint marker.
   - Repeat for the remaining lines.

6. Erase everything. Begin this drawing again. This time turn object snap off.
7. First, draw the rectangle (any size), then create the same drawing as before using the single object snap overrides. To draw the circles:
   - On the Home tab, click Draw panel > Circle.
   - Before you specify the centerpoint of the circle, shift+right-click and select Endpoint.
   - Click the Endpoint of the line.
   - Make the circle any size and repeat these steps for the other three circles.
8. To draw the four connecting lines from the midpoint of each line in the rectangle:
   ■ On the Home tab, click Draw panel > Line.
   ■ Shift+right-click and select Midpoint from the shortcut menu.
   ■ Move the mouse to the midpoint and click when you see the Midpoint object snap marker.
   ■ Continue with the Line command. Shift+right-click and select Midpoint from the short-cut menu and move the mouse to the midpoint of the adjacent line. Click when you see that marker.
   ■ Repeat these steps for the remaining lines. Though it is far easier and quicker to use running object snap, it is also convenient to occasionally use the object snap overrides. In this exercise you turned object snap off to do the second drawing, however note that it can be left on when the object snap overrides are needed.

9. Close all files. Do not save.
Exercise: Use Object Snaps

In this exercise, you create geometry using running object snaps and object snap overrides. When you have completed the exercise, you will be able to use object snaps to create and edit geometry.

Note: The exercise covers most but not all objects snaps.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 2: Creating Basic Drawings. Click Exercise: Use Object Snaps.

1. Open M_Object-Snaps.dwg.
2. On the status bar, make sure the following settings are on:
   - Object snap
   - Dynamic input

3. To set object snaps:
   - On the status bar, right-click Object Snap. Click Settings.
   - In the Drafting Settings dialog box, Object Snap tab, set the running object snaps as shown in the following illustration.
   - Clear all object snaps in the column on the right-side.
   - Click OK.

4. To draw a line:
   - On the Home tab, click Draw panel > Line.
   - Select the endpoints as shown in the following illustration. Notice the appearance of the object snap.
   - Press ENTER to end the Line command.
5. Press ENTER to repeat the Line command. Use the Endpoint object snap to create another line right next to the previous one.

6. To draw a circle:
   - On the Home tab, click Draw panel > Circle.
   - Touch the outer circle and you should see the Center snap marker. When the marker appears, click to select the center point.

   Enter 6. Press ENTER. Your circle should appear as shown in the following image.

   7. Repeat the Circle command for the other three corners of the part. Tip: The last radius value that you used is remembered, so when you are prompted for the radius, press ENTER. Over the next few steps, you will use the object snap overrides to create geometry on the part.

   8. To draw a line:
      - On the Home tab, click Draw panel > Line.
      - SHIFT+right-click and click Quadrant on the shortcut menu.
      - Select the lower quadrant of the circle on the bottom left of the part.
      - SHIFT+right-click and click Perpendicular on the shortcut menu.
      - Select the vertical line on the part. Press ENTER to end the Line command.
9. Repeat the previous step on the opposite side of the part.

10. Close all files. Do not save.
Lesson: Using Polar Tracking and PolarSnap

In this lesson, you learn how to create geometry at precise distances and angles from other geometry using polar tracking and PolarSnap.

You might not use polar tracking and PolarSnap every day, but knowing how and when to use these tools greatly increases your productivity in certain situations.

In the following illustration, polar tracking and PolarSnap are used to create geometry at precise angles and distances.

Objectives

After completing this lesson, you will be able to:

- Use the Polar Tracking and PolarSnap modes efficiently and effectively.
Using Polar Tracking and PolarSnap

Because everything that you create requires some degree of precision, it is critical that you learn the different options for creating geometry accurately and yet efficiently. Previously, you learned how to enter coordinate data in the form of absolute and relative coordinates. These methods, though important, are not always the most efficient for creating geometry.

Using polar tracking and PolarSnap, you can create geometry with the same precision as coordinate entry allows you, but more efficiently. To use these features, you need to adjust their options and turn them on using the status bar buttons.

In the following illustration, the same paths are being drawn using polar tracking and PolarSnap. The alignment paths appear as dotted lines extended indefinitely from the point of your cursor. The polar tooltips display the current position of the cursor relative to the last point selected. The path on the left is using polar tracking with an absolute angle measurement, while the path on the right is using the Relative to Last Segment option.

Using polar tracking with PolarSnap, you can accurately draw the previous geometry without having to enter cumbersome coordinates.

Command Access

Menu Bar: Tools > Drafting Settings > Polar Tracking tab
Keyboard Shortcut: F10
Status Bar: Polar Tracking; Right-click > Settings
Drafting Settings Dialog Box: Polar Tracking Tab

Use the following options to control various aspects of the polar tracking feature.

1. Select to turn on polar tracking. You can also press F10 to toggle polar tracking on or off.

2. Select an angle from the list to increment the polar alignment paths as the cursor approaches the selected angle.

3. Select to snap to the additional angles defined in the list.

4. Click to define an additional PolarSnap angle.

5. Click to delete the selected angle in the Additional Angles list.

6. Click to display the angle of the alignment path as an absolute angle in the current coordinate system.

7. Click to display the angle of the alignment path relative to the last segment drawn.

Drafting Settings Dialog Box: Snap and Grid Tab

Use the Snap and Grid tab of the Drafting Settings dialog box to adjust the snap settings for use with polar tracking. Use the options highlighted in the following illustration to enable precision cursor movement along the polar tracking alignment path.

1. Click to enable the cursor to snap to predefined distances along the alignment path.

2. Enter a distance to increment the cursor as it moves along the alignment path. This option is only available when PolarSnap is selected.
Procedure: Using Polar Tracking and PolarSnap

The following steps give an overview of using polar tracking and PolarSnap to create geometry.

1. Right-click Polar Tracking on the status bar and click Settings. In the Drafting Settings dialog box, Polar Tracking tab, you can turn polar tracking on and off and select an increment angle from the list.

2. You can set a PolarSnap increment as shown in the following list or key in values with direct distance entry.
   - In the Drafting Settings dialog box, Snap and Grid tab, select the Snap On (F9) option.
   - Under Snap Type, click PolarSnap.
   - Under Polar Spacing, for Polar Distance, enter a distance.
   - Click OK.
3. Begin creating geometry such as lines or polylines. Click a point in the drawing window and drag your cursor to the next point. The polar tracking tooltip displays the polar distance and angle.

4. Continue selecting points, using the polar tracking tooltips for precise distances and points as shown.

Polar Tracking and PolarSnap Guidelines
- Using polar tracking, you can quickly snap to predefined angle increments while moving the cursor to draw or edit geometry.
- Polar tracking is more flexible than traditional Ortho mode that restricts your cursor movement to horizontal or vertical directions, yet polar tracking offers the same benefit of being able to easily draw lines at common angles.
- Using PolarSnap, you can select points along the alignment path that would otherwise require the use of cumbersome coordinate entry.
- Unlike Grid snap, which increments all cursor movement, PolarSnap forces the cursor to move in increments only when the angle of the cursor is equal to a polar tracking angle increment. When the cursor angle is not an increment of the polar tracking angle, the cursor can move freely.
**Grid and Snap**

When you activate the grid, a pattern of dots appears in the background. The area represented by these dots is referred to as the drawing limits.

In the following illustration, the rectangle was drawn with Grid and Snap turned on. Notice how the rectangle is aligned perfectly with the grid pattern.

To turn on Grid or Snap, click the appropriate buttons on the status bar.

**Note:** You can turn these two settings on or off independently of each other.
Ortho Mode

An alternate method to polar tracking is Ortho mode. When Ortho mode is turned on, your cursor can move parallel only to the X or Y axes, so you can quickly draw straight lines or move items easily along the X or Y axes.

In the following illustration, lines were drawn using Ortho mode. The arrow indicates the temporary override symbol that appears when a temporary override key is being used. In this case, the temporary override for Ortho mode is active.

Click ORTHO on the status bar or press F8 to turn Ortho mode on or off.

Note: Press and hold SHIFT while drawing or moving geometry to activate the Ortho mode temporary override. As long as the SHIFT key is pressed, Ortho mode is active.
Exercise: Use Polar Tracking and PolarSnap

In this exercise, you create lines at precise distances and angles using polar tracking and PolarSnap. When you have completed the exercise, you will be able to use the polar tracking and PolarSnap features to create precise geometry.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 2: Creating Basic Drawings. Click Exercise: Use Polar Tracking and PolarSnap.

1. Open M_Roller.dwg.
2. On the status bar, make sure the following settings are on:
   - Snap
   - Polar tracking
   - Object snap
   - Model

3. Right-click Polar Tracking and select Settings.

   In the Drafting Settings dialog box, Polar Tracking tab:
   - Select 15 from the Increment Angle list.
   - Under Polar Angle Measurement, click Absolute.

The completed exercise

Lesson: Using Polar Tracking and PolarSnap  ■  125
4. On the Snap and Grid tab:
   ■ Click PolarSnap.
   ■ Enter 1 in the Polar Distance field.

5. On the Object Snap tab:
   ■ Make sure Endpoint and Node are selected.
   ■ Click OK.

6. To draw the line using polar tracking:
   ■ Activate the Line tool.
   ■ Specify the line’s start point from the point object, using the Node object snap override.
   ■ Drag the cursor to the right until the polar tracking tooltip reads 25.00 < 0 degrees. Click the point.

7. Position the cursor so that the polar angle tooltip reads 15.00 < 45. Click the point.

8. Position the cursor so that the polar angle tooltip reads 25.00 < 0. Click the point.

9. Position the cursor so that the polar angle tooltip reads 15.00 < 315. Click the point.
10. Position the cursor so that the polar angle tooltip reads 25.00 < 0. Click the point.

11. Move the cursor upwards until the polar tracking cursor reads 70.00 < 90. Click the point.

12. Repeat these steps to draw the top half of the object which mirrors the bottom half, changing the Polar angle accordingly. Your final endpoint should be at the original start point.

13. Press ENTER to repeat the Line command. Select the endpoints indicated in the following image to draw the inner vertical lines. Press ENTER to end the Line command.

14. Close all files. Do not save.
Lesson: Using Object Snap Tracking

In this lesson, you learn what object snap tracking is and how it can assist you in creating geometry. When you have completed the lesson, you will be able to describe and use object snap tracking to position geometry.

Object snap tracking is the most efficient way to locate a point using your existing objects as reference.

In the following image, object snap tracking is used to quickly locate the center of the rectangle.

Objectives

After completing this lesson, you will be able to:

- Describe object snap tracking.
- Use object snap tracking to position geometry.
About Object Snap Tracking

You often need to place or create geometry at a location relative to other objects in the drawing. While you could create construction geometry for the purpose of aligning the new geometry, with object snap tracking you can accomplish the same result much faster.

Object Snap Tracking Defined

Object snap tracking works in combination with object snaps to enable you to temporarily acquire and track up to seven points. Once you acquire points, object snap tracking provides horizontal, vertical, or polar alignment paths relative to the points that you have acquired.

In the following image, the table is being moved to the room center using object snap tracking. To center the table in the room, the midpoint of the wall on the left (1) and the midpoint of the wall below (2) have been acquired. Triangular glyphs at the midpoints indicate that the points have been acquired. As the table is positioned near the imaginary intersection, the alignment paths (3) appear indicating the intersection. The Dynamic Input interface displays the current position as 0 degrees from the left midpoint and 90 degrees from the lower midpoint.
When you need to know the center of a noncircular object such as a rectangle or polygon, use object
snap tracking to locate the center point.

**Object Snap Tracking Guidelines**
- Use object snap tracking to reduce the need to create construction geometry.
- You can use object snap tracking to calculate the center point of noncircular objects.
- When you use object snap tracking in conjunction with dynamic input, the Dynamic Input
  interface displays position information related to the acquired points.

**Using Object Snap Tracking**

To use object snap tracking, you acquire points from geometry in the drawing using running object
snaps. As you acquire points on the geometry, a small plus (+) sign appears on the point. This indicates
that the point is being used for object snap tracking.

In the following image, the midpoint of the left side of the rectangle has been acquired. Notice the
plus (+) symbol indicating the acquired point. The midpoint of the bottom of the rectangle is being
touched to acquire the point.
Lesson: Using Object Snap Tracking

**Touching to Acquire a Point**
To touch a point, hover over the point with your cursor but DO NOT CLICK to select the point. The acquired indicator appears inside the object snap marker when the point has been acquired.

**Command Access**

**Object Snap Tracking**

Menu Bar: **Tools > Drafting Settings > Object Snap / Object Snap Tab**

Keyboard Shortcut: **F11**

Status Bar: **Object Snap Tracking > Right-click > Settings**

**Drafting Settings Dialog Box**

Turn Object Snap Tracking on from the Status Bar, from the Object Snap tab in the Drafting Settings dialog box, or by pressing F11. Object Snap must be on and modes must be selected for Object Snap Tracking to work.
In the Polar Tracking tab, you can choose whether to track Orthogonally Only (simplest method) or to Track using all polar angle settings.

1. Alignment paths only appear for horizontal and vertical alignments.

2. Alignment paths appear for all polar angles defined.

Press and hold \texttt{SHIFT+Q} to temporarily turn object snap tracking on or off.

**Procedure: Using Object Snap Tracking**

The following steps outline how to use object snap tracking to acquire points.

1. On the status bar, make sure the \texttt{Osnap} and \texttt{Otrack} settings are on.
2. Start any command that prompts you to select a point.
3. To specify a point using object snap tracking, touch the point with the cursor. A small plus (+) appears, indicating that the point has been acquired.

4. Touch another point to acquire its location.

5. If more than two points are required, continue to touch points.
6. Move your cursor to a location that would be considered an intersection of the acquired points, based on orthogonal or polar angle settings. The alignment paths appear as your cursor approaches the calculated intersection.

7. Click to select the calculated point.
Guidelines for Acquiring Points with Object Snap Tracking
- To acquire a point, touch it with the cursor.
- To release a point, touch an acquired point with the cursor.
- You can acquire up to seven points for object snap tracking.
- If you attempt to acquire more than seven points, previous points are automatically released on a first-acquired, first-released basis.

Object Snap Tracking Settings Key Points
- Object snap tracking uses running object snaps to acquire points.
- To use object snap tracking, object snaps must be turned on with at least one object snap selected.
- Hover over the object snap points but do not select them.
Practice Exercise: Object Snap Tracking

Practice using object snap tracking orthogonally.

1. Begin a new drawing.
2. Be sure that Object Snap and Object Snap Tracking are both selected in the status bar.

Right-click Object Snap and be sure that the Midpoint selection mode is selected.

3. Draw a rectangle any size:
   - On the Home tab, click Draw panel > Rectangle.
   - Click the first corner; click the opposite corner.

4. Draw a circle (any size) in the center of the rectangle:
   - On the Home tab, click Draw panel > Circle.
   - Hold the mouse over the midpoint of one of the lines in the rectangle until you see a small cross.
   - Then hold the mouse over the midpoint of one of the adjacent lines.
   - Then bring your curser to the middle of the rectangle.
   - Click at the intersection of the two dotted lines of the horizontal and polar angles.
   - Specify the circle size by clicking a point in the graphics window, or entering a value on the command line.

5. Close all files. Do not save.
Exercise: Use Object Snap Tracking

In this exercise, you use object snap tracking to create a side view of the part. After completing this lesson, you will be able to use object snap tracking in other drawings.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 2: Creating Basic Drawings. Click Exercise: Use Object Snap Tracking.

1. Open M_Object-Tracking.dwg.
2. On the status bar, make sure the following settings are turned on:
   ■ Polar tracking
   ■ Object snap
   ■ Object snap tracking
   ■ Dynamic input
3. Right-click Object Snap Tracking. Click Settings.
4. In the Drafting Settings dialog box, select the running object snaps as shown in the following image. Click OK.
5. To draw a rectangle:
   ■ On the Home tab, click Draw panel > Rectangle.
   ■ Acquire the lower right corner of the existing shape and move the mouse to the right along the extension path.
   ■ Enter 40 in the Dynamic Input field. Press ENTER.
■ Move the cursor up and to the right.
■ Enter 31.75, 69.85. Press ENTER.

6. To repeat the rectangle command:
■ Right-click in the graphics window. Click Repeat RECTANG.
■ Select the lower right corner of the previous rectangle as the start point.
■ Enter 17.53, 25.4. Press ENTER.

7. To draw a line:
■ On the Home tab, click Draw panel > Line.
■ Select the top right corner of the first rectangle.
■ Move the cursor to the right at 0 degrees. Enter 90.55. Press ENTER.

8. Move the cursor to acquire a tracking point from the lower right corner of the second rectangle. Track back to the line until the angle shows 90 degrees. Click to select the point.
9. Move the cursor to the left. Enter 46.1. Press ENTER.

10. Acquire the point where the arc and angled line meet (1). Track back to the point where the current line meets the tracking line (2). Click the intersection of the alignment paths.

11. Acquire the midpoint of the top line of the second rectangle. Track upwards until you get to the intersection of the two tracking lines. Click that point.

12. Select the midpoint of the top line of the second rectangle. Press ENTER to complete the line command.

13. Close all files. Do not save.
This lesson describes how to set up units in a drawing.

When you create drawings, one of the first things you must do is define the current working units. The units settings determine how you enter distances as well as how the values are returned to you.

The following illustration shows how the software presents the current units through the dynamic input interface.

Objectives

After completing this lesson, you will be able to:

■ Describe units and how they affect your drawing.
■ Use the Units command to set drawing units.
About Units

Units represent the baseline of all the geometry that you create in your drawing. It is up to you to determine what unit of measurement will be used in your drawing.

When you begin a blank drawing, the default units are based in the decimal system. Because the software is not capable of distinguishing inches from millimeters, it assumes that a value of 1 is equal to either 1 inch or 1 mm. Setting the appropriate units determines the format in which the software presents values to you via the command line, status bar, polar tracking, and dynamic input interface.

While the software is not a true units-based system, meaning it doesn't understand the difference between 1 inch and 1 millimeter, there are some assumptions that can affect other settings such as Imperial Architectural units (for example 1'-6"), and alternate dimension display.

Unit Guidelines

The following are some guidelines you should refer to regarding units:

- The software is set by default to decimal units.
- A unit of 1 can be equal to 1 inch or 1 millimeter.
- If you need to input imperial architectural units for distances, you must select the Architectural type drawing units. The software will not understand the architectural units format 1'-6" if the Units are set to Decimal.
- When you are using Architectural Units, type the ‘foot’ mark, but it is not necessary to type "inches" as the software will assume inches if no symbol is typed. Example 16' -2" can be simply typed: 16'2
- When using Architectural units, you may type 16'-2" or the equivalent in inches: 194
- If you work primarily with metric units, then you should use the default decimal unit setting.
- AutoCAD is accurate 14 decimal places (1.00000000000000). What you see for units precision will be rounded up to the nearest decimal place that you have determined in the Units dialog box.
- Simply picking points in the drawing window will not guarantee that you have specified the precise length or angle unless you use the drawing aids determined in the drafting settings.
Units Example

The following image illustrates the assumptions made regarding units. In this image, a single line was drawn at a length of 18 units. When dimensioned with both a metric and imperial dimension style, the dimensions report different lengths.

This occurs because the default dimension styles have preset conversion factors when you display alternate units. While you could change these conversion factors to represent any conversion imaginable, by default the software assumes a conversion using inches or millimeters as the base unit.

![Image of a line with dimensions 18mm (0.709 in.) and 1'-6" (457.20 mm)]

Setting Units

You use the Units command to set up the units for the drawing. You can change the drawing units at any time, but it is recommended that you do so at the beginning of each drawing you create. When you use drawing templates or the New Drawing wizard, the units for the drawing are set accordingly.

In the following image, the drawing units have been set to accept surveyor units for angle input.

![Image of a line with a surveyor angle of N 35° 14' E]

Command Access

Units

Command Line: **UNITS**
Application menu: **Drawing Utilities > Units**
Drawing Units Dialog Box

When you start the Units command, the Drawing Units dialog box is displayed. You set the unit types for length, angle, and insertion scale. You can set the precision for both length and angle units and you can also set the angle direction. The precision options are displayed in the selected unit format.

To set your drawing units, select the appropriate unit in the Length and Angle lists and then set the unit’s precision with the Precision lists for length and angle.

Current Unit Setting
The current unit setting affects the manner in which values are presented to you as well as the format in which you can enter distances and angles. Regardless of the unit setting you choose, you can always enter values in decimal format.

Warning!
The Lighting area shown in the Units dialog box is not available in AutoCAD LT.
Procedure: Setting Drawing Units

The following steps give an overview of setting drawing units.

1. On the command line, enter *units* and press ENTER.
2. In the Drawing Units dialog box, select the appropriate length and angle unit types. If necessary, you can also adjust the precision options for both length and angle.

3. Click OK.
4. You can now enter values using the format of the selected unit for length and angle. When the software presents values to you via the interface, they are in the selected unit format.

Guidelines for Setting Units

- While it is possible to set the drawing units at any time, it is recommended that you do this when you start a new drawing.
- Regardless of the current unit setting, you can always enter units in decimal format.
- To input values in a format other than decimal, you must set the appropriate unit type.
Practice Exercise: Setting Units

In this practice exercise, you create a new blank drawing, set the drawing units to Architectural, and draw a rectangle 54' 6" x 34'2". Then you zoom all to see your work.

1. Begin a new drawing. In the Select template dialog box, select the acad drawing template.

2. To set the architectural drawing units:
   - On the command line, enter units and press ENTER.
   - In the Drawing Units dialog box, under Length, select Architectural in the Type list.
   - Click OK to exit.

3. To draw the 54'6" x 34'2" rectangle:
   - On the Home tab, click Draw panel > Rectangle.
   - Specify the first corner point.
   - To specify the opposite corner, enter: @54'6,34'2
   - Note: You do not have to enter inches.

4. To zoom your drawing:
   - Enter Z and press ENTER.
   - Enter A and press ENTER.
Exercise: Use Architectural Units

In this exercise, you set the drawing to use architectural units. Then, using the dynamic input interface, you sketch the outline of a simple floor plan.

1. Open I_Architectural-Units.dwg.
2. To set the unit type:
   - Click the Application button > Drawing Utilities > Units.
   - In the Type list under Length, select Architectural.
   - In the Precision list, select 0'-0 1/8".
   - In the Precision list under Angle, select 0.0.
   - Click OK.
3. To draw a line:
   - On the Home tab, click Draw panel > Line.
   - Enter 10',10'. Press ENTER.
   - Move the cursor to the right.
   - Enter 6'-8. Press TAB.
   - Enter 0. Press TAB.
   - Click anywhere in the drawing.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 2: Creating Basic Drawings. Click Exercise: Use Architectural Units.
4. For the next point:
   - Move the cursor down and to the right.
   - Enter 2'4.25. Press TAB. Enter 45. Press TAB again.
   - Click anywhere in the drawing to accept the point.

5. For the next point:
   - Enter 4'. Press TAB.
   - Enter 0. Press TAB.
   - Move the cursor to the right.
   - Click anywhere in the drawing to accept the point.

6. For the next point:
   - Move the cursor up and to the right.
   - Enter 2'4-1/4. Press TAB.
   - Enter 45. Press TAB.
   - Click anywhere in the drawing to accept the point.

7. For the next point:
   - Move the cursor to the right.
   - Enter 45'-8". Press TAB.
   - Enter 0. Press TAB.
   - Click anywhere in the drawing.

8. For the next point:
   - Move the cursor up.
   - Enter 42'-8". Press TAB.
   - Enter 90. Press TAB.
   - Click anywhere in the drawing.

9. For the next point:
   - Move the cursor to the left.
   - Enter 15'-3". Press TAB.
   - Enter 180. Press TAB.
   - Click anywhere in the drawing.

10. For the next point:
    - Move the cursor down.
    - Enter 6'-2". Press TAB.
    - Enter 90. Press TAB.
    - Click anywhere in the drawing.
11. For the next point:
   - Move the cursor to the left.
   - Enter 44'-5". Press TAB.
   - Enter 180. Press TAB.
   - Click anywhere in the drawing.

12. Right-click and click Close, or select the endpoint of the line where you started.

13. Close all files. Do not save.
Exercise: Use Surveyor's Units

In this exercise, you set the drawing units to accept Surveyor's Units for angle input, and use the Dynamic Input interface to draw a site boundary.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 2: Creating Basic Drawings. Click Exercise: Use Surveyor's Units.

1. Open M_Survey-Units.dwg.
2. To set the unit type:
   - Click Application Button > Drawing Utilities > Units.
   - In the Angle type list, select Surveyor's Units.
   - In the Angle Precision list, select N0d00'00" E.
   - Click OK.

3. To draw a line:
   - On the Home tab, click Draw panel > Line.
   - Enter 4000,4000. Press ENTER.
   - Enter 17497. Press TAB.
   - Enter N85d14' E. Press TAB.
   - Click anywhere in the drawing.

4. For the next point:
   - Move the cursor up and to the right from the previous point.
   - Enter 25498. Press TAB.
   - Enter N2d57' E. Press TAB.
   - Click anywhere in the drawing.
5. For the next point:
   - Move the cursor up and to the left from the previous point.
   - Enter **19000**, Press TAB.
   - Enter **N80d40' W**. Press TAB.
   - Click anywhere in the drawing.
   - Right-click and click Close.
   The site boundary appears as shown.

6. Close all files. Do not save.
Challenge Exercise: Architectural

In this exercise, you use what you have learned in Chapter 2 to draw a basic floor plan.

You have the option of completing this exercise using either imperial or metric units. Select one version of the exercise to complete the steps.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 2: Creating Basic Drawings. Click Challenge Exercise: Architectural Metric.
Metric Units

1. Open M_ARCH-Challenge-CHP02.dwg.
2. Draw the floor plan so its lower-right corner matches up with the point in the drawing file as shown in the image.

3. Draw the door so it is 51 mm thick.

4. Save and close all files.
Imperial Units

1. Open I_ARCH-Challenge-CHP02.dwg.
2. Draw the floor plan so its lower-right corner matches up with the point in the drawing file as shown in the image.
3. Draw the door so it is 2" thick.

4. Save and close all files.
Challenge Exercise: Mechanical

In this exercise, you use what you have learned in Chapter 2 to create the initial geometry for a small mechanical assembly drawing.

**Note:** In the following images, the views are closer together than they will appear in your drawing.

The completed exercise

---

**Completing the Exercise**

To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click *Chapter 2: Creating Basic Drawings*. Click *Challenge Exercise: Mechanical*. 


---
1. Open *M_MECH-Challenge-CHP02.dwg*.

2. Locate the point in the drawing labeled Start Point 1. Use the basic drawing commands to sketch the following views. You do not need to place dimensions or create centerlines.

   **Note:** Some circles are dimensioned with diameter values, others with radius values. Also, each drawing view contains a point you should use as the start point.

3. Locate the point on the drawing labeled Start Point 2. Use the basic drawing commands to sketch the following views. You do not need to place dimensions or create centerlines.

4. Erase the Start Point 1 and Start Point 2 text and leaders.

5. Save and close all files.
Chapter Summary

The concepts and techniques covered in this lesson serve as the building blocks for every drawings that you create. The sooner you master these concepts, the sooner you will be able to move on to more advanced geometry creation and editing.

Having completed this chapter, you can:

- Identify the default coordinate system and use dynamic input, direct distance, and shortcut menus.
- Use the Line, Circle, Arc, Erase, Rectangle, and Polygon commands to create and erase geometry in the drawing.
- Use object snaps to accurately place and create objects in the drawing.
- Activate and use the Polar Tracking and PolarSnap modes to more accurately create geometry at different angles in the drawing.
- Enable and use object snap tracking to position geometry in the drawing.
- Use the Unit command to set up the drawing environment.
- Use the concepts and tools that you learned in Chapter 2 to begin a small architectural floor plan.
- Use the concepts and tools that you learned in Chapter 2 to create the initial geometry for a small mechanical assembly drawing.
Manipulating Objects

Editing objects is a common part of all design tasks. Whether you make modifications as a result of a design change or in the process of creating more complex objects, editing is something you will be required to do frequently as you draw.

Objectives

After completing this chapter, you will be able to:

- Use different selection methods to select objects in the drawing.
- Move objects in the drawing using object snaps, object tracking, and coordinate entry for precise placement.
- Use the Copy command or grips to create new objects from existing objects in the drawing.
- Change the angle of objects in the drawing by using the Rotate command or with grips.
- Create mirrored images of objects in the drawing using the Mirror command or with grips.
- Use the Array command to create rectangular and circular patterns of objects in the drawing.
- Change the size of objects in the drawing.
- Use grips to edit objects and display geometric information.
- In this exercise, use what you learned about modifying objects to modify the floor plan.
- In this exercise, use what you learned about modifying objects to edit geometry.

Standard Object Snap and Status Bar Settings

Before completing the exercises in this chapter, refer to the "Settings for the Exercises" section in the Introduction in Volume 1.
Lesson: Selecting Objects in the Drawing

This lesson describes how to select objects using several different options and methods. You need to select objects in your drawing in order to modify and manipulate those objects. As your drawing grows in complexity and contains more objects, you need to use different selection methods to select these objects efficiently.

Objectives

After completing this lesson, you will be able to:

- Use implied, manual window, and crossing selection methods to select objects.
- Select objects for grip editing and identify the type of editing that can be done using grips.
- Use several different selection methods to select objects.
Using a Window to Select Objects

An object or group of objects that you select is also called a selection set. There are a variety of methods for selecting, adding, and removing objects within this selection set.

Selection sets are useful when you want to modify a number of objects. You can create a selection set either before or after activating the pertinent command.

If you want to select an individual object, you simply click it. You can continue to select additional objects as needed. As each new object is added to the selection set, the object's appearance changes to dashed lines.

In response to the Select Objects prompt, there are many methods you can use to select several objects at the same time.

Implied Window Selection

An implied window is a method of selecting objects by creating a selection window around those objects. To select objects using an implied window, click in a blank area of the drawing then drag the cursor from left to right and click the opposite corner of the selection window. Objects enclosed completely within the implied window will be selected.

- Only objects that are entirely within the rectangular window are selected.
- If any part of an object is outside the window, that object is not selected.
- Although the drag movement must be from left to right, it can also be up and across, or down and across the drawing area. The drag movement shown here is up and across.
- The window selection area has a solid outline and a differently colored shading to distinguish it from that used in a crossing selection.
- The shaded area indicates the points in space used to define the corners of the rectangular Window.
**Manual Window Selection**

You can define a selection window by using the Window selection method. In response to any Select Objects prompt, enter **W** and press ENTER. This enables you to create a regular selection window in which you are not restricted as to the direction of the cursor movement when defining the points. When you specify the Window option, you can define the window from left-to-right or right-to-left, and it always results in a regular selection window. Only objects that are completely within the selection window will be included in the selection set.

**Implied Crossing Selection**

Implied crossing means that you have not manually specified a specific selection method. To make a crossing selection, you specify opposite corners that define a rectangular area. The first corner point must be in your drawing area, but cannot be touching any existing objects. After specifying the first corner point, you drag the cursor from right to left to create a crossing selection that is in the opposite direction of the previous Window selection.

- All objects that are within or touched by the rectangular crossing window are included in the selection set.
- Although the drag movement must be from right to left, it can be up and across or down and across the drawing area.
- The crossing window has a dashed outline and a differently colored shading to distinguish it from that used in a window selection.
- The shaded area indicates the points in space that were used to define the corners of the rectangular window.

**Manual Crossing Selection**

You can define a non-implied Crossing Window by using the Crossing Window selection method. In response to any Select Objects prompt, enter **C** and press ENTER. This enables you to create a Crossing selection window where the direction of the cursor movement is not restricted when you define the points. When you specify Crossing Window, you can define the window from left to right or right to left, and it always results in a Crossing selection window.
Guidelines
- Implied windowing enables you to automatically create a selection window by clicking two points in a blank part of the drawing area to define the selection window.
- You can create an implied window when the Command line is blank (no command is active), or in response to a Select objects prompt.
- Noun-Verb selection is on by default in the software options. This enables you to select objects before starting a command to modify those objects.

Object Selection with Grips

Grips are selectable points on geometry that you use to initiate editing of the selected object. Grips appear when you select an object and no command is currently active.

Grips Defined

Grips on selected objects are displayed as colored boxes. If you click a grip, it changes color and becomes a selected, or hot grip. If you place your mouse over an unselected grip, the color also changes and it becomes a hover grip.

With a hot grip, you can perform editing tasks on the object such as move, mirror, rotate, scale, and stretch. A hover grip can display specific dimension information.

The following illustration shows a common object with grips displayed.
**Using Hover Grips**

Place your mouse over a grip without selecting it and the grip becomes a *hover* grip. These grips are used with Dynamic Input to provide real-time dimensional information such as the current length, angle, and diameter of objects in the drawing. The following illustration on the left demonstrates a hover grip on a rectangle. On the right, a hover grip is shown on a circle object.

![Hover Grip Example](image)

**Using Selected Grips**

With Dynamic Input turned on, you can select a grip to display fields where you can input new values such as length and radius. On the left, the illustration shows a selected grip where you can change the length of the top line of the rectangle. On the right, the illustration shows the result of changing that value.

![Selected Grip Example](image)

**Display Grip Editing Options**

Right-click a selected grip to display a menu of grip editing options. The default grip editing option is Stretch. With grip editing, you can perform all of the operations on the menu without having to start a command.
Removing Selection from Grips
To remove a hot grip, press ESC. Press ESC again to remove selection from all grips in the current selection set. To remove a single object from a selection set, press SHIFT + click the object.

Guidelines for Grip Editing
- Grips appear on selected objects only when the Command line is blank.
- You can select objects first, so that they are highlighted with grips, then you can choose one of the modify commands for that selection.
- When used in conjunction with Dynamic Input, you can use grips to resize geometry by entering new values for length, angle, radius, and coordinates in the Dynamic Input fields.
- You can combine the grip copy option with your grip editing tasks. Right-click anywhere in the drawing and select Copy. The original object remains unchanged. Multiple copies can be made using the grip editing command options.
- When using the grip copy option, you can make multiple copies at regular intervals based on your first copy by holding down the shift key when placing your next copy.
- You can perform clipboard edit options of the object selected by right-clicking and choosing: Cut, Copy, Copy with base point or Paste.
- You can change the base point of the object being edited with grips. Right-click anywhere in the drawing and click Base Point to define a new base point for the objects selected.
- You can use the Reference option when rotating or scaling objects during a grip edit. Right-click anywhere in the drawing and click Reference.
Select Objects Options

You can use several keyboard options to select objects on the Select Objects command prompt. These options include Window Polygon, Crossing Polygon, Fence, All, Last, and Previous. Enter the capitalized letter for the option and press ENTER.

The select object options are not so apparent. It is best to memorize those that are most useful. However, if you should enter an incorrect letter at the select object prompt, such as the letter y (which is not an option), AutoCAD® will display the entire list of options as shown in the example below.

```
Command: e
ERASE
Select objects: y

"Invalid selection"
Expects a point or
Window/Last/Crossing/BOX/ALL/Fence/WPolygon/CPolygon/Group/Add/Remove/Multiple/
P Previous/Undo/Auto/Single/AllObject/Object

Select objects:
```

Selecting with a Window Polygon

To select objects within a non-rectangular window, use the following procedure:

- At the Select Objects prompt, enter **wp** (for Window Polygon).
- Specify points that define an area that entirely encloses the objects that you want in the selection set.
- Press ENTER to close the polygon selection area and complete the selection.
Practice Exercise: Windows Polygon Selection

Draw the outer shape shown below and fill it with a random arrangement of rectangles. Then practice using the Windows Polygon selection option to erase the rectangles.

1. Turn Polar Tracking on. Draw the outer shape any size, resembling more or less the shape shown in the illustration:
   - Begin the Line command.
   - Start at the lower left corner (1) and follow the points to draw each line as shown below.
   - If you were able to do this continuously, when you get to point (6), you may enter C to close the line segments. Otherwise, you will have to select the Endpoint.

2. To draw the rectangles inside the shape:
   - First check that Object Snap is turned off.
   - Begin the Rectangle command.
   - Pick the first corner, then the opposite corner.
   - Continue until you have filled your object with rectangles.

3. To erase the rectangles using the Windows Polygon selection option:
   - Be sure that Object Snap is turned off.
   - Begin the Erase command.
   - At the Select objects prompt, enter WP and press ENTER.
   - Begin the Window Polygon at point (1) and continue until you get back to point (1).
   - Press ENTER to complete the Window Polygon and press ENTER again to erase the objects.

   Notice that making the Windows Polygon was like stretching a rubber band around the objects.

4. Undo. You may Save this drawing in order to practice erasing the objects using the Crossing Polygon option in the next section.
Selecting with a Crossing Polygon

To select objects enclosed or crossed by an irregularly shaped crossing polygon area, use the following procedure:

- At the Select Objects prompt, enter `cp` (for Crossing Polygon).
- Specify points that define an area that encloses or crosses the objects that you want to select.
- Press ENTER to close the polygon selection area and complete the selection. Occasionally you will find that it is not possible to completely enclose the objects you want to select. In this situation, you can select objects using a selection fence.
Practice Exercise: Crossing Polygon Selection

If you saved the last exercise, you may proceed to step 3. Otherwise, draw the outer shape shown below and fill it with a random arrangement of rectangles. Then practice using the Crossing Polygon selection option to erase the rectangles.

1. Turn Polar Tracking on. Draw the outer shape any size, resembling more or less the shape shown in the illustration:
   - Begin the Line command.
   - Start at the lower left corner (1) and follow the points to draw each line as shown below.
   - If you were able to do this continuously, when you get to point (6), you can enter C to close the line segments. Otherwise, you will have to select the Endpoint.

2. To draw the rectangles inside the shape:
   - First check that Object Snap is turned off.
   - Begin the Rectangle command.
   - Pick the first corner, then the opposite corner.
   - Continue until you have filled your object with rectangles.

3. To erase the rectangles using the Crossing Polygon selection option:
   - Be sure that Object Snap is turned off.
   - Begin the Erase command.
   - At the Select objects prompt, enter CP and press ENTER.
   - Begin the Crossing Polygon at point (1) and continue until you get to back to point (1).
   - Press ENTER to complete the Crossing Polygon and press ENTER again to erase the objects.

Note that it was possible to select the complete rectangles because they are polylines (connected lines).

4. Undo. You may Save this drawing to in order to practice the Crossing Polygon window in the next section.
Selecting with a Fence

A selection Fence enables you to make a series of line segments across the objects you wish to select. To select objects using the Fence option:

- At the Select Objects prompt, enter f (for Fence selection).
- Specify points that define a series of line segments that cross the objects you wish to select.
- Press ENTER to complete the selection fence.
Practice Exercise: Fence Selection

Practice using the Fence selection option. First draw the lines and circles as shown below. Then erase the lines.

1. Draw the lines and circles (any size):
   ■ Begin the Line command and draw the line segments as shown.
   ■ Next draw the circles near the intersection of the lines.

2. Erase the lines using the Fence selection option:
   ■ Begin the Erase command.
   ■ At the Select objects prompt, enter F and press ENTER.
   ■ Click the first fence point at (1)
   ■ Click the second fence point at (2)
   ■ Click the third fence point at (3) and press ENTER.
   ■ Press ENTER to complete the Erase command.
Selecting with the All Option
You can select all of the available objects in a drawing by entering all at the Select Objects prompt. Be careful using this option as it also affects objects on layers that are turned off, thawed, or unlocked. To use the All option:

- At the Select Objects prompt, enter all. Press ENTER.
- All displayed objects and all objects that are on layers that are turned off are selected.
- Press ENTER to complete the selection.

You can use the CTRL+A method to select all objects in the drawing, but you must select the objects first, prior to starting a command. Pressing CTRL+A in response to a Select Objects prompt selects all objects in the drawing, but also cancels the current command.

Selecting with the Last Option
To select the most recently created visible object, enter L (Last) at the Select Objects prompt. To use the Last option:

- At the Select Objects prompt, enter L. Press ENTER.
- The most recently created object is selected.
- Press ENTER to complete the selection.

Selecting with the Previous Option
Selection sets are stored in memory. You can recall the most recent selection set by entering P (Previous) at the Select Objects prompt. To use the Previous option:

- At the Select Objects prompt, enter P. Press ENTER.
- All objects in the previous selection set are selected again.
- Press ENTER to complete the selection.

You can remove objects from the current selection set by holding down SHIFT and selecting the objects again. To remove multiple objects at the same time, you can use both the Implied Window and Implied Crossing methods while holding down SHIFT.
Practice Exercise: Other Selection Options

In this practice exercise, you use selection options that include Last, Previous, All, and Remove. First, you begin by drawing several lines and circles as shown.

1. Draw some lines and circles.

2. Practice using the Last selection option:
   - Begin the Erase command.
   - At the Select object prompt, enter L and press ENTER.
   - Notice that the last object drawn is highlighted.
   - Press ENTER to execute the command.

   Note that your last object drawn may be different than the one shown above.

3. Copy one or several objects in your drawing, placing them randomly as shown below.

4. Repeat the copy command and try the Previous select object option:
   - Begin the Copy command.
   - At the Select object prompt, enter P and press ENTER.
   - Notice the previous selection you made is selected again.
   - Press ESC to escape the Copy command.
5. Practice selecting all objects, then remove an object from the selection set:
   - Begin the Erase command.
   - At the Select object prompt, enter **ALL** and press ENTER (only once).
   - Notice all the objects are highlighted.
   - Hold down the SHIFT key and select a single item from the selection set.
   - Notice that it is no longer highlighted.
   - Press ENTER to complete the Erase command.

*Note that you can enter R and ENTER to remove the objects from the selection set. Enter A to add objects into the selection set.*
Exercise: Select Objects

In this exercise, you use selection methods to erase objects in the drawing. You will be able to use these same methods to create selection sets in other drawings.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 3: Manipulating Objects. Click Exercise: Select Objects.

1. Open M_Selecting-Objects.dwg.
2. Zoom into the area shown in the following image.

3. Erase using the Implied Window selection option, then remove selected objects from the selection set:
   - Begin the Erase command.
   - Click near point (1), then near point (2), as indicated in the following image.

   The selected geometry is highlighted. Only the objects that were completely enclosed by the window should be included in the selection set.

4. To remove objects from the selection set:
   - Press SHIFT+select to select the three lines indicated in the following image. This removes them from the selection set.
   - Press ENTER to complete the erase command.
5. To erase using an implied crossing window:
   - Start the Erase command.
   - Click near point (1), then near point (2) as indicated in the following image. Notice that you are now clicking from right to left. All of the objects that the selection window crosses are highlighted.
   - Press ENTER to complete the Erase command.

6. In another part of the drawing (zoom in if necessary), erase selected objects using the Crossing Polygon selection option:
   - Begin the Erase command.
   - At the Select objects prompt, enter **CP**. Press ENTER.
   - Click the points for the crossing polygon following the illustration below.
   - Begin with (1) and follow the points consecutively until you get to (6) and press ENTER.
   - All of the objects that the polygon window has crossed are highlighted.
   - Press ENTER to complete the Erase command.

7. This time erase using the Window Polygon selection option:
   - Start the Erase command.
   - At the Select objects prompt, enter **WP**. Press ENTER.
   - Click the points for the window polygon following the illustration below.
   - Begin with (1) and follow the points consecutively until you get to (8). Press ENTER.
   - Only the objects that are completely within the polygon window are highlighted.
   - Press ENTER to complete the Erase command.

8. Now practice selecting objects with the Fence selection option. Zoom if necessary to the part of the drawing shown below:
   - Begin the Erase command
   - At the Select objects prompt, enter **F**. Press ENTER.
   - Click in the drawing as indicated in the illustration below, beginning with (1).
   - When you reach point (7), press ENTER to complete the selection set.
   - Press ENTER to execute the Erase command.
9. Use the Last selection option to erase the last object made in this drawing:
   - Zoom to the part of the drawing illustrated below.
   - Begin the Erase command.
   - At the Select object prompt, enter L. Press ENTER.
   - Notice that the arrow to the left is highlighted. This was the last object created when this drawing was completed.
   - Press ENTER to finish the erase command.

![Diagram of a drawing with arrows indicating the last object created.]

10. View the entire drawing and erase all:
   - At the Command line, enter Z and press ENTER.
   - Enter E and press ENTER. You should now be viewing the extents of the drawing.
   - Start the Erase command.
   - At the Select objects prompt, enter ALL. Press ENTER.
   - Everything visible in the drawing will be highlighted.
   - Press ENTER to start the command.
   - At the Command line, enter U. Press ENTER to undo.

11. Close all files. Do not save.
Lesson: Changing an Object's Position

This lesson describes how to use the Move command to reposition objects in the drawing and how to move an object using grips.

Moving objects is a common procedure for changing the position of objects in your drawing. The Move command enables you to move objects to different locations in the drawing using a variety of placement techniques.

Objectives

After completing this lesson, you will be able to:

■ Use grips or the Move command to move objects using object snaps, coordinate entry, and object snap tracking.
Moving Objects

The Move command enables you to reposition an object in the drawing by selecting a base point, where the object is moving from, followed by a point to define where the object is moving to. You can select the two points or use the Displacement option of the command. If you use the Displacement option, the coordinate values you enter specify a relative distance and direction from the basepoint you selected. Another option is to use grips to reposition an object. You select a grip and then activate the Move command and select a position to move the selected grip and the object to.

Command Access

Move

Command Line: MOVE, M
Ribbon: Home tab > Modify Panel > Move
Menu Bar: Modify > Move
Shortcut Menu: Select objects then right-click anywhere in the drawing window and click Move.
Procedure: Moving Objects with the Move Command

The following steps provide an overview for moving objects in the drawing with the Move command.

1. On the ribbon, click Home tab > Modify panel > Move.
2. Select the objects to move and press ENTER to end the object selection.

3. Specify a base point (where the objects are moving from).

4. Specify a second point (where the objects are moving to).

The object is moved to the new point.
**Procedure: Moving Objects Using Grips**

The following steps provide an overview of using grips to move objects.

1. Select an object to activate its grips.
2. Click a grip to activate grip edit mode. By default, this point will also be used as the base point for the move.
3. Right-click anywhere in the drawing. Click Move.
4. Click to position the object in a new location.

**Guidelines**

Follow these guidelines when using the Move command:

- When you specify the base point for the move, it should be on or near the object being moved unless you are using other objects to define a reference vector for the move.
- By default, the option for Noun-Verb selection is turned on in the software; this enables you to select the objects to move prior to starting the Move command.
Practice Exercise: Move Objects

In this practice exercise, you draw two rectangles (of any size) then move one of them so that it is one unit to the right of the other rectangle offset from its midpoint. You use two different techniques to move this object.

1. Begin a new, blank drawing using the *acad.dwt* template.

2. To set up the drawing drafting settings:
   - Polar tracking and object snap should be on.
   - Object snap Midpoint mode should be selected.

3. Draw two rectangles any size in the drawing window.

4. To move the rectangle:
   - On the Home tab, click Modify Panel > Move.
   - Select the rectangle on the right and press ENTER.
   - At the prompt to specify the basepoint, click the midpoint as indicated below.

5. Move the rectangle to the midpoint of the other rectangle as indicated in the following illustration:

6. Now, move the rectangle again using grips:
   - With the command line blank, select the rectangle.
   - Select a grip on the rectangle and right-click.
   - On the shortcut menu, click Copy.

   - Select the midpoint on the rectangle as indicated below:

   - Select a grip on the rectangle again.
   - Right-click and click Move.
- Drag the rectangle to the right until the polar direction is 0 degrees.
- Enter 1 and press ENTER.
Exercise: Move Objects

In this exercise you use the Move command to move objects in the drawing. When you’ve finished, you will be able to move objects in other drawings using object snaps, object tracking, and coordinate entry.

You have the option of completing this exercise using either imperial or metric units. Select one version of the exercise to complete the steps.

1. Open M_Moving-Objects.dwg.
2. Zoom into the lower left corner of the drawing, as shown in the following image.

3. Select the sink to move it into the kitchen:
   - With the command line blank, select the sink.
   - Notice that it is a single object with a grip located at the midpoint. You will learn more about these kinds of symbols, or blocks, later in this course.
   - Select the grip on the sink and drag it to the midpoint of the line that represents the wall in the kitchen.
   - Click to relocate the sink to this new position.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 3: Manipulating Objects. Click Exercise: Move Objects Metric.

Exercise: Move Objects (Metric Units)

In this exercise, you move the furnishings into the designated rooms using the Move command and grips. Polar Tracking, Object Snap, and Object Snap Tracking modes must be on.
4. Zoom out, then zoom to view the area of the drawing shown in the following image.

5. To position the love seat as illustrated below:
   - With the Command line blank, select the love seat.
   - Select the single grip on it and drag the object towards the wall as indicated. Hover over the midpoint of the wall to acquire a tracking point, then drag the cursor along the alignment path and click to position the object as shown.
   **Note:** An exact distance from the wall is not critical.

6. Use the Move command to relocate the couch to the interior of the room as indicated:
   - Activate the Move command.
   - Select the couch object. Press ENTER.
   - Select the base point using the midpoint object snap.
   - Select the midpoint of the wall to position the couch.

7. Repeat the Move command and select the desk and chair:
   - Repeat the Move command.
   - Click to create a selection window around the desk and chair as indicated below.
   - Press ENTER to end the selection set.
8. To position the desk and chair:
   - Select the midpoint of the desk as indicated.
   - Hold down SHIFT+D while positioning the cursor. This temporarily turns off all object snaps to prevent the desk from snapping to the wall.
   - Drag the cursor to position the desk and chair as shown.

9. Adjust your view to include this area of the drawing.

10. Move the dinette set to the interior of the room as shown:
   - With the Command line blank, select the dinette set.
   - Select the grip at the center.
   - Drag the dinette set towards the room.
   - Hover over the midpoint of the first wall, then the midpoint of the adjacent wall as indicated.
   - Drag the dinette set to the middle of the room. Click when you see the tracking lines of the midpoints intersect.

11. To relocate the water closet towards the other wall:
   - With the Command line blank, select the water closet.
   - Select the grip and drag it upwards.
   - Enter 650 and press ENTER.
12. Zoom to display your entire drawing.
13. Close all files. Do not save.

**Exercise: Move Objects (Imperial Units)**

You move the furnishings into the designated rooms using the Move command and grips. Polar Tracking, Object Snap, and Object Snap Tracking modes must be on.

1. Open _I_Moving-Objects.dwg_.
2. Zoom into the lower left corner of the drawing, as shown in the following image.

3. Select the sink to move it into the kitchen:
   - With the command line blank, select the sink.
   - Notice that it is a single object with a grip located at the midpoint. You will learn more about these kinds of symbols, or *blocks*, later in this course.
   - Select the grip on the sink and drag it to the midpoint of the line representing the wall in the kitchen.
   - Click to relocate the sink to the new position, as shown.

4. Zoom out, then zoom to view the area of the drawing shown in the following image.

5. To position the love seat as illustrated below:
   - With the command line blank, select the love seat.
   - Select the single grip on it and drag the object towards the wall as indicated. Hover over the midpoint of the wall to acquire a tracking point, then drag the cursor along the alignment path and click to position the object as shown.
   - **Note:** An exact distance from the wall is not critical.
6. Use the Move command to relocate the couch to the interior of the room as indicated:
   - Activate the Move command.
   - Select the couch object. Press ENTER.
   - Select the base point using the midpoint object snap.
   - Select the midpoint of the wall to position the couch.

7. Repeat the Move command and select the desk and chair:
   - Repeat the Move command.
   - Click to create a selection window around the desk and chair as indicated below.
   - Press ENTER to end the selection set.

8. To position the desk and chair:
   - Select the midpoint of the desk as indicated.
   - Hold down SHIFT+D while positioning the cursor. This temporarily turns off all object snaps to prevent the desk from snapping to the wall.
   - Drag the cursor to position the desk and chair as shown.
9. Adjust your view to include this area of the drawing.

10. Move the dinette set to the interior of the room as shown:
    - With the command line blank, select the dinette set.
    - Select the grip at the center.
    - Drag the dinette set towards the room.
    - Hover over the midpoint of the first wall, then the midpoint of the adjacent wall as indicated.
    - Drag the dinette set to the middle of the room. Click when you see the tracking lines of the midpoints intersect.

11. To relocate the water closet towards the other wall:
    - With the command line blank, select the water closet.
    - Select the grip and drag it up.
    - Enter 2'3 and press ENTER.

12. Zoom to display your entire drawing.

13. Close all files. Do not save.
Lesson: Creating New Objects from Existing Objects

This lesson describes how to duplicate geometry in the drawing by using the Copy command.

Since the inception of computer aided design, one of the biggest benefits has been the ability to easily copy geometry and use it in other places on the drawing instead of having to manually redraw the geometry when you need it.

Objectives

After completing this lesson, you will be able to:

- Use grips or the Copy command to copy objects in the drawing.
Copying Objects

In conventional drafting, one of the most time-consuming tasks is to duplicate an object. You use the Copy command to quickly create duplicates of objects at a specified distance from the original.

After starting the Copy command and selecting the object(s) to copy, you then specify the base point (where the object is being copied from) followed by the second point or displacement (where the object is being copied to). To create multiple copies, simply continue specifying second points or displacement values.

Command Access

Ribbon: **Draw tab > Modify panel > Copy**

Command Line: **COPY, CO**

Menu Bar: **Modify > Copy**

Shortcut Menu: **Select objects then right-click anywhere in the drawing window and select Copy.**

**Copy Command vs Clipboard Copy**

Do not confuse the Copy command with other similar copy commands found on the shortcut menu. If you select an object and right-click anywhere in the drawing, the Copy and Copy with Base Point options appear on the shortcut menu. These options
copy geometry to the clipboard, as in other standard Windows applications, making the geometry available to Paste in other drawings.

Procedure: Copying Objects with the Copy Command

The following steps describe an overview for copying objects in the drawing.

1. On the ribbon, click Home tab > Modify panel > Copy.
2. Select the object(s) to copy and press ENTER.
3. Specify a base point for the copy.
4. Specify a second point or displacement.
5. Continue to specify second points to create additional copies.

Procedure: Copying Objects Using Grips

The following steps give an overview of using grips to copy objects.

1. Select an object to activate its grips.
2. Click a grip to activate grip edit mode. By default, this point will also be used as the base point for the move.
3. Right-click anywhere in the drawing. Click Move.
4. Right-click anywhere in the drawing. Click Copy.
5. Click to position the copied object in a new location.

Guidelines

Follow these guidelines when using the Copy command:

- When you specify the base point for the copy, it should be on or near the object being copied unless you are using other objects to define a reference vector for the copy.
- By default, the option for Noun-Verb selection is turned on in the software; this enables you to select the objects to copy prior to starting the Copy command.
Practice Exercise: Copy Objects

In this practice exercise, you use the Copy command and the object grips. First, draw a circle and a line, as shown on the left in the following image.

1. To set up the drawing:
   - Draw the circle (any size).
   - Draw the line near the circle (any length).

2. Copy the circle and line to the right:
   - On the Home tab, click Modify panel > Copy.
   - Select the circle and the line and press ENTER.
   - At the prompt, click a basepoint on or near those objects.
   - Drag the mouse to the right and click.
   - Press ENTER to end the Copy command.

3. Copy the circle using grips:
   - Select the circle on the right.
   - Select one of the quadrant grips to activate it.
   - Right-click the grip, then click Copy.
   - Drag the mouse to create a larger copy of the circle and click.
   - Continue to drag and click several times to create multiple copies of the circle.
   - Press ESC to end the grip copy procedure.
   - Press ESC to clear the circle selection.
4. Copy the line using grips:
   - With the command line blank, click the line.
   - Select a grip at one of the endpoints.
   - Right-click the grip and click Move.
   - Right-click again and click Copy.
   - Continue to click in the drawing window to make multiple copies of the line.
   - Press ESC to end the copy procedure.
   - Press ESC to clear the line selection.

Note the following:
- When using copy with grips, select Copy after you have selected an option, such as Move, Mirror, Rotate, Scale, or Stretch.
- Stretch with grips is the default action.
- How the object behaves with grips often depends on which grip you select. For instance, if you had selected the midpoint grip of the line instead of the endpoint, it would have enabled you to move the line as you copied it.
Exercise: Copy Objects

In this exercise, you copy objects in the drawing using the Copy command. When you’ve finished, you will be able to use the Copy command to duplicate geometry in other drawings.

3. To make multiple copies of the red screw head:
   - On the Home tab, click Modify panel > Copy.
   - Select the screw object as shown. Press ENTER.
   - Touch the circle to display the center object snap marker. Click to select the center point of the circle as the base point.

4. Select the center point of the circle as shown in the following image.

5. Continue selecting the center points of the remaining circles in the top view as shown in the following image. Press ENTER to end the Copy command.

Completing the Exercise

To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 3: Manipulating Objects. Click Exercise: Copy Objects.

1. Open M_Copy-Objects.dwg.

2. Zoom into the upper left view of the drawing.
   - On the status bar, right-click Object Snap. Ensure that the Center and Intersection options are selected.

3. To make multiple copies of the red screw head:
   - On the Home tab, click Modify panel > Copy.
   - Select the screw object as shown. Press ENTER.
   - Touch the circle to display the center object snap marker. Click to select the center point of the circle as the base point.

4. Select the center point of the circle as shown in the following image.

5. Continue selecting the center points of the remaining circles in the top view as shown in the following image. Press ENTER to end the Copy command.
6. To create a copy of the side view of the screw:
   - Press ENTER to repeat the Copy command.
   - Select the edge view of the pan head screw as shown. Press ENTER.
   - Using the center object snap, select the center of the ellipse used to create the pan head screw as the base point.

7. To create additional copies:
   - Using the Intersection object snap option, select the intersections as shown in the following image to position the copies.
   - Press ENTER to exit the Copy command.

8. Pan or zoom the view to see a side view of the geometry.

9. Next, create a copy of the geometry in the side view for use as a section view:
   - On the command line, enter `co` Press ENTER.
   - Click two points to define a window selection around the geometry. Press ENTER.

10. To place the copy of the geometry:
    - Select the center of one of the circles in the view as the base point.
    - Verify that Ortho or Polar Tracking mode is turned on.
    - Drag the cursor to the right and enter 50. Press ENTER.
    - Press ENTER to exit the Copy command.

11. Close all files. Do not save.
Lesson: Changing the Angle of an Object's Position

This lesson describes how to use the Rotate command to rotate objects in a drawing. You learn how to use the Rotate command using the default options, and also learn how to use the Reference and Copy options while rotating objects. This lesson also describes how to rotate an object using grips.

After you have created or inserted objects in the drawing, at times you must change the angle of those objects. You can do this easily with the Rotate command, or by using grips to rotate the object.

Objectives

After completing this lesson, you will be able to:

- Use grips or the Rotate command to rotate objects in the drawing.
Rotating Objects

You use the Rotate command to rotate objects in the drawing. Command options enable you to rotate the objects simply by entering an angle for the rotation or by defining a reference angle and then entering a new angle for the reference angle. If you need to make a copy of the object while rotating, you can specify the Copy option. When the Copy option is selected, a copy of the object is rotated, leaving the original object in its current position. You can also use grips to rotate the object.

In the following image, two chair objects are being rotated with the Copy option.

Command Access

Command Line: ROTATE, RO
Ribbon: Home tab > Modify panel > Rotate
Menu Bar: Modify > Rotate
Shortcut Menu: Select objects then right-click anywhere in the drawing window. Click Rotate.
Procedure: Rotating Objects

The following steps provide an overview of rotating objects using the Rotate command.

1. On the ribbon, click Home tab > Modify Panel > Rotate.
2. Select the object(s) to rotate and press ENTER.
3. Specify a base point for the rotation. The object will rotate around this point.
4. Specify a rotation angle by moving the cursor or entering an angle.
**Procedure: Rotating Objects Using Grips**

The following steps give an overview of using grips to rotate objects.

1. Select an object to activate its grips.
2. Click a grip to activate grip edit mode. By default, this point will also be used as the center point of rotation.
3. Right-click anywhere in the drawing. Click Rotate.
4. Specify a rotation angle.

![Image of rotating object with grips and angle measurement]

**Guidelines**

- Rotate the original object or use the Copy option to rotate a copy of the object.
- The base point for the rotation should be on or near the object being rotated. This is critical because the base point represents the point of rotation for the selected object.
- When appropriate, use polar tracking for accuracy and to speed up the process for defining the rotation angle.
- Use the Reference option to refer to the angle of the object that you want to change. You can enter the angle of that object, or specify that angle by selecting two points to determine the angle vector then entering the desired angle.


Practice Exercise: Rotate Objects

In this practice exercise, you draw a rectangle and rotate it using grips, the Rotate command, and the Reference option.

1. Draw a rectangle of any size.

2. To use the grips to rotate the object:
   ■ With the command line blank, select the object.
   ■ Select one of the grips.
   ■ Right-click the active grip. Click Rotate.
   ■ Drag the mouse around the rotation point, which is the grip that you selected.

3. Rotate the object again using the Rotate command this time.
   ■ On the Home tab, click Modify Panel > Rotate.
   ■ At the Select object prompt, select the rectangle and press ENTER.
   ■ At the prompt, specify the lower left corner as the basepoint.
   ■ Enter a rotation angle of 10. Press ENTER.
   ■ Notice that the object is rotated 10 degrees counterclockwise.
4. Rotate using the Reference option and orient the rectangle back to angle 0:
   - On the Home tab, click Modify Panel > Rotate.
   - Select the rectangle. Press ENTER.
   - Specify the lower left corner as the basepoint.
   - Right-click and click Reference.

5. Specify the reference angle by selecting the following points on the angle of reference:
   - Click the lower left corner endpoint (1).
   - Click the endpoint at (2) for the second point (any point along that line will work).
   - To specify the new angle, enter 0, or press ENTER to accept the default <0>.

6. The rectangle is now straight.

Note the following:
- When using the Reference option, clicking points on the line of reference using object snap is the most accurate method.
- The order in which you click the points on the line of reference determines what you enter for the new angle. For instance, if point (2) was selected before point (1), the new angle would have been 180.
Exercise: Rotate Objects

In this exercise, you use the Rotate command to rotate objects in the drawing. You use the default rotate method for specifying a rotation angle, as well as the Reference and Copy options of the Rotate command. When you have finished, you will be able to use the Rotate command to rotate objects in other drawings.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 3: Manipulating Objects. Click Exercise: Rotate Objects.

1. Open C_Rotate-Objects.dwg.
2. To rotate the computer:
   - Activate the Rotate command.
   - Select the computer object. Press ENTER.
   - Press SHIFT+right-click anywhere in the drawing. Click Insert.
   - Touch the computer block to display the Insert Object Snap marker, then select the point.
   
   Note: The Insert Object Snap override enables you to select the insertion point of the block.

3. To position the computer to face the chair:
   - Verify that the polar setting is selected.
   - Drag clockwise until the PolarSnap display reads 315 degrees. The distance is not critical, just make sure that your cursor is not activating any object snaps.
   - Click to select the point.
4. To select the chair:
   - On the Home tab, click Modify Panel > Rotate.
   - Click the chair object above the desk. Press ENTER.
   - Press SHIFT+right-click anywhere in the drawing. Click Insert.
   - Click the chair object to display the Insert Object Snap marker, then click to select the point.

5. To rotate the chair to face the desk:
   - Enter -90.
   - Press ENTER to rotate the chair 90 degrees counter-clockwise.
   The chair should be positioned facing the desk.

6. To select the chair and base point:
   - Press ENTER to repeat the Rotate command.
   - Select the chair object next to the small conference table. Press ENTER.
   - Select the center of the conference table as the base point.

7. To rotate the chair around the round table using the Reference option:
   - Right-click anywhere in the drawing. Click Reference.
   - Define the reference angle by selecting the center of the conference table and the midpoint of the chair back rest.
   - Enter 90. Press ENTER.
   The chair should be positioned 90 degrees up from the center of the conference table.

8. To make a copy of the chair while rotating it around the round table:
   - On the command line, enter RO. Press ENTER.
   - Select the chair object. Press ENTER.
   - Click the center of the conference table as the base point.
   - Right-click anywhere in the drawing. Click Copy.
   - Position the cursor so that the polar angle displays 90 degrees. Click to select that point.
   A copy of the chair is rotated.
9. To rotate both chairs with the Copy option so that four chairs are around your table:
   - Press ENTER to repeat the Rotate command.
   - Select both chair objects. Press ENTER.
   - Click the center of the conference table to specify the base point.
   - Right-click anywhere in the drawing window. Click Copy.
   - Position the cursor so that the polar angle displays 180 degrees. Click to select that point.

10. Close all files. Do not save.
Lesson: Creating a Mirror Image of Existing Objects

This lesson describes how to create mirrored versions of existing objects in the drawing. You can use symmetrical copies of objects and spaces to aid you in your designs. Whether they are simple consumer products or whole apartment buildings where adjacent apartments use symmetric floor plans, all make use of symmetry for a variety of reasons.

Objectives

After completing this lesson, you will be able to:

- Use grips or the Mirror command to mirror objects in the drawing.
Mirroring Objects

Using the Mirror command, you can create symmetric versions of geometry. When you activate the Mirror command, you are prompted to select the objects to mirror and to define a mirror line. The mirror line defines a vector across which all selected geometry is mirrored. After defining the mirror line, you can decide whether to erase or retain the source geometry. You can also control the Mirror command using grips.

Mirror works for all object types.

Command Access

Command Line: MIRROR, MI
Ribbon: Home tab > Modify panel > Mirror
Menu Bar: Modify > Mirror

Mirroring Text

You can use the MIRRTEXT system variable to reverse text in a mirror action. By default, the MIRRTEXT system variable is set to 0, which means the text is not reversed when mirrored. If you need the text to be reversed, set MIRRTEXT to 1.
Procedure: Mirroring Objects

The following is an overview of mirroring objects in the drawing with the MIRRTEXT system variable set to 0.

1. Activate the Mirror command.
2. Select the objects to be mirrored. Press ENTER.

3. Select two points to define the mirror line.

4. Enter Y to erase source objects or N to keep the source objects. Notice that the orientation of the text remains the same.
Procedure: Mirroring Text

The following is an overview of mirroring text in the drawing with the MIRRETEXT system variable set to 1.

1. Begin by setting the MIRRETEXT system variable to 1. This turns the mirroring of text on.
   - At the Command line, enter MIRRETEXT and press ENTER.
   - Enter 1 and press ENTER.
2. Activate the Mirror command.
3. Select the objects to be mirrored. Press ENTER.
4. Select two points to define the mirror line.
5. Enter Y to erase source objects or N to keep the source objects.
Procedure: Mirroring Objects Using Grips

The following steps give an overview of using grips to mirror objects.

1. Select an object to activate its grips.
2. Click a grip to activate grip edit mode. By default, this point will be used as the first point of the mirror line.
3. Right-click anywhere in the drawing. Click Mirror.
4. Move your cursor to define the mirror line. Click to select the point.

Guidelines for Mirroring Objects

- You can use the Mirror command on all geometry.
- By default, all new drawings have the MIRRTEXT system variable set to 0, so that text is not reversed in a mirror action.
- When MIRRTEXT is set to 0, the text does not mirror; however, the text alignment is mirrored, for example from left alignment to right.
- Drawings that were created in older versions may have the MIRRTEXT system variable set to 1. When you mirror a text object in one of these files, the text is reversed. To avoid reversal of the text, set the MIRRTEXT value to 0.
Practice Exercise: Mirror Objects

In this practice exercise, you mirror an object using the Mirror command and grips. First, you draw an object that you will mirror similar to the one shown.

1. Using the Line command, draw an object similar to the one illustrated above. It is best to draw an object that is asymmetric to understand the mirror command.

2. To mirror the object you have just drawn:
   - On the Home tab, click Modify panel > Mirror.
   - Select the objects. Press ENTER.
   - Click the first point of the mirror line.
   - Click the second point of the mirror line. Note that with polar tracking on, you can mirror the object around a specific angle.
   - Press ENTER to accept the default No <N> so that you do not erase the source object.

3. Zoom out, and mirror the objects using Grips.
   - With the command line blank, select the objects.
   - Right-click one of the grips (1). Click Mirror (2).
   - Right-click again. Click Copy (3).
4. Next, change the basepoint of the objects to mirror:
   - Right-click the selected grip. Click Basepoint.

5. Click the first and second points of the mirror line as indicated below. Notice that in this example polar tracking is on.

6. Press ENTER to complete the command and ESC to deselect the objects.
Exercise: Mirror Objects in the Drawing

In this exercise, you use the Mirror command to copy similar geometry from one side of a drawing to another. You also identify and correct a potential problem when mirroring text.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 3: Manipulating Objects. Click Exercise: Mirror Objects in the Drawing.

1. Open M_Mirror-Object.dwg.
2. To select the objects to mirror:
   - On the Home tab, click Modify panel > Mirror.
   - Enter WP. Press ENTER.
   - Create a window polygon around the objects as indicated below. Select points (1) through (4) in the blank area around the objects.
   - **Hint:** To avoid object snaps, zoom in to select the points.

   - When you have enclosed the object in the selection window, press ENTER.
   - Press ENTER again to complete the object selection.
3. Select the endpoint of the circle centerline as the first point of the mirror line.
4. Drag the cursor upward. Click anywhere above the first point.
   ■ Verify that polar tracking is on. Make sure that the cursor readout is 90 degrees.
   ■ Right-click and click No to keep the source objects.

5. Close all files. Do not save.
Lesson: Creating Object Patterns

This lesson describes what an array is and how you can use arrays to create duplicate objects, such as the circular array of chairs around the table in the following floor plan.

Most common patterns contain geometry that is duplicated in a rectangular or circular array. You can use the Array command to duplicate objects in a repeatable pattern.

Objectives

After completing this lesson, you will be able to:

- Use the Array command to pattern objects in the drawing.
Creating an Array of Objects

Using the Array command, you can duplicate existing objects in a rectangle or circular (polar) pattern. You can select which type of array to use in the Array dialog box. Click the Rectangular or Polar options to see point, distance, and method requirements for each type.

The following illustration shows a rectangular and polar array.

Command Access

Command Line: ARRAY, AR
Ribbon: Home tab > Modify panel > Array
Note: Do not confuse this command with the 3D Array command.

Menu Browser: Modify > Array
Array Dialog Box: Rectangular Array

1. Click to select the object(s) to include in the array.

2. Enter the number of rows (horizontal patterns) for the array.

3. Enter the number of columns (vertical patterns) for the array.

4. Enter a distance to offset each row. Use the simulated preview window to see the direction of the pattern.

5. Enter a distance to offset each column.

6. Enter an angle for the pattern.

7. Click Preview to preview the array. Preview is not available until you select an object or objects for the array.
Array Dialog Box: Polar Array

1. Click to select the object(s) to include in the array.

2. Enter the center point's coordinates in the X and Y fields or click the Select Point icon to select a center point in the drawing window.

3. Select the method for calculating the polar array.
   - Total number of items and angle to fill.
   - Total number of items and angle between items.
   - Angle to fill and angle between items.

4. Enter the total number of items for the array. This includes the original object.

5. Enter the total angle for the array. A negative number creates the array in a clockwise direction.

6. Select to rotate each object as it is placed in the array.

Zooming while using the Array command

Although you cannot zoom or pan the drawing using traditional methods while the Array dialog box or Array Preview is active, you can select the Pick Object button, or any of the other pick point buttons to temporarily hide the dialog box, allowing you to zoom and pan. To return to the Array dialog box, press ENTER without selecting any objects or points.
Procedure: Creating a Rectangular Array of Objects

The following steps give an overview of creating rectangular arrays.

1. On the ribbon, click Home tab > Modify Panel > Array.
2. In the Array dialog box, click the Rectangular option. Click Select Objects and select the objects to include in the array.

3. Enter row and column values, or click Pick Offset to define the row and column offset values.

```
Rows: 4  Columns: 2
```

4. If required, enter an angle for the array.
5. Click Preview to preview the array.
6. Right-click to accept and create the array, or press ESC to return to the dialog box.
Procedure: Creating a Polar Array of Objects

The following steps are an overview of creating polar arrays.

1. On the ribbon, click Home tab > Modify Panel > Array.
2. In the Array dialog box, click the Polar option. Click Select Objects and select the objects to include in the array.

3. In the Center Point fields, enter the X and Y coordinates for the center point of the array, or click Pick Center Point to select the center point in the drawing.

4. In the Method list, select the method to use for the array.
5. Enter values in the appropriate fields according to the method that you chose.

6. Click Preview to preview the array.
7. Right-click to accept and create the array, or press ESC to return to the dialog box.
Guidelines for Rectangular Versus Polar Array

Follow these guidelines when using the Array command:

- To create many regularly spaced objects, the Array command is faster than Copy command.
- For rectangular array, specify the number of rows and columns and the distance between each.

![Rectangular Array Diagram]

- For Polar Array, specify the number of copies of the object, the angle to fill, and whether the copies are rotated.
- Specify the center point about which the objects will array.
- A Polar Array is drawn counterclockwise or clockwise, depending on whether you enter a positive or a negative value for the angle to fill.

![Polar Array Diagram]
Practice Exercise: Creating an Array of Objects

In this practice exercise, you draw a 1 x 1 rectangle and create an array using the Polar and Rectangular array options.

1. Begin by drawing the rectangle:
   - Start the Rectangle command.
   - Click the first corner in the drawing window.
   - For the other corner enter D (for Dimensions). Press ENTER.
   - Enter a length of 1 and a width of 1.
   - Click to position the rectangle.

2. To create a polar array:
   - On the Home tab, click Modify panel > Array.
   - In the Array dialog box, click Polar Array (1).
   - Click the Select objects button (2) and select the rectangle. Press ENTER to return to the dialog box.
   - Click the Center point button (3) and, using object snap tracking, track a center point that is two units down from the midpoint of the rectangle as shown.
   - For Total number of items (4), enter 6.
   - For Angle to fill (5), enter 360.
   - Click OK (6).
   - Zoom to display your polar array, which should resemble the following illustration.
3. To create a rectangular array:
   - Create another 1 x 1 rectangle.
   - On the Home tab, click Modify panel > Array.

   In the Array dialog box, click Rectangular Array (1).
   - Click the Select objects button (2), and click the rectangle. Press ENTER to return to the dialog box.
   - Enter 12 for Rows (3) and Columns (4).
   - Enter 2 for Row offset (5) and Column offset (6).
   - Click OK (7).

   Zoom to display your rectangular array, which should resemble the following illustration.
Lesson: Creating Object Patterns

Exercise: Array Objects in the Drawing

In this exercise, you create polar and rectangular arrays of various pieces of office furniture in an office floor plan. When you have completed the exercise, you will be able to use the Array command to create arrays of objects in your drawings.

You have the option of completing this exercise using either imperial or metric units. Select one version of the exercise to complete the steps.

You have the option of completing this exercise using either imperial or metric units. Select one version of the exercise to complete the steps.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 3: Manipulating Objects. Click Exercise: Array Objects in the Drawing Metric.

Exercise: Array Objects in the Drawing (Metric Units)

1. Open M_Creating-Arrays.dwg.
2. To create a polar array, zoom into the area shown in the following image.
3. To create an array of the chair around the table:
   - On the Home tab, click Modify panel > Array.
   - In the Array dialog box, click Polar Array (1).
   - Click Select Objects (2). Select the chair.
   - Press ENTER to return to the dialog box.

   - Click Select Objects (2). Select the chair.
   - Press ENTER to return to the dialog box.
5. Zoom to display the area that is indicated in the following image. Make certain that the walls are visible.

6. Use the Rectangular array option to populate the remaining offices with the objects from the first two:
   - On the Home tab, click Modify panel > Array.
   - In the Array dialog box, click Rectangular Array.
   - Click the Select Objects button.
   - Select the objects indicated in the following image. Press ENTER.
   **Note:** Use two separate crossing windows to select the objects.

7. Set your desired number of rows and columns:
   - In the Array dialog box, for Rows, enter 4.
   - For Columns, enter 2.
   - Under Offset Distance and Direction, click the button indicated below to Pick Both Offsets.
8. Specify the unit cell as indicated:
- Click the endpoint of the line of the lower interior wall.
- For the other corner, click the endpoint of the line of the upper interior wall.
- Click Preview.
- Your rectangular array should appear as illustrated.
- Do not press ENTER.
- Use the wheel on the mouse to adjust the display of your drawing.

9. Close all files. Do not save.

Exercise: Array Objects in the Drawing (Imperial Units)
1. Open I_Creating-Arrays.dwg.
2. To create a polar array, zoom into the area shown in the following image.

3. To create an array of the chair around the table:
- On the Home tab, click Modify panel > Array.
- In the Array dialog box, click Polar Array (1).
- Click Select Objects (2). Select the chair.
- Press ENTER to return to the dialog box.
Click the Center point button (3).
With Object Snap on, select the center of the table.
For the total number of items (4), enter 6.
For the angle to fill (5), enter 360.
Click PREVIEW (6).
Do not press ENTER. Press ESC to return to the dialog box.

4. Change the total number of items:
   - In the Array dialog box, enter 8 for the total number of items (4).
   - Click OK to complete the polar array.
   - Eight chairs are arrayed around the table as in the following illustration.

5. Zoom to display the area that is indicated in the following image. Make certain the walls are visible.

6. Use the Rectangular array option to populate the remaining offices with the objects from the first two:
   - On the Home tab, click Modify panel > Array.
   - In the Array dialog box, click Rectangular Array.
   - Click the Select objects button.
   - Select the objects that are indicated in the following image. Press ENTER.
   **Note:** Use two separate crossing windows to select the objects.

7. Set your desired number of rows and columns:
   - In the Array dialog box, for Rows, enter 4.
   - For Columns, enter 2.
   - Under Offset Distance and Direction, click Pick Both Offsets.
8. Specify the unit cell as indicated:
   - Click the endpoint of the line of the lower interior wall.
   - For the other corner, click the endpoint of the line of the upper interior wall.

   ![Diagram showing the unit cell specification process.]

   - Click PREVIEW.
   - Your rectangular array should appear as illustrated.
   - Do not press ENTER.
   - Use the wheel on the mouse to adjust the display of your drawing.

   ![Rectangular array illustration.]

   - If necessary, press ESC to return to the dialog box and reselect the unit cell, or press ENTER to complete the Array command.

9. Close all files. Do not save.
Lesson: Changing an Object's Size

This lesson describes how to increase or decrease the size of objects in the drawing using the Scale command.

When you create drawings, it is often quicker to modify existing geometry then to create new geometry from scratch. With the Scale command, you can resize geometry to meet the current design requirements.

The object on the right was created by scaling the object on the left by .5.

Objectives

After completing this lesson, you will be able to:

- Use the Scale command or grips to scale objects in the drawing.
Scaling Objects

You use the Scale command when you need to change the size of existing geometry in the drawing. The Scale command can scale an entire drawing or just the objects that you select. After you select the geometry to be scaled, you have the option of scaling a copy of the selected geometry. If you choose this option, the original geometry remains unchanged while a copy of the geometry is scaled by the factor you specify. You can also control a scaling operation using grips.

Command Access

Command Line:
 SCALE, SC

Ribbon: Home tab > Modify panel > Scale

Note: Do not confuse this command with the 3D Scale command.

Menu Bar: Modify > Scale

Shortcut Menu: Select objects then right-click anywhere in the drawing window. Click Scale.
Command Options

With the Scale command, you can scale geometry using the following options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base Point</td>
<td>Use this option to define the point from which the selected geometry is scaled. If the base point is not coincident with the selected geometry, the distance between the base point and the geometry is scaled.</td>
</tr>
<tr>
<td>Copy</td>
<td>Use this option to scale a copy of the selected geometry. The original geometry is not scaled.</td>
</tr>
<tr>
<td>Reference</td>
<td>Use this option to specify a reference length, either by entering a value, or selecting two points. After you specify the reference length, enter a new length for the reference length. The scale factor is calculated as Reference Length = New Length.</td>
</tr>
</tbody>
</table>

Procedure: Scaling Objects

The following steps give an overview of scaling objects using the Scale command.

1. On the ribbon, click Home tab > Modify panel > Scale.
2. Select the objects to be scaled. Press ENTER to end the object selection.
3. Select a base point.
4. Enter a scale factor. Press ENTER.
Procedure: Scaling Objects Using Grips

The following steps give an overview of using grips to scale objects.

1. Select an object to activate its grips.
2. Click a grip to activate grip edit mode. By default, this point will also be used as the base point for the scale.
3. Right-click anywhere in the drawing. Click Scale.
4. Specify a scale factor.

Guidelines for Scaling Objects

- A value less than 1 decreases the size of the geometry. A value greater than 1 increases the size of the geometry. For example, entering a scale factor of .5 halves the size of the selected objects.
- The most recent scale factor used persists for the current editing session.
- To scale using the Reference option, use object snap to click two points on the object to define the reference scale. This is often quicker and more accurate than finding the distance and calculating a scale factor.
- When you use the Reference option, the two points that define the reference distance are independent from the scale base point.
Practice Exercise: Scaling Objects

In this practice exercise, you draw an object and scale it using the Scale command with the Reference option and grips with the Copy option. You draw a rectangle of any size and scale it to a specific size. Then you scale and copy it using grips.

1. Draw a rectangle of any size:
   - Start the Rectangle command.
   - Click the first corner.
   - Click the opposite corner.

2. To scale the rectangle using the Reference scale option:
   - On the Home tab, click Modify panel > Scale.
   - Select the rectangle. Press ENTER.
   - Click a basepoint on or near the rectangle.
   - Right-click and click Reference.
     - To specify a new length, enter 2 and press ENTER.

3. Use grips to scale and copy the rectangle at .5 scale and then at .25 scale of the original size. Select the middle of the rectangle for the basepoint:
   - With the command line blank, select the rectangle.
   - Right-click any grip on the rectangle. Click Scale.

   - Using object snap tracking, select the middle of the rectangle for the basepoint.
4. To specify the scale factors:
   - Enter .5. Press ENTER.
   - Enter .25. Press ENTER.
   - Press ESC to end the scale procedure.
   - Press ESC to clear the rectangle selection.

   Your drawing should look similar to the illustration below.
Exercise: Scale Objects Using the Copy Option

In this exercise, you use the Copy option of the Scale command to scale a copy of the link-arm profile geometry and leave the source geometry unchanged. You then rotate the original geometry and dimensions.

1. Open M_Scale-Copy.dwg.
2. On the Home tab, click Modify panel > Scale. Window select all of the geometry and dimensions in the drawing.

3. Press ENTER to accept the selection.
4. Select the center of the large circle as the base point.
5. Right-click anywhere in the drawing. Click Copy.
6. Enter 1.25 for the scale factor. Press ENTER.
7. To rotate the original objects:
   ■ Begin the Rotate command.
   ■ Enter P. Press ENTER to select the previous selection set.
8. Press ENTER to accept the selection set.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 3: Manipulating Objects. Click Exercise: Scale Objects Using the Copy Option.
9. Select the center point of the larger circle.

10. Enter 90. Press ENTER.

11. Close all files. Do not save.
Challenge Exercise: Grips

In this exercise, you use grips to edit and manipulate objects in a drawing. When you have completed the exercise, you will be able to use grips to effectively manipulate geometry without having to use the standard editing commands.

The completed exercise

Completing the Exercise

To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 3: Manipulating Objects. Click Challenge Exercise: Grip Edit Objects.

1. Open M_Grips-Exercise.dwg.
2. To move a door into position using grips:
   - Select the door.
   - Click the single grip to make it a selected grip.
   - Right-click. Click Move.
   - Drag the door into position. Click the endpoint of the wall. Your object will still be selected.
3. To copy the door using grips for the next room:
   - Click the grip again to make it a selected grip.
   - Right-click. Click Move.
   - Right-click. Click Copy.
   **Note:** With a single object, you do not need to click Move first and can proceed to Copy. With more than one object selected, you always need to click Move before clicking Copy.
   - Drag the door one room to the right. Click the endpoint of the wall.
   - Press ENTER to complete the copy.
   - Press ESC to release your selection.

4. To move the plant into position using grips:
   - Select the plant.
   - Click the grip to make it selected.
   - Right-click. Click Move.
   - Drag the plant to the upper-left corner as shown below.
5. To copy the plant using grips:
   - Click the plant grip again to make it selected.
   - Right-click. Click Move.
   - Right-click. Click Copy.
   - Drag and place the second plant in the lower-right corner as shown.
   - Press ENTER to finish the copy.
   - Press ESC to clear your selection.

6. To move the credenza and keyhole desk using grips:
   - Using the Move grip mode, drag the credenza into position as shown.
   - Using the Move grip mode, drag the keyhole table into position as shown.
7. To move the file cabinet into position using grips:
   - Select the file cabinet.
   - Click the grip to select it.
   - Right-click. Click Move.
   - Drag the object to the lower-left corner as shown below. Place the object about four units above the lower wall attached to the left side wall.

8. To rotate the file cabinet using grips:
   - Click the grip again to select it.
   - Right-click. Click Rotate.
   - Enter 90. Press ENTER.
   - Press ESC to clear your selection set.
9. Use the Move and Rotate grip modes again to place the computer and phone onto the desk as shown. Refer to the previous step if needed for the step-by-step process.
   - The computer object is rotated 45 degrees.
   - The phone object is rotated 90 degrees.

10. Use Move, Rotate, and Copy grip modes to place the chair object in the office as shown:
    - The desk chair is rotated -45 degrees and the conference table chair is rotated at 45 degrees. The remaining two chairs are rotated at 90 degrees.
    Your office layout should look like the following image.
11. Use the Copy and Base Point grip modes to copy many objects at once to populate the next office area to the right:

- Select all of the objects as shown in the following image.
- Pick any one of the available grips to make it hot.
- Right-click. Click Move.
- Right-click. Click Copy.
- Right-click. Click Base Point.
- Pick the inside top-left corner of the room (1) for the base point.
- Pick the top-left inside corner of the next room (2) for the move point.
- Press ENTER to complete the copy.
- Press ESC to release your selection set.
12. Use the Mirror and Copy grip modes to populate the next office area to the right:
   - Select all of the objects as shown in the following image.
   - Click any one of the available grips to select it.
   - Right-click. Click Mirror.
   - Right-click. Click Copy.
   - Right-click. Click Base Point.
   - Pick the midpoint of the outside wall section (1) between the doors for the base point.
   - Drag your cursor up at 90 degrees and pick point (2).
   - Press ENTER to complete the copy.
   - Press ESC to release your selection set.

13. Continue to use grips, as time permits, to populate the remaining offices with furniture.
14. Close all files without saving.
Challenge Exercise: Architectural

In this exercise, use what you learned about modifying objects to modify the floor plan.

You have the option of completing this exercise using either imperial or metric units. Select one version of the exercise to complete the steps.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 3: Manipulating Objects. Click Challenge Exercise: Architectural Metric.
Metric Units

1. Open the drawing you saved from the previous challenge exercise, or open M_ARCH-Challenge-CHP03.dwg.

2. Create geometry to represent the stairs for the building. You will create the stair in an open area of your building and then rotate it and move it into position:
   - Begin with a single line (1).
   - Array the line to create the stairs on the left.
   - Add the vertical lines on the left and the right.
   - Mirror all the lines to create the stairs on the right.
   - Create the remaining lines using Otrack and direct distance entry.
   - Do not create the centerline, it is there for dimensional purposes only.

3. Position the stairs in the lower stairwell as shown.
4. Mirror the lower stairs to the top stairwell to complete the drawing.

5. Save and close the drawing.

**Imperial Units**

1. Open the drawing you saved from the previous challenge exercise, or open `I_ARCH-Challenge-CHP03.dwg`.

2. Create geometry to represent the stairs for the building. You will create the stair in an open area of your building and then rotate it and move it into position:
   - Begin with a single line (1).
   - Array the line to create the stairs on the left.
   - Add the vertical lines on the left and the right.
   - Mirror all the lines to create the stairs on the right.
   - Create the remaining lines using Otrack and direct distance entry.
   - Do not create the centerline, it is there for dimensional purposes only.
3. Position the stairs in the lower stairwell as shown.
4. Mirror the lower stairs to the top stairwell to complete the drawing.

5. Save and close the drawing.
Challenge Exercise: Mechanical

In this exercise, use what you learned about modifying objects to edit geometry.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise.
In the onscreen list of chapters and exercises, click Chapter 3: Manipulating Objects. Click Challenge Exercise: Mechanical.

1. Open the drawing you saved from the previous challenge exercise, or open M_MECH-Challenge-CHP03.dwg.
2. Rotate the right side view 90 degrees as shown.
   Note: The views in the image are closer together than they will appear in your drawing.
3. Move the top view so that its midpoint aligns with the circles in the main view. Move the side view so that it is correctly aligned with the base view. The views for the Rack Slider Base should appear as shown.  
   **Note:** The views in the image are closer together than they will appear in your drawing.

4. Copy or mirror the two circles in the top view to the other side.

5. Rotate the right side view and move both the top and side view into alignment with the base view.  
   **Note:** The views in the image are closer together than they will appear in your drawing.
6. Mirror the geometry in the top and main views to complete the sketch as shown.

7. Save and close all files.
Chapter Summary

Every design you create begins with simple geometry. The procedures you use to edit these basic objects transform them into complex designs.

Having completed this chapter, you can:

- Use different selection methods to select objects in the drawing.
- Move objects in the drawing using object snaps, object tracking, and coordinate entry for precise placement.
- Use the Copy command or use grips to create new objects from existing objects in the drawing.
- Change the angle of objects in the drawing by using the Rotate command or with grips.
- Create mirrored images of objects in the drawing using the Mirror command or with grips.
- Use the Array command to create rectangular and circular patterns of objects in the drawing.
- Change the size of objects in the drawing.
- Use grips to edit objects and display geometric information.
- In this exercise, use what you learned about modifying objects to modify the floor plan.
- In this exercise, use what you learned about modifying objects to edit geometry.
Drawing Organization and Inquiry Commands

The ability to electronically manipulate, organize, and obtain information in a drawing far surpasses anything that you could accomplish if you were to use manual methods. To achieve this, you must attain proficiency with entering commands and using the other design methods available. This way, you will see how the software is much more useful than pencil and paper.

In this chapter, you learn how to organize objects in a drawing and how to use layers and linetypes to enhance your design practices. You also learn how to take advantage of the electronic design environment and use tools to obtain geometric information from objects in the drawing.

Objectives

After completing this chapter, you will be able to:

- In this lesson you will use layers to organize objects in your drawing.
- Identify and change the properties of objects.
- In this lesson you adjust object properties on several different types of objects. You begin by learning about the Quick Properties panel, how to access it and how to control its visibility and behavior. You then use the Quick Properties panel to quickly change object properties.
- Use the Match Properties command to apply the properties from a source object to destination objects.
- Use the Properties palette to change object properties.
- Use linetypes to distinguish objects in the drawing.
- Use the Inquiry commands (Distance, Radius, Angle, Area, List, and ID) to obtain geometric information from the drawing.
- In this exercise, you use what you learned about drawing organization and inquiry commands to create layers, manipulate objects and their layers, and create additional geometry on its correct layer.
In this exercise, you use what you learned about drawing organization and inquiry commands to add layers and hidden geometry to the drawing views.

**Standard Object Snap and Status Bar Settings**
Before completing the exercises in this chapter, refer to the "Settings for the Exercises" section in the Introduction in Volume 1.
Lesson: Using Layers

This lesson describes what layers are and how you can use them to organize objects in your drawing. For example, in the following illustration, objects might be placed on different layers, with dimensions on one layer, hidden lines on another, and the hole features isolated on a third. Each layer may have property settings that determine the color, linetype, and lineweight of the objects on that layer.

In a typical drawing, objects are placed to represent some part of the design. These objects can include geometry, text, dimensions, and borders. To organize your drawing, you need a way to logically group objects based on function, appearance, or other commonalities. There are many industry layering standards and most designers base their own standards on one of these. Most important is that you establish a standard for layering and you follow it.

After completing this lesson, you will be able to use layers to organize objects in your drawing.

Objectives

After completing this lesson, you will be able to:

- Describe how layers can be used to organize objects in your drawing.
- Describe the purpose of Layer 0.
- Access the Layer Properties Manager and use other commands to manage layers.
Organizing Objects with Layers

As your drawings increase in complexity, organization of the drawing objects becomes critical to efficiently managing the design data. You can use layers to logically group objects in the drawing.

In the following office layout, you would use layers to separate walls, partition walls, furniture, text, and equipment.

About Layers

Use layers to logically organize the objects in the drawing and to enforce linetype, color, and lineweight standards. When you group objects into layers, you can then control these objects by controlling the single layer. For example, if you put all the dimensions on a single layer, you could choose to hide these dimensions simply by freezing that layer.

The following image illustrates how layers are used to organize objects. The image on the left represents the logical grouping of similar objects, while the image on the right illustrates what you see in the software.
Using layers is similar to using overlays in a manual drafting environment where clear media that contains groups of related design elements are placed throughout the overall design. As a result, you see everything that you create, you have the flexibility to easily remove the overlays, and can focus on any aspect of your design.

**A Typical Layer Configuration**

A typical drawing could use layers to organize objects in the following way.

<table>
<thead>
<tr>
<th>Layer Name</th>
<th>Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Walls</td>
<td>All geometry representing walls.</td>
</tr>
<tr>
<td>Electrical</td>
<td>All geometry representing electrical.</td>
</tr>
<tr>
<td>Hidden</td>
<td>Geometry that is represented by hidden lines.</td>
</tr>
<tr>
<td>Landscape</td>
<td>Geometry representing landscaping objects.</td>
</tr>
<tr>
<td>Construction</td>
<td>Temporary geometry used for sketching or other construction geometry purposes.</td>
</tr>
<tr>
<td>Dimensions</td>
<td>Drawing dimensions.</td>
</tr>
<tr>
<td>Annotation</td>
<td>Text and notes.</td>
</tr>
<tr>
<td>Hatch</td>
<td>Hatch patterns, fills, gradients.</td>
</tr>
<tr>
<td>Titleblock</td>
<td>Borders, Title Block and title block information.</td>
</tr>
</tbody>
</table>

The preceding table is only an example of a typical layer configuration. Most companies have layer standards already defined to suit their particular needs. The following examples show a standard architectural layer configuration.
Typical Architectural Layer Configuration

Use the Layer Properties Manager to create and manage the layers in a drawing.

Layer Key Points

- Use layers to organize objects in your drawing.
- Layers have property settings that determine the color, linetype, and lineweight of the objects on that layer.
- Use the Layer Properties Manager dialog box to create and manage layers.
- Every drawing contains at least the default Layer 0.
- To organize a drawing, consider grouping objects onto layers based on function, appearance, or other commonalities.
- There are many industry standards concerning layering from which you can establish a layering standard for your drawings.
- When your drawing is organized with layers, you can easily control entire groups of objects.

Default Layer

Every drawing that you create has a default layer called 0 (zero). This ensures that every drawing contains at least one layer.

Default Layer Defined

When you create a new drawing, a number of layers may be present depending on the template that you used. Layer 0, however, is persistent regardless of the template used. Every drawing will contain the default layer 0.

Layer 0 cannot be renamed or deleted. AutoCAD® uses that layer to establish predictable behaviors for objects such as blocks, regardless of how other layers are named.
The following illustration shows the Layer Properties Manager dialog box in a drawing created from acad.dwt. The only layer present is 0.

Guidelines for Layer 0
The following are some specific guidelines related to Layer 0.

- You can create layers in addition to Layer 0 in the Layers Properties Manager when you begin a new drawing unless they are already provided in your company's drawing template.
- You can make a layer current first and then draw your objects. This automatically places the geometry on that current layer instead of Layer 0.
- Consider Layer 0 as your working layer when uncertain where to place geometry. Then, move the objects to the appropriate layer.
- You should create simple block geometry on Layer 0 so that when you insert it on another layer it takes on the properties of that layer. For example, a chair block created on Layer 0 and inserted on the Furniture layer will appear with the properties (Color, Linetype, Lineweight) that are assigned to the Furniture layer.
- You should insert blocks with multiple layers on Layer 0 so that the layers and colors assigned to the block appear the way they were created when you insert them into your drawing.

If you do create objects on layer 0, you can assign them to a different layer at any time.

Layer Tools
When you create and manage layers, you use the Layer Properties Manager and the Layer Control list on the ribbon. Together, these commands and tools provide you with the functionality required to effectively create, manage, and assign objects to layers.
Layers Panel

Command Access

Use the Layer Properties Manager to create layers and control the color, linetype, lineweight, and other properties of each layer.

Layer Properties Manager

Command Line: LAYER, LA
Ribbon: Home tab > Layers panel > Layer Properties

Menu Bar: Format > Layer...

To quickly make an object’s layer current, use the following command.

Make Objects Layer Current

Command Line: LAYMCUR
Ribbon: Home tab > Layers panel > Make Objects Layer Current

Menu Bar: Format > Layer Tools > Make Object's Layer Current
To return to the previous layer settings, use the following command.

**Layer Previous**

**Command Line:** `LAYERP`

**Ribbon:** Home tab > Layers panel > Previous

**Menu Bar:** Format > Layer Tools > Layer Previous

Layer Previous in AutoCAD LT
Layer Previous is not available in AutoCAD LT®.

**Layer Properties Manager Dialog Box**

Your primary tool for managing layers is the Layer Properties Manager. Use this dialog box to create and manage layers.
Command Options

The following options are available in the Layer Properties Manager dialog box for essential layer management.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Create Layer" /></td>
<td>Click to create a new layer. Enter a name for the layer in the field. Select the layer name twice to rename. Layer names can be listed in the Name column in ascending or descending order.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Delete Layer" /></td>
<td>Click to delete the selected layer. You cannot delete the current layer or layers containing objects. You can undo by selecting the Undo icon from the Quick Access toolbar.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Make Layer Current" /></td>
<td>Click to make the selected layer Current. You can also double-click the layer to make it the current layer.</td>
</tr>
</tbody>
</table>

Click the layer row and the appropriate column to assign or change the properties for that layer. Properties include Color (see below), Linetype (see below), Lineweight (see below) and whether the layer will Plot or not.

**Color:** Select a color from the AutoCAD Color Index. Note that the Color white will print black and be displayed black on a white drawing background and white on a black background.
Lesson: Using Layers

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Linetype:</strong></td>
<td>A blank drawing will contain the Continuous linetype. Select the Load button to load other linetypes.</td>
</tr>
<tr>
<td><strong>Lineweight:</strong></td>
<td>Various lineweights will not be displayed in the drawing window unless the Show Lineweight option is selected in the status bar. Note that the default lineweight is 0.01 inches or 0.25 mm.</td>
</tr>
</tbody>
</table>

**New Layer Properties**

When you create a new layer, the properties of the currently selected layer are duplicated for the new layer. If your new layer is going to have properties such as color or linetype in common with another layer, select the similar layer before you click New.

**Layer Status**

The visibility and availability of objects on specific layers are determined by the layer's status. The following table describes the potential status of a layer.

These icons appear in the Layer Properties Manager and the Layer list. Click the icon to change the status of the layer.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Light Bulb" /></td>
<td><strong>On:</strong> Objects on the layer are visible. <strong>Off:</strong> Objects on the layer are not visible but are still considered when the drawing is regenerated.</td>
</tr>
<tr>
<td>Icon</td>
<td>Status</td>
</tr>
<tr>
<td>------</td>
<td>--------</td>
</tr>
</tbody>
</table>
| ![Thawed](icon.png) OR ![Frozen](icon.png) | **Thawed:** Objects on the layer are visible.  
**Frozen:** Objects on the layer are not visible and are not considered when the drawing is regenerated. |
| ![New VP Freeze](icon.png) OR ![VP Freeze](icon.png) | **New VP Freeze:** Freezes layer in newly created viewports.  
**VP Freeze (Layout only):** The layer is not visible and will not print in the selected or current viewport if frozen. |
| ![Unlocked](icon.png) OR ![Locked](icon.png) | **Unlocked:** You can select and edit objects on the layer.  
**Locked:** You cannot select or edit objects on the layer. |

### Layer Control List

The Layer Control list is located on the Layers panel.

Select the down arrow to reveal the list of Layers in the drawing.

The Layer Control serves a dual purpose.
1. In normal operations, the current layer is displayed. However, when an object is selected with the Command line blank, the list displays the layer that the object is on. The following image shows that when the door block is selected, the A-Doors layer is displayed.

   ![Layer Control](image)

   It is helpful to know what layer the object is on. But you may also place the selected object or objects on another layer by choosing the layer from the drop down list.

2. After you create layers, you can use the Layer Control to select a layer to make it current, to change the layer status to Freeze or Thaw, Lock or Unlock, or turn layer On or Off.

   ![Layer Control](image)
Layer Tools Key Points

- Creating and managing layers requires the use of some key commands, the Layer Properties Manager, and the Layer Control list on the Layers panel.
- Your primary tool for managing layers is the Layer Properties Manager. Use this dialog box to create and manage layers.
- Once a layer is created, you cannot delete it if it is current or if there are objects referenced on that layer.
- Layer 0 cannot be deleted or renamed.
- Layer properties include color, linetype, lineweight, and whether the layer will plot or not.
- A layer status can be On or Off, Frozen or thawed, and Locked or Unlocked.
- Layers that are turned off are not visible but are still considered when the drawing is regenerated.
- Layers that are frozen are not visible and are not considered when the drawing is regenerated.
- With the Command line blank, you can select an object and see what layer it is on from the Layers Control list located on the Layers panel.
- You can select an object and move it to another layer using the Layers Control list.
- You can change a layer's status from the Layers Control list.
- The Layer Previous command returns you to the previous layer state, to the previous layer setting, and to the previous status of all layers in the drawing.

Performance Tip

For better performance on large drawings, freeze layers instead of turning them off. Objects on layers that are turned off are still considered when the drawing is regenerated, while objects on layers that are frozen are not considered, and thus not calculated when the drawing is regenerated.
Lesson: Using Layers

Practice Exercise: Layer Tools

In this practice exercise, you create layers in the Properties Manager dialog box and select the layer from the Layer Control list to draw objects on the appropriate layer.

1. To create the layers:
   - On the ribbon, click Home tab > Layers panel > Layer Properties.
   - In the dialog box, click New.
   - Create the following layers:
     - Layer Name: Circle, Color: Red
     - Layer Name: Line, Color: Blue
     - Layer Name: Rectangle, Color: Green
   
   **Note:** If you enter the layer name and then a comma, a new layer name field appears. The layers are automatically listed in alphabetical order.

2. Close the Layer Properties Manager dialog box.

3. In the Layer Control list, select the Circle layer to make it current and draw circles on that layer.

4. Repeat the previous step:
   - Click the Rectangle layer to make it current and draw rectangles.
   - Click the Line layer to make it current and draw lines.
Exercise: Work with Layers

In this exercise, you freeze and thaw layers and lock and unlock them. You create new layers, set the current layer, and create new geometry on the current layer.

The completed exercise

Completing the Exercise

To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 4: Drawing Organization and Inquiry Commands. Click Exercise: Work with Layers.

1. Open M_Create-Layers.dwg.
2. Study the drawing, paying particular attention to the color and linetype of the objects. Turn the Dimensions layer off to make it easier to view and make changes to the geometry in the drawing:
   - On the Home tab, click Layers panel > Layer Control list.
   - Click the Sun icon to freeze the Dimensions layer. The icon changes from a sun to a snowflake indicating that the layer is frozen.

3. To make the hidden layer current:
   - On the Home tab, click Layers panel > Layer Control list.
   - Select Hidden to set it as the current layer.

4. Zoom into the area shown and draw lines on the Hidden layer:
   - Using the Line command, create a line from point 1 to point 2 and another from point 3 to point 4 as shown in the following illustration.
   - Make sure you are snapping to the exact endpoint or intersection on the existing objects.
5. Draw a line on the Center layer across the center of the object as indicated below:
   - Zoom out so that the entire drawing is displayed, then zoom into the area shown below.
   - On the Home tab, click Layers panel > Layer Control list. Select the Center layer.
   - Start the Line command.
   - Acquire the 180 degree quadrant point of the large circle and drag your cursor to the left along the extension path.
   - In the dynamic input field, enter 5. Press ENTER.
   - Drag your cursor outside the large circle to the right along the extension path.
   - In the Dynamic Input field, enter 85. Press ENTER.
   - Press ENTER again to end the Line command.

6. To create another line across the center of the object:
   - Press ENTER to repeat the Line command.
   - Acquire the 270 degree quadrant point of the large circle and drag your cursor downward along the extension path.
   - In the Dynamic Input field, enter 5. Press ENTER.
   - Drag your cursor outside and above the large circle along the extension path.
   - In the Dynamic Input field, enter 85. Press ENTER.
   - Press ENTER again to end the Line command.
7. Use the Rotate command to rotate both centerlines 30 degrees. Use the center of the large circle as the base point for the rotation.

8. Thaw the Dimension Layer:
   - On the Home tab, click Layers panel > Layer Control list. Click the snowflake icon to thaw the Dimensions layer.
   - Zoom out to the extents of your drawing.

9. To observe object properties in the Layer Control list:
   - With the command line blank, click any dimension.
   - Notice that the Dimensions layer appears in the Layer Control list.
   - Press ESC so that the command line is blank.
   - Move your cursor over any object on the Visible layer as shown below. Notice the padlock symbol that is displayed. Objects on the visible layer are locked and cannot be modified, however, you may add more geometry to any locked layer.
Lesson: Using Layers

10. Try to move some of the objects including ones which are on a locked layer:
- Start the Move command.
- Select all of the objects in the auxiliary view. Press ENTER.
- Click any point on the drawing. Enter 25. Press TAB.
- In the Angle field, enter 30. Press TAB.
- Click anywhere in the drawing to complete the Move command. Notice that some of the objects did not move.
- Undo the Move command.

11. This time you will move the objects again, but first you unlock the layer that some of these objects are on:
- On the Home tab, click Layers panel > Layer Control list. Click the padlock icon on the Visible layer. Note that the padlock changes from a closed lock to an open lock indicating that the layer is unlocked.
- Repeat the Move command from the previous step. Notice how all of the objects are moved.
- Relock the visible layer.

12. To create a new layer:
- On the Home tab, click Layers panel > Layer Properties.
- In the Layer Name field, click Visible. The properties of layer Visible are used as the default properties for the new layer.
- In the Layer Properties Manager dialog box, click New Layer (1).
- In the Layer Name field (2), enter Title Block.
- Click the Color field (3) and select White.

13. To add another layer:
- Click New Layer again.
- In the Layer Name field, enter Viewport.
- Click the Color field and select Cyan. Click OK.
- Click in the Plot field. This sets the Viewport layer to nonplotting.
- Click the layer Title Block.
- Right-click. Click Set Current.
- Click the X to close the Layer Properties Manager dialog box.

14. Zoom out to the extents of your drawing.
15. To create a rectangular border:
   - Start the Rectangle command.
   - Enter 0,0. Press ENTER.
   - Right-click. Click Dimensions.
   - Enter 400 for the length. Press ENTER.
   - Enter 277 for the width. Press ENTER.
   - Click anywhere near the Auxiliary view to complete the command.

16. Close all files. Do not save.
Lesson: Changing Object Properties

This lesson describes what object properties are and how to change the properties of objects in a drawing. Every object that you create in a drawing has associated properties. For example, a line has an associated color, layer, linetype, and length as shown in the following Quick Properties panel.

It is very common practice to change the properties of objects as you work on a drawing. One way to access and change some object properties is to select the object and use the Layers and Property panels in the Ribbon to change the Layer or override the color, linetype or lineweight. Another method to change object properties is with the Properties palette which provides a number of options depending on the items selected.

The following illustration shows the object properties of a selected circle as displayed in the Properties palette.

After completing this lesson, you will be able to describe the various properties of objects, identify the current settings, and assign and change object properties for existing objects in the drawing.

Objectives

After completing this lesson, you will be able to:
■ Describe what object properties are and explain how they are used.
■ Describe the use and effect of the ByLayer property.
■ Change object properties.

About Object Properties

The most common object properties include Layer, Color, Linetype, and Lineweight. In most instances, an object's color, linetype, and lineweight are determined by the layer on which it was drawn. When you create new objects, you should make sure that the object properties settings in the layers that you create produce the desired results.

However, you may view, override, or change some object properties from the settings in the Layers and Properties panels. These options are limited to Layer, Color, Linetype, and Lineweight.

In the Properties palette, shown below, you can access a more complete list of object properties that you may view or change. The list of properties that is displayed depends on the type of object or variety of objects that you select.
Object Properties - Line

The 3D Visualization group shown in the previous image is not available in AutoCAD LT.

Warning!

Definition of Object Properties

Object properties control how an object looks, both on screen and in print. The following image shows objects with specific Linetype, Lineweight, and Color properties.
Example of Object Properties

It is common practice in 2D drafting to represent a feature or surface that is obscured by another with a hidden linetype. The hidden line indicates that the feature exists behind the current visible surface. Another common practice is to use colors to distinguish between objects in complex drawings and assigning different colors to different object types.

In the following image, the object lines are shown with the Continuous linetype and a unique color. The section line is shown with the Phantom linetype and unique color. The hole centerlines are shown with the Centerline linetype and a unique color. The hidden edge lines are shown with the Hidden linetype and a unique color. More than likely, the information in this drawing is organized into layers which determine the color and linetype of these objects. However, at a glance, it would be impossible to know precisely how the object properties have been assigned without further investigation.

1. Object lines shown as Continuous linetype.
2. Hole centerlines shown as Center linetype.
3. Hidden edge lines shown as Hidden linetype.
4. Section line shown as Phantom linetype.
ByLayer Property

The Properties panel in the Home tab of the ribbon displays the current property settings for objects that you create in a drawing. The default settings are ByLayer which means that the object properties are determined by the layer. By default, all objects use the ByLayer setting for color, linetype, and lineweight.

The following image shows the default ByLayer settings on the object Properties panel.

![ByLayer Settings](image)

Definition of the ByLayer Property Setting

The ByLayer property setting is assigned to objects and specifies its color, linetype, lineweight, and plot style. This special property setting is the equivalent to using a specific color such as red or a specific linetype such as Hidden. When property types are set to ByLayer, the object assumes the property setting that is defined in the object's layer. If you change the property in the layer, all objects with the ByLayer setting update accordingly.

The ByLayer setting not only enables consistency across objects on the same layer, it also ensures that all objects update accordingly if you change the layer's color, linetype, or lineweight properties.

You should only override an object's color, linetype, or lineweight property to something other than ByLayer when absolutely necessary. When you look at a drawing that contains objects of the same colors and linetypes, the natural inclination is to assume those objects are on the same layers.

Example of Changing Object Properties from the ByLayer Default

It is common drafting practice to place certain object types on their own layers. For example, all centerlines would be on the same layer, all object lines on their own layer, and so forth. By following this structure, you can readily control the display of all your objects both on screen and in print.
In the following image, the object lines, centerlines, and hidden lines all have their properties set to ByLayer.

If you change the lineweight of the layer of the object lines, all of the objects on that layer change to reflect the layer setting. This change is shown in the following image.
Changing Object Properties

One way to change the properties of objects is to use the controls in the Layers and Properties on the ribbon. By selecting the object or objects, you can view properties and make changes simply by selecting the desired options from the lists.

To turn the Layers or Properties panels on, right-click on the Home tab and click Panels. Then select Layers and Properties from the list.
Layers Panel - Layer Control List

The following image shows the Layers panel. With an object selected, you can view and modify the layer associated with that object.

Properties Panel - Select a Linetype

The following image shows the Properties panel with the linetype list selected. Using this panel, you can view and modify an object's color, linetype, and lineweight.

Show/Hide Lineweight

The Show/Hide Lineweight option on the status bar controls the visibility of lineweights in the drawing.

Click to turn this feature on or off. Right-click and select Settings to adjust the display scale.
Procedure: Changing an Object's Layer Property

The following steps give an overview of how to change an object's layer property using the Layer Control list in the Layers panel.

1. Select one or more objects in your drawing that need to be moved to a different layer.
2. On the Home tab, click Layers panel > Layer Control list. Select the layer where you want to move the objects.

3. Press ESC to clear your selection.

Procedure: Changing an Object's Color Property

The following steps describe how to change an object's color by selecting a color from the list on the Properties panel.

1. Select one or more objects in your drawing that need to have their color changed.
2. On the ribbon, click Home tab > Properties panel > Object Color. Select the desired color from the list.

3. Press ESC to deselect the objects.

Procedure: Changing an Object's Linetype Property

The following steps describe how to change an object's linetype by selecting the list of linetypes from the Properties panel. You can load desired linetypes that are not in the list by selecting Other.

1. Select one or more objects in your drawing that need to have their linetype changed.
2. On the ribbon, click Home tab > Properties panel > Linetype. Select the desired linetype from the list.

3. Press ESC to deselect the object.

Procedure: Changing an Object's Lineweight Property

The following steps describe how to change an object's lineweight by using the lineweight list on the Properties panel.

1. Select one or more objects in your drawing that need to have their lineweight changed.
2. On the ribbon, click Home tab > Properties panel > Lineweight. Select the desired lineweight from the list.

![Linenweight Settings]

3. Press ESC to deselect the object.

**Change Properties Guidelines**

- Make sure that you display the Layers and Properties panels. If they are not visible, right-click in the Home tab of the ribbon to turn them on.
- Be sure the Command line is blank, then use the window or crossing selection to quickly select one or more objects to view or change their properties.
- If you select the wrong object, just press SHIFT and select it again to remove it from the selection set.
- When you select more than one object with different properties, the field in the property option will be blank. This is because only one property can be listed at a time.
- You can select more than one object and choose a property that you want to assign to all of the objects selected.
- Object properties should be determined *by the layer* (ByLayer) whenever possible.
- Linetypes not shown in the list can be loaded into the drawing.
- Be sure the Lineweight display option is on in the status bar and adjust the lineweight display in the Settings dialog box.

**Object Selection**

Remember to press the ESC key after you complete each change and before you select more objects. This prevents accidental changes to the properties of previously selected objects.
Practice Exercise: Changing Object Properties

In this practice exercise, you draw simple objects on the default layer 0. Then you create additional layers with object properties as specified. Finally, you select the objects and change the properties using the lists from the Layers and Properties panels.

1. Begin a new drawing from the `acad.dwg` template and draw some lines, circles, and rectangles on the default layer 0.

2. On the Home tab, click Layers panel > Layer Properties. In the Layer Properties Manager, create several layers with the following names and colors:
   - Circles - red
   - Lines - blue
   - Rectangles - cyan

3. To assign a hidden linetype to the Lines layer:
   - In the Layer Properties Manager, on the Lines layer, click Continuous.
   - In the Select Linetype dialog box, click Load.
   - In the Load or Reload Linetypes dialog box, scroll to and click HIDDEN.
   - Click OK to exit the dialog boxes.

4. To assign a Lineweight of 0.35 to the layer named Rectangles:
   - In the Layer Properties Manager dialog box, click the Default lineweight of the Rectangles layer.
   - In the Lineweight dialog box, click 0.35 mm lineweight.

<table>
<thead>
<tr>
<th>S.</th>
<th>Name</th>
<th>O.</th>
<th>L.</th>
<th>Color</th>
<th>Linetype</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Circles</td>
<td></td>
<td></td>
<td>white</td>
<td>Continuous</td>
</tr>
<tr>
<td></td>
<td>Lines</td>
<td></td>
<td></td>
<td>blue</td>
<td>Continuous</td>
</tr>
<tr>
<td></td>
<td>Rectangles</td>
<td></td>
<td></td>
<td>cyan</td>
<td>Continuous</td>
</tr>
</tbody>
</table>
5. To change the object properties:
   - With the command line blank, select all of the circles. On the Home tab, click Layers panel > Layer. Select the Circle layer. Press ESC to deselect the objects.
   - Repeat this step for the lines and rectangles and place them on their designated layers.
   - Press ESC to deselect all objects.
   - Your drawing should look similar to what is shown in the following illustration.

6. On the status bar, be sure the Show Lineweight setting is on.

7. To change the object properties again:
   - With the command line blank, select all of the object you have drawn.
   - On the Home tab, click Properties panel > Linetype(1) > Hidden.
   - In the Lineweight list (2), click 0.40.
   - From the Color list (3), select White.
   - Now all of the objects in your drawing should have the same color, linetype, and lineweight as in the following image.

   ![Image of settings with Lineweight set to 0.40 and Color set to White]

   It is difficult to tell at a glance which objects are on the layers.

8. Change the object properties back to ByLayer:
   - With the command line blank, select all of the objects that you have drawn.
   - On the Home tab, click Properties panel > ByLayer for (1) Color, (2) Linetype, and (3) Lineweight.

   ![Image of settings with ByLayer selected for Color, Linetype, and Lineweight]

   - Press ESC to deselect all of the objects.
   - Your objects should display the properties that you assigned to each object in step 5.
Exercise: Change Object Properties

In this exercise, you use the Layers and Properties toolbars to change the layer, linetype, and lineweight of selected objects.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 4: Drawing Organization and Inquiry Commands. Click Exercise: Change Object Properties.

1. Open I_Change-Properties.dwg.
2. To change the linetype of the overhead doors to ByLayer:
   - Select the overhead doors indicated by the arrows.
   - On the Home tab, click Properties panel > Linetype.
   - Select ByLayer. Press ESC to clear your selection set.
3. To move some of the machine labels to another layer:
   - With the command line blank, select the text for machine numbers 47 through 54.
   - On the Home tab, click Layers panel > Layer.
   - Select the machine labels layer to move the numbers to this layer.
   - Press ESC to clear your selection set.
4. To move some tables to another layer:
   ■ Select the three round tables as shown.
   ■ On the Home tab, click Layers panel > Layer.
   ■ Click the furniture layer to move the tables to this layer.
   ■ Press ESC to clear your selection set.

5. To change the lineweight of objects:
   ■ On the status bar, click Show/Hide Lineweight to turn on the lineweight visibility.
   ■ Zoom into the stairwell area on the drawing.
   ■ Select the inside walls of the stairwell, all stair treads, and the door lines.
   ■ On the Home tab, click Properties panel > Lineweight.
   ■ Click ByLayer. Press ESC to clear your selection set.

6. To change the color of objects:
   ■ Zoom into the upper right part of your drawing.
   ■ Select the lines of the counter space as indicated.
   ■ On the Home tab, click Properties panel > Color.
   ■ Select the ByLayer property to change each object's color to that of its layer.
   ■ Press ESC to clear your selection set.
7. To move some machines to another layer:
   ■ Select the machines labeled 5 through 10 without selecting the numerical label.
   ■ On the Home tab, click Layers panel > Layer.
   ■ Click the machine layer to move these machines to that layer.
   ■ Press ESC to clear your selection set.

8. Close all files. Do not save.
Lesson: Quick Properties

In this lesson you adjust object properties on several different types of objects. You begin to learn about the Quick Properties panel, how to access it, and how to control its visibility and behavior. You then use the Quick Properties panel to quickly change object properties.

Object properties are adjusted frequently in each drawing editing session. The Quick Properties panel enables you to streamline and simplify the process because you only see the properties that you need. This enables you to make object property changes much faster.

Objectives

After completing this lesson, you will be able to:

- Describe the Quick Properties panel and settings.
- View object properties using the Quick Properties panel.
About Quick Properties

The Quick Properties panel is a convenient way to view and modify object properties without losing space to the larger Properties palette. Quick Properties are automatically displayed when you select an object, and they disappear when the object is deselected. You can view and modify the properties of the object that are displayed in the Quick Properties panel. While beyond the scope of this lesson, you can use the CUI dialog box to change the properties that are displayed on the Quick Properties panel to show the properties that you use the most.

Quick Properties Panel

The following options are available in the Quick Properties panel.

1. **Object Type**: Displays the type of object selected.

2. **Object Properties**: Lists object properties.

3. **Customize**: Displays the Customize User Interface (CUI) dialog box where you can specify the object types and the properties that display for them in the Quick Properties panel.

4. **Options**: Displays the options menu where you can close, customize, and change Quick Properties settings. You can also set the location mode to cursor or float and specify whether the Quick Properties panel automatically collapses.

When multiple objects are selected, the Quick Properties panel only displays properties that are common to all selected objects. You can select a specific type of object from a drop down list to display all of the Quick Properties for that object type.
Quick Properties Settings

You can specify how and where the Quick Properties panel is displayed in the Drafting Settings dialog box, Quick Properties tab. The following settings are available:

1. **Enable Quick Properties Palette**: Displays the type of object selected. When multiple objects are selected, a drop down list enables you to select a specific type of object.

2. **Palette Display**: Sets the Quick Properties panel to display all objects or only the objects that have defined Quick Properties in the Customize User Interface (CUI).

3. **Palette Location**: Sets the location mode of the Quick Properties panel to Cursor or Static.

4. **Palette Behavior**: Enables the Quick Properties panel to display only the number of properties specified for Default Height. You must scroll or expand the Quick Properties panel to view properties if more than the default number are available.

**Location Modes**

The Quick Properties panel can be displayed in three different modes:

- **Cursor mode** – Use this option to display the panel alongside the cursor when an object is selected.
- **Static mode** – Use this option to display the panel in the same place on the screen unless you manually reposition it.
Using Quick Properties

When Quick Properties are turned on, the Quick Properties panel displays when you select an object. The Quick Properties panel no longer displays when you deselect that object. If you do not want the Quick Properties panel to display each time you select an object, use the toggle functionality on the status bar or in the Drafting Settings dialog box to turn Quick Properties off.

Command Access

Quick Properties

Keyboard Shortcut: **CTRL+SHIFT+P**
Object Shortcut Menu: **Quick Properties**
Status Bar: **Quick Properties**

Procedure: Using Quick Properties

The following steps give an overview of using Quick Properties.

1. On the status bar, verify Quick Properties is turned on.
2. Select an object.
3. In the Quick Properties panel, view or change the desired object property.
4. Press ESC to exit the Quick Properties panel.
Exercise: Use Quick Properties

In this exercise, you use the Quick Properties palette to view various object properties. You also customize the Quick Properties palette to control the circumstances in which the palette appears and the options it displays.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 4: Drawing Organization and Inquiry Commands. Click Exercise: Use Quick Properties.

1. Open c_quick_properties.dwg.
2. On the status bar, right-click Quick Properties. Click Settings.
3. In the Drafting Settings dialog box, Quick Properties tab:
   - Place a check mark in the box next to the Enable Quick Properties Palette option.
   - For the Palette Display, click All Objects.

4. Under Palette Location:
   - Click Cursor-dependent.
   - For Quadrant, select Bottom-Right.
   - For Distance in Pixels, enter 20.

5. Under Palette Behavior:
   - Verify that Collapse Palette Automatically is selected.
   - For the minimum number of rows, enter 2.

6. Click OK.
7. Select a line object in the drawing. The Quick Properties panel automatically appears to the bottom right of the cursor.

8. Move your cursor over the Quick Properties panel. The panel expands to display more properties.

9. Press ESC to clear the selected line.

10. Select a dimension in the drawing. The Quick Properties panel automatically displays two property rows.

11. On the status bar, right-click Quick Properties. Click Settings.

12. In the Drafting Settings dialog box, Quick Properties tab, under Palette Behavior, clear the check mark for the Collapse Palette Automatically option. Click OK.

13. Select a dimension in the drawing. The Quick Properties panel automatically expands.

14. Press ESC to clear the selected dimension.

15. Close all files. Do not save.
Lesson: Matching Object Properties

This lesson describes how to change the properties of objects in a drawing to match the properties of other objects in the drawing or in another drawing.

A typical drawing will contain objects with properties that are unique to the individual object and properties that are shared by other objects in the drawing.

After completing this lesson, you will be able to use the Match Properties command to apply the properties from a source object to destination objects.

The following illustration shows how several objects in the drawing can have common properties.

Objectives

After completing this lesson, you will be able to:

- Use the Match Properties command to apply the properties from a source object to destination objects.
Matching an Object's Properties

You use the Match properties command to assign properties of one object to another by selecting a source object and a destination object.

In the following illustration, the properties from a source hatch object (1) are applied to the destination hatch (2).

Command Access

Match Properties

Command Line: MATCHPROP
Ribbon: **Home tab > Clipboard panel > Match Properties**
Menu: **Modify > Match Properties**
Property Settings Dialog Box

The properties that you select in the Property Settings dialog box determine which properties from the source object are copied to the destination objects. To adjust the Match Properties settings, after you activate the Match Properties command and select the source object, right-click anywhere in the drawing and select Settings.

The Property Settings dialog box is divided into two areas, Basic Properties and Special Properties.

1. Basic Properties are properties that are common to most objects.

2. Special Properties are properties that are specific to a certain type of object. For example, if you select the Text option, the text style of the source object is assigned to the destination text object. In some situations, you may not want to copy the text style to the destination text, so you would clear the Text option. Only the basic properties that are selected are copied to the destination text.

Match Properties Across Multiple Drawings
If you have multiple drawings open at once, you can use the Match Properties command to match the properties of an object in one drawing to an object in another drawing.
Procedure: Matching Object Properties

The following steps give an overview of using the Match Properties command to apply properties from a source object to a destination object.

2. Select a source object.

3. To control which properties are assigned to the destination object, right-click anywhere in the drawing and click Settings. Select the properties in the Properties Settings dialog box.
4. Select the destination objects.

Guidelines for Matching Properties

- When you use the Match Properties command, you can select only one source object.
- You must select the source object directly. Implied windowing or other window selection methods are not available.
- You can match the properties from the source object to an unlimited number of objects. When selecting the destination objects, you can use any selection method.
- You can match properties from objects in one drawing to objects in another drawing that is opened.
- To adjust the matching properties settings, begin Match Properties, select the source object and right-click to access the Settings dialog box.
Practice Exercise: Match an Object’s Properties

In this practice exercise, you create several rectangles on Layer 0. You create a new layer with specified properties and draw some rectangles on that layer. Then you use the Match Properties command on selected rectangles.

1. Begin a new, blank drawing.
2. Draw several rectangles on the default Layer 0.
3. Create a new layer:
   - In the Layer Properties dialog box, create a new layer with the following object properties:
     - Name: Test
     - Color: blue
     - Linetype: Hidden (first Load the hidden linetype into the drawing)
     - Lineweight: 0.35 (select Show Lineweight in the status bar)
   - Set this layer current.
   - Exit the dialog box.
4. Draw several more rectangles. The second set of rectangles should have the object properties designated in the new layer settings, and the first set of rectangles should have the default object properties.

5. To match the properties:
   - On the Home tab, click Clipboard Panel > Match Properties.
   - On the new layer, select one of the rectangles (1) that you have drawn.
   - Create a crossing window as indicated below to select the rectangles that are on layer 0.
   - Press ENTER to exit the Match Properties command.

6. The object properties of the rectangles should now match.

Note: Select Show Lineweight on the status bar to view the new layer properties.
Exercise: Match Object Properties

In this exercise, you use the Match Properties command to apply one object's properties to other objects. When you have completed the exercise, you will be able to use the Match Properties command to aid in more efficient drawing creation.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 4: Drawing Organization and Inquiry Commands. Click Exercise: Match Object Properties.

1. Open C_Match-Properties1.dwg.
2. To match the properties of one window block to others:
   - On the Home tab, click Clipboard Panel > Match Properties.
   - Select the window block (1) as the source object.
   - For the destination objects, select the window blocks located at (2), (3), and (4).
   - Press ENTER to exit the command.
3. To match some of the properties from the single door to the double doors:
   - On the Home tab, click Clipboard Panel > Match Properties.
   - Select the single door swing arc (1).
   - Right-click in the drawing window. Click Settings.
   - In the Property Settings dialog box, under Basic Properties, make sure the Color (2) option is cleared.
   - Click OK to return to the drawing window.
   - Press ENTER to exit the Match Properties command.

   **Note:** Since the color of the double door was not set to ByLayer, it did not change. If you click any object on the double door, you notice that the Doors layer is displayed in the Layer Control list on the Layers panel.
4. To match some of the properties from one wall hatch to another:
   - On the Home tab, click Clipboard Panel > Match Properties.
   - Select the wall hatch (1) between the two doors as shown in the image below.
   - Right-click in the drawing area. Click Settings.
   - In the Property Settings dialog box, make sure the Hatch option is cleared and the Color option is selected.

5. To match hatch styles between wall hatches:
   - With the Match Properties command started, right-click and click Settings to open the Property Settings dialog box.
   - Select the Hatch option. Click OK.
   - In the drawing window, select the same hatch as in the previous step.
   - This time, the hatch style changes along with the basic properties.
   - Continue to select the rest of the mismatched wall hatches.
   - Press ENTER to end the command.

6. To match properties across dimensions:
   - On the Home tab, click Clipboard Panel > Match Properties.
   - Select the overall dimension across the bottom of the drawing as the source object.
   - Select all of the dimensions across the top of the drawing.
   - Press ENTER to exit the Match Properties command.

   - Click OK to exit the dialog box and return to the drawing window.
   - Select the wall hatch (2) immediately above the source hatch.
   - Only the basic properties of the hatch change. Since the hatch style is not part of the basic properties, the hatch's pattern stays the same.
7. Open another drawing and match properties from objects in one drawing to another:
   ■ Open the C_Match-Properties2.dwg drawing.
   ■ On the View tab, click Window panel > Tile Vertically to view each drawing side by side.
   ■ Select one drawing to activate the window and Zoom Extents.
   ■ Select the other drawing window and repeat the Zoom Extents command.
   ■ In the drawing that you just opened, zoom to the lower right corner where it reads CONFERENCE ROOM.

8. To match properties from one drawing to the next:
   ■ On the Home tab, click Clipboard Panel > Match Properties.
   ■ Select the LG. CONFERENCE text in the drawing as indicated above.
   ■ Select the other drawing C_Match-Properties1.dwg to activate the drawing window.
   ■ Select the text objects in the drawing.

   ■ Continue to select all of the text objects.
   ■ Press ENTER to exit the command.

9. When object properties are matched from one drawing to the another, all referenced object properties (i.e. layer, text style, linetype) are brought into the matched drawing.

10. Close all files. Do not save.
Lesson: Using the Properties Palette

This lesson describes the Properties palette and how to use it to modify object properties. Each object you create has a set of properties that defines how the object appears in the drawing. In fact, as you create the objects, you are assigning properties as part of the geometry creation process. You can view and modify these properties with the Properties palette.

After completing this lesson, you will be able to use the Properties palette to adjust object properties.

The following illustration shows a typical drawing containing objects of different types. You can use the Properties palette to modify the common property types of dissimilar objects at the same time.

Objectives

After completing this lesson, you will be able to:

- Use the Properties palette to adjust object properties.
Using the Properties Palette

You can use the Properties palette to change the characteristics of an object such as its color, linetype, lineweight, or layer. The Properties palette is context sensitive, so it only displays the properties that are relevant to the type of object that you select.

Object Properties

Properties are organized into separate groups, such as General, Geometry, and Misc. Click the arrows on the title area for each group to collapse or expand the group.

Read-only properties are indicated by a gray background in the values column, and cannot be selected.

You can select read-write properties. Options for changing these properties vary with the property. Some are lists, some are simple text boxes, and others require you to click an icon in the field to redefine a point.
Command Access

Properties Palette

Command Line: PROPERTIES
Ribbon: Home tab > Properties panel > Dialog Box Launcher

Menu: Modify > Properties; Tools > Palettes > Properties; right-click an object > Properties
Keyboard Shortcut: CTRL+1

You can also double-click on some objects to access the Properties palette.

Selecting Objects Using the Object Types List

When you have multiple object types selected, the Object Types list shows all of the objects. When you select different types of objects, the Properties palette displays only those property types that are common to all object types that are selected. For each object type that you select, the object type name appears in the list. You can select an object type in the list to adjust properties for the selected objects of that type.

For example, in the following illustration, the Object Type list is shown with two objects that are selected, a polyline and a text object.
Procedure: Using the Properties Palette to Change Object Properties

The following steps give an overview of using the Properties palette to change object properties.

1. On the ribbon, click Home tab > Properties panel > Dialog Box Launcher > Properties or press CTRL+1.
2. Select the objects to adjust properties for.
3. You can change any value in a read-write field and all changes occur in real time.
4. Press ESC to cancel the object selection. The Properties palette remains open.

Key Points for Using the Properties Palette

- The Properties palette differs from a traditional dialog box interface in that it can remain open while you are using other commands.
- Other methods are available for editing an object's properties, but the Properties palette provides a common interface for changes to different object types and to the properties of multiple objects simultaneously.
- Click the Auto-hide icon on the Properties palette (shown in the following illustration) to make the palette collapse when the cursor moves away from it.
Exercise: Manipulate Object Properties

In this exercise, you learn how the Properties palette functions. When you have completed the exercise, you will be able to effectively manipulate objects and their properties using the Properties palette.

1. Open C_Properties-Palette.dwg.
2. To open the Properties palette, press CTRL+1.

Note: If the Properties palette is already open, CTRL+1 will close it. You can also access the Properties palette by double-clicking an object in the drawing. This either opens the Properties palette if it is not currently open, expands the palette if Auto-hide is set, sets the focus to the palette if it was already open, or launches the PEDIT command if you double-click a polyline.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 4: Drawing Organization and Inquiry Commands. Click Exercise: Manipulate Object Properties.

3. Click the Auto-hide button in the upper left corner of the Properties palette as shown in the image.

The completed exercise
This causes the Properties palette to expand when you move the mouse over it and contract when the mouse moves away. You can also dock the palette by dragging it to the edge of the application window.

4. Change object properties using the palette:
   - Select all of the objects in the drawing.
   - On the Properties palette, change the color and linetype to ByLayer.
   - Press ESC to clear the selection and notice the change in color.

5. Zoom in to the area shown.

6. To change the color of selected polylines:
   - Select all of the geometry in the window.
   - On the Properties palette, select Polyline from the Object Type list.
   - Select the Color property and set it to Blue.
   - Press ESC and notice that all polylines in the selection are now blue.

7. To change the display of the drawing:
   - Zoom to the extents of the drawing.
   - Zoom to the area shown in the image.
8. To select objects to change:
   - On the Home tab, click Layers panel > Layer. Turn off Layer 1 in the Layer list.
   - Select the large circle in the view.

9. To change the diameter of the circle using the palette:
   - On the Properties palette, change the Diameter to 64.
   - Press ENTER.
   The diameter changes.

10. Use a crossing window selection to select more objects in the view.

11. To change object properties by filtering:
   - Use the Object List at the top of the Properties palette to filter just the circle objects.
   The properties common to all circles appear in the Properties palette.
   - Change the diameter to 32 units.
   - Press ENTER.
   The diameters of all circles in the selected view change to 32.

12. Close all files. Do not save.
Lesson: Using Linetypes

This lesson describes how to use linetypes in your drawings. After completing this lesson, you will be able to describe linetypes and how they are used in a drawing and use the Linetype Manager to add linetypes to your drawing.

Linetypes are used to distinguish objects in the drawing from one another. You can use them to represent hidden geometry in a specific view, to show centerlines for dimensioning, or perhaps just to add clarity to the drawing.

For example, the following illustration shows a solid linetype used for geometry and a centerline linetype used for centerlines for dimensioning. The dashed linetype indicates hidden geometry.

Objectives

After completing this lesson, you will be able to:

- Describe linetypes and how they are used in a drawing.
- Use the Linetype Manager to add linetypes to your drawing.
About Linetypes

In a typical drawing, you find linetypes associated with many objects. While the specific linetypes used may vary from one discipline to another, the concept of using linetypes remains consistent. They are always used to distinguish objects from one another and to make the drawing easier to read and understand.

The following illustration contains continuous, hidden, and center linetypes. Each of these linetypes have meaning within the discipline in which they are used.

Linetypes Defined

Linetypes are an attribute of an object that determines how it looks. The linetype helps to distinguish one object from another in a design. For example, a hot water line could be represented by the HW linetype and a gas line in a building could be represented by the GAS linetype.

This image shows common linetypes used in drafting and design.
Linetype Examples

In the following image, you see two pieces of steel overlapping one another. It is impossible to tell which object lies on top of the other.

![Image of overlapping steel pieces]

This second image uses hidden lines on the vertical steel object to show you that it lies beneath the horizontal piece of steel.

![Image of steel piece with hidden lines]

Linetype Key Points

- Linetypes are used to distinguish objects from one another.
- Linetypes add visual clarity to the drawing.
Adding Linetypes to Your Drawing

To add linetypes to your drawing, you generally assign the linetype to layers and then create objects on the appropriate layers. The object’s linetype can be set to ByLayer, which means the object assumes the linetype of the layer.

By default, the only linetype available in the drawing is Continuous. To use additional linetypes, you must load them into the drawing. The primary method for adding linetypes to the drawing is with the Linetype Manager.

Command Access

Linetype Manager

Command Line: LINETYPE
Ribbon: Home tab > Properties panel > Linetype list > Other
Menu Bar: Format > Linetype
About the Linetype Manager

The Linetype Manager dialog box displays all of the linetypes that are currently loaded in the drawing. To load additional linetypes, click Load. To delete linetypes, select the linetype and click Delete. You cannot delete a linetype if it is currently being referenced by other objects in the drawing.
Loading Linetypes

When you select Load from the Linetype Manager dialog box a list of linetypes provided by AutoCAD appears that lets you add additional linetypes to the drawing. You can scroll through the list and select the desired linetypes.

Loading Linetypes from the Layer Property Manager

You can also add linetypes to a drawing from the Layer Properties Manager. Click to assign the linetype to a layer. If the linetype is not available in the Select Linetype dialog box, click Load to load the linetype using the Load or Reload Linetypes dialog box.

Controlling Linetype Scale

Depending on the size of the objects in your drawing, you may have to adjust the linetype scale in order for the lines to appear correctly. For example, to see the gaps in a centerline that is 12 units long, you would set your linetype scale to 1.0, but to see the gaps correctly in a centerline that is 240 units long, you would set your linetype scale to 10.0.

In the following illustration, both lines are center linetypes, but the lower line appears with a more dense pattern as a result of a smaller linetype scale.

```
___   ___   ___   ___   ___   ___
```

```
___   ___   ___   ___   ___   ___
```
You can control linetype scale in the drawing using two different methods.

- **LTSCALE**: This is a global linetype scale factor that affects all of the objects that use linetypes in the drawing. To change the global linetype scale, on the Command line, enter LTSCALE and then enter a positive number. The default scale factor is set to 1.

- **Linetype Scale property**: You can set the linetype scale factor for selected objects. Double-click the object to access the Properties palette (or right-click and select Properties from the shortcut menu). Enter a new value in the Linetype Scale property field. The Linetype Scale property works in combination with the global linetype scale factor for the drawing. For example, if the global linetype scale factor is set to 2 and the linetype scale property is set to 0.5, the net result is a linetype scale factor of 1 for the selected object.

**Properties Palette**

**Procedure: Adding Linetypes to a Drawings**

The following steps give an overview of adding linetypes to a drawing.

1. On the ribbon, click Home tab > Properties panel > Linetype list > Other.
2. In the Linetype Manager, click Load.

3. In the Load or Reload Linetypes dialog box, select the linetypes. Click OK.

4. The selected linetypes appear in the Linetype Manager. Click OK.

   *Press the Shift or Ctrl key to select more than one linetype.*

5. The linetypes are now available to apply to layers or individual objects.
Linetype Management Guidelines

- By default, a blank drawing will contain only one linetype, the continuous linetype.
- Add only the linetypes that you need for your drawing.
- Delete linetypes that are not being referenced or used from the Linetype Manager dialog box or with the PURGE command.
- A linetype that is being referenced or used cannot be deleted.
- To use other linetypes, you must load them into the drawing first and then apply them to the object or layer.
- Control linetype scale with the LTSCALE command. For example, an LT scale of 24 will multiply the size of all of the linetypes in a drawing by 24.
- Set the linetype scale of individual objects only when necessary using the Properties palette. Linetype scale settings made to individual objects are multiplied by the overall LTSCALE factor.
- Certain linetypes are available at and 2 times the normal size. Example: HIDDEN, HIDDEN2 (.5x) and HIDDEN2X (2x).
- By default, all object properties are drawn in the ByLayer mode, so objects will take on the property settings of the current layer. You can override the default mode by selecting a specific linetype from the Linetype list on the Properties panel.
Practice Exercise: Add Linetypes to Your Drawing

In this practice exercise, you draw a simple object. You add the HIDDEN linetype to the drawing, apply it to the object that you create, and then change the LTSCALE.

1. Begin a new drawing and make a rectangle.

2. To access the Linetype Manager:
   - On the Home tab, click Properties panel > Linetype list > Other.

3. To load the linetype:
   - In the Linetype Manager dialog box, click Load.
   - In the Load or Reload Linetypes dialog box, scroll to find the HIDDEN linetype.

4. To apply the hidden linetype to the object:
   - Click the HIDDEN linetype.
   - Click OK to load and exit the dialog boxes.
   - With the command line blank, click the rectangle.
   - On the Home tab, click Properties panel > Linetype list.
   - Select HIDDEN.

   - Press ESC to deselect the rectangle and view the results.
5. To change the linetype scale:
   ■ On the command line, enter `LTSCALE`. Press ENTER.
   ■ Enter a new scale factor of 2. Press ENTER.
   ■ View the results.

```
  __________
  |          |
  |          |
  |          |
  __________
```
Exercise: Use Linetypes

In this exercise, you load linetypes into the drawing and assign them to layers. You then create new geometry using the new linetypes.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 4: Drawing Organization and Inquiry Commands. Click Exercise: Use Linetypes.

2. To load linetypes:
   - On the Home tab, click Properties panel > Properties to open the Linetype Manager dialog box.
   - In the Linetype Manager dialog box, click Load.
   - In the Load or Reload Linetypes dialog box, locate and click the CENTER linetype.
   - Locate the HIDDEN linetype and press CTRL + click the linetype (this enables you to select more than one option from the list, but not the options in between).
   - Click OK to load the lines and to exit the dialog boxes.
3. To apply the loaded linetypes to the selected layers:
   - On the Home tab, click Layers panel > Layer Properties.
   - In the Layer Properties Manager dialog box, find the CENTER layer and click the linetype field for that layer (currently Continuous).
   - In the Select Linetype dialog box, click the CENTER linetype. Click OK.
   - This applies the CENTER linetype to the CENTER layer.
   - Repeat the steps to apply the HIDDEN linetype to the HIDDEN layer.
   - Note: Linetypes may also be loaded from this dialog box.
   - Click OK to exit the dialog box and close the Layer Properties Manager.

4. Notice that the centerlines now appear in the drawing. To change the linetype scale:
   - On the command line, enter LTSCALE. Press ENTER.
   - For the scale factor, enter .75. Press ENTER. Notice the effect that the new linetype scale has on the centerlines.

5. To create another centerline, first make the Center layer current:
   - On the Home tab, click Layers panel > Make Object's Layer Current.
   - Select any centerline on the drawing. The current layer should now be the Center layer.
   - Start the Line command.
   - Use object snap tracking to track a line from the center object snap above and below the object as indicated below.
6. Before drawing the hidden lines, make the HIDDEN layer current. Freeze the HATCH layer and select the appropriate object snap settings:
   - On the Home tab, click Layers panel > Layer list. Select HIDDEN to make it current.
   - Select the Layer List again and Freeze the HATCH layer.
   - On the status bar, be sure that polar tracking, object snap, and object snap tracking are all selected.
   - On the status bar, right-click Object Snap. Click Settings.
     - Use the Line command to draw two line segments in the front view that track the right and left quadrants of the small circles in the top view. Draw the line segments so that they intersect the slanted line and are perpendicular to the bottom line as indicated below.
   - Select the Endpoint, Quadrant, Intersection, and Perpendicular object snap modes.
7. Use the same technique to draw the hidden lines in the side view:
   - Using the line command, track the endpoint of the corner in the front view as indicated (*do not select this endpoint!*).
   - Drag the cursor to the side view until it intersects with the left vertical line of the object and click.
   - Drag the cursor to the right side of the object to draw the line perpendicular to the right vertical line and click.
   - Press ENTER to complete the line command.
   - Repeat to create the other horizontal line using the adjacent corner in the front view.

8. To refine the hidden hole detail in the front view:
   - Zoom to this area.
   - Trace the endpoint of the inside corner (*DO NOT click the endpoint*).
   - Drag the cursor until it intersects with the vertical hidden line and click.
   - Drag the line until it is perpendicular with the vertical hidden line to the right and click.

9. To refine the hidden hole detail in the side view, you copy lines from the front view and modify them:
   - Start the Copy command.
   - Window select from the left to right to select the hole detail in the side view.
   - Press ENTER to complete the selection.
   - Click the intersection of the centerline and the bottom line in the front view as the basepoint.
Drag the copied objects to the right. Click the intersection point of the centerline and bottom line in that view.

Press ENTER to complete the Copy command.

10. To change the linetypes and modify the copied lines:
   - With the command line blank, select the lines that you just copied.
   - Click the lower grip in the line segment on the left. Drag it perpendicular to the horizontal line as indicated.
   - With the objects still selected, on the Home tab, click Layer Control list > Hidden.
   - Press ESC to deselect all lines. The previously selected lines should all be on the HIDDEN layer.
   - With the command line blank, select the upper hidden horizontal line.
   - Select the endpoint on the right and drag it to the endpoint object snap of the vertical hidden line as indicated below. Use the intersection or perpendicular object snap mode.
   - Repeat this for the opposite endpoint.
11. To change the linetype scale of the selected line segments:
   - With the command line blank, select the two short hidden line segments as indicated below.
   - Right-click and select Properties.
   - In the Linetype scale field, enter .5
   - Press ENTER to apply this change to the selected lines.
   - Click the X in the upper left corner of the Properties dialog box to close it.
   - Press ESC to deselect the line segments.
   - Observe that the linetype scale changes to the scale of the previously selected lines.

12. To convert other lines to the HIDDEN layer:
   - With the command line blank, select the hole details as indicated below.
   - In the Layer Control list, select the HIDDEN layer.
   - Press ESC to deselect the lines and observe the change.
   - In the Layer Control list, select the HIDDEN layer.
   - Press ESC to deselect the lines and observe the change.
13. To complete this side view, it will no longer be a section view. Modify the lines accordingly:
   ■ With the command line blank, select the vertical line as indicated below.
   ■ Click the lower grip and use object tracking to track the inside corner as indicated.
   ■ Press ESC to deselect the line and grips.

14. To adjust the horizontal lines:
   ■ With the command line blank, select the line that is indicated below.
   ■ Select the left grip and drag it to the newly located endpoint of the vertical line.
   ■ Press ESC to deselect the line, then click the other horizontal line that is indicated below.
   ■ Select the right endpoint grip and drag it so that the line is perpendicular to the vertical line to its right.

15. To delete the underlying line segment:
   ■ With the command line blank, use a window to select the short line segment, clicking from left to right.
   ■ Use the Erase command or press DELETE.
Note: It is important to pay attention to the lines that are on top of other lines and delete those that are not necessary.

16. To erase the hatch pattern that is no longer necessary:
   - In the Layer Control list, thaw the HATCH layer.
   - With the command line blank, select the hatch pattern.
   - When it is highlighted, enter E. Press ENTER.
   - Zoom out to observe the changes.

17. Close all files. Do not save.
Lesson: Using Inquiry Commands

This lesson describes how to use the Measuregeom command and other inquiry commands to obtain geometric information on objects in the drawing.

As you create objects, the defining points and object types are stored in the drawing database. You can use the commands on the Inquiry toolbar to retrieve this information or to obtain distances, angles, areas, object types, and other important data for objects.

Objectives

After completing this lesson, you will be able to:

- Describe measuring and explain why the data is useful.
- Describe how to use measure tools including distance, radius, angle, area, and volume.
- Obtain information about objects, such as type, location, dimensions and properties.
About Measuring

You can calculate the distance, radius, angle, area, and volume of selected objects or a sequence of points by measuring.

Measuring is especially useful when collecting data for building and manufacturing. In the following illustration, Radius is used to obtain the brick arch radius and is mandatory for accurate construction.

Definition of Measuring

Measuring is used to ascertain the extent, dimensions, and capacity of certain objects. Measuring enables you to obtain geometric information from such things as arches, room areas, polylines, and 3D solids.
Example of Area Measurement

The following illustration shows the results of using the Area tool to obtain the total square footage of a floor plan. **Note:** The Area tool also provides perimeter data.

Using Measure Tools

Measure tools are used to pull specific data from objects. They provide a quick and effective way to collect useful information such as the total amount of concrete needed for a foundation or the precise volume of an excavation area. This information is frequently necessary to communicate pertinent measurements to outside sources or to ensure that a design meets criteria. The process for obtaining such information is combined into a single command in which different measurement options are chosen.
The following illustration shows the Volume option that is used to acquire data from a 3D object.

Command Access

**Measuregeom**

Command entry: `measuregeom`

Ribbon: **Home tab > Utilities panel > Measure drop-down > Distance/Radius/Angle/Area/Volume**

Menu: **Tools > Inquiry > Distance/Radius/Angle/Area/Volume**
Measure Command Options

The following illustrates the different measuring tools and what they are used for.

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distance</td>
<td>Measures the distance between two specified points or totals the distance between multiple points.</td>
</tr>
<tr>
<td>Radius</td>
<td>Measures the radius and diameter of a specified arc or circle.</td>
</tr>
<tr>
<td>Angle</td>
<td>Measures the angle of a specified arc, circle, line, or vertex.</td>
</tr>
<tr>
<td>Area</td>
<td>Measures the area and perimeter of an object or defined area. There are also options to keep a running total as you define areas or to subtract specified regions from total calculated area.</td>
</tr>
<tr>
<td>Volume</td>
<td>Measures the volume of an object or a defined area. There are also options to keep a running total as you define volume or to subtract specified regions from total calculated volume.</td>
</tr>
</tbody>
</table>

Selection Accuracy is Key

For the same reason you use object snaps to create geometry, using object snaps to select points for Inquiry commands is critical. If you estimate the point selection, the value returned will not be accurate.
Measure Distance

The Distance option of the Measuregeom command prompts you to select two points on the drawing and then returns information about the distance between them, their angles in and from the XY plane, and their delta values (distance traveled along each axis) in both 2D and 3D planes. The information is presented to you on the command line in the format shown below. You can also see it in the Text Window by pressing F2.

\[ \text{Distance} = 157.1924, \text{Angle in XY Plane} = 34, \text{Angle from XY Plane} = 0, \text{Delta X} = 130.3938, \text{Delta Y} = 87.7889, \text{Delta Z} = 0.0000 \]

The following image illustrates the values returned with the Distance command.

Process: Measuring Distance

The following steps give an overview for acquiring the distance between two points using the Distance option of the Measuregeom command.

1. On the ribbon, click Home tab > Utilities panel > Measure drop-down > Distance.
2. Select first point.
3. Enter M for Multiple Points and select second point.

4. Continue to select points until you arrive at starting point.

5. Right-click and select Enter to close command.

6. Note running total of the distance acquired.

**Process: Measuring Radius**

The following steps give an overview for acquiring the radius using the Radius option of the Measuregeom command.

1. On the ribbon, click Home tab > Utilities panel > Measure drop-down > Radius.

2. Select arc.
3. Note radius and diameter of arc.

Procedure: Measuring an Angle

The following steps give an overview for acquiring the angle of two lines using the Angle option of the Measuregeom command.

1. On the ribbon, click Home tab > Utilities panel > Measure drop-down > Angle.
2. Select first line.
3. Select second line.
4. Observe resulting angle.
Process: Measuring Area

The following steps give an overview for acquiring the area of a space using the Area option of the Measuregeom command.

1. On the ribbon, click Home tab > Utilities panel > Measure drop-down > Area.

2. Enter Add at the command prompt and select the first point.

3. Continue selecting points in a sequence that defines the perimeter of the area. Press Enter.

4. Enter Subtract at the command prompt and select the first point of the area to subtract.

5. Continue selecting points until you arrive back at the starting point. Press ENTER and note the new total area.
ID Point

With the ID Point command, you can retrieve the precise location of any point in the drawing. When you start the ID Point command, you are prompted to specify a point. This can be a point in the drawing or a point on an object. The ID Point command returns the coordinate of the point you select, as shown below.

\[ X = 624.3266 \quad Y = 208.1684 \quad Z = 0.0000 \]

As with all other Inquiry commands, the values are returned in the current units of the drawing.

Command Access

**ID Point**

Command Line: **ID**
Ribbon: **Home tab > Utilities panel > ID Point**
Menu bar: **Tools > Inquiry > ID Point**

**Selection Accuracy is Key**

For the same reason you use object snaps to create geometry, using object snaps to select points for Inquiry commands is critical. If you estimate the point selection, the value returned will not be accurate.

**Procedure: Identifying a Precise Location**

The following steps give an overview of identifying a precise location in the drawing.

1. Start the ID command.
2. Use an object snap to accurately select a point in the drawing. The coordinate is displayed on the command line.

\[ \text{Note: F2 will display the entire AutoCAD Text Window.} \]
Guidelines

Consider the following guidelines when using the Measure tools:

- When you measure an object, the position at which you select the object determines the measurement of the object.
- If you use multiple points, a running total of the distance based on existing line segments and the current rubber band line is calculated.
- The Measuregeom command cannot calculate the area of a self-intersecting object.
- With the Area tool you may turn on the Add or Subtract mode and either keep a running total of area as you define areas or subtract a specified area from the total area.
- With the Volume tool you may turn on the Add or Subtract mode and either keep a running total of volume as you define regions or subtract a specified region from the total volume.
- When using the Volume tool, you may select 3D solids or 2D objects. However, if you select a 2D object you must specify a height for that object.
- You can select polylines when using the Distance, Area, and Volume options.
Practice Exercise: Acquiring Distance and Coordinates

In this practice exercise you make a simple drawing, then you inquire about the distance between two points and coordinate the information.

1. Draw two circles (any size).
2. To acquire the distance between two points:
   - Begin the Distance command.
   - With Object Snap on, specify the Center of one circle as the first distance.
   - Specify the Center of the other circle.
   - View the distance in the Command line or in the AutoCAD Text Window (F2).
3. To view the X and Y coordinates of a specific point:
   - Begin the ID command.
   - With Object Snap on, specify the Center of one of the circles you have drawn.
   - View the coordinate in the Command line or in the AutoCAD Text Window (F2).

Note that the type and precision of the coordinate and distance information is determined by the settings in the Drawing Units.
Obtaining Object Information

List Command

The List command returns information on objects you select in the drawing. The information is displayed in the text window. The type of information retrieved is dependent on the type of object you select. You can select one or more objects to obtain information such as:

- Object type
- Space (model or paper)
- Layer
- Handle (unique identifier in the drawing database)
- Geometric data (location, size, etc.)

The following image represents an object created with the Polygon command. The information following the image represents the information provided by the List command when this type of object is selected.

Command Access

Command Line: **LIST, LI**

Ribbon: **Home tab > Properties panel > List**

Menu Bar: **Tools > Inquiry > List**
Listing Multiple Objects
If you select multiple objects, the properties for each object will be listed sequentially in the text window.

Procedure: Obtaining Information About Objects

The following steps give an overview of using the List command to information about objects.

1. Start the List command.
2. Select one or more objects. Press ENTER.
   Information about the selected objects is listed in the text window.
Practice Exercise: Obtaining Object Information

In this practice exercise, you draw each type of object that you have learned: circle, arc, line, rectangle. You also practice the List command and observe what information is displayed for each unique object.

1. Draw the following objects (any size):
   - Circle
   - Line
   - Arc
   - Rectangle

2. To List each object separately:
   - Begin the List command.
   - Select the circle and press ENTER.
   - Observe the information listed in the AutoCAD Text Window.
   - Press F2 to close the text window.

3. Repeat the previous steps for each object drawn.
Exercise: Obtain Geometric Information

In this exercise, you use the Inquiry commands to obtain geometric information about objects and points in a drawing.

You obtain information about the numbered objects and points in the following illustration.

3. On the Utilities panel click Measure and then click Distance. Use the Endpoint object snap and select points (7) and (8).
   ■ What is the distance? ________________
   ■ What is the angle? __________________

4. On the Utilities panel click Measure and then click Radius. Select circle (2) and press ENTER. Repeat this procedure for circle (3) and circle (4).
   ■ What is the radius for circle (2)? _________
   ■ What is the radius for circle (3)? _________
   ■ What is the radius for circle (4)? _________

Note: The List command also displays the radius of circles.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 4: Drawing Organization and Inquiry Commands. Click Exercise: Obtain Geometric Information.

1. Open M_Inquiry.dwg.
2. On the ribbon, click Home tab > Utilities panel. If the Utilities panel is not visible, right-click anywhere on the ribbon and then click Panels > Utilities panel.
5. Enter List on the command line and select the rectangle between points (10) and (11). Press ENTER.
   - What type of object is it?
     ____________________
   - What Layer is the rectangle on?
     ____________________
   - What is the area of the rectangle?
     ____________________
   - What is the perimeter of the rectangle?
     ____________________

6. Close the Text Window.

7. On the Utilities panel, click Measure and select Distance. Then select Distance and select the center points of circles (2) and (3).

8. Repeat the Distance command and select the center points of circles (2) and (4).

9. Press F2 to open the Text Window.
   - What is the Distance between circle (2) and circle (3)? ____________________
   - What is the Distance between circle (2) and circle (4)? ____________________

10. Close the Text Window.

11. Repeat the List command and select line (5). Press ENTER.
    - What is the angle of the line? ______________
    - What is the Delta X value? ______________
    - What is the Delta Y value? ______________

12. Close the Text Window.

13. On the Utilities panel, click ID Point and use the Endpoint object snap to select point (1).
    - What are the coordinate values?
      X:____________
      Y:____________
      Z:____________

14. On the Utilities panel, click Measure and then select Area. Click Area.
    - Right-click anywhere in the drawing. Click Add.
    - Beginning at point (1), use objects snaps to select the endpoints around the outer profile.
    - After you select all points, press ENTER.
    - Right-click anywhere in the drawing. Click Subtract.
    - Right-click anywhere in the drawing. Click Object.
    - Select each of the three circles.
    - Select the rectangle.
    - Press ENTER.
    - What is the net area of the profile after subtracting the circles? ______________

15. Exit the Area command.

16. Close all files without saving.
## Answers to Exercise Questions

<table>
<thead>
<tr>
<th>Step</th>
<th>Answer</th>
</tr>
</thead>
</table>
| 3.   | Distance = 55 mm  
     | Angle = 212 degrees |
| 4.   | Radius for circle 2 = 17.25 mm  
     | Radius for circle 4 = 10.00 mm |
| 5.   | Object type =  
     | LWPOLYLINE  
     | Area = 1764.00 mm  
     | Perimeter = 318.00 mm |
| 9.   | Distance between circles 2 and 3 = 103.9447 mm  
     | Distance between circles 2 and 4 = 105.6296 mm |
| 11.  | Angle = 131 degrees  
     | Delta Y = 44.9275 mm |
| 13.  | X  
     | = 253.1353  
     | Y = 0.0000  
     | Z = 0.0000 |
| 14.  | Net area = 24255.3940 mm |
Exercise: Measure Objects

In this exercise, you use distance, radius, angle, area, and volume to extract specific data from the floor plan.

1. Open I_Measure.dwg.
2. Zoom into the powder room at the right side of drawing.
3. On the Home tab, click Utilities panel > Measure drop-down > Distance.
4. Acquire the total lengths of the walls in the powder room.
   - Select the first point in the powder room
   - At the command line prompt, enter M and press ENTER to use the Multiple points option.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 4: Additional Enhancements. Click Exercise: Measure Objects.
Continue clicking each inside corner until you arrive back at the original starting point.

Notice the total length of all walls in the powder room.

5. Acquire the radius of the stairway wall.
   - On the Home tab, click Utilities panel > Measure drop-down > Radius.
   - Select the outside edge of the curved stairway wall to the left of the powder room.

   - Click the wall to acquire the wall's radius.
6. Use the angle option to ensure the walls are at a 90 degree angle.
   - On the Home tab, click Utilities panel > Measure drop-down > Angle.
   - Select the bottom wall of the powder room.
   - Select the wall behind the sink.
   - Verify that the two walls are at a 90 degree angle.

7. Find the area of the floor in the powder room.
   - On the Home tab, click Utilities panel > Measure drop-down > Area.
   - Click each of the interior corners of the powder room consecutively.
   - Finish clicking points at your starting point.
   - Press ENTER to view the area of the powder room floor.
8. Find the volume of the powder room.
   ■ On the Home tab, click Utilities panel > Measure drop-down > Volume.
   ■ Click each of the interior corners of the powder room consecutively.
   ■ Press ENTER. You are prompted to enter a height.
   ■ For height, enter 108 (note the 9' ceiling height). Press ENTER.
   ■ Notice the volume of the room.

9. Close all files. Do not save the drawings.
Challenge Exercise: Architectural

In this exercise, you use what you learned about drawing organization and inquiry commands to create layers, manipulate objects and their layers, and create additional geometry on the correct layer.

You have the option of completing this exercise using either imperial or metric units. Select one version of the exercise to complete the steps.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 4: Drawing Organization and Inquiry Commands. Click Challenge Exercise: Architectural Metric.

Metric Units
1. Open the drawing you saved from the previous challenge exercise, or open M_ARCH-Challenge-CHP04.dwg.
2. Create nine layers with the following names and color properties:
   - Annotation = white
   - Dimension = red
   - Doors = 30
   - Plumbing Fixtures = magenta
   - Stairs = white
   - Titleblock = red
   - Wall-Interior = cyan
   - Windows = blue
   - Viewports = 9

3. Put the stair geometry on the Stairs layer and the door geometry on the Doors layer.

4. Thaw the Existing Building - Apparatus Bay layer.

5. Save and close the drawing.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 4: Drawing Organization and Inquiry Commands. Click Challenge Exercise: Architectural Imperial.

Imperial Units

1. Open the drawing you saved from the previous challenge exercise, or open I_ARCH-Challenge-CHP04.dwg.

2. Create nine layers with the following names and color properties:
   - Annotation = white
   - Dimension = red
   - Doors = 30
   - Plumbing Fixtures = magenta
   - Stairs = white
   - Titleblock = red
   - Wall-Interior = cyan
   - Windows = blue
   - Viewports = 9

3. Put the stair geometry on the Stairs layer and the door geometry on the Doors layer.

4. Thaw the Existing Building - Apparatus Bay layer.

5. Save and close the drawing.
Challenge Exercise: Mechanical

In this exercise, you use what you learned about drawing organization and inquiry commands to add layers and hidden geometry to the drawing views.

Note: The following image depicts only some of the views requiring hidden line geometry.

```
1. Open the drawing you saved from the previous challenge exercise, or open M_MECH-Challenge-CHP04.dwg.
2. Open the Layer Properties Manager:
   - Create a new layer named Hidden and make it the current layer.
     - Color = 151
     - Linetype = Hidden
   - Create a new layer named Centerline.
     - Color = Magenta
     - Linetype = Center
   - Create a new layer named Annotation.
     - Color = Magenta
     - Linetype = Continuous
   - Freeze and lock the Start Points layer.
3. Set the LTSCALE system variable to 0.75.
```
4. With the Hidden layer current, create the hidden geometry in these views using points in each view as references. Then create the centerline objects and place them on the Centerline layer. **Note:** In the following image, the views are closer together than they are in the drawing.

5. Save and close all files.
Chapter Summary

There is more to creating drawings than drawing lines, circles, and arcs. Part of the drawing process involves the use of layer and linetype standards as well as retrieving geometric information from objects in the drawing.

Having completed this chapter, you can:

- Use layers to organize objects in your drawing.
- Identify and change the properties of objects.
- Use the Quick Properties palette to quickly change object properties.
- Use the Match Properties command to apply the properties from a source object to destination objects.
- Use the Properties palette to change object properties.
- Use linetypes to distinguish objects in the drawing.
- Use the Inquiry commands (Distance, Radius, Angle, Area, List, and ID) to obtain geometric information from the drawing.
- In this exercise, you use what you learned about drawing organization and inquiry commands to create layers, manipulate objects and their layers, and create additional geometry on its correct layer.
- In this exercise, you use what you learned about drawing organization and inquiry commands to add layers and hidden geometry to the drawing views.
Altering Objects

Of all CAD design tasks, editing objects is most common. Editing is something you will be required to do nearly every time you draw whether as the result of design changes or just the standard practice of creating more complex objects from simple ones.

Objectives

After completing this chapter, you will be able to:

- Change the length of objects using the Trim and Extend commands.
- Create parallel and offset geometry in your drawing by using the Offset command.
- Use the Join command to combine multiple objects into a single object.
- Break objects into two or more independent objects.
- Apply a radius corner to two objects in the drawing.
- Apply an angled corner to two objects in the drawing.
- Use the Stretch command to alter the shape of objects in the drawing.

Standard Object Snap and Status Bar Settings
Before completing the exercises in this chapter, refer to the “Settings for the Exercises” section in the Introduction in Volume 1.
Lesson: Trimming and Extending Objects to Defined Boundaries

This lesson describes how to trim and extend objects in the drawing.

A typical design process involves shortening or lengthening the construction lines or other geometry at various times to represent the design's features.

After completing this lesson, you will be able to describe the uses of the Trim and Extend commands to modify objects, cut edges, and extend boundaries in your drawing.

The following image illustrates lines that need to be trimmed.

Objectives

After completing this lesson, you will be able to:

■ Use the Trim and Extend commands to modify geometry in your drawing.
Using the Trim and Extend Commands

You can use the Trim command to shorten and the Extend command to lengthen existing geometry to meet the edges of other objects. This means that you can create an object such as a line and later adjust it to fit precisely between other objects.

When you use the Trim command, you select objects to use as cutting edges and trim geometry back to those objects. You select the portion of the object to trim, not the portion to keep.

In the following image, the arrows indicate where you would click to trim the lines.

When you use the Extend command, you select objects to use as boundary edges and extend geometry to those objects.

In the following illustration, the boundary edge (2) is indicated with an arrow. Selecting the lines (1) at the location of the arrows extends each line to the first boundary edge it encounters. The completed command is illustrated in the image on the right.

Before extend and after extend
Command Access

**Trim**

Command Line: TRIM, TR
Ribbon: Home tab > Modify panel > Trim
Menu Bar: Modify > Trim

**Extend**

Command Line: EXTEND, EX
Ribbon: Home tab > Modify panel > Extend
Menu Bar: Modify > Extend
Procedure: Trimming Objects

The following steps give an overview of using the Trim command to shorten objects to cutting edges.

1. On the ribbon, click Home tab > Modify panel > Trim.
2. Either select the objects to serve as cutting edges (1) and then press ENTER, or press ENTER without selecting any objects. Pressing ENTER without selecting activates implied selection, where all suitable objects in the drawing are treated as potential cutting edges.

3. Select the objects to trim (2).
4. Press ENTER to end the command and view your completed operation.

**Procedure: Extending Objects**

The following steps give an overview of using the Extend command to lengthen objects to boundary edges.

1. On the ribbon, click Home tab > Modify panel > Extend.
2. Either select the objects to serve as boundary edges (1) and then press ENTER, or press ENTER without selecting any objects. Pressing ENTER without selecting, activates implied selection, where all suitable objects in the drawing are treated as potential boundary edges.
3. Select the objects to extend (2).

4. Press ENTER to end the command and view your completed operation.
Guidelines for Trim and Extend

Consider the following guidelines when using the Trim and Extend commands:

- Cutting or boundary edges may be lines, arcs, circles, polylines, ellipses, splines, xlines, regions, blocks, text, and rays.
- If you do not specify a cutting or boundary edge and press ENTER instead at the Select Objects prompt, all objects become potential cutting edges or boundaries. This is called implied selection.
- If you hold down the SHIFT key, you can SHIFT + select to switch between Trim and Extend. For example, if you are in the Trim command, you can hold down SHIFT and select objects to be extended to the boundary edge. Similarly, you can be in the Extend command and use SHIFT + select to trim objects to a cutting edge.
- Cutting and boundary edges do not have to intersect the object being trimmed or extended if you use the Edge option set in the Extend mode. With this setting, you can trim or extend an object to where it would intersect if the cutting or boundary edges were extended. For example, in the following illustration, the lower line (2) in the left illustration can be extended as if line (1) really was extended to point (3) as shown in the illustration on the right.

![Illustration of Trim and Extend](image)

Extended Edge Mode

Guidelines for Trim and Extend Options

- The default edge mode for Trim and Extend is *No Extend*. Most of the time, you will want to use these commands with this default setting.
- The Trim or Extend *Project* option is for 3D.
- The Trim or Extend *Erase* option enables you to erase line segments within either of these commands.
- The Trim or Extend *Undo* option enables you to reverse an action you have made to trim or extend without exiting either of these commands.

**Note:** You can right-click to select these options from the shortcut menu or you can type the capitalized letter of the option at the Command line and press Enter.
Practice Exercise: Trim and Extend

In this practice exercise, you use the Trim and Extend commands. First, draw two rectangles. Across one rectangle, draw a series of lines that intersect the rectangle. Inside the other rectangle, create lines that do not touch the sides of the rectangle as shown below. You also practice the Trim and Extend commands using the Fence selection option.

1. To set up this practice exercise:
   - Draw two rectangles of any size.
   - Across one rectangle, draw a series of lines that intersect the rectangle.
   - Inside the other rectangle, draw a line that is completely inside and copy it several times.

2. To use the Trim command, select the cutting edges first:
   - On the Home tab, click Modify panel > Trim.
   - Select the rectangle for the cutting edge.
   - Press ENTER.

3. To trim the lines:
   - Click the portion of the line segment that you want to remove.
   - Trim all of the line segments to the left of the rectangle as indicated below.

4. Continue to trim, this time using the Fence option:
   - Right-click in the graphics window. Click Fence.
   - Click the first fence point just above the series of line segments to the right of the rectangle (1).
   - Click the next fence point just below the bottom line segment to the right of the rectangle (2).
5. To complete the Trim command:
   - Press ENTER to complete the Fence selection option.
   - Press ENTER to exit the Trim command.

6. To use the Extend command, select the boundary edges first:
   - On the Home tab, click Modify panel > Extend.
   - Select the rectangle for the boundary edge.
   - Press ENTER.

7. To extend the lines, select the line near the end that you want to extend:
   - Click each line towards the left of the rectangle (1).
   - Right-click. Click Fence.
Click just above the line towards the right side of the rectangle (1).

Click just below the bottom line (2) as indicated below.

8. To complete the Extend command:
   ■ Press ENTER to complete the Fence selection line option.
   ■ Press ENTER to exit the Extend command.
   ■ View your results.
**Exercise: Trim and Extend Objects**

In this exercise, you use the Trim and Extend commands to trim and extend edges on the drawing. When you have completed the exercise, you will be able to trim and extend geometry using standard trim and extend methods. You will also be able to use the Edge option to extend or trim geometry to implied intersections and the SHIFT+select feature to switch between trimming and extending.

The completed exercise

3. Use the Trim command to complete the slot geometry:
   - On the Home tab, click Modify panel > Trim.
   - Select the lines highlighted in the following image as the cutting edges.
   - Press ENTER.

4. Select the lines to trim at the points indicated in the following image. Press ENTER.

---

**Completing the Exercise**

To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click *Chapter 5: Altering Objects*. Click Exercise: Trim and Extend Objects.

1. Open M_Trim-Extend.dwg.
2. Zoom to display the view as shown in the following image.
5. Zoom out to display the entire drawing.

6. To use the Extend command:
   - On the Home tab, click Modify panel > Trim drop-down > Extend.
   - Select the geometry highlighted in the following image as your boundary edges.
   - Press ENTER.

7. To complete the view on the left:
   - Right-click anywhere in the drawing window. Click Edge.
   - Right-click anywhere in the drawing window. Click Extend.
   - Select the geometry indicated in the following image as the objects to extend.
   **Note:** You need to select the two horizontal lines twice because they are initially extended to the first boundary. The second selection extends them to the next boundary that the edge intersects.

8. SHIFT+select the lines indicated in the previous image to trim them.

9. Press ENTER to end the Extend command.
10. To remove the construction lines:
   - Start the Erase command.
   - Select the lines indicated in the following image. Press ENTER.

11. Your completed drawing.

12. Close all files. Do not save.
This lesson describes how to use the Offset command to create geometry that is offset from or parallel to other geometry in the drawing.

In a typical drawing, you are likely to find several objects that are parallel to or offset from each other. You can use the Offset command to create this effect on geometry in the drawing and increase efficiency by reusing existing geometry.

The following illustration shows several parallel lines and concentric circles. The Offset command can be used to create these types of objects.

Objectives

After completing this lesson, you will be able to:

- Use the Offset command to create parallel and offset geometry.
Offsetting Objects

The Offset command creates a new object whose shape parallels the shape of a selected object. For example, in the following image, the inside shape has been offset twice using the Offset command with the Multiple option.

Command Access

Command Line: **OFFSET, O**

Ribbon: **Home tab > Modify panel > Offset**

Application Menu: **Modify > Offset**
Command Options

The Offset command has the following options. From the shortcut menu, either right-click to select the option or enter the capitalized letter and press ENTER.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Through</td>
<td>Offsets a selected object the distance of a point picked in the drawing window.</td>
</tr>
<tr>
<td>Erase</td>
<td>Erases the source object after it has been offset.</td>
</tr>
<tr>
<td>Layer</td>
<td>Offsets the object to the original source layer or the current layer.</td>
</tr>
<tr>
<td>Multiple</td>
<td>Makes multiple offsets of the object in increments specified by the offset distance.</td>
</tr>
</tbody>
</table>

Procedure: Offsetting Geometry a Specific Distance

The following steps give an overview of offsetting geometry a specified distance.

1. On the ribbon, click Home tab > Modify panel > Offset.
2. Specify the offset distance by selecting two points.
   **Note:** You can enter a value instead of selecting points.

3. Select the object to offset.
4. Select a point on the side where you want to place the new objects.

5. Select another object to offset or exit the command.

**Procedure: Offsetting Geometry Through a Point**

The following steps give an overview of using the Offset command with the Through option to offset a line through a point on a circle.

1. On the Home tab, click Modify panel > Offset.
2. Right-click anywhere in the drawing. Click Through. You can also enter `t` on the command line.
3. Select the object to offset.

4. Specify the point through which to offset the object. **Note:** The top horizontal line represents the position of the object after the offset. If it were extended, it would pass through the point indicated by the cursor.

5. Select another object to offset or exit the command.
Procedure: Offsetting Multiple Objects

The following steps give an overview of serially offsetting geometry a specified distance using the Multiple option.

1. On the Home tab, click Modify panel > Offset.
2. Specify the offset distance by entering a value or selecting two points.

3. Select the object to offset.

4. Right-click anywhere in the drawing. Click Multiple.
5. Select a point on the side where you want to place the new objects.
6. Select another point to offset the last object by the same amount.

Guidelines for Using the Offset Command

- Setting the offset distance is the default and most common method for using offset. Enter the distance and press ENTER.
- The offset distance may also be set by picking two points in the drawing window. When using this method, it is best to use object snap and reference objects in the drawing to accurately set a distance.
- When you begin the Offset command, the last offset distance used is displayed in the Command line. Press Enter to accept this distance, or enter a new offset distance then press ENTER.
- Use the Multiple option to create a series of offsets once you have selected the original object to offset. Then simply click the side to offset as many times as needed.
- An offset object will automatically retain the color, layer, and linetype of the source object unless you change the offset Layer option to Current. The most common method is to keep the offset objects on the source layer.
- When you offset a circle, arc or polyline, at some point it may not be possible to create the offset to the inside or outside of the object because of geometry restrictions. For example, if the offset distance is greater than the radius of a circle, it would be impossible to offset to the inside of that circle.
- You remain in the Offset command until you press ENTER, unless you have initiated the Through option. Then only one offset is created through the object selected.
Practice Exercise: Offsetting Objects

In this practice exercise, you practice using the Offset command with three different methods. First, draw a circle, a line, and a rectangle, and then offset the rectangle a specific distance. Offset the circle through a selected point. Make multiple offsets of the line.

1. To offset a distance:
   - On the Home tab, click Modify panel > Offset.
   - Enter an offset distance of .05. Press ENTER.
   - Select the rectangle (1).
   - Click inside the rectangle.
   - Select the new rectangle (2).
   - Click inside the rectangles.
   - Select the next rectangle (3) and click inside the rectangles.
   - Press ENTER to complete the Offset command.

2. To offset through a point:
   - On the Home tab, click Modify panel > Offset.
   - Right-click in the drawing window. Click Through.
   - Select the object to offset. Select the Circle.
   - Specify a point through another object. Select anywhere on the adjacent rectangle.
   - Press ENTER to exit the Offset command.
3. To make multiple offsets:
   - On the Home tab, click Modify panel > Offset.
   - Enter an offset distance of .1. Press ENTER.
   - Select the line to offset.
   - Right-click the selected object. Click Multiple.
   - Specify a point on the side of the line to offset.
   - Continue to make offsets of the line.
   - Press ENTER to end the Offset command.
Exercise: Create Parallel and Offset Geometry

In this exercise, you use the Offset command to create geometry that is offset from existing geometry in the drawing. You also use the Trim command to clean up the geometry after it has been offset. When you have completed the exercise, you will be able to use the Offset command in other drawings.

Completing the Exercise

To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 5: Altering Objects. Click Exercise: Create Parallel and Offset Geometry.

1. Open M_Offset-Objects.dwg.
2. Zoom to display the upper-left view as shown.

3. To offset a circle:
   - On the Home tab, click Modify panel > Offset.
   - On the command line, verify that the current settings for the offset are as follows:
     - Current settings: Erase source=No
     - Layer=Source
     - OFFSETGAPTYPE=0
   - If the settings are different from the above, do the following, otherwise continue at the next primary bullet:
     - Right-click anywhere in the drawing window. Click Erase. Click No.
     - Right-click anywhere in the drawing window. Click Layer. Click Source.
   - Enter 7.5. Press ENTER.
   - Select the small circle, then select a point outside the circle.
4. Select the top outside edge of the part and select a point below the profile as shown.

5. To complete the offset:
   - Select the bottom outside edge of the part and select a point above the profile as shown.
   - Press ENTER to exit the Offset command.

6. To trim the objects created in the previous step:
   - On the Home tab, click Modify panel > Trim.
   - Use the large circle and vertical line as the cutting edges.
   - Select the objects created with the Offset command near the points indicated with arrows.

7. To offset the vertical line and place it on the current layer:
   - On the Home tab, click Modify panel > Offset.
   - Right-click anywhere in the drawing. Click Layer. Click Current.
   - Enter 5.25. Press ENTER.
   - Select the vertical line indicated in the following image and then select a point to the left of the line.
   - Press ENTER to end the Offset command.

8. Zoom to display the entire drawing.

9. To offset the centerlines using existing views to set a distance:
   - On the Home tab, click Modify panel > Offset.
   - Select the two points indicated in the following image to specify the offset distance.
10. To complete the offset:
   - Select the centerline in the upper left view and select a point above the centerline.
   - Select the centerline again and select a point below the centerline.
   - Press ENTER to exit the Offset command.

11. Using the Trim command, clean up the hidden lines as shown in the following image.

12. To create a hidden pocket in the front view:
   - On the Home tab, click Modify panel > Offset.
   - Right-click anywhere in the drawing window. Click Through.
   - When prompted for the object to offset, select the centerline in the left view (1).
   - When prompted for the through point, select the point indicated in the following image (2).

13. To offset another line:
   - When prompted for the object to offset, select the centerline again (1).
   - When prompted for the through point, select the point indicated in the following image (2).
14. To complete the pocket:
   - When prompted for the object to offset, select the vertical line in the lower left view (1).
   - When prompted for the through point, select the point on the top-left view (2).
   - Press ENTER to exit the Offset command.

15. Use the Offset command with the Through option to offset the centerline through the quadrants of the smaller circle, then use the Trim command to clean up the lines as indicated in the following image.

16. Close all files. Do not save.
Lesson: Joining Objects

When you edit drawings, extra objects that are produced increase the overall size of the drawing and may complicate your drawing process.

Several situations can lead to incomplete or incorrect geometry such as broken line segments, arcs, or open polylines. Importing geometry from other programs or 2D geometry that originated in a 3D model could result in geometry that appears to be correct but, on closer examination, contains unwanted breaks. Use the Join command to fix these broken objects and combine them into single objects.

Objectives

After completing this lesson, you will be able to:

- Use the Join command to join similar objects.
Joining Objects

Use the Join command to combine individual segments of like objects into a single object, to reduce file size, and to improve drawing quality. The Join command can be used on polylines, lines, arcs, elliptical arcs, and splines.

Command Access

Command Line: JOIN, J
Ribbon: Home tab > extended Modify panel > Join
Menu Bar: Modify > Join

Command Options

With the Join command, you can combine similar objects into one object.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select source object</td>
<td>Use this option to select the object that other objects will be joined to.</td>
</tr>
<tr>
<td>Select objects to join to source</td>
<td>Use this option to select objects that you join to the source object.</td>
</tr>
</tbody>
</table>
### Option | Description
--- | ---
Select arcs to join to source or [cLose] | This option appears if the source object is an arc. The close option closes the arc and converts it to a circle.
Select elliptical arcs to join to source or [cLose] | This option appears if the source object is an elliptical arc. The close option closes the elliptical arc.

**Join Command Example**

1. Two lines with a gap are joined into a single line.
2. Two concentric arcs are joined into a single arc.
3. Two concentric ellipse objects are joined into a single ellipse.
4. A line is joined to an open polyline.

**Procedure: Joining Lines with the Join Command**

The following steps provide an overview of joining lines using Join.

1. On the Modify panel, click Join.
2. Select the source line.

---
3. Select the other lines to join to the source line and press ENTER.

The selected line segments are joined together.

Procedure: Converting an Arc to a Circle with the Join Command

The following steps provide an overview of converting an arc to a circle using the Join command.

1. On the Modify Draw panel, click Join.
2. Select an arc.

3. Right-click and click Close on the shortcut menu.
The arc is converted to a circle.

Guidelines

When you use the Join command to join objects, the following rules apply.

- Lines:
- Polylines and splines:
- Arcs:
- Elliptical Arcs:

Joining Arcs or Elliptical Arcs

When you join arcs or elliptical arcs together, the source object is always extended to the other objects in a counterclockwise direction. In the following image, the source arc is selected at point (1) while the other arc is selected at point (2). The source arc is extended counterclockwise to meet the other arc.
Practice Exercise: Joining Objects

Quite often when you edit your drawing, changes occur that require you to join or rejoin segments. In this practice exercise, you draw a circle and a line with a rectangle that overlaps both objects. First trim these objects, then erase the rectangle. Use the Join command to reconnect the circle and line segments.

1. Draw the circle, line and rectangle as illustrated above.

2. To Trim the circle and the line:
   ■ Begin the Trim command.
   ■ Select the rectangle for the cutting edge and press ENTER.
   ■ Select the portion of the line and circle inside the rectangle to trim.

3. Erase the rectangle.

4. To join the line segments:
   ■ Begin the Join command.
   ■ Select the Source object (1).
   ■ Select the object to join (2).
   ■ Press ENTER to complete the command.

5. To Join the arc segments and close them.
   Method 1:
   ■ Begin the Join command.
   ■ Select one arc (1) then select the other (2).
   ■ Press ENTER to join the two arcs.

   Notice how the arcs work in a counterclockwise direction. The order in which you select the arcs determines how they are joined. For instance, if you had selected arc (2) first then arc (1), the segments would have been joined at the top.
   ■ Repeat the Join command
   ■ Select the arc.
   ■ Right-click on the selected object. Click Close.
Note: If you were to enter this option at the Command line, you would enter L and press ENTER, indicated by the capitalized letter L.

- The arc is now closed, making it a circle again.

6. To Join the arc segments and close them.
   
   Method 2:
   - Begin the Join command.
   - Select one arc segment.
   - Right-click the selected object. Click Close.

- Begin the Erase command.
- Hold down the Shift + Spacebar keys and select the circle in the area of the remaining arc segment. Click until you see that the arc segment is selected.
- Press ENTER to erase the arc.

The arc is now closed to form a circle, but the remaining arc segment should be erased.
Exercise: Join Objects

In this exercise, you use Join to join lines and arcs.

1. Open M_Join-Objects.dwg.
2. Mirror a door from the right side of the room to the left side. Use the Mid Between 2 Points object snap to obtain the midpoint of the room and erase the source object.

3. To join the wall lines to the shorter segments left from removing the door:
   - On the Modify panel, click Join.
   - When prompted for the source object, select the inside wall line (1).
   - When prompted for the line to join, select the inside short line (2).
   - Press ENTER.

4. Join the two outer wall lines following the same method used in the previous step. Your drawing should now look like the following image.

5. Use Trim to remove the wall sections at the new door location. Your drawing should now look like the following image.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 5: Altering Objects. Click Exercise: Join Objects.
6. To modify the conference desk in this office by removing the rectangular wing:
   ■ Zoom in to the table.
   ■ Delete the three lines as shown.

7. Use Join to close the circle that represents the table:
   ■ Start the Join command.
   ■ When prompted for the source object, select the open circle.
   ■ Right-click the selected object. Click close.

8. Close all files without saving.
Lesson: Breaking an Object into Two Objects

This lesson describes how to break objects into two separate objects using the Break command. The two new objects have the same properties as the original, but you can modify them independently.

There may be instances when you need to break an object into two or more separate pieces. While the Trim command can accomplish this, the Break command can break objects without the need for cutting geometry and the resulting pieces can have coincident endpoints.

After completing this lesson, you will be able to identify the command options for Break and use the command to break objects.

In the following illustration, the Break command was used to break an existing line (1) so that the properties of the resulting new object could be changed independently (2).

Objectives

After completing this lesson, you will be able to:

- Use the Break command to break objects.
Breaking Objects

Using the Break command, you can break a single object into two independent objects. You accomplish this by first selecting the object to break and then specifying the break points.

The Modify panel contains two versions of the Break command. While each version executes the core Break command, one breaks the object leaving a gap between the two remaining pieces and the other breaks the object at one point, leaving the ends coincident (touching). In this lesson, you learn both Break methods.

In the following image, the Break command was used to break the line indicated by the middle arrow, at the points indicated by the arrows pointing to the intersections.

Command Access

Command Line: **BREAK, BR**

Ribbon: **Home tab > Modify panel > Break**

Menu Bar: **Modify > Break**
Command Access

Break at Point

Command Line: BREAK, BR
Ribbon: Home tab > Modify panel > Break at Point

Menu Bar: Modify > Break

Command Options

The Break command provides the following options. Select the Break at Point option on the 2D Draw panel if you want both first and second break points to be the same.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Point</td>
<td>Specifies the first point of the break. If this option is not specified, the point where you select the object is used as the first point.</td>
</tr>
<tr>
<td>Second Point</td>
<td>Specifies the second point of the break. Select any point on the object or enter @ and press ENTER to use the first point as the second point (results in the object broken so that endpoints are coincident).</td>
</tr>
</tbody>
</table>
Procedure: Breaking Objects Using the Break Command

The following steps give an overview of breaking objects using the Break command.

1. On the Modify panel, click Break.
2. Select the object to break. If you do not manually specify the first point of the break, then the point at which you select the object is used as the first point of the break.

3. Right-click anywhere in the drawing. Click First Point.
4. Select the first point of the break.

5. Select the second point of the break.

The selected object is broken at the points specified.
Procedure: Breaking Objects Using the Break at Point Command

The following steps give an overview of breaking objects using the Break at Point command.

1. On the Modify panel, click Break at Point.
2. Select the object to be broken.

3. Select the first break point.

4. The first break point is automatically used for the second break point, resulting in two objects with coincident endpoints.  
   *Note that when the object is selected the grips display the broken segment.*
Guidelines for Breaking Objects

- You can use the Break command on lines, circles, arcs, polylines, and splines.
- If you do not manually specify the first point, the point at which the object was selected is used as the first point.
- When breaking an object at the intersection of another object, be sure to specify which object you want to break first.
- Circles break in a counter-clockwise direction. The portion that gets removed depends on the order in which you select the breakpoints.
- You can use the @ key and press ENTER to use the first point as the second point, which results in the object being broken in such a way that the resulting endpoints are coincident.

When to use Break

Use the Break command only when there are no cutting edges that would allow you to use the Trim command or to break an object at a specific point without a gap.
Practice Exercise: Breaking Objects

In this practice exercise you practice the Break command by drawing a vertical line with a series of offset lines that intersect as shown below on the left, and practice the Break at a Point command by drawing two intersecting lines as shown below on the right.

1. Draw the lines as shown above.
2. To break the lines leaving a gap:
   - Turn Object Snap off to avoid selecting the Intersections.
   - Begin the Break command.
   - Select a line at point (1).
   - Click the second break point (2).
   - Repeat the Break command.
   - Continue to select the break points of each line on one side of the vertical line, then the other as shown below.

3. To Break an object at a select point:
   - Turn Object Snap on.
   - Begin the Break at a Point command.
   - Select the line segment as indicated below.
Select the Intersection of the two lines.

The line segment is now broken at the intersection.
Exercise: Break Objects

In this exercise, you use the Break and Break at Point commands and change the layer in order to show the hidden parts of the object in two different ways. When you have completed the exercise, you will know the difference between breaking at single points and breaking an object at two points.

1. Open \textit{C\_Break-Object.dwg}.

2. Zoom in on the part of the drawing shown.

The completed exercise

Completing the Exercise

To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click \textit{Chapter 5: Altering Objects}. Click \textit{Exercise: Break Objects}.

3. To remove a portion of a line:
   - Start the Break command.
   - Select the outside object as shown.
   - Right-click and click First Point.

\textbf{Note}: The benefit of using this option is that you can select the object and then precisely select the two break points.
4. Select the first break point (1). Then select the second point (2).

5. Zoom out to display your entire drawing. Zoom in to the area shown.

6. To break the line at a point without removing any of it:
   - Start the Break at Point command.
   - Select the outer object as shown.

7. Select point (1) to specify the break point.

8. Break the line again without removing any of it:
   - Start the Break at Point command.
   - Select the outer object again (1).
   - Select the Intersection at point (2) to specify the break point.

9. Select the line between the two break points to highlight it.
10. To move this object to the Hidden2 layer:
   - On the Layers panel, click the Layers list.
   - Click the Hidden2 layer to move the selected object to this layer.

11. Press ESC. Your drawing should look like the following image.

12. Close all files without saving.
Lesson: Applying a Radius Corner to Two Objects

This lesson describes how to fillet objects using the Fillet command. Fillets and rounds are common in mechanical drawings, but you can use the Fillet feature across all design disciplines to create radius geometry connecting two objects.

After completing this lesson, you will be able to identify options of the Fillet command and use the command to create radius geometry between two objects.

Objectives

After completing this lesson, you will be able to:

■ Use the Fillet command to create radius geometry connecting two objects.
Creating Fillets

You can use the Fillet command to connect two objects quickly with a smoothly fitted arc of a specified radius. You usually use it to represent a rounded edge on a corner; an inside corner is called a fillet and an outside corner is called a round. You can fillet lines, arcs, circles, ellipses, polylines, xlines, splines, and rays.

You can also create a sharp corner with the Fillet command by specifying a radius value of 0.

![Original objects, Fillet radius nonzero, Fillet radius zero]

Command Access

**Fillet**

Command Line: **FILLET, F**

Ribbon: **Home tab > Modify panel > Fillet**

Menu Bar: **Modify > Fillet**

Command Options

The following options are available for the Fillet command.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Reverses the previous action of the Fillet command.</td>
</tr>
<tr>
<td>Polyline</td>
<td>Fillets all vertices of a polyline using the current radius value.</td>
</tr>
</tbody>
</table>
### Option Table

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Radius</td>
<td>Sets the radius for the fillet arc.</td>
</tr>
<tr>
<td>Trim / No Trim</td>
<td>When Trim mode is selected, the lines are trimmed to be tangent with the fillet. If Trim mode is set to No Trim, the fillet radius is drawn but the lines are not trimmed.</td>
</tr>
<tr>
<td>Multiple</td>
<td>When the Multiple option is selected, you can create multiple fillets without restarting the command.</td>
</tr>
</tbody>
</table>

---

**Procedure: Applying a Radius Corner with the Fillet Command**

The following steps give an overview of how to apply a radius corner with the Fillet command.

1. Start the Fillet command.
2. On the command line, verify the current fillet settings. If required, set the options appropriately.
   
   ![Command: FILLETCurrent settings: Mode = TRIM, Radius = 1.0000Select first object or [Undo/Polyline/Radius/Trim/Multiple]:](image)

3. Select the first object to fillet.
4. Select the second object to fillet. The fillet is created.

**Note:** If you choose the Polyline option, the last step is not required, since all vertices of the polyline are filleted at once.

**SHIFT+Select for Zero-Radius Fillet**

Regardless of the current Fillet Radius setting, if you SHIFT+select the two objects, a zero-radius fillet is applied.
Guidelines

- Depending on the locations you specify, more than one possible fillet can exist between the selected objects. Always select the part of the objects that you want to keep.

<table>
<thead>
<tr>
<th>Original objects</th>
<th>Possible results</th>
<th>Possible results</th>
</tr>
</thead>
</table>

- You can fillet parallel lines, xlines, and rays. The current fillet radius is ignored and an arc is created that is tangent to both parallel objects and located in the plane common to both objects.

- You can also fillet a polygon, or an entire polyline, or remove fillets from an entire polyline.

- If you set a nonzero fillet radius, fillet arcs are inserted at the vertex of each polyline segment that is long enough to accommodate the fillet radius.
Key Points

- The fillet radius is the radius of the arc that connects the objects.
- If both objects being filleted are on the same layer, the fillet arc is created on that layer. Otherwise, the fillet arc is created on the current layer.
- Entering a radius value of 0 creates a sharp corner.
- Holding down the shift key while selecting the object to fillet will override the current radius value and create a radius of 0.
- An object that is filleted to a polyline becomes part of that polyline.
- A polyline can not be filleted to an arc. Explode the polyline, then fillet the objects and join them again using the Polyedit command.
Practice Exercise: Creating Fillets

In this practice exercise, you use the Fillet command on a simple rectangle.

1. Draw a rectangle.
2. To Fillet a single corner:
   - Begin the Fillet command.
   - Enter \texttt{R} and press ENTER.
   - Specify a fillet radius of \texttt{.25} and press ENTER.
   - Click the lines near one corner of the rectangle as indicated below.

3. Now change the radius and use the Fillet polyline option:
   - Begin the Fillet command.
   - Enter \texttt{R} and press ENTER.
   - Specify a fillet radius of \texttt{.5} and press ENTER.
   - Enter \texttt{P} and press ENTER.
   - Select the rectangle.

4. Now change the fillet radius to \texttt{0} to make sharp corners on the rectangle:
   - Begin the Fillet command.
   - Enter \texttt{R} and press ENTER.
   - Enter a fillet radius of \texttt{0} and press ENTER.
   - Enter \texttt{P} and press ENTER.
   - Select the rectangle.

\textbf{Note:} If this rectangle was made of separate line segments instead of a polyline, the previous radius would have remained and you could not have used the Polyline option to fillet all of the corners at once.
Exercise: Create a Filleted Corner

In this exercise, you create fillets on the objects in the drawing. You use different options of the Fillet command to create the desired results. When you have finished, you will be able to use the Fillet command in other drawings.

1. Open M_Create-Fillets.dwg.
2. Zoom in to the lower-left area of the drawing.

3. To use the Fillet command to create an end cap on parallel lines:
   - Start the Fillet command.
   - Right-click anywhere in the drawing area. Click Multiple.
   - Select the lines as shown.

4. To complete the fillet:
   - Select the lines on the opposite side of the view.
   - Press ENTER to end the Fillet command.

5. Pan or zoom to the top-left of the drawing.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 5: Altering Objects. Click Exercise: Create a Filleted Corner.
6. To create a blend between the part profile and the screw bosses:
   ■ Start the Fillet command.
   ■ Right-click anywhere in the drawing area. Click Multiple.
   ■ Right-click anywhere in the drawing area. Click Trim. Click No Trim.
   ■ Right-click anywhere in the drawing area. Click Radius.
   ■ Enter 2. Press ENTER.
   ■ Select the horizontal line, and then select the larger circle.

7. Repeat the selection on the opposite side of the circle.
The fillet should appear as shown.

8. To complete the boss creation:
   ■ Repeat the selection process on the other bossed areas in the drawing, as indicated in the following image.
   ■ Press ENTER to end the Fillet command.

9. Zoom to display the entire drawing.
10. To ignore the radius setting and create a sharp corner while using the fillet command:
    ■ Start the Fillet command.
    ■ On the command line, confirm the radius is still set to 2.0000.
    ■ Select the horizontal line.
    ■ Press SHIFT+ select the vertical line to create a zero-radius fillet.
11. To complete the right view:
   - Press ENTER to repeat the Fillet command.
   - On the right-side view, select the top horizontal line.
   - Press SHIFT+ select the right-side vertical line to create a zero-radius fillet.

12. Close all files without saving.
This lesson describes how to use the Chamfer command to create chamfer features on objects in the drawing.

There are many situations that call for a chamfer. Any time you need to create an angled intersection on objects in the drawing, the Chamfer command should be your first choice.

After completing this lesson, you will be able to identify options of the Chamfer command and use the command to create chamfered features.

Objectives

After completing this lesson, you will be able to:

- Use the Chamfer command to create chamfer features.
Creating Chamfers

You use the Chamfer command to quickly create a line between two nonparallel lines. It is usually used to represent a beveled edge on a corner. You can chamfer lines, polylines, xlines, and rays.

Command Access

Command Line: CHAMFER, CHA
Ribbon: Home tab > Modify panel > Chamfer
Menu Bar: Modify > Chamfer

Note: Select the Chamfer command from the drop-down menu.
Menu Bar: Modify > Chamfer
Command Options

The following options are available when using the Chamfer command.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Use this option to undo the previous action of the Chamfer command.</td>
</tr>
<tr>
<td>Polyline</td>
<td>Use this option to chamfer a 2D polyline. All polyline vertices are chamfered at the current distance or angle settings.</td>
</tr>
<tr>
<td>Distance</td>
<td>Use this option to specify distance values for the chamfer.</td>
</tr>
<tr>
<td>Angle</td>
<td>Use this option to create the chamfers based on one distance and an angle.</td>
</tr>
<tr>
<td>Trim</td>
<td>Use this option to set the Trim and No Trim modes. When Trim mode is active, the objects being chamfered are trimmed to the start of the chamfer lines. When No Trim mode is set, the objects selected for the chamfer are not trimmed.</td>
</tr>
<tr>
<td>Method</td>
<td>Use this option to switch between the Distance or Angle methods for creating the chamfer.</td>
</tr>
<tr>
<td>Multiple</td>
<td>Use this option to create multiple chamfers without having to restart the command.</td>
</tr>
</tbody>
</table>

Using Chamfer Options

- With the Distance method, you specify the amount that each line should be trimmed or extended.

Original objects   Chamfer distances nonzero   Chamfer distances zero

- With the Angle method, you can also specify the length of the chamfer and the angle it forms with the first line.
Using the Trim and No Trim modes, you can trim or extend chamfered objects to the chamfer line or retain the chamfered objects as they were before the chamfer, as shown next.

- You can chamfer all corners of a polyline using the Polyline option.
- The Multiple option allows you to chamfer more than one set of objects without leaving the command. For example, you could chamfer the four corners of the square shown next with one Chamfer command.

**Procedure: Creating Chamfers**

The following steps give an overview of creating chamfers with the Chamfer command.

1. Start the Chamfer command.
2. Confirm the settings on the command line. If necessary, adjust the options as required for the design intent.
   
   **Command**: `_chamfer(NOTRIM mode) Current chamfer Dist1 = 1.0000, Dist2 = 1.5000Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]`
3. Select the first object to be chamfered.
4. Select the second object to be chamfered. The chamfer feature is created.

**Note**: If you choose the Polyline option, step 4 is not required, as all vertices of the polyline will be filleted at once.

**Chamfer Guidelines**

- If both objects being chamfered are on the same layer, the chamfer line is created on that layer. Otherwise, the chamfer line is created on the current layer.
- Entering chamfer distances of 0 creates a sharp corner.
- Setting equal chamfer distances is the same as setting the angle at 45 degrees.
- When setting chamfer distances the first distance is always applied to the first line you pick.
- Chamfering a line to a polyline will automatically join it to the polyline.
- A closed polyline will chamfer in a counter-clockwise direction.
- Hold down the SHIFT key while selecting the object to override the chamfer distance values and create a sharp corner.
Practice Exercise: Creating Chamfers

In this practice exercise, you draw an 8 x 6 rectangle and create chamfers using the Chamfer command.

1. To draw the rectangle:
   - Begin the Rectangle command.
   - Click in the drawing window to specify the first corner.
   - For the other corner, enter @8,6 and press ENTER.

2. To make a 45 degree corner using the chamfer command:
   - Begin the Chamfer command.
   - Right-click anywhere in the drawing. Click Angle.
   - Enter 1 and press ENTER for the chamfer length on the first line.
   - Enter 45 and press ENTER to specify the chamfer angle from the first line.
   - Select the first corner then the adjacent corner as indicated below.
   - Repeat until all 4 corners are chamfered.
   - Press ENTER to exit the chamfer command.
   **Note:** You could have used the Distance option and entered both distance lengths at 1 for the same results.

3. To chamfer using the polyline option:
   - Draw another 8 x 6 rectangle (see #1).
   - Begin the Chamfer command.
   - See that the current chamfer length is 1 and the angle is 45 degrees.
   - Right-click anywhere in the drawing. Click Polyline.
   - Select the rectangle.
   - All corners are chamfered.
4. To chamfer using the Distance option where the distances are not equal:
   - Draw another 8 x 4 rectangle.
   - Begin the Chamfer command.
   - Right-click anywhere in the drawing. Click Distance.
   - Enter 1 for the first chamfer distance and press ENTER.
   - Enter .5 for the second chamfer distance and press ENTER.
   - Select the first line (1) and select the second line (2).
   - Repeat the Chamfer command.
   - Select the line at (3), then select the line at (4).
   Remember that the first distance is always applied to the first line you select and the second distance is applied to the second line selected.
   - Repeat the Chamfer command and add chamfers to all four corners as shown below.

5. To chamfer using the Distance option combined with the Polyline option when the distances are not equal:
   - Draw an 8 x 6 rectangle.
   - Begin the Chamfer command.
   - Note that the current chamfer distance 1 is 1 and distance 2 is .5.
   - Right click anywhere in the drawing. Click Polyline.
   - Select the rectangle.
   Chamfer works in a counter-clockwise direction. Therefore, chamfering a polyline with non-equal distances gives you this kind of result.
Exercise: Create a Chamfered Corner

In this exercise, you create chamfer features using the Multiple, Distance, and Angle options of the Chamfer command. When you have completed the exercise, you will be able to use the Chamfer command to add chamfer features to geometry in other drawings.

3. To create a 1-unit chamfer:
   - Start the Chamfer command.
   - Right-click anywhere in the drawing window. Click Distance.
   - When prompted for the first chamfer distance, enter 1. Press ENTER.
   - Press ENTER for the second chamfer distance, as it defaults to the value of the first chamfer distance.
   - Right-click anywhere in the drawing window.
   - Click Multiple. This enables you to create multiple chamfers without restarting the Chamfer command.

4. To complete the chamfer:
   - Select the lines indicated in the following image near their intersections.
   - Note: The chamfers have already been applied in this image. You may need to turn on the Trim option if it is off.
   - DO NOT exit the chamfer command. Proceed to the next step.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 5: Altering Objects. Click Exercise: Create a Chamfered Corner.

1. Open M_Create-Chamfers.dwg.
2. Zoom in on the lower left view of the drawing.
5. Select the lines near their intersections as shown in the following image. Press ENTER to end the Chamfer command.

6. Use Zoom and Pan to display the top-left view in the drawing.

7. To create more 1-unit chamfers in this view:
   - Start the Chamfer command.
   - Right-click anywhere in the drawing window. Click Multiple.
   - Select the lines indicated in the following image.
   
   **Note:** The lines have already been chamfered in this image.

8. Repeat the chamfers on the right side of the view. Press ENTER to end the Chamfer command.

9. To create additional chamfers using the Angle and Multiple options:
   - Press ENTER to repeat the Chamfer command.
   - Right-click anywhere in the drawing window.
   - Click Angle.
   - Enter 1 for the chamfer length on the first line.
   - Enter 60 for the chamfer angle from the first line.
   - Right-click anywhere in the drawing window.
   - Click Multiple.
   - Select the edges in the order indicated in the following image.
   
   **Note:** The chamfers have already been applied in this image.

10. Select the edges on the opposite side of the view.
11. Use Zoom and Pan to display the lower-left view as shown.
   - Apply the chamfers to the edges of the part on both sides of the view.
   - Press ENTER to end the Chamfer command.

12. Using the Line command, draw line segments at each location in which a chamfer was created.

13. Zoom to display your entire drawing.
14. Close all files without saving.
Lesson: Changing Part of an Object's Shape

This lesson describes how to use the Stretch command to change part of an object's shape. Reusing objects and ease of editing are key benefits of using the Stretch command. As your design evolves, changes to features naturally occur as part of the process, or perhaps you are attempting to reuse geometry from another drawing and some features require a change in length or shape. The Stretch command can help in these situations by enabling you to modify the shape of existing objects easily.

After completing this lesson, you will be able to describe key aspects of the Stretch command and use the command to stretch objects.

Objectives

After completing this lesson, you will be able to:

- Use the Stretch command to stretch objects.
Stretching Objects

You use the Stretch command to change the shape of objects in the drawing, defining the area to be stretched with a crossing window or crossing polygon selection tool. After you define the stretch window, you then specify a base point and a second point for the stretch.

Defining the stretch operation with a crossing window or crossing polygon is critical because the area that is crossed by the selection method determines how the objects are stretched.

Command Access

**Stretch**

Command Line: `STRETCH, S`

Ribbon: **Home tab > Modify panel > Stretch**

Menu Bar: **Modify > Stretch**
Procedure: Stretching Objects Using Grips

The following steps give an overview of using grips to stretch objects.

1. Select an object to activate its grips.
2. Select any grip (use SHIFT+select to select multiple grips).
3. Click and drag the grips to a new location.

---

Procedure: Stretching Objects

The following steps give an overview of stretching objects in a drawing.

1. Start the Stretch command.
2. Select the objects to be stretched by defining a crossing window or crossing polygon selection.
3. Select the base point for the stretch.
4. Select the second point or enter a value for the stretch distance.

Stretch Guidelines
- When you stretch objects, you must define the stretch window using a crossing window (CW) or crossing polygon (CP). If you use implied windowing, you must create the selection from right to left.
- Objects that are crossed by the selection window are stretched, while objects that are completely enclosed by the window are moved.
- To stretch an object in a straight line, be sure that Polar Tracking or Ortho Mode is on.
- After you have selected your object(s) to Stretch, pick a basepoint near the object but far enough away from any other objects you might snap to accidentally.
Practice Exercise: Stretching Objects

In this practice exercise, you draw some rectangles and then practice using the Stretch command to stretch using grips.

Keep in mind that object endpoints included in the crossing selection window are moved or stretched to a new location. Endpoints left out of the crossing selection window remain anchored to their position.

1. To Stretch the large rectangle:
   - Draw a rectangle with another one inside, as shown above.
   - Begin the Stretch command.
   - Begin an implied crossing window by clicking the right corner (1) of the selection window then click the opposite corner to the left (2), as indicated below.
   - Press ENTER to complete your selection.
   - Click a basepoint near the object (1). DO NOT SELECT the next point. Drag the cursor to the left (2) as shown below, enter 2, and press ENTER.

2. To stretch both rectangles:
   - Begin the Stretch command.
   - Begin an implied crossing window picking corners first at (1) and then at (2) as shown below.
   - Press ENTER to complete the selection.
   - Click a basepoint near the object as shown below and drag to the left.

   Enter 2 and press ENTER.

Notice that Polar Tracking or Ortho Mode be on to ensure that you drag the objects in a straight line.
3. To stretch the large rectangle and move the small rectangle using the Stretch command:
   - Begin the Stretch command.
   - Begin an implied crossing window first at point (1) then at point (2). Be sure the smaller rectangle is completely inside the selection window.
   - Press ENTER to complete the selection.
   - Click a basepoint near the object as indicated below.
   - Drag the cursor to the left.
   - Enter 2 and press ENTER.

Notice that the small rectangle was completely within the selection window so all endpoints or vertex points were moved.

4. To stretch an object using grips:
   - With the Command line blank, select a rectangle.
   - Hold down the SHIFT key and click two endpoints as indicated below.
   - Release the SHIFT key and click one of those points again.
   - Drag the cursor to the left and click on the Midpoint of that line.
5. To stretch a single vertex or endpoint of an object:
   - With the command line blank, select the rectangle.
   - Click a corner endpoint.
   - Drag to the right and click.
   - Press ESC to deselect the object.

Notice that the single endpoint or vertex was moved and the other endpoints remained anchored. The lines in between were stretched.
Exercise: Stretch Objects

In this exercise, you use the Stretch command to increase the area of the rooms in the floor plan. When you have finished, you will be able to use the Stretch command to stretch geometry in other drawings.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 5: Altering Objects. Click Exercise: Stretch Objects.

1. Open M_Stretch-Objects.dwg.
2. On the status bar, turn Osnap off.
3. To add 2000 units to the left side of the structure:
   - On the Modify panel, click Stretch.
   - Click point (1) then point (2) to define the stretch crossing window.
   - Press ENTER.
4. To complete the stretch operation:
   - Click to select near the bottom corner of the wall and drag the cursor to the left 180 degrees.
   - Enter 2000. Press ENTER.
   - Notice that the dimensions also update to reflect the new size.

5. To use stretch with a Crossing Polygon selection:
   - Press ENTER to repeat the Stretch command.
   - Enter CP to specify a crossing polygon selection. Press ENTER.
   - Define the crossing polygon by clicking points, as shown in the following image.

6. To add 2000 units to the right side of the structure:
   - Press ENTER to complete the crossing polygon selection.
   - Press ENTER to complete the object selection.
   - Click a point near the bottom corner of the wall.
   - Drag your cursor to the right at 0 degrees and enter 2000. Press ENTER.
Lesson: Changing Part of an Object’s Shape

7. To use stretch with a crossing selection:
   - Right-click anywhere in the drawing.
   - Click Repeat Stretch.
   - Enter `C`. Press ENTER for a crossing window.
   - Click near point (1) and then point (2) to define the crossing window. Press ENTER.

8. To slide an interior wall 1500 units to the right:
   - Click a point below the floor plan, and then drag to the right at 0 degrees.
   - Enter 1500. Press ENTER.
   Notice how the window object moved with the stretch operation. This occurred because any geometry that is fully enclosed by the stretch window is moved rather than stretched.

9. To select a window to move within a wall:
   - Start Stretch.
   - Click near point (1) and then point (2) to define the crossing window.
   - Press ENTER.

10. To complete the move:
    - Click a point to the right of the window, and then drag to the right at 0 degrees.
    - Enter 1000. Press ENTER.
    Notice how the window object moved with the stretch operation and the dimension updated to reflect the new window location.
11. To select a door to relocate within a wall:
   - Start the Stretch command.
   - Click near point (1) and then point (2) to define the crossing window.
   - Press ENTER.

12. To relocate the door:
   - Click a point to the right of the door, and then drag to the right at 0 degrees.
   - Enter 1200. Press ENTER.
   Notice how the door object moved, and the wall objects were stretched.

13. Close all files without saving.
Challenge Exercise: Architectural

In this exercise, you use what you learned about altering objects to modify the floor plan.

You have the option of completing this exercise using either imperial or metric units. Select one version of the exercise to complete the steps.

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 5: Altering Objects. Click Challenge Exercise: Architectural Metric.

Metric Units
1. Open the drawing you saved from the previous challenge exercise, or open M_ARCH-Challenge-CHP05.dwg.
2. Create the geometry to represent a wall 189 mm thick, working on the basis that the original lines you created represented the outside of the exterior and structural walls. The image shows the bottom stairwell. Note that the lines you drew for the stairwell in the Chapter 2 challenge exercise were dimensioned from the outside wall to the leading, or inside, edge of the wall. Add the door opening to the lower staircase to match the opening in the upper staircase.
3. Add a 915 mm door opening in the right wall, positioned as shown in the image.

4. Add 15 window openings that are 914 mm wide and positioned as dimensioned. In the wall sections that jog out to the left toward the corners with the dimensions of 500, center the openings along that inside wall.
5. Add six window openings that are 610 mm wide and positioned as dimensioned.

6. Create the interior walls 124 mm wide on the Wall-Interior layer. The 3 thicker walls are 336 mm. All interior door openings are 915 mm wide. Position the walls based on the dimensions shown in the image. For any geometry not specifically dimensioned, estimate its position and draw it as shown in the image.

7. Save and close the drawing.
Imperial Units

1. Open the drawing you saved from the previous challenge exercise, or open I_ARCH-Challenge-CHP05.dwg.

2. Create the geometry to represent a wall 7" thick, working on the basis that the original lines you created represented the outside of the exterior and structural walls. The image shows the bottom stairwell. Note that the lines you drew for the stairwell in the Chapter 2 challenge exercise were dimensioned from the outside wall to the leading, or inside, edge of the wall. Complete all of the exterior walls.

Add the door opening to the lower staircase to match the opening in the upper staircase.

3. Add a 3'-0" door opening in the right wall, positioned as shown in the image.
4. Add 15 window openings that are 36" wide and positioned as dimensioned. In the wall sections that jog out to the left toward the corners with the dimensions of 1'-8", center the openings along that inside wall.

5. Add six window openings that are 24" wide and positioned as dimensioned.
6. Create the interior walls 5" wide on the Wall-Interior layer. The three thicker walls are 13.5". All interior door openings are 3'-0" wide. Position the walls based on the dimensions shown in the image. For any geometry not specifically dimensioned, estimate its position and draw it as shown in the image.

7. Save and close the drawing.
Challenge Exercise: Mechanical

In this exercise, you use what you learned about altering objects to edit geometry.

**Note:** In the following image, the views are closer together than they will appear in your drawing.

The completed exercise

---

**Completing the Exercise**

To complete the exercise, follow the steps in this book or in the onscreen exercise.

In the onscreen list of chapters and exercises, click *Chapter 5: Altering Objects*. Click *Challenge Exercise: Mechanical*.

1. Open the drawing you saved from the previous challenge exercise, or open *M_MECH-Challenge-CHP05.dwg.*
2. Create and edit geometry so the views for the Rack Slider Top appear as shown.  
   **Note:** The views in the image are closer together than they will appear in your drawing.

![Image of Rack Slider Top views]

3. Create and edit geometry so the views for the Rack Slider Base appear as shown. Use Join to join the collinear lines that were created with Mirror in a previous challenge.  
   **Note:** The views in the image are closer together than they will appear in your drawing.

![Image of Rack Slider Base views]
4. Create and edit geometry so the side view for the Rack Slider Base appears as shown. Note the 3mm radius fillets.

![Side View of Rack Slider Base]

5. Copy geometry from the area indicated to the upper-right of the view.
   - Scale the resulting geometry to twice its regular size.
   - Draw a circle around the scaled geometry, then trim the geometry to the circle.

![Scaled and Trimmed Geometry]

6. Copy geometry from the existing views to create the assembly views. You won't need the hidden and centerlines.
   - Thaw the Start Points layer.
   - Use the Assembly Start Point to locate the position of the assembly front view.
   - Erase geometry as required if it would be hidden by other parts as it is assembled.

![Assembly Views]
7. Delete the Assembly Start Point leader and text.
8. Create the centerlines for the detail view.
9. With the Hidden layer current, create the hidden geometry in these views using points in each view as references. Then create the centerline objects and place them on the Centerline layer. 

**Note:** In the following image, the views are closer together than they are in the drawing.
10. Copy the geometry for the side view to create a section (you will apply hatching in a later challenge exercise). Move the hidden geometry to the Visible layer, then delete and trim unnecessary geometry. Delete the hole geometry.

11. ■ Copy the section view to the start point to the right of the side assembly view.
■ Copy the Rack Slide Top's side view and position it on top of the section view, then move hidden lines to the visible layer and remove the unnecessary geometry.

12. Save and close all files.
Chapter Summary

Every design you create begins with simple geometry. The procedures you use to edit these basic objects transform them into complex designs.

Having completed this chapter, you can:

■ Change the length of objects using the Trim and Extend commands.
■ Create parallel and offset geometry in your drawing by using the Offset command.
■ Use the Join command to combine multiple objects into a single object.
■ Break objects into two or more independent objects.
■ Apply a radius corner to two objects in the drawing.
■ Apply an angled corner to two objects in the drawing.
■ Use the Stretch command to alter the shape of objects in the drawing.