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Chương 1 
TÍNH NĂNG CƠ BẢN CỦA MAPINFO 

 
1.1. Tập tin dữ liệu của MapInfo 
 - Trong Mapinfo dữ liệu được tổ chức thành các lớp dữ liệu (table). Đây là 
một tập hợp gồm nhiều tập tin có cùng tên nhưng phần mở rộng là *.tab, *.dat, 
(*.wks, *.dbf, *.xls), *.map, *.id, và *.ind. Tuỳ theo tính chất của dữ liệu mà 
thành phần trên thay đổi từ 2 đến 6 tập tin trên. 
 tậptinX.tap: mô tả cấu trúc của dữ liệu. 
 tậptinX.dat: chứa dữ liệu dạng bảng (hàng và cột). 
 tậptinX.map: mô tả các đối tượng đồ hoạ. 
 tậptinX.id: liên kết dữ liệu với các đối tượng. 

tậptinX.ind: chỉ mục (giúp tìm kiếm đối tượng đồ hoạ khi sử dụng chức 
năng Query > Find). 

Mapinfo xem tập tinX.tab là đại diện cho tập hợp các tập tin trên. Có 
nghĩa khi chọn một tập tin có phần mở rộng là *.tab (trong môi trường MapInfo) 
là chọn một lớp dữ liệu của MapInfo. 

Nếu dữ liệu là ảnh dạng ma trận raster), tập tin Y.bmp (hay *.jpg, *.gif,…) 
sẽ kết hợp với tập tin Y.tab (nếu được khai báo toạ độ địa lý tương ứng). 

Ngoài các tập tin dữ liệu trên, MapInfo còn được sử dụng được dữ liệu 
xây dựng trong các phần mềm khác như Lotus 123 (*.wks), Dbase hay Foxbase 
(*.dbf) hay Excel (*.xls) cũng như dạng văn bản (*.txt). 

Mở một lớp dữ liệu với File > Open Table. 

 

ThS. Nguyễn Đức Bình – ThS. Hoàng Hữu Cải – KS. Nguyễn Quốc Bình 
Bộ môn LNXH – ĐHNL Tp. HCM, Tháng 3/2003 
 

1



Xây dựng bản đồ số hoá với MapInfo 6.0 
 

Trong khung Preferred View, mặc định là Automatic, có nghĩa: 
Nếu lớp dữ liệu có chứa dữ liệu không gian (Spatial data), tức các đối 

tượng  địa lý với toạ độ tương ứng  được lưu trữ dưới dạng số (digital format), 
trên màn hình sẽ xuất hiện một cửa sổ bản đồ (map window) với các đối tượng 
của lớp dữ liệu (có thể chỉ một số các đối tượng này). 

Nếu dữ liệu không có dữ liệu không gian, chỉ có dữ liệu phi không gian 
(còn gọi là dữ liệu thuộc tính): trên màn hình sẽ xuất hiện một cửa sổ dữ liệu 
theo dạng hàng-cột (browser window) của lớp dữ liệu đó. 

Ta có thể chọn Browser để xem dữ liệu, Current Mapper: mở trong 
cùng cửa sổ đang mở, New mapper: cửa sổ bản đồ mới, hay No View: không 
hiện gì trên màn hình (nhưng sẽ được đưa vào trong bộ nhớ của máy tính). 

Chúng ta có thể mở nhiều lớp dữ liệu một lúc, và thông thường để xây 
dựng một bản đồ chúng ta sử dụng đến nhiều lớp dữ liệu. 

1.2. Thao tác trên cửa sổ bản đồ 
Thay đổi độ phóng đại và vùng nhìn thấy: 
Tham số Zoom trên trên thanh trạng thái cho biết giá trị ngoài thực tế của 

chiều rộng cửa sổ bản đồ đang hoạt động. 
Tắt mở thanh trạng thái bằng Show/Hide Status Bar trong mục Options 

của menu chính. 
Để thay đổi độ lớn của bản đồ trong cửa sổ bản đồ, chúng ta có thể sử 

dụng: biểu tượng phóng lớn (dấu + trong vòng tròn kính lúp) hay thu nhỏ (dấu – 
trong vòng tròn kính lúp). 

Vào Map > Change View hay click biểu tượng của chức năng này (dấu ? 
trong vòng tròn kính lúp), cửa sổ Change View xuất hiệnvới các tham số: 

Zoom (-windows width): cho biết giá trị hiện tại. 
Map Scale: cho biết giá trị hiện tại 1 cm trên bản đồ (máy tính) tương ứng 

với khoảng cách bao nhiêu trên thực tế. 
Chúng ta có thể thay đổi một trong hai tham số và khi thay đổi một tham 

số thì tham số kai cũng thay đổi tương ứng. 
Center of windows: cho biết toạ độ trung tâm cửa sổ bản đồ. Dĩ nhiên khi 

thay đổi một toạ dộ này thì nội dung trong khung nhìn cũng thay đổi. 
Thường sau khi mở một lớp dữ liệu, có thể trong cửa sổ bản đồ không 

chứa hết tất cả các đối tượng. Để thấy được tất cả các đối tượng trong cửa sổ này 
chúng ta vào Map > View Entire Layer rồi chọn lớp dữ liệu muốn xem trong 
cửa sổ View Entire Layer và click OK. 

Chúng ta có thể trở lại tình trạng cửa sổ bản đồ trước khi vừa được thay 
đổi với Map > Previous View.  
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Để có thêm một cửa sổ bản đồ giống như một cửa sổ đang làm việc, chúng 
ta vào hoặc Map > Clone View hoặc Edit > Copy Map Window (Ctrl-C) rồi 
Edit > Paste Map Window (Ctrl-V). 

* Ngoài ra, chúng ta cũng có thể di chuyển đối tượng trong cửa sổ bản đồ 
với biểu tượng bàn tay trong hộp công cụ Main (Click vào ô có biểu tượng này, 
sau đó di chuyển mouse trong cửa sổ bản đồ rồi bấm và kéo mouse theo hướng ta 
muốn) 

* Dĩ nhiên chúng ta mở rộng hay thu hẹp cửa sổ bản đồ bằng cách di 
chuyển các cạnh của khung cửa sổ. 
Cách chọn đối tượng địa lý trong cửa sổ bản đồ: 

* Chúng ta có thể chọn trực tiếp một đối tượng hiện diện trong khung nhìn 
cửa sổ bản đồ bằng cách click biểu tượng Select (dấu mũi tên lớn) trong hộp 
công cụ Main, sau đó di chuyển cursor vào trong cửa sổ bản đồ, đến vị trí của 
đối tượng muốn chọn và click. đối tượng đó sẽ được hiện rõ lên. Để chọn nhiều 
đối tượng, chúng ta bấm giữ phím Shift trong khi click các đối tượng tiếp theo. 

* Click biểu tượng Marquee Select (dấu mũi tên trong hình vuông đường kẻ 
đứt đoạn) hay Rad select (dấu mũi tên trong hình tròn đường kẻ đứt đoạn) để 
chọn tất cả các đối tượng trong hình tròn hay hình chữ nhật do chúng ta vẽ ra. 

*Biểu tượng Boundary select (dấu mũi tên trong hình đa giác đường kẻ đứt 
đoạn) là để chọn tất cả các đối tượng bên trong ranh giới của một đối tượng kiểu 
vùng đã xác định trước. 

* Chúng ta còn có thể chọn một (hay nhiều) đối tượng từ danh sách các đối 
tượng trong cửa sổ dữ liệu. Một lớp dữ liệu có đối tượng địa lý luôn đi kèm danh 
sách các đối tượng này. Để xem chúng chúng ta vào Windows> New Browser 
Windows (hay bấm phím F2), chọn tên lớp dữ liệu trong cửa sổ Browser Table 
và click OK. 

Trong cửa dữ liệu (Browser Windows) chúng ta có thể chọn đối tượng 
theo yêu cầu của chúng ta, ví dụ muốn chọn đối tượng có tên là “xyz”, chúng ta 
sẽ chọn trong cửa sổ dữ liệu đối tượng này một cách dễ dàng. Khi chúng ta click 
vào ô trống ở đầu hàng của một đối tượng chúng ta đã chọn tương ứng đối tượng 
đó trong cửa sổ bản đồ, một cách để có thể làm đối tượng này xuất hiện là click 
vào chức năng Query>Find selection. 

* Muốn biết thông tin về một vị trí nào đó trong cửa sổ bản đồ, chúng ta 
sử dụng cửa sổ Info (khung chữ I trong hộp công cụ Main). Một khi chọn biểu 
tượng này và sau đó click vào một vị trí trong cửa sổ bản đồ Info tool cho biết tại 
điểm vừa được click có bao nhiêu lớp dữ liệu, chúng ta click vào một trong 
những lớp dữ liệu này sẽ hiện ra các thông tin chứa trong lớp dữ liệu đó (liệt kê 
giá trị các cột của lớp dữ liệu này của đối tượng tương ứng). Chúng ta có thể sửa 
hay nhập lại các giá trị này. 
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1.3. Thao tác trên dữ liệu 
1.3.1. Thay đổi thuộc tính của một lớp dữ liệu trong MapInfo. 

Để xem và thay đổi các thuộc tính (thấy được, sửa đổi được, được chọn và 
tự động ghi chú cho các đối tượng) của một lớp dữ liệu sau khi được mở trong 
Map Info, chúng ta vào Map>Layer Control (khi đang làm việc trên một cửa sổ 
bản đồ) hay click biểu tượng của chức năng này trong hộp công cụ Main. Sau đó 
trên cửa sổ Layer Control, muốn gắn thuộc tính nào cho lớp dữ liệu chúng ta  
click vào ô tương ứng của thuộc tính này. 
1.3.2. Xem và sửa đổi các thuộc tính của dữ liệu: 

Các đối tượng của một lớp dữ liệu chỉ có thể sửa đổi khi lớp dữ liệu này 
có thuộc tính thấy được và sửa đổi được. Chỉ có thể có một lớp dữ liệu sửa đổi 
được tại một thời điểm. 

Các kiểu đối tượng trong Map Info bao gồm: kiểu đa giác (vùng), kiểu 
điểm, kiểu đường và kiểu văn bản (thông tin phi không gian)  

* Để xem thông tin của một đối tượng, chúng ta chọn đối tượng đó rồi vào 
Edit>Get Info, hoặc Double Click lên đối tượng. Chúng ta có thể thay đổi một 
số thuộc tính của đối tượng bằng cách click vào khung Style trong cửa sổ các đối 
tượng. 

* Để thay đổi vị trí địa lý chúng ta có thể di chuyển đối tượng bằng cách 
bấm (giữ chốc lát cho đến khi cursor có hình mũi tên 4 chiều) và kéo mouse. 

Để thay đổi hình dạng của đối tượng kiểu vùng hay kiểu đường chúng ta 
sử dụng chức năng Edit>Reshape hay click vào biểu tượng của chức năng này 
sau khi một đối tượng được chọn. Các điểm trung gian (node) của đối tượng sẽ 
hiện lên, chúng ta có thể di chuyển vị trí hay xoá các điểm này; cũng có thể thêm 
các điểm nay với biểu tượng Add node trong hộp công cụ Drawing. 

Chúng ta cũng có thể sử dụng các chức năng Cut Copy và Paste trong 
mục Edit để xoá, sao dán các đối tượng trong một lớp dữ liệu hay giữa các lớp 
dữ liệu. 
1.3.3. Lớp dữ liệu tạm thời trong cửa sổ bản đồ 

Khi mở một hay nhiều lớp dữ liệu có các đối tượng địa lý, mỗi lớp dữ liệu 
này trong cửa sổ bản đồ là một “Layer”,một lớp bản đồ. Trong cửa sổ bản đồ, 
ngoài các lớp bản đồ được mở với File >OpenTable, luôn luôn có một lớp bản 
đồ tạm thời gọi là Cosmetic Layer.  Cosmetic Layer là một lớp trong suốt và 
luôn nằm ở vị trên cùng của “chồng”các lớp bản đồ. Chúng ta có thể hoặc Map 
Info trong quá trình xử lí sẽ in thông tin trên lớp bản đồ này. Để lưu lại những 
thông tin này, chúng ta vào Map>Save Cosmetic Objects và nhập tên một lớp 
dữ liệu mới. Chúng ta có thể xoá các thông tin trên Cosmetic Layer với Map> 
Clear Cosmetic Layer. 
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1.3.4. Workspace 

Map Info có khả năng lưu giữ môi trường hiện có bao gồm các lớp dữ liệu 
và thứ tự những cửa sổ được mở, kích thước và vị trí của chúng trên màn hình, 
cũng như kiểu chữ, kiểu đường, kiểu biểu tượng,… đã dùng để thể hiện các đối 
tượng, trong một tập tin có phần mở rộng là *.Wor, gọi là Workspace (môi 
trường làm việc vào một thời điểm). 

Để tạo một workspace, chúng ta vào File>Save Workspace và nhập tên 
một tập tin dạng *.wor ở thư mục tương ứng và chúng ta mở lại tập tin *.wor này 
với File>Open Workspace để trở lại môi trường này. 

Chúng ta thường sử dụng workspace để lưu lại môi trường đang làm việc 
mà chúng ta muốn tiếp tục về sau như số hoá bản đồ hay để lưu các bản đồ 
chuyên đề đã được trang trí và sắp xếp trên trang in. 
 

<><//>%%%<//><> 
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Chương 2 
XÂY DỰNG DỮ LIỆU KHÔNG GIAN 

 
2.1. Tạo dữ liệu mới trong MapInfo 

Để xây dựng một dữ liệu mới theo dạng của MapInfo (Table), chọn File > 
New Table, cửa sổ New Table sẽ xuất hiện. 

 
Chọn Open New Mapper hay Add to Current Mapper khi muốn tạo các 

đối tượng đồ họa. Nếu chỉ muốn tọa một cơ sở dữ liệu thì chọn Open New 
Browser, Click Create, cửa sổ New Table Structure xuất hiện. Cách khai báo 
trong cửa sổ này như sau: 

 
 Mục Projection:  

Nếu tạo dữ liệu ở một vùng địa lý mới, trước hết phải khai báo mục 
Projection. Projection (hệ quy chiếu) là phương pháp làm giảm sự biến dạng 
xảy ra khi chuyển các đối tượng địa lý trên mặt đất lên mặt phẳng của bản 
đồ giấy. 

Click Projection, cửa sổ Choose Projection xuất hiện: 
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 or  

- Nếu muốn khai báo theo toạ độ địa lý (kinh độ và vĩ độ) thì chọn 
Longtitude/Latitude trong mục Category. Trong phần Category Members, tùy 
theo hệ quy chiếu của bản đồ mà chúng ta có thể khai báo: 

- Longtitude / Latitude, chung cho các hệ quy chiếu  
- Hay Longtitude / Latithde (WGS 84), nếu hệ quy chiếu là UTM. 
- Hay Longtitude / Latitude (Pulkovo 1942), nếu hệ quy chiếu là Gauss. 
- Nếu muốn khai báo theo hệ quy chiếu, trường hợp hệ quy chiếu là UTM 
(Universal Transverse Mercator) ta chọn Universal Transverse Mercator 
(WGS 84) trong mục Category. Tiếp theo tùy theo vị trí của vùng khảo sát mà 
chọn UTM Zone 48, Northern Hemisphere (WGS 84) hay UTM Zone 49, 
Northern Hemisphere (WGS 84)  trong phần Category Members. Trường hợp 
hệ quy chiếu là Gauss, trong mục Category chúng ta có thể chọn Gass- 
Kruger  (Pulkovo 1942), và trong phần Category Members chọn GK Zone 18 
(Pulkovo 1942). Trong MapInfo chưa có hệ quy chiếu Gauss đúng như ngành 
địa chính sử dụng, khai báo vừa rồi chỉ là tương đối. 
* Trường hợp vùng dữ liệu đã có các bản đồ dạng số, chúng ta nên mở một 

trong các bản đồ đã có và tạo mới một dữ liệu trong cửa sổ bản đồ đang hoạt 
động (Add to Current Mapper), các tham số liên quan đến Projection là giống 
như của cửa số bản đồ hoạt động. 

Dữ liệu được tạo trong MapInfo có dạng là một bảng (tabular) gồm các 
hàng (row) và cột hay vùng (column, field). Mỗi vùng (cột) là một thuộc tính 
tương ứng của các hàng là các đối tượng.  

Click Add field để thêm vùng mới. Nhập tên của vùng này vào cửa sổ 
Name, ví dụ: Maso; sau đó chọn kiểu dữ liệu của vùng này trong cửa sổ Type. 
Tùy theo tính chất của vùng mà kiểu dữ liệu có thể là: 

- Kiểu số nguyên (Integer): lưu dữ các số nguyên (± 2.100.000.000) 

- Kiểu số nguyên ngắn (Smal Integer):     -nt-                  (±  32.767) 
- Kiểu số ký tự (Character): tối đa 254 ký tự. 
- Kiểu số thập phân (Decimal):lưu giữ các số thập phân dấu chấm cố                  

định ; tối đa dài 19 số.   
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- Kiểu số thập phân động (Float): lưu các số thập phân dạng dấu chấm tự do. 
- Kiểu ngày tháng (Date): theo dạng mm/dd/yy hay mm-dd-yyyy, cách nhau 

bằng dấu / hay dấu -. Ví dụ:  03/15/92 
- Kiểu luận lý (Logical): chỉ có hai giá trị là T (True) hay yes và F (False) 

hay no. 
Khai báo xong cho mỗi vùng, muốn khai báo thêm ta click Add filed và 

cứ thế tiếp tục. Sử dụng Up và Down để  xếp thứ tự các vùng, Remove Field để 
loại bỏ các vùng đang được đánh dấu trong danh sách. 

Khi tạo một lớp dữ liệu không gian mới (số hóa), thường chỉ có 2 vùng 
(cột) đó là vùng tên và vùng mã số của các đối tượng địa lý. Mã số thường là các 
mức độ khác nhau của các đối tượng tương ứng. Các đối tượng địa lý có thể cùng 
tên hay / và cùng mã số. Chúng ta sẽ thêm các vùng khác sau này khi cần.  

Click Create để đặt tên cho lớp dữ liệu mới này cùng với thư mục thích hợp. 

2.2. Số hoá bản đồ 
2.2.1. Định nghĩa. 

Số hóa bản đồ là quá trình vẽ lại một bản đồ giấy trên máy tính nhằm tạo 
một bản vẽ dạng số (digital format) của bản đồ đó.  

Số hóa là một cách nhập dữ liệu không gian, nó ghi nhận tọa độ địa lý của 
các đối tượng trên mặt đất, lưu trữ dưới dạng số để có thể xử lý trên máy tính.  

Có hai phương pháp số hóa bản đồ: số hóa với bàn số hóa (digitizer) và số 
hóa từ ảnh quét qua máy quét (scanner) của bản đồ giấy. 
2.2.2. Tiến trình số hóa trên ảnh quét 

2.2.2.1. Khai báo đăng nhập tọa độ của ảnh quét 

Bản đồ được quét qua máy quét (scanner) tạo nên các tập tin ảnh với phần 
mở rộng là *.tif, *.jpg, *.bmp,… Tùy theo kích thước bản đồ mà quét thành 
những tập tin ảnh khổ A4 (với máy quét thông dụng), hay A3, A0… 

Để sử dụng các tập tin ảnh này như bản đồ giấy, ta phải khai báo đăng 
nhập toạ độ của nó và có thể sử dụng như bản đồ nền trong suốt quá trình số hóa. 

 
Vào File > Open Table, chọn Raster Image trong mục List Files of 

Type, kế tiếp chọn thư mục và tập tin dạng ảnh đã được quét. Click OK, chọn 
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Register trong cửa sổ xuất hiện để đăng nhập tọa độ địa lý tương ứng. Cửa sổ 
Image Registration xuất hiện với các mục cần khai báo: 

 
Click Projection để khai báo thông số của hệ quy chiếu như đã đề cập ở trên. 
Click Units để khai báo về đơn vị bản đồ là độ (degrees), hay mét (meters) 

tùy theo hệ quy chiếu tương ứng và điều kiện của bản đồ tham khảo. 
Kế tiếp là khai báo các điểm xác định vị trí địa lý của khu vực bản đồ đã 

được quét. Tối thiểu phải khai báo bốn điểm và Click vào khung New  để khai 
báo một điểm mới. 

Sử dụng khung có dấu + hay – (phóng to hay thu nhỏ hình ảnh) và các 
thanh trượt để đưa một khu vực của bản đồ vào vùng nhìn trên máy tính. 

Mỗi khi muốn khai báo điểm mới, phải xác định rõ vị trí toạ độ của điểm 
đó trên bản đồ giấy và dịch chuyển ảnh quét sao cho vị trí của điểm đó nằm trong 
khung nhìn. Click vào khung New, biểu thị ví trí của mouse thay đổi từ hình 
tượng mũi tên thành dấu chữ thập. Di chuyển mouse đến đúng vị trí tương ứng 
của điểm muốn định vị và click, sẽ xuất hiện cửa sổ Add control Point. 
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Nhập kinh độ của điểm đã chọn vào khung Map X và vĩ độ vào khung 

Map Y theo tọa độ hệ mét hay hệ độ đã khai báo trong mục Units. 
Có thể đặt tên cho điểm này trong khung Label. 
Click Ok, trong vùng thông tin các điểm đăng nhập sẽ xuất hiện thêm một 

hàng tham số của điểm vừa được khai báo. 
Khi đã khai báo tối thiểu 4 điểm, nên chú ý đến thông tin trong cột Error. 

Trị số trong cột này sẽ được tính toán tự động theo toạ độ các điểm đã được khai 
báo. Dĩ nhiên các trị số này càng nhỏ thì bản đồ đăng nhập càng tương hợp với vị 
trí địa lý thực. 

Di chuyển thanh sáng đến hàng ghi thông tin của một điểm, ta có thể thay 
đổi khai báo điểm đó bằng cách click Edit, khai báo toạ độ trong mục Map X và 
Map Y trong cửa sổ Edit Control Point, hay xoá nó với Remove hay để điểm 
này xuất hiện trong khung hình với Goto. 

Khi các thông tin trong cột Errors là chấp nhận được, click OK để kết thúc 
việc đăng nhập toạ độ của vùng ảnh quét. MapInfo sẽ tạo một tập tin có tên giống 
như tên của tập tin ảnh và phần mở rộng là *.tab, và hiện trên màn hình trong cửa 
sổ bản đồ của bản đồ ảnh vừa đăng nhập. 

Ta có thể điều chỉnh độ sáng và độ tương phản của ảnh trong Table > 
Raster> Adjust Image Style. 
2.2.2.2. Chỉnh sửa toạ độ của ảnh quét sau khi khai báo 

Sau khi đăng nhập, muốn khai báo toạ độ vị trí các điểm, vào Table > 
Raster> Modify Image Registration, sẽ xuất hiện cửa sổ Image Registration 
để chúng ta thêm/bớt/sửa đổi vị trí các điểm. 

Trong MapInfo có một khả năng khác để nhập và sửa đổi toạ độ các điểm 
định vị khi chúng ta đã có một lớp dữ liệu bản đồ dạng số của vùng bản đồ ảnh 
muốn đăng nhập với một số vị trí địa lý đặc biệt như giao điểm các sông hay các 
đường, hay hệ thống lưới ô vuông từng km,… 
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Vào File > Open Table, chọn lớp dữ liệu bản đồ đã có của vùng địa lý 
tương ứng. Mở tiếp bản đồ ảnh (dạng raster, nếu muốn nhập toạ độ các điểm định 
vị) hay tập tin *.tab của bản đồ ảnh này (dạng MapInfo, nếu muốn sửa đổi tọa độ 
các định vị). Sau đó vào Table > Raster > Modify Image Registration, cửa sổ 
Image Registration xuất hiện, click New để đăng nhập một điểm mới hay chọn 
một hàng ghi thông tin của điểm muốn sửa tọa độ; vào Table > Raster > Select 
Control Point from Map, khi vào phạm vi cửa sổ bản đồ hoạt động, cursor có 
dạng chữ thập (+), di chuyển cursor đến vị trí tương ứng trên bản đồ trong cửa sổ 
bản đồ hoạt động và click, cửa sổ Edit Control Poin xuất hiện với toạ độ mới do 
MapInfo tính toán từ lớp bản đồ đã có. Click OK để chọn. Dĩ nhiên sau khi nhập 
hay sửa đổi các điểm, click OK trong cửa sổ Image Registration để hoàn tất 
việc đăng nhập. 
2.2.2.3. Số hóa 

Dữ liệu số hóa được ghi vào một lớp dữ liệu mới. Vào File > New Table, 
mở chồng lên cửa sổ của tập tin ảnh đã được đăng nhập một Table mới. Kiểm tra 
lớp này để biết rõ là được chọn (selectable) và sửa đổi được (editale) trong 
Map> Layer Control hay click biểu tượng của chức năng này. 

Tùy theo đối tượng muốn số hóa là điểm, đường hay đa giác mà ta chọn 
biểu tượng đồ họa tương ứng trong hộp công cụ Drawing. Tính chất của các đối 
tượng này (kích cỡ, màu sắc, kiểu dạng,…) được xác định với các biểu tượng 
trong cửa sổ này hay trong Option > Line Style / Region Style / Symbol Style. 
Ta cũng có thể nhập văn bản với kiểu chữ, kích cỡ, màu sắc và độ nghiêng tuỳ 
chọn tại một vị trí bất kỳ. 

Để số hóa các đối tượng tiếp giáp nhau cùng chung một ranh giới, nên sử 
dụng khả năng bắt điểm (snap to node) – bấm phím S để tắt mở khả năng này-
Các chức năng xóa, cắt chia, xóa phần ngoài, nối kết lại các đối tượng địa lý 
cũng thường được sử dụng trong quá trình số hóa  . 

Để lưu dữ liệu vào đĩa, bấm Ctrl-S hay vào File > Save Table. 
2.2.3. Tiến trình số hóa với bàn số hóa (digitizer) 

2.2.3.1. Cài đặt dụng cụ số hóa 

- Chọn driver của thiết bị thích hợp. 
- Gắn chắc chắn bản đồ (hay vùng bản đồ) muốn số hóa vào bàn số hóa. 

Điều này rất quan trọng vì bản đồ không được dịch chuyển trong thời gian số 
hóa, làm sai các điểm định vị đã được khai báo. 
2.2.3.2. Tạo lớp dữ liệu số hóa  

Dữ liệu số hóa sẽ được lưu trong một vùng dữ liệu mới của MapInfo, lớp 
dữ liệu này có tọa độ địa lý tương ứng với bản đồ sẽ được số hóa. Chúng ta vào 
File > New Table và khai báo như đã thảo luận. Sau khi click Create trong cửa 
sổ New Table Structure, sẽ xuất hiện cửa sổ bản đồ của lớp dữ liệu mới này dù 
chưa có một thông tin nào. Chúng ta cần xem lại tọa độ chính xác của vị trí sẽ 
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được số hóa đầu tiên, sau đó vào Map > Change View, khai báo tương ứng 
trong ô X và ô Y của Center of Window trong cửa sổ Change View như sau: 

 
Chúng ta chỉ cần khai báo đầy đủ và chính xác cho lớp dữ liệu bản đồ đầu 

tiên của một khu vực địa lý. Các bản đồ khác sẽ “copy” lại các tham số này. 
Thường một lớp dữ liệu bản đồ chỉ thể hiện cho một tính chất, vì vậy chúng ta sẽ 
có nhiều lớp dữ liệu bản đồ cho một khu vực, như lớp dữ liệu về sông suối ao hồ, 
lớp dữ liệu về hệ thống giao thông trên bộ bao gồm đường quốc lộ, đường tỉnh 
lộ,… cũng như đường xe hỏa nếu có, lớp dữ liệu về hiện trạng sử dụng đất, tài 
nguyên rừng, lớp dữ liệu về loại đất, về vị trí các trung tâm hành chánh,… 

Khi cửa sổ bản đồ của lớp dữ liệu bản đồ sẽ được số hóa trong trạng thái 
hoạt động, chúng ta vào Map > Digitizer Setup (nếu chúng ta cài đặt bàn số hóa 
phù hợp).  
2.2.3.3. Xác định những điểm định vị để số hóa trong MapInfo 

Để cho việc đồ vẽ trên bản đồ giấy giao tiếp thích hợp với MapInfo, 
chúng ta phải cung cấp vài thông tin về bản đồ đó. Chúng ta thực hiện cách này 
trong cửa sổ Digitizer Setup. Ở đó, chúng ta phải xác định những điểm đinh vị 
phù hợp với bản đồ, hệ quy chiếu và đơn vị sử dụng, cũng như xác lập cấu hình 
trên mouse số hóa. 
2.2.3.4.  Xác định hệ quy chiếu và đơn vị bản đồ  

MapInfo cần biết hệ quy chiếu đã sử dụng cho bản đồ giấy. Nếu khai báo 
sai hệ quy chiếu (distortion - vặn vẹo) của bản đồ trong quá trình số hóa. Chúng 
ta không thể thay đổi hệ quy chiếu sau khi đã bắt đầu số hóa, vì vậy phải chắc 
chắn rằng hệ quy chiếu được khai báo đúng. 

Đơn vị bản đồ có thể là theo hệ độ (tọa độ địa lý) hay hệ mét (tọa độ 
UTM). Tùy theo thông tin trên bản đồ giấy để chọn đơn vị. 

Trước khi tiến hành khai báo các điểm định vị tọa độ bản đồ trên bàn số 
hóa, chúng ta click khung Buttons để chọn nút trên mouse số hóa dùng cho điểm 
bắt đầu và các điểm trung gian (thường là nút số 1) cũng như nút dùng cho điểm 
kết thúc của một đối tượng (có thể nút số 2). 
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2.2.3.5. Nhập các điểm định vị tọa độ địa lý của bản đồ giấy 

Để đăng nhập tọa độ các điểm định vị tọa cho bàn số hóa từ bản đồ giấy, 
chúng ta click vào khung Add, sẽ xuất hiện cửa sổ Pick Tablet Point. 

 
Chúng ta di chuyển mouse số hóa đến vị trí chúng ta muốn chọn, khi di 

chuyển mouse số hóa thì giá trị Tablet X và Tablet Y sẽ thay đổi và cho biết tọa 
độ của vị trí hiện tại, click nút 1 hoặc nút 2, sẽ xuất hiện cửa sổ Add Control 
Point và chúng ta sẽ nhập tọa độ của điểm vừa mới được chọn trên bàn số hóa, 
kinh độ trong khung Map X và vĩ độ trong khung Map Y như đã thảo luận ở trên. 

Sau khi khai báo tối thiểu 4 điểm định vị với sai số chấp nhận được (xem 
các trị số trong cột Errors) chúng ta click OK trong cửa sổ Digitizer Setup. 
2.2.3.6. Số hóa 

Tùy theo loại bàn số hóa, chúng ta sử dụng một lúc vừa mouse thường vừa 
mouse số hóa, nhưng khi bàn số hoạt động thì mouse số hóa sẽ có hai chức năng, 
hoặc mouse bình thường hoặc mouse số hóa, để chuyển đổi qua lại giữa hai chức 
năng này chúng ta click phím D trên bàn phím. 

Để số hóa một đối tượng nào đó chúng ta xem đối tượng đó chúng ta xem 
đối tượng đó thuộc kiểu nào, điểm đường hay vùng và click vào biểu tượng 
tương ứng trong hộp công cụ Drawing sau đó di chuyển mouse số hóa đến đối 
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tượng được số hóa, click phím D, bắt đầu số hóa với nút số 1 và sẽ kết thúc với 
nút số 2 (như đã khai báo ở trước). Lưu ý rằng sau khi click phím D để khởi động 
việc số hóa, vị trí của mouse số hóa là đường ngang và đường thẳng đứng hết 
màn hình, nếu không có dấu hiệu này thì phải kiểm tra lại vùng nhìn thấy trên 
cửa sổ bản đồ có phù hợp với tọa độ của vùng sẽ được số hóa hay không. Dùng 
chức năng Map > Change View để khai báo lại trung tâm vùng nhìn và mức độ 
zoom của cửa sổ bản đồ. 

Các thao tác khác giống như đã thảo luận trong phần số hóa trên ảnh quét. 
 

===$$$=== 
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Chương 3 
TỔ CHỨC DỮ LIỆU  

 
Thông tin mang tính địa lý trên một vùng lãnh thổ bao gồm rất nhiều lớp 

dữ liệu chuyên đề khác nhau (thuộc đơn vị hành chính nào, trên loại đất nào, hiện 
trạng sử dụng đất là gì, tài nguyên rừng phân bố khu vực nào, bao nhiêu…) và 
mỗi dữ liệu chuyên đề thường được xây dựng thành một lớp dữ liệu riêng với 
bản đồ tương ứng. 

Sau khi xây dựng các lớp dữ liệu (table) từ số hoá các bản đồ, thể hiện các 
đối tượng địa lý trong vùng khảo sát, Map Info có khả năng bổ sung các số liệu 
phi không gian (số liệu thuộc tính - yếu tố kinh tể xã hội ) bằng nhiều cách. 

Trong quá trình làm việc, Map Info thường tạo ra các lớp dữ liệu tạm thời 
(selection) lưu trong bộ nhớ với tên bắt đầu là Querry và tiếp theo là số thứ tự, ví 
dụ, Query1, Query2, vì vậy muốn ghi lên đĩa chúng ta vào File>Save as rồi đặt 
tên cho các lớp dữ liệu có thể sẽ được sử dụng lại. 

 
3.1.Thay đổi cấu trúc dữ liệu 

Một cấu trúc dữ liệu được tạo ra ban đầu có thể chỉ thích hợp ở thời điểm 
mà chúng được xây dựng hay tạo ra. Trong quá trình sử dụng, quản lý… có xảy 
ra những sự thay đổi nào đó mà cấu trúc dữ liệu cũ không còn phù hợp được nữa 
mà cần phải thay đổi. Khi đó chúng ta tiến hành thay đổi cấu trúc dữ liệu của của 
trúc dữ liệu cũ để thích hợp với thời điểm hiện tại. Chúc ta thực hiện như sau: 

Vào Table >Maintenance>Table Structure, chọn lớp dữ liệu muốn tu 
chỉnh, cửa sổ Modify Table  Structre xuất hiện. (Giống như cửa sổ New Table 
Structure). 
Click Add Field để thêm vùng (cột) với tên và kiểu được khai báo tiếp theo. 

Muốn sửa đổi các tính chất của một vùng đã khai báo, dịch chuyển thanh 
sáng đến vùng này và chọn tính chất (tên, kiểu) muốn thay đổi. Có thể sắp xếp lại 
thứ tự các vùng với khung Up hay Down để di chuyển một vùng lên trên hay  
xuống dưới (lên phía trước hay lùi về sau). Cũng có thể loại bỏ vùng đánh dấu 
với Remove. 
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3.2. Liên kết với cơ sở dữ liệu có sẵn 

Cơ sở dữ liệu có sẵn có thể có phần mở rộng *.dbf (dbase), *.wks (lotus), 
*.xls (excel) hay *.txt (ASCII). MapInfo sử dụng được các cơ sở dữ liệu này 
như là những lớp dữ liệu riêng sau khi hoàn tất thủ tục khai báo. 

Vào File>Open Table, chọn tập tin cơ sở dữ liệu  theo các dạng trên (chọn 
kiểu tương thích trong List File of Type) trong cửa sổ Open Table. 

 
o Cơ sở dữ liệu dạng *.dbf. (Dbase III, Dbase  4, Foxbase, Fox pro)  

Chọn dBASE DBF trong cửa sổ List Files of Type. Nhập hay chọn tập tin 
dạng *.DBF trong thư mục tương ứng. Trong cửa sổ Preferred View có thể chọn 
Automatic, Browser (bảng dữ liệu), Current Mapper (cửa sổ bản đồ hiện 
hành), New Mapper (cửa sổ bản đồ mới) hay No View (không hiện dữ liệu). 
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Click Ok xuất hiện cửa sổ dBASE Dbf Information giữ mặc định trong khung 
File Characer Set: Window Us & W Europe (“ANSI”) 

 
Click OK, sẽ xuất hiện cửa sổ dữ liệu (Browser) của tập tin *.dbf  tương 

ứng… để tạo tập tin dạng *.tab tương ứng trong cùng thư mục của tập tin *.dbf 
được chọn. 

o Cơ sở dữ liệu dạng *.xls (Excel version 4.0, version 5.0 hoặc cao hơn) 
Thông thường dữ liệu trong excel lấy hàng trên cùng làm tên cột (vùng) vì 

vậy trong cửa sổ Excel Information chúng ta khai báo như sau: 
Trong khu Name Frame chọn Other sẽ xuất hiện khung ghi giới hạn của 

dữ liệu. Mapinfo sẽ cho thấy toàn vùng dữ liệu từ hàng cột nào tới hàng cột nào. 
Chúng ta sẽ thay đổi là tăng thêm một hàng đối vị trí đầu tiên của vùng dữ liệu. 
Ví dụ: thay vì là A1:P18 thì đổi lại A2:P18 Click OK, đánh dấu vào mục Use 
Row Above Selected Range For Column Titles chúng ta xác định hàng đầu tiên 
là tên các cột) rồi click OK. Cửa sổ Browser xuất hiện với dữ liệu theo dạng 
hàng và cột của tập tin *.xls  mới được đưa vào. Mapinfo đã tạo ra tập tin dạng 
*.tab cùng tên với tập tin *.xls  (một lớp dữ liệu của Mapinfo) 

o Cơ sở dữ liệu dạng văn bản có dấu cách (dấu Tab hay dấu phẩy...) 
Nhập tên tâp tin dạng văn bản với List File Of Type là Deimited ASCII 

cửa sổ Delimited ASCII Information xuất hiện. Trong khung Delimited chọn 
Tab hay Other tuỳ theo dấu cách trong tập tin dạng văn bản, giữ mặc định trong 
khung File Character là Window US & W. Europe (“ANSII”) và đánh dấu 
vào mục Use First Line For Column Titles nếu hàng đầu tiên trong tập tin dạng 
văn bảng là tên cột 

o Tương tự cho tâp tin dạng văn bản *.wks (lotus 123) 
Như vậy, sau khi hoàn tất thủ tục khai báo, Mapinfo đã tạo tập tin dạng 

*.tab liên kết với một cơ sở dữ liệu theo các dạng trên để hình thành một lớp dữ 
liệu riêng trong Mapinfo. 
Lưu ý: trong các dạng dữ liệu trên, tốt nhất là nên chuyển thành dạng *.dbf trước 
khi chuyển vào Mapinfo vì Mapinfo chỉ thay đổi được cấu trúc của dạng cơ sở 
dữ liệu này. 
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3.3. Cập nhật và bổ sung dữ liệu 
3.3.1 Bổ sung số liệu thông kê 

 
Mỗi tính chất của mỗi đối tượng được bổ sung vào một vùng mới và tuỳ 

theo kiểu số liệu để khai báo thích hợp trong kiểu vùng. 
Có thể nhập dữ liệu trực tiếp trong Mapinfo. Vào Window > New  

Browser Window chọn lớp dữ liệu muốn bổ sung thêm, sẽ xuất hiện một cơ sở 
dữ liệu  (Browser) liệt kê dữ liêu theo hàng và cột, nhập dữ liệu vào các ô thích 
hợp. 

Để có thể sử dụng những phần mềm khác nhau như Exel hay Foxpro để 
nhập các số liệu này, ta phải lưu dữ liệu dưới dạng dBASE DBF với một tên 
khác. Vào file > Save Copy As, chọn lớp dữ liệu cần lưu; trong cửa sổ Save 
Copy Of Table As. Chọn save File As Type là dBASE DBF ta sẽ có một tập tin 
của lớp dữ liệu tương ứng có phần mở rộng là .dbf. Vào Excel hay Foxpro để 
mở tập tin này để cập nhật, lưu ý là không được thay đổi vị trí của các hàng, vì 
Mapinfo đã lưu thông tin về các đối tượng địa lý đồ hoạ theo thứ tự của các hàng 
3.3.2. Bổ sung dữ liệu do Mapinfo tính toán được 

Trong Mapinfo với các hàm và các phép toán chúng ta có thể xác lập các 
biểu thức tính toán tự động trên từng đối tượng (các hàng trong bảng). Biểu thức 
trong Mapinfo bao gồm tên vùng của lớp dữ liệu được mở. Trong đó obj là  một 
tên vùng đặc biệt chỉ đến đối tượng địa lý của các hàng trong bảng dữ liệu - các 
toán tử và các hàm. 

• Các toán tử trong Mapinfo bao gồm theo mức độ ưu tiên:  
(); ^; dấu âm (-); * v à / ; + và - ;  
contains, ccontains entire, within, entirely within, intersect (các toán tử dùng cho 
các đối tượng địa lý); 
=, <>, <, >, <=, >= (các toán tử so sánh) 
not ; and ; or (các toán tử luận lý) 
Các hàm của Mapinfo, có dạng tên hàm (tham số), bao gồm: 

• Các hàm toán học 
Abs.(số): trả về trị tuyệt đối của số 
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Cos(số - đơn vị: radian): trả về cosin của số 
Sin(số - đơn vị: radian): trả về sin của số 
Tan(số - đơn vị: radian): trả về tang của số 
Int(số): trả về phần nguyên của số 
Maximun (số 1, số 2): trả về số có giá trị lớn hơn 
Minimun (số 1, số 2): trả về số có giá trị nhỏ hơn 
Round. 

• Các hàm chuỗi kí tự 
Str$(biểu thức): trả về chuỗi kí tự tường ứng của biểu thức  
Chr$(số) ; trả về ký tự tương ứng trong theo mã ASCII 
Instr(số, chuỗi 1, chuỗi 2): tìm trong chuỗi 1 bắt đầu tại vị trí  số, nếu có 
chuỗi 2 thì trả về vị trí của chuỗi 2, nếu không có thì trả về số 0. để bắt đầu từ 
chuỗi số 1, số sẽ là 1 
Ltrim$(chuỗi): trả về chuỗi sau khi cắt bỏ các khoảng trắng phía trước 
Lcase$(chuỗi): trả về chuỗi với chữ thường 
Lef$9chuỗi, số): trả về chuỗi với số số ký tự bên trái 
Mid$(chuỗi, số 1, sô 2); trả về chuỗi bắt đầu từ vị trí số 1 và dài số 2 ký tự 
Proper$ (chuỗi): trả về chuỗi với ký tự đầu là hoa  
Right$(chuỗi): trả về chuỗi gồm số ký tự từ bên phải  
Rtrim$(chuỗi): trả về chuỗi sau  khi cắt hết khoảng trắng bênphải  
Ucase$(chuỗi): trả về chuỗi chữ hoa  
Len(chuỗi): trả về số ký tự của chuỗi. 
Val(chuỗi): trả về giá trị bắng số của chuỗi 

• Các hàm ngày tháng 
Curdate(): trả về tháng / ngày / năm của ngày hôm nay 
Day(tháng / ngày / năm): trả về ngày của tháng  tháng / ngày / năm 
Month(tháng / ngày / năm): trả về tháng của  tháng / ngày / năm 
Year(tháng / ngày / năm): trả về năm của tháng / ngày / năm 
Weekday(tháng / ngày / năm): trả về thứ tự của ngày trong tuần của  tháng / 
ngày / năm. chủ nhật có thứ tự là 1 

• Các hàm có liên quan tới các đối tượng địa lý 
Area(obj, “donvi”): trả về diện tích của đối tượng theo donvi 
Centroidx(obj): trả về trị số kinh độ của điểm trọng tâm của đối tượng 
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Centroidy(obj) trả về trị số vĩ độ của điểm trọng tâm của đối tượng 
Distance (x1, y1, x2, y2, ‘donvi’): trả về gía trị khoảng cách giữa hai điểm có 
toạ độ là (x1,y1) và (x2, y2) theo đơn vị đã ghi 
Objectlen (obj, “donvi”) ; trả về giá trị chiều dài của đối tươngh theo đơn vị 
đã ghi. chỉ cho đối tượng là đường hay đa giác 
Perimeter(obj, “donvi”):.trả vền giá trị chu vi của đối tượng theo đơn vị đã 
ghi. chỉ cho đối tưọng đa giác, elllips 

• Các hàm có kết quả là đối tượng địa lý: 
Buffer(obj, số_đoạn, rộng,: đơn vị”): trả về vùng đệm  của đối tượng “rộng” 
bao nhiêu “đơn vị” với quy cách vòng tròn chia làm ‘số đoạn’ đoạn 
Centroid(obj): trả về điểm trọng tâm của đối tượng 
Createcircle(x, y, r): trả về một vòng tròn với tâm có toạ độ (x, y) và bán kính 
r tính bằng radius 
Createline(x1, y1, x2, y2):.trả về đường thẳng nối liền hai điểm có toạ độ (x1, 
y1, x2, y2) 
Createpoint(x, y) ; trả về điểm có toạ độ (x, y) 

Ngoài ra mapinfo còn có một số từ khoá có thể dùng trong các biểu thức: 
any, all, in, và between…and. Ví dụ: 

- field_x = any (“TP.HCM”, “ĐN”, “KG”) 
- field_x in (“TP.HCM”, “ĐN”, “KG”) 
=> tất cả các đối tượng mà cột field_x có giá trị là “TPHCM” hay “ĐN” hay 
”Kg” 
- field_x <> all (“TP.HCM”, “ĐN”, “KG”) 
- field_x not in(“TP.HCM”, “ĐN”, “KG”) 
=> tất cả các đối tượng mà cột field_x có giá trị không là “TPHCM” hay 
“ĐN” hay ”Kg” 
- field_x beetween 5000 and 10000 
=> tất cả các đối tượng mà cột field_x có giá trị trong khoảng từ 5000 đến 
10000 

Đơn vị chiều dài:  mi (milies),  in(inches),  ft (feet),  yd(yard), km, m, cm, mm 
đơn vị tính diện tích: sq mi (squar miles), sq in (square inches), sq ft (suqre feet), 
sq yd (square yard), arce sq km (km2), sq m (m2), sq cm (cm2), sq mmm (mm2), 
hectare,… 
* Với update column:  chúng ta cập nhật hay bổ sung từng cột dữ liệu một 
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Vào tablbe > update column  cửa sổ update column xuất hiện với các mục như 
sau: 
- Table to Update   chọn lớp dữ liệu muốn cập nhật trong số các  lớp dữ liệu đã 
mở. 
- Get value from table:  lấy giá trị từ lớp dữ liệu nào? Có hai trường hợp: 
*  Từ lớp dữ liệu muốn cập nhật: 
- Column to update: chọn vùng muốn cập nhật 
- value:  nhập một biểu thức hợp lệ; thương sử dụng khung Assist để xây dựng 

biểu thức 
Ví dụ:  

Tính diện tích đối tượng địa lý (xã và thị trấn) của một xã nào đó chúng ta 
thêm cột ‘diện tích”vào Thuc_tap_xa.tab và sử dụng hàm area() 
Vào update column khai báo như sau: 
         Column to update; dientich 
         Value: area(obj, “hectare”) 

 
* Từ một lớp dữ liệu khác: 

Click khung Joint để xác định vùng tham chiếu liên kết giữ hai lớp dữ 
liệu. 
- Column to update: một vùng có sẵn hay một vùng mới (add new temporary 
column). 
- Calculate: cách tính toán (có thể là: value hay các biểu thức tổng hợp như 
average, count, minimum, maximumn, sum, weighted average (trung bình gia 
trọng), proportion sum (tổng số theo tỉ lệ), propotion average (trung bình theo tỉ 
lệ) và proportion weighted average (trung bình gia trọng theo tỉ lệ). 
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Ghi chú: các biểu thức Average, Count, Minimumn, Sum,Weighted 
Average có tham số là các giá trị của dữ liệu; các biểu thức tỷ lệ (proportion) thì 
xử lý các đối tượng địa lý. 
- of: thường là một cột hay một biểu thức hợp lệ 
Sau cùng; CLICK OK để tiến hành cập nhật. 
Ví dụ: 
* Calculate: Value 

Trước hết chúng ta mở hai lớp dữ liệu, lớp muốn bổ sung 
(thuc_tap_xa.tab).và lớp có số liệu (Du_lieu_xa_B.tab) sau đó nên thêm một cột 
với tên tương ứng (danso90) vào lớp dữ liệu sẽ được bổ sung (thuc_tap_xa.tab) 
bằng Table > Maintenance > Table tructure, xong vào Update columns khai 
báo như sau: 

 
Trong trường hợp này, hai lớp dữ liệu có số hàng như nhau vì vậy chúng 

ta có thể chọn khung Joint tên của cột dữ liệu giống nhau của hai lớp dữ liệu giữa 
chúng với nhau. Ví dụ:  tenxa hay maso 

 
* Calculate: Sum 

Trường hợp này chúng ta chọn tên cột liên kết giữa hai lớp dữ liệu trong 
cửa sổ Joint là Tenxa. Việc tính tổng số của dân số năm 1990 sẽ thực hiện cho 
các hàng có cùng giá trị trong cột Tenxa của lớp dữ liệu Du_lieu_xa B.tab, sau 
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đó gán trị số tính được này cho cột danso90 của lớp dữ liệu thuc_tap_ xa.tab ở 
hàng có giá trị của cột tenxa  tương ứng. 
 Mặc khác, chúng ta cũng có thể tính toán dữ liệu cho một cột (trường dữ 
liệu) là một tổng, hiệu, tích, thương… từ các các trường dự liệu khác nhau. 
 Để thực hiện điều này, chúng ta vào Table > Update columns. Sau đó 
khai báo giống như các bước trên. Riêng trong mục of  thì chọn Expression thay 
vì chọn các trường dữ liệu khác. 

 

 
Như vậy, giá trị trong cột TongDS là kết quả của cột 

DANSO80+ĐANSO90 – DANSO02. 
* Calculate: Proportion sum 

Lớp dữ liệu vùng chay_rung.tab định vị các vùng xảy ra cháy rừng trên 
địa bàn lâm trường. Tính xem diện tích cháy rừng theo từng đơn vị hành chánh 
xã là bao nhiêu?  

Chúng ta mở hai lớp dữ liệu Chay_rừng.tab và du_lieu_xa.tab (đã cập 
nhật số liệu diện tích) vào Update Column, chọn: 
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           - Table to Update: du_lieu_xa.tab 
           -  Column to Update: 
           - nếu đã tạo trước một column thì có thể cập nhật trong cột này 
           - nếu chưa tạo trước thì chọn: add new temporary column 
           - Get value from table:  chay_rung.tab 
Chọn joint: Intersect 
           - Calculate : Proportion Sum 

- of :DTchayR 

 
Như vậy, chúng ta có được diện tích rừng bị cháy theo từng xã. 

3.4. Chọn và kết hợp dữ liệu theo điều kiện 
3.4.1 Chọn các đối tượng theo điều kiện trong một lớp dữ liệu. 

Vào File > Open để mở lớp dữ liệu cơ sở. Sau đó vào Querry > Select, 
khai báo các mục trong cửa sổ select như sau: 
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Mục Select Records from Table:click vào khung này và chọn lớp dữ liệu 

tương ứng. 
Mục That Satisfy: nhập một biểu thức luận lý hợp lệ - thường click Assist 

để xây dựng và kiểm tra biểu thức này. 
Mục Store Results In Table: nhập tên cho lớp dữ liệu thoả mãn điều kiện 

trên. Có thể giữ mặc định là selection  muốn lưu lớp dữ liệu phải vào File > Save 
As để lưu vào thư mục và tên tập tin tuỳ chọn. 

Trong mục Sort Results By Column: click vào khung này chọn tên vùng 
muốn xếp theo thứ tự. Mặc định là None = không. 

Đánh dấu vào Browse Results để xem kết quả trong một cửa sổ dữ liệu 
mới. 

Với chức năg Select chúng ta xây dựng được một lớp dữ liệu mới thoã 
theo điều kiện đã lập ra. Lớp dữ liệu này thường có ít đối tượng (số hàng) hơn 
nhưng giữ nguyên cấu trúc dữ liệu (số cột). Dĩ nhiên chúng ta có thể thay đổi cấu 
trúc này theo ý muốn của chúng ta, nhưng có một chức năng để thực hiện trực 
tiếp điều này, đó là SQL Select. Ngoài ra còn thực hiện một số chức năng hữu 
ích khác. 

Sau khi mở lớp dữ liệu cơ sở, vào Querry > SQL Select cách khai báo 
các mục trong cửa sổ SQL Select  như sau: 
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Trước hết nên khai báo mục From Table di chuyển cursor vào khung này 

và click để nhập tên, lớp dữ liệu cơ sở, chúng ta có thể nhập trực tiếp từ bàn phím 
tên của lớp dữ liệu này nhưng nên click khung Table để chọn. Ở đây chọn 
Thuc_tap_xa.tab. 

Trong mục Select Column. Nếu chọn tất cả các cột thì giữ dấu * (mặc 
định) nếu chỉ chọn một số cột thì xoá dấu * rồi click  khung Column để chọn. 
Ngoài ra chúng ta còn có thể xây dựng các biểu thức tính toán và hình thành 
thêm các cột mới. Điều này có nghĩa lớp dữ liệu mới sẽ có số cột như cũ hay ít 
hơn và cũng có thể nhiều hơn. 

Để đặt tên cho cột mới của một biểu thức tính toán, chúng ta ghi tên cột 
trong dấu ngoặc kép ngay sau biểu thức. 

Ví dụ: DTchay / area(obj, “hectare”) “dientich” 
Trong mục Where Condition có thể để trống hay nhập một biểu thức 

luận lý hợp lệ. Trường hợp là một biểu thức luận lý thì chỉ những hàng phù hợp 
với biểu thức này mới xuất hiện trong lớp dữ liệu tạm thời (selection). 

Kế tiếp trong mục Groupp By Column click khung Column để chọn cột 
muốn tính gộp cho các giá trị giống nhau (subtotal). Trong cột đó mặc định là 
không chọn cột nào. 

Trong mục Order By Column, click khung Columns để chọn cột muốn 
sắp xếp theo thứ tự mặc định là không cột nào được chọn, và nếu có thì theo thứ 
tự tăng dần. Muốn sắp theo thứ tự giảm dần, chúng ta thêm desc vào sau tên cột 
đã chọn. 

Để xây dựng các biểu thức tính toán trong SQL Select, ngoài ra các thành 
phần thông thường là tên cột, hàm, và toán tử, Mapinfo còn có thêm các hàm 
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thống kê như: Avg (trung bình cộng), Sum (tổng), Min (giá trị tối thiểu, Max (giá 
trị cực đại), Wtavg (trung bình gia trọng) và Count (đếm số đối tượng tương 
ứng). Các hàm thống kê được liệt kê trong khung Aggregetes. 

Các lớp dữ liệu mới phát sinh từ hàm thống kê là lớp dữ liệu tổng hợp của 
một cột nào đó, chúng được lưu tạm trong các  Querry hay Selection. 

Trường hợp có xét Group By Columns số hàng sẽ là giá trị khác nhau 
của cột này. 

 
Ví dụ:  
Select Column: tenxa, count(*) “danso80”, sum(tenxa) “dientich” 
Group by Colmns: tenxa 
Order by Column: tenxa 

Kết quả là:  
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3.4.2 Kết hợp với một lớp dữ liệu khác 

Để kết hợp hai lớp dữ liệu với các thông tin khác nhau chúng ta cùng mở 
hai lớp dữ liệu này, sau đó vào Querry > SQL Select. Trong cửa sổ SQL Select 
chúng ta sẽ khai báo như sau: 

Mục From Table: Click khung Table và chọn các lớp dữ liệu để liên kết 
Sau khi chọn các lớp dữ liệu trong vùng Where Condition sẽ xuất hiện 

tên cột dữ liệu để liên kết hai lớp dữ liệu với nhau. 
Mục Select Column: dấu * là chọn tất cả các cột của hai lớp dữ liệu. 

Click khung Column và chọn các vùng muốn thể hiện trong một lớp dữ liệu mới. 
Có thể tạo cột mới với các biểu thức tính toán hay các hàm thống kê. 

Các mục khai báo như đã thảo luận ở phần 4.1 
Ví dụ: Lớp dữ liệu Thuc_tap_xa.TAB bao gồm các đối tượng địa lý là xã 

hay thị trấn, lớp dữ liệu Du_lieu_xa_B.TAB chứa các số liệu thống kê về rừng 
trồng của các xã theo thời gian. Hai lớp dữ liệu cùng có cột Tenxa và 
Trongnam1, nên có thể sử dụng một trong hai cột này để liên kết hai lớp dữ liệu. 
Mở hai lớp dữ liệu này vào Querry SQL Select sẽ khai áo trong cửa sổ SQL 
Select như sau: 

 
Kết quả là một lớp dữ liệu mới với tất cả các đối tượng địa lý và các cột số 

liệu về Rungnam1. Muốn sử dụng lớp dữ liệu này chúng ta phải lưu vào đĩa với  
File > Save As. 
   Trường hợp khai báo Group By Columns là cột vung thì lớp dữ liệu mới 
chỉ có 4 đối tượng ứng với 4 vùng là các đối tượng đầu tiên của mỗi vùng. 
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3.5. Tuỳ chọn nội dung cửa sổ dữ liệu  
Khi vào Windows  > New Browser Windows, chọn một lớp dữ liệu, cửa 

sổ dữ liệu của lớp dữ liệu đó sẽ xuất hiện với tất cả các cột và tên cột đúng như 
đã khai báo trong Table Structure. 

Để chỉ thể hiện trong cửa sổ này những cột theo ý muốn của chúng ta và 
tên các cột có thể viết lại cho rõ ràng (nhưng không thể ghi dấu tiếng việt) vào 
Browser > Pick Fields thí dụ, chọn xem dữ liệu của lớp Du_lieu_xa.TAB cưa sổ 
Pick fields xuất hiện như trang sau: 

 
Để không thể hiện một hay nhiều vùng (Field). Trong khung Column In 

Browser chọn các vùng này- sử dụng phím Shift hay Control khi chọn nhiều 
vùng sau đó Click vào khung Remove để loại chúng ra khỏi danh sách các vùng 
sẽ được thể hiện. 
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Để thay đổi tiêu đề một vùng chúng ta đánh dấu vùng đó trong khung 
Column In Browser sau đó nhập tên mới vào vùng Name trong khung Edit 
Browser Column.  Ví dụ, đổi tên cột vùng “Tenxa” thành “Ten_phuong” 

Ngoài ra chúng ta có thể thể hiện thêm các vùng mới bằng cách chọn 
Expression. Trong khung Fields In Table nhập biểu thức hợp lệ trong cửa sổ 
Expression, thí dụ, Trongdam1 / Rungtrong1 biểu thức này được thêm vào, sau 
đó sửa lại tiêu đề vùng (mục Tenxa trong khung Edit Browser Column là 
Mat_do như trong cửa sổ sau: 

 
Ghi Chú: Việc sửa đổi tên các tiêu đề vùng này không ảnh hưởng đến dữ liệu và 
không lưu được trong Workspace, chỉ có gí trị tạm thời khi cửa sổ dữ liệu này 
còn được mở, nếu được lưu trong Workpace thì các vùng được chọn để thể hiện 
vẫn còn tác dụng. 

><><><&><><>< 
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Chương 4 
PHÂN TÍCH KHÔNG GIAN 

 
Phân tích không gian là khả năng đặc biệt của các phần mền hệ thông tin 

địa lý. Chính khả năng này đã giúp chúng ta xây dựng những bản đồ quy hoạch 
hay phân tích mới dựa trên các bản đồ đã số hóa. 

MapInfo cung cấp một số chức năng như kết hợp, chia cắt, xoá một phần 
đối tượng bản đồ, tạo vùng đệm của một đối tượng hay tạo điểm chung của hai 
đối tượng. Các chức năng này được thực hiện cho các đối tượng trong cùng một 
lớp dữ liệu hay trên hai lớp dữ liệu khác nhau. Các đối tượng này thường phải 
xử lí được.  

Để cho đối tượng xử lí được, trước hết lớp dữ liệu của các đối tượng này 
phải có thuộc tính sửa đổi được (editable), sau đó chúng ta chọn đối tượng 
(select) bằng một trong các cách đã thảo luận, tiếp đến là vào Objects > Set 
Target hay bấm Ctrl-T, đối tượng sẽ được đánh dấu là xử lí được. 

4.1. Kết hợp các đối tượng địa lý 
Chức năng kết hợp (combine) không cần thiết phải chọn đối tượng xữ lý 

được, chúng ta chọn các đối tượng muốn kết hợp với nhau sau đó vào Objects > 
Combine. Cửa sổ Data Aggregation xuất hiện với các tham số sau: 

 
Trong cột Destination sẽ liệt kê tất cả tên cột của lớp dữ liệu. 
Trong cột Method, ta có thể chọn 1 trong 4 kiểu trong khung Aggregation 

Method bên dưới là: Blank (để trống), Sum (tổng giá trị của các đối tượng được 
chọn), Value (một giá trị bằng) hay Average (trung bình cộng  giá trị của các đối 
tượng được chọn) với Weight by (gia trọng theo cột) hay không. 
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Nếu chúng ta chọn No Data thì giá trị các cột trên là 0 hay Blank. 
Một đối tượng mới sẽ được hình thành với các tham số đã khai báo. 

4.2. Xóa phần đối tượng xử lý được nằm trong đối tượng chuẩn 

 
Sau khi xét một (hay nhiều) đối tượng xử lý được, chúng ta chọn một (hay 

nhiều) đối tượng làm chuẩn (bắt buộc là kiểu đa giác) mà chúng ta muốn xoá 
phần đối tượng làm chuẩn. Sau khi chọn xong, vào Objects > Erase. Trường hợp 
đối tượng xử lý được kiểu đa giác, sẽ xuất hiện cửa sổ Data Desaggregation 
tương tự như cửa sổ ở trên chỉ khác ở trong khung Desaggregation Method có 
Area Proportion có nghĩa là sẽ tính giá trị theo tỷ lệ diện tích của đối tượng mới 
so với đối tượng cũ.  
4.3. Xoá phần đối tượng xử lý nằm bên ngoài đối tượng chuẩn 

Ngược với trường hợp trên,để xóa phần đối tượng nằm bên ngoài đối 
tượng chuẩn (cũng bắc buộc là kiểu đa giác), chúng ta sau khi xét Object > Set 
Target và chọn một (hay nhiều) đối tượng chuẩn ta vào Object > Erase Outside 
và khai báo thích hợp trong cửa sổ Data Desaggregation. Kết quả như sau: 

 
4.4. Cắt chia đối tượng được xử lý theo ranh giới của các đối tượng 
chuẩn 

Trường hợp này sẽ chia cắt đối tượng được xử lý thành 2 (hay nhiều) 
vùng: các vùng có đối tượng chuẩn và vùng không có đối tượng chuẩn. Tương tự 
như trên, nhưng sau khi chọn đối tượng được xử lý và đối tượng chuẩn, chúng ta 
vào Option > Split. 

ThS. Nguyễn Đức Bình – ThS. Hoàng Hữu Cải – KS. Nguyễn Quốc Bình 
Bộ môn LNXH – ĐHNL Tp. HCM, Tháng 3/2003 
 

32



Xây dựng bản đồ số hoá với MapInfo 6.0 
 

 
Ngoài 3 cách xử lý chính như trên, MapInfo còn có một số chức năng khác: 

• Tạo vùng đệm bao quanh một (hay nhiều) đối tượng: 
Đối tượng có thể là điểm, đường hay đa giác. Vùng đệm là một đối tượng mới 
trong lớp dữ liệu chứa đối tượng chuẩn, dĩ nhiên lớp dữ liệu này có thuộc tính 
sửa đổi được (edit table). 

Trước hết chọn các đối tượng muốn tạo vùng đệm, sau đó vào Object > 
Buffer; cửa sổ Buffer Objects xuất hiện như sau: 

 
o Value: giá trị bề rộng vùng đệm, phụ thuộc vào mục Units (đơn vị) ở 

dưới. 
o From Column: có thể khai báo giá trị bề rộng là giá trị của một cột 

nào đó của lớp dữ liệu. Sử dụng trong trường hợp giá trị của Value 
thay đổi theo từng đối tượng. 

o Units: có thể là km, m, cm, mm,... 
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o Smoothness (sự phẳng liền): nhập số đoạn tạo nên một vòng tròn. Số 
đoạn càng nhiều thì đường ranh của vòng đệm càng phẳng liền (ít gảy 
khúc). Số đoạn mặc định là 12, nhưng có thể tăng lên 20 hoặc 24. 

o Nếu chọn One buffer for all objects: tạo ra vùng đệm chung. 
o Nếu chọn One buffer for each object: tạo ra 1 vùng đệm cho mỗi đối 

tượng  (có thể nhiều vùng đệm được tạo ra). 

• Kết hợp các đối tượng cùng giá trị trong một cột: 
Chức năng này kết hợp các đối tượng có cùng một giá trị để hình thành 

một đối tượng mới với kích thước lớn hơn với các số liệu được kết hợp lại; có thể 
xem chức năng này là ngược với chức năng chia cắt (Slit) và sử dụng chức năng 
này để kết hợp những phần tử đối tượng đã bị chia cắt. 

Vào Table > Combine Objects Using Column và khai báo cột có các đối 
tượng có cùng giá trị muốn kết hợp lại trong mục Group Objects By Column 
trong cửa sổ Combine Objects Using Column. 

 
Nếu chúng ta chọn lớp dữ liệu để lưu kết quả là cùng lớp dữ liệu được xử 

lý thì kết quả (các đối tượng mới) sẽ được ghi tiếp thêm ở phía sau trong lớp dữ 
liệu này. 

• Thể hiện vị trí địa lý của một địa chỉ (Geocoding). 
MapInfo có khả năng thể hiện vị trí của một địa chỉ (số nhà tên đường) 

của một đối tượng khi chúng ta có dữ liệu về hệ thống đường và số nhà tương 
ứng cho từng đoạn một, và mỗi đoạn đường này là một đối tượng địa lý trong 
một lớp dữ liệu riêng. 
Ví dụ: 

Chúng ta muốn thể hiện vị trí các Chòi Canh trên bản đồ hệ thống đường 
(duong.tab) theo địa chỉ các Chòi Canh này (diachi.tab). 
Vào Table > Geocode, khai báo trong cửa sổ Geocode như sau: 
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Click khung Symbol để đặt dạng, màu và kích cở đối tượng. 

Thường chúng ta chọn Mode: Automatic (kiểm tra chính xác các tên 
đường trong hai lớp dữ liệu) cho lần I, sau đó chọn Mode Interactive để xác nhận 
những địa chỉ liên hệ được trong lần I. Khi xử lý với chức năng Geocode lần II, 
chúng ta vẫn giữ nguyên các khai báo trên, chỉ thay đổi tham số của Mode. 

Sau khi xử lý với Geocode, lớp dữ liệu dia_chi.tab có các đối tượng  điểm 
tại vị trí tương ứng, thể hiện được trong cửa sổ bản đồ. 

• Tạo điểm từ số liệu về tọa độ địa lý: 
Từ số liệu về tọa độ địa lý (kinh độ và vĩ độ) của các điểm, MapInfo có 

thể thể các điểm này trên bản đồ với vị trí tương ứng. Sau khi mở lớp dữ liệu có 
số liệu về tọa độ địa lý (ví dụ kinh độ và vĩ độ), vào Table > Create Points, cửa 
sổ Create Points xuất hiện và được khai báo như sau: 

 
Vào Projection để khai báo phép chiếu phù hợp với số liệu về tọa độ. 

Thường chọn là Longitude/ Latitide cho cả Categoty và Cetegory Members trong 
cửa sổ Choose Projection nếu số liệu là từ các hàm của MapInfo. 
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Click vào khung Using Symbol để chọn dạng, màu, kích cỡ  của các đối 
tượng điểm sẽ được tạo ra này. 

Sau khi Click OK để thực hiện, MapInfo đã tạo thêm các đối tượng mới 
trong cửa sổ bản đồ của lớp dữ liệu hay tạo mới một bản đồ của lớp dữ liệu chưa 
có đối tượng địa lý. 

• Định vị dữ liệu trên bản đồ: 
Chức năng này (Query > Find) dùng  để định vị từng đối tượng của lớp 

dữ liệu trong cửa sổ bản đồ. Khi vào Query > Find, sẽ xuất hiện cửa sổ Find gần 
giống như cửa sổ Geocode và chúng ta khai báo như sau: 

 
For Objects in Column: chỉ chọn được cột đã lập chỉ mục (index). 
Click khung Mark with Symbol để đặt dạng, màu và kích cở đối tượng. 
Click vào OK, sẽ xuất hiện tiếp cửa sổ Find thứ nhì với 1 khung để nhập 

giá trị của cột chỉ mục đích sử dụng. Trường hợp không nhớ giá trị này, chúng ta 
bấm phím <Enter> để thực hiện bảng danh sách các giá trị của cột chỉ mục và 
chúng ta di chuyển cursor để chọn giá trị mong muốn, chọn xong click OK. Đối 
tượng tương ứng được đánh dấu trong cửa sổ bản đồ và ghi trên lớp dữ liệu tạm 
thời Cosmetic Layer. 

Nếu chúng ta muốn đánh dấu tiếp, chúng ta lại vào Query > Find, nhưng 
từ lần thứ hai sẽ xuất hiện ngay cửa sổ Find thứ nhì, không xuất hiện lại cửa sổ 
Find ban đầu. Trường hợp chúng ta muốn trở lại cửa sổ Find I để khai báo một 
cột khác chẳng hạn, chúng ta click vào khung Respecify. 

• Phân vùng lãnh thổ khảo sát (Redistrict). 
Đây là một qúa trình tập hợp các đối tượng địa lý và sau đó tính toán tổng 

giá trị của các cột dữ liệu cho mỗi tập hợp được hình thành. Một ưu điểm của quá 
trình này là các giá trị của vùng tự điều chỉnh khi chúng ta thêm hay bớt một hay 
nhiều thành phần của chúng. Điều này giúp chúng ta phân vùng một cách linh 
động đáp ứng với một tiêu chuẩn nào đó. 
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Việc phân vùng này không tạo nên một đối tượng địa lý mới hay làm thay 
đổi kiểu của chúng, nó chỉ là công cụ tạo nhóm năng động nhằm thể hiện các đối 
tượng gom nhóm trên bản đồ cùng với những thông tin liên quan. Chúng ta có 
thể phân vùng cho những đối tượng kiểu vùng, kiểu đường hay kiểu điểm, nhưng 
số vùng được thành không quá 300. 

Qúa  trình sắp xếp đối tượng vào các vùng làm thay đổi giá trị của các đối 
tượng trong cột dữ liệu được chọn, vì vậy để không làm ảnh hưởng đến các số 
liệu đã có chúng ta nên tạo một cột mới giành cho việc phân vùng này. 

Sau khi mở lớp dữ liệu, chúng ta vào Window > New Redistrict 
Window. Cửa sổ New Redistrict Window, cách khai báo các tham số như sau: 

 
Source Table: nhập tên lớp dữ liệu nguồn – vd: Dia_chi. 
District Field: nhập tên cột làm cơ sơ phân vùng – nên tạo riêng một cột 

với các giá trị kiểu số để sử dụng cho từng mục đích phân vùng vì trong quá trình 
phân vùng giá trị của các đối tượng trong cột này sẽ bị thay đổi. Giả sử chúng ta 
phân thành 3 vùng có diện tích xấp xĩ nhau, chúng ta thêm cột PV_DT kiểu 
Small Integer và cập nhập giá trị theo cột STT/ID. Chúng ta chọn cột PV_DS làm 
cơ sở để phân vùng. 

Trong khung Fields to Browse mặc định sẽ liệt kê tên cột đã khai trong 
District Field, Count (số đếm các đối tượng trong một vùng), Fill (tô màu - 
trường hợp đối tượng kiểu đa giác). 

Trong khung Available Fields sẽ liệt kê các tham số tổng hợp như tổng 
hợp hay giá trị phần trăm của các cột dữ liệu. Chúng ta sử dụng khung Add hay 
Remove để thêm hay bớt các cột dữ liệu tổng hợp muốn thể hiện. 

Khung Up và Down để sắp xếp thứ tự các cột sẽ thể hiện lên trong cửa sổ 
dữ liệu. 

Sau khi đã sắp xếp các cột, click OK, sẽ xuất hiện cửa sổ dữ liệu phân 
vùng (district browser) và các đối tượng trong cửa sổ bản đồ được tô màu (nếu có 
cột Fill - kiểu đa giác – hay Symbol - kiểu điểm - hay Line - kiểu đường). Khi 
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hoạt động với cửa sổ dữ liệu phân vùng, trên menu sẽ có thêm mục Redistrict. 
Trong cửa sổ Main hai biểu tượng Set Target District và Assign Selected 
Objects trở nên hoạt động, đây là hai thao tác thường dùng trong quá trình sắp 
xếp các đối tượng vào các vùng khác nhau. 

Để chuyển một đối tượng địa lý (nguồn đối tượng –A) vào vùng của một 
đối tượng khác (đối tượng đích –B), trước hết chúng ta xét đối tượng B làm đối 
tượng đích bằng cách chọn (select) đối tượng này rồi click vào biểu tượng Set 
Target District; sau đó chọn (select) đối tượng A và click vào biểu tượng Assign 
Selected Objects (có nghĩa chuyển đối tượng được chọn-A- vào vùng đích) các 
số liệu trong các cột trong cửa sổ dữ liệu phân vùng được tự động tính toán lại 
phù hợp với số đối tượng mới của vùng. 

 
><><><><>< 
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Chương 5 
XÂY DỰNG VÀ KẾT XUẤT BẢN ĐỒ 

 
Khi chúng có những lớp dữ liệu riêng biệt về một khu vực lãnh thổ, chúng 

ta có thể xây dựng các bản đồ chuyên đề khác nhau. Xây dựng bản đồ trên máy 
tính là kết hợp các dữ liêu đã được số hoá, sắp xếp thứ tự, ghi chú giải,... cũng 
như sắp xếp vị trí của chúng để có thể in ra giấy. Chúng ta sẽ sử dụng các chức 
năng trong mục Map trên menu chính. 

Trước hết vào File> Open Table, chọn mở các lớp dữ liệu cần thiết cho 
bản đồ dự định xây dựng. Dĩ nhiên các dữ liệu này cùng liên quan đến một khu 
vực địa lý và cùng hiện trên một cửa sổ bản đồ (Map Window). 

5.1. Sắp xếp thứ tự các lớp dữ liệu 
Chức năng này được thực hiện trong cửa sổ Layer Control (vào 

Map>Layer control hay click biểu tượng tương ứng) khi đang làm việc trên một 
cửa sổ bản đồ. 

Thông thường tất cả các lớp dữ liệu đã được mở đều xuất hiện trong vùng 
Layer trên cửa sổ Layer Conltrol, nhưng đôi khi vì tỉ lệ vùng nhìn lớn nên có 
thể nằm ngoài giới hạn của một lớp dữ liệu nào đó nên lớp dữ liệu này không 
hiện diện trong cửa sổ bản đồ hoạt động. Để thêm một lớp dữ liệu đã mở vào một 
cửa sổ bản đồ click khung Add trong cửa sổ Layer Control, chọn trong cửa sổ 
Add Layer các lớp dữ liệu muốn thêm và click vào khung Add. 

Để thay đổi thứ tự các lớp dữ liệu, chọn từng lớp dữ liệu sử dụng khung 
Up hay Down để đưa lớp dữ liệu lên hoặc xuống. 

5.2. Thay đổi cách thể hiện của đối tượng 
Thường áp dụng cho những dữ liệu “phụ” của bản đồ (đối với lớp dữ liệu 

chuyên đề -chính- sẽ trình bày sau) với khung Display trong cửa sổ Layer 
Control. Chức năng này nhằm gán tạm thời các thuộc tính về thể hiện cho các 
đối tượng địa lý của một lớp dữ liệu. Chọn lớp dữ liệu muốn thay đổi thuộc tính 
thể hiện, rồi click khung Display, cửa sổ Display options của lớp dữ liệu được 
chọn xuất hiện như sau: 
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Khung Display Mode: Xuất hiện đủ các kiểu đối tượng của một lớp dữ 

liệu (kiểu điểm, đường, vùng hay văn bản). Muốn gán thuộc tính để thể hiện tạm 
thời cho một trong (hay tất cả) các kiểu, chúng ta phải click vào ô trống đằng 
trước chữ Style Override. Sau đó chúng ta click vào từng kiểu đối tượng. 

Kiểu điểm: các khung trong cửa sổ Symbol Style cho phép chúng ta chọn 
dấu hiệu trong lớp phông chữ, kích cỡ và màu sắc. Chúng ta còn có thể xét độ 
nghiêng (góc quay) cũng như một số khác như khung viền,bóng nổi,... 

Kiểu đường: chúng ta khai báo trong Line Style để chọn các thuộc tính 
như kiểu (liền nét, đứt đoạn, chấm gạch,...), màu sắc và độ rộng. 

Kiểu vùng: với kiểu vùng này chúng ta có thể cài đặt kiểu tô (hoa văn và 
mầu nền) và kiểu đường bao quanh (liền nét, ứt đoạn,... màu sắc và độ rộng). 

Kiểu văn bản: chúng ta xét phông chữ, cơ sở và mầu sắc, ngoài ra còn xét 
dạng nền của văn bản là không, nền từng chữ hay nền chung cho đoạn văn bản 
cùng với màu sắc của nền. 

Khung Zoom Layering để xét cho lớp dữ liệu được thể hiện trên cửa sổ 
bản đồ khi cửa sổ bản đồ có một mức độ phóng đại nào đó do chúng ta xác định. 

Trường hợp chúng ta muốn lớp dữ liệu đang xét luôn được thể hiện trong 
cửa sổ bản đồ thì chúng ta sẽ mặc định. Ngược lai,chúng ta click vào ô trống 
đằng trước dòng chữ Display with Zoom range và chọn độ zoom tối thiểu và tối 
đa trong 2 khung bên dưới. 

Sau khi cài Zoom Layering, nếu mức độ zoom của bản đồ cho phép thể 
hiện lớp dữ liệu thì trong cửa sổ Layer Control lớp dữ liệu được đánh dấu màu 
đen, ngược lại nếu mức dộ zoom ngoài giới hạn thể hiện của một lớp dữ liệu đã 
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được mở thì lớp dữ liệu này được đánh dấu màu đỏ trong cột thuộc tính nhìn thấy 
được.  

Các khai báo khác là Show Line Direction (dùng cho kiểu đường), Show 
Nodes (dùng cho kiểu đường và vùng), Show Centroids (dùng cho kiểu vùng). 

5.3. Ghi chú trên bản đồ 
        Chúng ta có thể ghi văn bản một cách tự do trong cửa sổ bản đồ với phông, 
cở, màu và độ nghiêng của chúng. Tuy vậy để có thể ghi chú thống nhất cho các 
đối tượng của lớp dữ liệu, MapInfo cho phép chúng ta định dạng thích hợp cho 
mỗi lớp dữ liệu. Để định dạng các ghi chú này chúng ta click vào khung Label 
trong cửa sổ Layer Control.      

 
        Trước hết chúng ta xét nội dung của ghi chú trong khung Label with. 
Chúng ta có thể chọn giá trị các cột của lớp dữ liệu hoặc là một biểu thức dạng 
chuỗi.  
        Trong khung Visibility, chúng ta có thể chọn:  

- On: cho phép luôn nhìn thấy. 
- Off: không cho phép nhìn thấy. 
- Display with range: cho phép nhìn thấy trong khoảng phóng đại 

được xét bởi Min. Zoom và Max. Zoom ở bên dưới. 
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Cũng trong khung này chúng ta xét cho phép các ghi chú này được chồng 
nhau (Overlay) và được lặp lại (Duplicate) hay không cũng như số ghi chú tối đa 
cho các đối tượng của lớp dữ liệu (xét từ trên xuống, nếu muốn ghi chú được cho 
tất cả các đối tượng thì bỏ trống ô Maximun Labels. 

Kế tiếp trong khung Styles chúng ta có thể chọn kiểu dạng của văn bản 
(phông, cở, và màu chữ). Đối với Label Lines (đường nối từ trung tâm của đối 
tượng đến ghi chú), chúng ta có thể chọn None (không), Line (chỉ có đường nối) 
hay Arrow (đường nối có mủi tên). Việc định dạng kiểu đường cùng với màu sắc 
và độ rộng được thực hiện bằng cách click vào khung định dạng. 

Trong khung Position, mục Anchor Point dành để chọn vị trí của ghi chú 
đối với trọng tâm của kiểu vùng và mục Rotate Label with Line (quay ghi chú 
theo chiều của đoạn được chọn). Mục Label Offset 2 Point cho biết trị số về 
khoảng cách giữa ghi chú và điểm neo (anchor point), chúng ta có thể thay đổi 
trị số này nếu thấy cần. 

Lưu ý rằng các ghi chú này chỉ hiện diện trong Workspace nếu chúng ta 
không ghi chúng thành một tập tin riêng, có nghĩa chúng không làm thay đổi lớp 
dữ liệu. Chúng ta có thể xoá từng ghi chú bằng cách chọn chúng (Select) rồi bấm 
Delete, nhưng để xoá toàn bộ ghi chú chúng ta vào Map > Clear Custom Labels. 
Ngược lại, để ghi lưu các ghi chú này thành một lớp dữ liệu dạng văn bản, chúng 
ta trước hết Copy chúng vào Cosmetic Layer sau đó vào Map > Save Cosmetic 
Layer và nhập tên một lớp dữ liệu mới. 

Bây giờ chúng ta sẽ chuẩn bị cho chủ đề chính của bản đồ, dĩ nhiên để có 
thể xây dựng được một bản đồ chủ đề chúng ta phải có lớp dữ liệu tương ứng mà 
chúng ta muốn thể hiện trên bản đồ. Đây là lớp bản đồ mà chúng ta sẽ tô màu nên 
vị trí của lớp bản đồ này thường nằm dưới cùng hay không che khuất các lớp bản 
đồ khác nằm dưới nó. 

5.4. Xây dựng bản đồ chuyên đề 
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Xây dựng bản đồ chuyên đề là để thể hiện bản đồ theo một mục đích sử 
dụng khác nhau từ bản đồ số hoá.  

Ví dụ, chúng ta thể hiện bản đồ mô tả hiện trạng sử dụng tài nguyên rừng 
thông qua màu sắc, đồ thị,.. thì chúc ta thực hiện như sau:  

Chọn menu Map > Create Thematic Map sẽ xuất hiện họp thọai Create 
Thematic Map – Step 1 of 3. Trong đó: 

• Individual. 
Chọn khung Individual và click vào Next, sẽ xuất hiện cửa sổ Create 

Thematic Map – Step 2 of 3 để chúng ta chọn tên lớp (Table) và cột (Field) dữ 
liệu muốn xây dựng thành bản đồ. 

 
Tùy theo số trường hợp khác nhau có thể thể hiện được trên bàn đồ mà 

chúng ta thường phân cấp đối tượng cho phù hợp, và việc phân cấp này thường 
được sắp xếp riêng trong một cột mang ý nghĩa mã số, có nghĩa số đối tượng 
của mỗi cấp thường khác nhau. Với một lớp dữ liệu chúng ta có thể thực hiện 
việc phân cấp nhiều lần (tạo nhiều cột ghi mã số) tùy theo cách khai thác dữ liệu. 
Chúng ta có thể không xét những đối tượng có giá trị của cột đã chọn là 0 hay để 
trống bằng cách đánh dấu vào ô trống phía trước dòng Ignore Zeroes or Blanks. 
Sau khi chọn cột dữ liệu mà MapInfo sẽ phân thành các cấp khác nhau tuỳ theo 
giá trị của cột, click Next.  
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Cửa sổ Create Thematic Map – Step 3 of 3 xuất hiện với kết quả sơ bộ 

của việc thể hiện các cấp đối tượng được nhìn thấy trong khung Preview và 
chúng ta có thể thay đổi về dạng thể thực hiện (Style) cũng như các chú giải 
(Legend) bằng cách click vào ô có các chữ này trong khung Customize. 
MapInfo cho phép chúng ta thay đổi cách sắp thú tự các cấp tùy theo giá trị của 
cột được chọn là tăng (Ascending) hay giảm (Descending) dần. 

Để thay về dạng thức, chúng ta click vào khung Styles, cửa sổ Customize 
Individual Style xuất hiện và tùy theo kiểu của các đối tượng là đa giác, đường 
hay điểm mà trong khung Preview cũng như trong khung Style sẽ được thể hiện 
tương ứng. Ứng với mỗi cấp được liệt kê trong khung Individual Value chúng ta 
có thể chọn dạng thức tùy ý bằng cách click vào khung Style. 
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Để thay đổi nội dung lời chú giải, click vào khung Legend, cửa sổ 

Cuctomize Legend xuất hiện các mục sau: 

 
Trước hết là đề tựa của chú giải chúng ta có thể xét phông, cở và màu sắc 

của tựa đề trong 2 mục Tittle (tựa chính) và Subtittle (tựa phụ). Trong nội dung 
chú giải cho các cấp (Range Labels), MapInfo trước hết cho phép chúng ta định 
dạng cho kiểu văn bản, đồng thời sửa đổi nội dung, mặc định là giá trị của các 
cấp. Khai báo và sửa đổi xong, click OK để xác nhận. Nếu muốn chọn các khai 
báo này là mặc định (để dùng thống nhất cho các lần sau) chúng ta click vào 
khung Save As (trong mục template) trước khi click OK. 
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Sau khi click OK trong cửa sổ Create Thematic Map – Step 3 of 3, lớp 
bản đồ chuyên đề trong cửa sổ bản đồ sẽ được thể hiện như chúng ta đã sắp đặt 
trong quá trình xây dựng vừa xong, cùng với sự xuất hiện của sửa sổ Legend 
(chú giải). 

• Ranges (phân hạng) 
Nếu chúng ta chọn khung Ranges và click Next, cửa sổ Create Theamatic 

Map – Step 2 of 3 xuất hiện cũng để chúng ta khai báo tên và cột dữ liệu. Sau đó 
trong cửa sổ Create Thematic Map – Step 3 of 3, sẽ xuất hiện thêm ô Ranges 
trong khung Customize. Để thay đổi số cấp cũng như xét lại giới hạn của các cấp 
chúng ta click vào Ranges. 

Trong cửa sổ Customize Ranges, chúng ta khai báo trước hết mục Method 
(phương pháp). 

 
Thường chúng ta chọn phương pháp Custom để tùy tiện khai báo các tham 

số liên quan. Chúng ta sẽ khai báo tiếp về số cấp trong mục # of Ranges, và để 
thay đổi giới hạn của mỗi cấp chúng ta sẽ khai báo lại trong khung Custom 
Ranges, khi các trị số này thay đổi thí giá trị tương ứng trong khung liệt kê tỷ lệ 
với số đối tượng của mỗi cấp. Chúng ta có thể khai báo lại từ đầu kết quả đạt 
được theo dự kiến. Sau cùng click OK để xác nhận. 

Trong khung Preview của cửa sổ Create Thematic Map – Step 3 of 3 
chúng ta thấy màu các cấp thay đổi theo độ đậm nhạt dần, và chúng ta có thể thay 
đổi chúng cũng như các chú giải như đã thảo luận ở trên. 

• Graduated và Dot Density (độ lớn của dấu hiệu hay độ dày của điểm):  
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Chọn khung Graduate hoặc Dot Density trong cửa sổ Create Thematic 
Map – Step 1 of 3 và click Next, cửa sổ Create Thematic Map – Step 2 of 3 
xuất hiện để chúng ta chọn tên lớp và cột dữ liệu. Tương tự như với Ranges, 
nhưng trong khung Cuctomize của cửa sổ Create Thematic Map – Step 3 0f 3 
ô Setting thay cho ô Ranges và khung Styles không hoạt động. 

Trường hợp chọn Graduated, khi click ô Settings sẽ xuất hiện cửa sổ 
Customize Graduated Symbols với các mục: 

 
- Symbol: để xét hình dạng, kích cở và màu sắc của dấu hiệu thể hiện. 
- At Value: nhập giá trị tương đương với độ lớn của dấu hiệu đã chọn. 
- Trong khung Options, sẽ cho phép chúng ta xét dấu hiệu cho các giá 

trị âm cũng như cách thức MapInfo thể hiện sự biến thiên của các 
dấu hiệu tùy theo giá trị của cột dữ liệu là Square Root, Constant 
hay Log. MapInfo khuyến cáo nên chọn Square Root nó thể hiện tỉ 
lệ biến đổi vừa phải, theo diện tích của dấu hiệu. 

             Trường hợp chọn Dot Density, sau khi click ô Settings, xuất hiện cửa sổ 
Customize Dot, Density Settings và chúng ta sẽ khai trước hết mục Each dot 
Present....Units là giá trị tương ứng của cột dữ liệu ứng với 1 điểm thể hiện. Kế 
tiếp là chúng ta xét kích cở của các điểm lớn hay nhỏ (Large hay Smalls). 
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• Bar Charts hay Pie Charts (biểu đồ cột hay biểu đồ bánh):  
Trái với 4 khung đã thảo luận chỉ khảo sát trên một cột dữ liệu, 2 khung này 

nhằm thể hiện phối hợp giá trị của nhiều cột dữ liệu. 
Khi chọn Bar Charts hay Pie Charts rồi click Next, trong cửa sổ Create 

Thematic Map – Step 2 of 3 chúng ta sẽ khai báo trước hết tên lớp dữ liệu trong  
mục Table. Sau đó chúng ta sẽ chọn các cột dữ liệu sẽ được thể hiện trong biểu 
đồ, có thể chọn cả một biểu thức hợp lệ để tính toán giá trị của các đối tượng 
trong các cột tương ứng. 

 
Trong cửa sổ Create Thematic Map – Step 3 of 3, MapInfo cho phép 

chúng ta chọn kích cở và màu sắc thể hiện các giá trị khi chúng ta click Styles 
trong khung Customize. 

Trường hợp Bar Charts, trong cửa sổ Customize Bar Styles chúng ta chọn 
quy cách của dấu hiệu (Brush) cho các cột, chủ yếu là xét màu. Chúng ta sẽ chọn 
tiếp cách thể hiện là chồng nhau (Stacked) hay xếp kế nhau (Mutiple Bars) với 
thuộc tính phụ thể hiện tỉ lệ các giá trị là Graduated Stack đối với Stacked và 
Independent Scales đối với Mutiple Bars. Chúng ta xét tiếp theo kích thước và 
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tỷ lệ tương ứng của các thanh thể hiện. Chúng ta có thể vào Options để xét thêm 
một số thuộc tính khác như vị trí thể hiện so với trọng tâm của đối tượng,... 

 
Tương tự đối với trường hợp Pie Charts.  

Sau khi đã hình thành bản đồ chuyên đề chúng ta có thể sửa đổi các tham 
số đã chọn bằng cách vào Map > Modify Thematic Map hay nhấn đúp (Double 
click) trong cửa sổ Legend để xuất hiện cửa sổ Modify Thematic Map (tương 
tự như cửa sổ Create Thematic Map – Step 3 of 3). 

Một khi đã xây dựng một bản đồ chuyên đề của một lớp dữ liệu, lưu ý là 
từ một lớp dữ liệu chúng ta có thể xây dựng nhiều bàn đồ chuyên đề, trong 
cửa sổ Layer Control sẽ xuất hiện thêm lớp bản đồ này; khi chúng ta chọn lớp 
bản đổ này trong cửa sổ Layer Control khung Thematic trở nên hoạt động, 
click vào khung này sẽ xuất hiện cửa sổ Modify Thematic Map, chúng ta có thể 
xoá chúng đi bằng cách chọn lớp bản đổ muốn xoá và click Remove. 

5.5. Định lưới tọa độ địa lý và tỷ lệ bản đồ 
MapInfo ngoài chương trình chính còn một số chương trình phụ kèm theo 

để thực hiện một số chức năng riêng, trong đó có việc định lưới tọa độ và chọn tỷ 
lệ bản đồ. 

Để chạy các chương trình phụ này chúng ta vào File > Run MapBasic 
Program, chúng ta sẽ chọn trong cửa sổ Run MapBasic Program tập tin 
Gridmakr.mbx và Scalebar.mbx trong thư mục phụ Tools của thư mục chương 
trình MapInfo. Một khi chọn chạy một chương trình phụ này, trên thanh menu 
chính xuất hiện thư mục Tools. 
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• Định lưới toạ độ địa lý (Gridmakr.mbx) 
Vào Tool > Grid Maker > Create Grid, chúng ta khai báo trong cửa sổ 

Create Long/Lat Grid như sau: 

 
- Kiểu (Object style): nên chọn kiểu đường để có thể nhìn xuyên qua. 
- Khoảng cách giữa các đường: mặc định là 1 độ, nhưng tùy theo quy mô để 

xét trị số này. Có thể chọn là 15’ (phút) (= 0.25 hệ thập phân) khi xét ở cấp 
tỉnh, 10’ (= 0,166666) ở cấp huyện và 5’ (= 0,083333) ở cấp xã. Đối với 
đơn vị sử dụng là meters thì thường chọn 10000m cho cấp tỉnh, 1000 m cho 
cấp huyện, 500 m cho cấp xã (các con số này chỉ là tương đối vì còn tuỳ 
thuộc vào tỷ lệ bản đồ được chọn. 

- Kế tiếp là chọn vùng (Extents). Nên tham chiếu đến phạm vi kinh độ và vĩ 
độ của vùng theo bản đồ địa hình để khai báo trong trường hợp này.   

Sau khi click vào OK, MapInfo yêu cầu chúng ta nhập tên cho lớp dữ liệu 
về lưới toạ độ này. Đây sẽ là một lớp bản đồ với các đối tượng đường hay vùng 
nên chúng ta có thể sửa đổi cho phù hợp với yêu cầu của chúng ta.                  

• Tạo thước tỷ lệ (Scalebar.mbx). 
   Vào Tools > Draw  ScaleBar, cửa sổ Draw Distance Scale in Mapper 

xuất hiện và chúng ta khai báo chiều dài của thanh tỷ lệ Length of Scale Bar 
theo đơn vị hệ mét hay hệ inch. Chúng ta có thể chọn phông và cở chữ cũng như 
kiểu tô trên thanh tỷ lệ. 
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           Thanh tỷ lệ theo chiều dài và dạng thức đã chọn sẽ được vẽ trên lớp bản 
đồ Cosmetic Layer, chúng ta có thể di chuyển chúng để chọn vị trí thích hợp và 
lưu thành một tập dữ liệu riêng với Map > Save Cosmetic Objects. 

5.6. Sắp xếp trang in (Layout) 
Trang in (Layout) là một dạng thể hiện cửa sổ bản đồ hiện hành trên trang 

giấy in, nội dung của nó tuỳ thuộc vào nội dung của cửa sổ bản đồ, vì vậy trước 
khi làm việc với trang in chúng ta nên chuẩn bị tốt cửa sổ bản đồ liên quan. 

Trước hết là kiểm tra và đặt lại nếu cần khổ giấy và chiều cao của trang in 
File> Page Setup. 

  
Vào Window > New Layout Window (F5), trong cửa sổ New Layout 

Window chúng ta thường chọn One Frame for Window cho cửa sổ bản đồ đang 
hoạt động. Click OK, một cửa sổ trang in (Layout) xuất hiện trên menu chính có 
thêm mục Layout. 

Thông thường chọn trong cửa sổ bản đồ là một bản đồ chuyên đề với các 
chú giải, vì vậy trong cửa sổ trang in sẽ có 2 đối tượng: khung chứa bản đồ và 
khung ghi chú giải. Chúng ta có thể xét dạng thức cho 2 đối tượng này (dạng 
đường viền và dạng màu tô) 
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Tương tự như trong cửa sổ bản đồ, MapInfo cho chúng ta xét vị trí tương 
đối của khung bản đồ trong cửa sổ trang in bằng cách vào Layout > Change 
Zoom, và để xem trọn trang in trong cửa sổ trang in chúng ta sử dụng chức năng 
View Entire Layout. 

Trong cửa sổ này chúng ta cũng có thể vẽ thêm các đối tượng cũng như 
ghi thêm các ghi chú như tiêu đề bản đồ, nguồn gốc bản đồ,...với các dạng thức 
rất linh động và sắp xếp chúng với chức năng Align Objects (dóng hàng và đối 
tượng). Chọn các đối tượng muốn dóng hàng vào Layout > Align Objects: 

 
- Khung Horizontal: để dóng hàng theo chiều đứng (bên trái, ở giữa 

hay bên phải). 
- Khung Vertical: để dóng hàng theo chiều ngang (ở trên, ở giữa hay ở 

dưới)  
Trên trang in chúng ta có thể thêm các nội dung khác như 1 bảng dữ liệu, 

1 biểu đồ đồ hoạ hay một cửa sổ bản đồ khác,....sẽ được xác định trong cửa sổ 
Frame Objects khi chúng ta chọn biểu tượng Frame trong hộp công cụ 
Drawing. 

Với Frame Objects, chúng ta rất chủ động sắp đặt nội dung trang in. 
Chức năng Create Drop Shadow trong mục Layout giúp chúng ta tạo 

một khung viền nổi phía sau đối tượng của trang in. 
Chúng ta lưu trang in theo dạng Worspace. 
 

===&<>&=== 
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Chương 6 
MỘT SỐ TIỆN ÍCH KHÁC  

 

6.1. Thao tác trên các đối tượng 
• Làm tròn góc (Smooth) và trở về nguyên trạng (Unsmooth) 

Từ menu Object>Smooth và Object>UnSmooth để làm tròn góc hay trả về 
nguyên trạng. 

Hai chức năng này chỉ thực hiện trên đối tượng đường.Chức năng làm tròn 
góc sẽ làm tròn các góc của đường gẫy khúc và chức năng làm trở về nguyên 
trạng sẽ phục hồi lại nguyên trạng của đối tượng đã được làm tròn góc. 

• Chuyển đổi từ kiểu đa giác thành kiểu đường và ngược lại: 
Từ menu Object>Convert to Polynes và object>Convert to Regions để thực 
hiện chúng. 

Chú ý: Chỉ có kiểu đường mới làm tròn góc được nên có thể làm tròn góc 
một đa giác chúng ta chuyển đổi nó thành kiểu đường. 

Ngoài ra, để sử dụng một đối tượng địa lý cho hai hay nhiều lớp dữ liệu 
khác nhau, như một khúc sông vừa có kiểu đường trong lớp dữ liệu sông suối 
vừa có kiểu vùng trong lớp dữ liệu ranh giới hành chính, chúng ta chuyển đổi từ 
kiểu vùng sang kiểu đường để tránh sai số khi số hoá nhiều lần. 

• Tạo giao điểm chung cho các đối tượng lân cận:  
Chúng ta chọn Object >OverlayNodes để tạo giao điểm chung này. 

Để tạo thêm một (hay các) trung gian trên một đối tượng xử lý được kiểu 
đường hay kiểu vùng tại điểm giao tiếp đối với tượng chuẩn. 

• Tạo giới hạn vùng nhìn trong cửa sổ bản đồ: 
Chúng ta có thể giới hạn vùng nhìn trong cửa sổ bản đồ theo ranh giới của 

một đối tượng theo kiểu đa giác.Chọn (Select) đối tương này rồi vào Map>Set 
Clip Region hay click biểu tượng của chức năng này trong cửa sổ Main để đặt 
đối tượng này là giới hạn vùng cắt. Tới đây muốn xem toàn cửa sổ bản đồ hay 
chỉ trong giới hạn vùng cắt chúng ta xét Clip Region On hay Off trong mục Map 
hay click vào biểu tượng này trong cửa sổ Main. 

Thao tác này chỉ có tác dụng tạm thời đối với cửa sổ bản đồ đang hoạt 
động, không làm thay đổi lớp dữ liệu. 

6.2. Thao tác trên tập tin của lớp dữ liệu (Table) 
Các thao tác dưới đây có thể thực hiện cho các lớp dữ liệu đang được mở. 
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6.2.1. Đổi tên lớp dữ liệu 

Vào Table > Maintenance  > Rename Table, chọn tên lớp dữ liệu trong 
cửa sổ Rename Table rồi click khung Rename, nhập tên mới cho lớp dữ liệu 
trong cửa sổ Rename Table thứ hai. Nếu chúng ta đổi tên thư mục (Directory) 
thì lớp dữ liệu này sẽ được chuyển đến thư mục đã khai báo. 

                    
6.2.2. Xoá lớp dữ liệu trên đĩa 

Vào Table > Maintenance > Delete Table, chọn lớp dữ liệu muốn xoá 
trong cửa sổ Delete Table rồi click khung Delete; click OK trong cửa sổ mới 
xuất hiện để xoá. 

                
6.2.3. Xoá khoảng dung lượng đĩa của các đối tượng đã bị sửa đổi 

Mỗi khi chúng ta thao tác trên các đối tượng địa lý như kết hợp lại, chia 
cắt, sửa đổi vị trí các điểm trung gian,.... MapInfo sẽ tạo ra một hay nhiều đối 
tượng mới. Mặc dù đã xoá thông tin của các đối tượng đã được sửa đổi nhưng 
dung lượng chiếm trên đĩa của đối tượng này vẫn còn tồn tại. Để xoá khoảng 
trống vô ích này trong các tập tin, chúng ta vào Table > Mainrenance > Pack 
Table. 
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Chọn tên lớp dữ liệu trong khung Pack Table, để mặc định các lựa chọn 
khác rồi click OK. Sau khi thực hiện thao tác này lớp dữ liệu không còn hiện 
diện màn hình nhưng vẫn còn đang mở. Muốn chúng xuất hiện trong một cửa sổ 
nào đó chúng ta click khung Add trong cửa sổ Layer Control của cửa sổ đó, hoặc 
muốn hiện trong một cửa sổ bản đồ mới chúng ta vào Window > New Map 
Window.  
6.2.4. Thể hiện dữ liệu bằng biểu đồ 

Một khả năng khác của MapInfo là có thể thể hiện số liệu các cột của lớp 
dữ liệu đang mở theo dạng biểu đồ. 

Nếu chỉ muốn thể hiện biểu đồ của một số đối tượng (hàng) chúng ta phải 
chọn các đối tượng đó trước khi vào Window > New Graph Window (F4). 

Trong cửa sổ New Graph Window (cửa sổ biểu đồ) chúng ta sẽ khai báo 
tên lớp dữ liệu hay các đối tượng đã được chọn trước (Selection), sau đó xác định 
các cột  mà số liệu sẽ được thể hiện trên biểu đồ và cuối cùng là chọn cột/hàng để 
làm tên cho các đối tượng trên. 

 
Click OK, trên màn hình sẽ hiện thêm cửa sổ biểu đồ và trên menu (chính) 

sẽ hiện Graph (thay cho Map hay Layout, hay Browser). 
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. 
Để thay đổi cách thể hiện mặc định như trên, chúng ta sử dụng các chức 

năng trong mục Graph. 
           - Graph > Formatting…: 
           Khi vào chức năng này, cửa sổ Formatting sẽ xuất hiện, cho phép chúng 
ta đặt tựa với phông, cở chữ tuỳ chọn cho biểu đồ; chúng ta cũng có thể chọn 
kiểu biểu đồ (diện tích, hình cột, hình bánh, dạng đường hay điểm), 2 hay 3 
chiều, có quay ngang hay không,... 

 
- Graph > Grids and Scales >: 
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           Hai chức năng này dùng để xét thuộc tính của trục ghi tên và trục ghi giá 
trị số của các đối tượng bao gồm trị số tối thiểu, tối đa, đơn vị, cách đánh dấu 
đơn vị, tên của trục,.... 

 
- Graph > Series:  

         Vào chức năng này chúng ta có thể thay đổi cách thể hiện các cột số liệu 
bao gồm kiểu, kích cở, màu sắc. 

 
6.2.5. Xuất nhập các dạng dữ liệu để trao đổi với các phần mền khác 

• Xuất: (Export). 
Các lớp dữ liệu trong MapInfo có thể chuyển thành một số dạng khác như 

Các MapInfo chuyển đổi (*.mif), dạng Autocad (*.dxf), dạng văn bản (.txt) hay 
dạng cơ sở dữ liệu (.dbf). Chỉ hai dạng trước (*.mif và *.dxf) bảo toàn được các 
đối tượng địa lý. Thường chúng ta chuyển thành dạng *.dxf vì dạng này thông 
dụng nhất.  
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Chúng ta có thể xuất toàn bộ lớp dữ liệu hay chỉ là một số các đối tượng 
của lớp dữ liệu, trong trường hợp này chúng ta phải chọn các đối tượng này trước 
khi vào Table < Export. Chúng ta sẽ chọn lớp dữ liệu hay chỉ các đối tượng 
được chọn trong cửa sổ Export Table. Click Export, sẽ xuất hiện cửa sổ Export 
Table to File. 

 
Trong cửa sổ này chúng ta chọn File Format là AutoCAD DXF, và tên tập 

tin dạng DXF tương ứng với dữ liệu (rừng trồng năm 1998), xong click Export. 
Trong cửa sổ DXF Export Information mới xuất hiện, chúng ta nên chọn như 
sau: 

 
Nên đánh dấu vào khung Preserve Multi-Polygon Regions as DXF Blocks 

và Preserve Attribute Data để lưu các thông tin thuộc tính của đối tượng bao 
gồm nhiều đa giác. 
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Click Save, MapInfo sẽ tiến hành tập tin chuyển đổi theo dạng đã chọn 
(*.dxf) 

• Nhập: (Inport)  
MapInfo có thể sử dụng thông tin từ một số dạng khác như dạng 

AutoCAD DXF, dạng MapInfo chuyển đổi. Sau đây là tiến trình đăng nhập 
thông tin dạng DXF vào MapInfo. 

Vào Table > Import, trong cửa sổ Import File chúng ta chọn Import 
format là AutoCAD DXF, và tập tin cần chuyển nhập 
(rung_trong_nam_1998.dxf) trong thư mục đã lưu.  

(xuất hiện cửa sổ gần giống như cửa sổ Export Table to File) 
Click Open, xuất hiện cửa sổ DXF Import Information. 

 
Trong cửa sổ này chúng ta phải click vào khung Projection để khai báo 

phép chiếu phù hợp bản đồ sử dụng (khai báo giống như các cách khai báo đã 
thể hiện). Click vào khung  Set Transformation để biết đơn vị của toạ độ mà 
bản đồ sẽ đang định vị. Ở đây chỉ thể hiện toạ độ Max/Min của bản đồ và của 
tập tin *.dxf (mặc định hai tập tin này sẽ có cùng tọa độ Max/Min). Sau khi khai 
báo xong, chúng ta click OK và máy sẽ thực hiện việc đăng nhập. 

Để xem lại kết quả, chúng ta vào Map > New Map Window và Map > 
New Browser Window, và chọn tên lớp dữ liệu mới này, trên màn hính sẽ xuất 
hiện: 
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Trong cửa sổ này, chúng ta có thể chọn nhiều lớp dữ liệu (tối đa 4 lớp) 

trên cùng một cửa sổ bản đồ bằng cách chọn các lớp dữ liệu khác nhau tại các 
dòng  Map Tables. 

6.3. Kết xuất dữ liệu đo đạc bằng GPS thông qua MapSource 4.0 và 
đăng nhập vào MapInfo 
 MapSource 4.0 không xử lý được dạng dữ liệu đo đạc được. Các dữ liệu 
này nhất thiết phải được chuyển qua các phần mền khác để xử lý và áp dụng cho 
các mục đích của chúng ta. Ở tài liệu này, dữ liệu được kết xuất để chuyển vào 
MapInfo. 
6.3.1. Kết xuất dữ liệu đo đạc từ máy định vị GPS  

Dữ liệu từ máy định vị GPS đã được chuyển vào máy tính thông qua phần 
mềm chuyên dụng, ở đây sử dụng MapSourse 4.0. Lưu file tốt nhất dưới dạng 
*.dxf.  

Để kết xuất sang dạng tập tin *.dxf, từ cửa sổ của MapSource chúng ta vào 
menu File> Export… như hình sau: 
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Sau đó chúng ta tìm kiếm để chọn tên tập tin cần chuyển đổi. Chú ý là 
trong mục Save As Type phải chọn ở chế độ DXF (*.dxf). Và chọn Save để lưu 
tập tin đã chọn thành tập tin mới 

 
Khi đó, MapSource cho ra cửa sổ DXF Export Customization sau: 

 
Thông thường chúng ta giữ nguyên các giá trị khai báo mặc định của chúng 

mà không cần khai báo thêm và click OK. Kết quả sẽ cho kết quả là một tập tin 
có dạng *.dxf. Tiến trình kết xuất dữ liệu đã thành công. 
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6.3.2. Đăng nhập dữ liệu vào MapInfo 

Từ MapInfo ta chọn menu Table > Import… chúng ta được cửa sổ như sau: 

 
Trong cửa sổ Import File này, chúng ta chọn tập tin cần chỉnh sửa dạng 

*.dxf. Ví dụ là 437-449.dxf. Sau đó click Open chúng ta sẽ được cửa sổ sau: 
 

 
Trong cửa sổ DFX Import Information này, trước tiên chúng ta phải 

click vào khung Projection… để khai báo phép chiếu cho lớp dữ liệu bản đồ này 
theo các cách khai báo đã thể hiện. Nếu chúng ta muốn dữ lại tất cả các dữ liệu 
gốc từ tập tin *.dxf thì click vào mục Preserve Attribute Data. Sau đó click vào 
khung Set Transformation… để xem tọa độ địa lý của dữ liệu cần đăng nhập. 
Chúng ta có cửa sổ sau: 
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Trong cửa sổ Set Coordinate Transformation chúng ta nhận thấy có hai 

cột toạ độ. Cột bên trái là toạ độ XMax, XMin và YMax, YMin của dữ liệu ở dạng tập 
tin *.dxf. Và tương tư, cột bên phải là toạ độ của tập tin sẽ được chuyển sang 
dạng *.TAB mà MapInfo sẽ quản lý. Cuối cùng, click OK thì dữ liệu sẽ được 
chuyển sang dạng *.TAB mà MapInfo quản lý.   

6.4. Chỉnh sửa dữ liệu của bản đồ số hoá 
Bản đồ số hoá không tránh khỏi những sai số hệ thống: thứ nhất là do sai 

số cục bộ của một vùng nhỏ (so với hệ thống toàn cầu, hoặc so với hệ thống phân 
vùng – Đông Nam Á, Châu Á, Đông bán cầu,…); thứ hai là do sai số trong khi số 
hoá bản đồ, có hai trường hợp xảy ra: (1) do độ chính xác khi nhập dữ liệu đầu 
vào từ ảnh - ảnh vệ tinh, ảnh máy bay hay scaner, (2) do dữ liệu ghi nhận từ GPS. 

Trong tài liệu này, chúng ta chỉ xem xét sai số do dữ liệu đầu vào từ GPS. 
Sai số này thông thường (phổ biến nhất): do người sử dụng xác định mức độ sai 
số cho phép của GPS - phụ thuộc vào từng chủng loại máy GPS; do địa hình thực 
địa không bằng phẳng, có nhiều đồi và khe trũng hoặc dưới tán rừng rậm…; do 
các thời điểm đo khác nhau trong năm. 

Do vậy, việc khắc phục những nhược điểm này là hết sức cần thiết để tăng 
độ chính xác cho dữ liệu trên quy mô một vùng như một lâm trường, một huyện 
hay một xã nào đó.  

Sau khi chúng ta đã chuyển dữ liệu hoàn tất từ MapSource sang MapInfo 
(theo quy trình đã trình bày) mà phát hiện có sự sai lệch chúng ta thực hiện việc 
chỉnh sửa như sau: 

Từ của sổ Set Coordinate Transformation này, chúng ta muốn dịch 
chuyển toạ độ X, Y của tập tin sẽ được thực hiện (*.TAB) sang một tọa độ XiYi 
thì chúng ta phải cộng/trừ một giá trị tương ứng cho cả giá trị XMax, XMin và YMax, 
YMin. Sau đó click OK và chúng ta có được một tập tin *.TAB với tọa độ như 
mong muốn. 

Ví dụ: Trên một bản đồ về giao thông, chúng ta muốn dịch chuyển chúng 
từ một toạ độ ban đầu đến một toạ độ cách đó với giá trị XMax

 = XMin = -450 m và 
YMax = YMin = +350. Ta có cửa sổ sau khi khai báo như sau:  
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Chú ý: Cột X,Y bên trái giữ nguyên giá trị ban đầu và cột X, Y bên phải đã thay 
đổi giá trị. 

Cuối cùng, chúng ta click OK sẽ cho kết quả là lớp dữ liệu như hình sau đây. 

 
Lớp dữ liệu đã được chuyển đổi theo một đường chéo của hình chữ nhật 

có cạnh là 450 x350 (m) về phía trên bên trái. 

 
=============####=============== 
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